source: projects/specs/trunk/g/glabels/glabels-vl.spec @ 521

Revision 521, 8.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           glabels
2Version:        2.2.7
3Release:        1%{?_dist_release}
4Summary:        A program for creating labels and business cards for GNOME
5Summary(ja):    GNOME 用のラベルと名刺を作成するためのプログラム
6
7Group:          Applications/Publishing
8License:        GPLv2+
9URL:            http://glabels.sf.net
10
11Source0:        http://dl.sf.net/%{name}/%{name}-%{version}.tar.gz
12#Patch0:        %{name}-libxml-XML_PARSE_HUGE.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  desktop-file-utils
17BuildRequires:  evolution-data-server-devel >= 1.8
18BuildRequires:  gettext
19BuildRequires:  gtk2-devel >= 2.10
20BuildRequires:  glib2 >= 2.12
21BuildRequires:  libglade2-devel >= 2.6
22BuildRequires:  libgnomeui-devel >= 2.16
23BuildRequires:  libSM-devel
24BuildRequires:  libxml2 >= 2.6
25BuildRequires:  perl-XML-Parser
26BuildRequires:  scrollkeeper
27BuildRequires:  intltool
28
29Requires(post): desktop-file-utils
30Requires(post): /sbin/ldconfig
31Requires(post): shared-mime-info
32
33Requires(postun):       desktop-file-utils
34Requires(postun):       /sbin/ldconfig
35Requires(postun):       shared-mime-info
36
37Requires:       %{name}-libs = %{version}-%{release}
38Requires:       %{name}-doc = %{version}-%{release}
39       
40%description
41gLabels is a lightweight program for creating labels and
42business cards for the GNOME desktop environment.
43It is designed to work with various laser/ink-jet peel-off
44label and business card sheets that you'll find at most office
45supply stores.
46
47%description -l ja
48gLabels はGNOME デスクトップ環境用のラベルや名刺を
49作成するための軽量のプログラムです。
50殆どのオフィス用品店で見つけることができる様々な
51レーザー/インクジェット用のラベルや名刺用紙に対応するよう
52設計されています。
53
54%package        devel
55Summary:        Development files for %{name}
56Summary(ja):    %{name} の開発ファイル
57License:        LGPLv2+
58Group:          Development/Libraries
59Requires:       %{name}-libs = %{version}-%{release}
60
61%description    devel
62This package contains the header files and development documentation for
63libglabels.
64
65%description -l ja devel
66このパッケージは libglabels のヘッダファイルと
67開発ドキュメントを含んでいます。
68
69
70%package        libs
71License:        LGPLv2+
72Summary:        Shared liblaries for %{name}
73Summary(ja):    %{name} の共有ライブラリ
74Group:          Development/Libraries
75
76%description    libs
77This package contains the shared libraries for %{name}.
78
79%description -l ja libs
80このパッケージは %{name} の共有ライブラリを含んでいます。
81
82
83%package        doc
84License:        GFDL
85Summary:        Runtime documentation for %{name}
86Summary(ja):    %{name} の実行ドキュメント
87Group:          Development/Libraries
88Requires(post): scrollkeeper
89Requires(postun):       scrollkeeper
90
91%description    doc
92This package contains the runtime documentation and manual pages for %{name}.
93
94%description -l ja doc
95このパッケージは %{name} の実行ドキュメントとマニュアルを含んでいます。 
96
97%prep
98%setup -q
99#%patch0 -p1 -b .libxml-XML_PARSE_HUGE
100
101
102%build
103%configure --disable-update-mimedb --disable-update-desktopdb --disable-static
104make %{?_smp_mflags}
105
106
107%install
108rm -rf %{buildroot}
109make install DESTDIR=%{buildroot}
110desktop-file-install                                    \
111        --vendor=vine                                   \
112        --dir %{buildroot}%{_datadir}/applications      \
113        --delete-original                               \
114        %{buildroot}%{_datadir}/applications/%{name}.desktop
115%find_lang %{name}
116## Fix encodings.
117for DOC_FILE in AUTHORS ChangeLog NEWS; do
118        %{_bindir}/iconv -f iso8859-1 -t utf-8 ${DOC_FILE} > ${DOC_FILE}.conv;
119        mv -f ${DOC_FILE}.conv ${DOC_FILE};
120done
121
122rm -rf %{buildroot}%{_libdir}/libglabels.la
123rm -rf %{buildroot}%{_libdir}/libglabels.a
124
125
126%post
127update-desktop-database &> /dev/null ||:
128update-mime-database %{_datadir}/mime &> /dev/null ||:
129
130%postun
131update-desktop-database &> /dev/null ||:
132update-mime-database %{_datadir}/mime &> /dev/null ||:
133
134
135%post   libs -p /sbin/ldconfig
136
137%postun libs -p /sbin/ldconfig
138
139
140%post   doc
141scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
142
143%postun doc
144scrollkeeper-update -q ||:
145
146
147%clean
148rm -rf %{buildroot}
149
150
151%files -f %{name}.lang
152%defattr(-,root,root,-)
153%doc AUTHORS ChangeLog COPYING COPYING.README_FIRST NEWS README TODO
154%{_bindir}/glabels*
155%{_datadir}/application-registry/glabels.applications
156%{_datadir}/applications/vine-glabels.desktop
157%{_datadir}/glabels/
158%{_datadir}/mime/packages/glabels.xml
159%{_datadir}/mime-info/glabels.*
160%{_datadir}/pixmaps/glabels/
161%{_datadir}/pixmaps/glabels*.png
162
163%files  devel
164%defattr(-,root,root,-)
165%doc AUTHORS COPYING-LIBGLABELS
166%doc %{_datadir}/gtk-doc/html/libglabels
167#%exclude %{_libdir}/libglabels.la
168#%exclude %{_libdir}/libglabels.a
169%{_includedir}/libglabels/
170%{_libdir}/libglabels.so
171%{_libdir}/pkgconfig/libglabels.pc
172
173%files  libs
174%defattr(-,root,root,-)
175%doc AUTHORS COPYING-LIBGLABELS
176%{_libdir}/libglabels.so.*
177
178%files  doc
179%defattr(-,root,root,-)
180## Manual ("man") pages are automatically marked as %%doc by RPM.
181%doc AUTHORS COPYING-DOCS
182%doc %{_datadir}/gnome/help/glabels/
183%{_datadir}/omf/glabels/
184%{_mandir}/man?/glabels.*
185
186
187%changelog
188* Wed Mar 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.7-1
189- New upstream release
190- dropt Patch0
191- added BuildRequires: libSM-devel
192
193* Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.6-1
194- New upstream release
195- changed BuildRequires: gtk2 to gtk2-devel
196- added BuildRequires: intltool
197- added Patch1 from Fedora
198
199* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.5-1
200- initial build for VineSeed
201
202* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 2.2.4-1
203- Update to new upstream bug-fix release (2.2.4):
204  * Corrected button order in "Open" and "Save as" dialogs.
205  * Fixed performance problem when large number of fonts are installed.
206  * Corrected several i18n problems.
207  * Fixed "paste" bug that created phantom object views.
208  * Fixed performance problem when many objects are selected.
209  * New templates. 
210
211* Tue Aug 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2.3-2
212- fix license tag (again)
213
214* Thu Aug 21 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.3-1
215- Update to new upstream bug-fix release (2.2.3).
216- Drop glabels-batch segfault patch (fixed upstream).
217  - fix-batch-segfault.patch
218
219* Fri Aug 08 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.2-3
220- Add patch from Casey Harkins to fix a segfault in glabels-batch:
221  + fix-batch-segfault.patch
222- Resolves: bug #458473.
223
224* Mon Jul 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2.2-2
225- fix license tag
226
227* Tue Mar 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.2-1
228- Update to new upstream bug-fix release (2.2.2).
229
230* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.1-2
231- Autorebuild for GCC 4.3
232
233* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.1-1
234- Update to new upstream bug-fix release (2.2.1).
235
236* Mon Jan 14 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.0-1
237- Update to new upstream release (2.2.0 Final); Yay!
238
239* Sun Dec 16 2007 Peter Gordon <peter@thecodergeek.com> - 2.1.5-1
240- Update to new upstream development snapshot (2.1.5).
241
242* Tue Aug 21 2007 Peter Gordon <peter@thecodergeek.com> - 2.0.4-7
243- Rebuild with new BuildID-enabled binutils.
244
245* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 2.0.4-6
246- Update License tagging (GPLv2+). This necessitates a split of two
247  subpackages:
248  (1) glabels-doc: Runtime documentation for gLabels (GFDLv1.1+)
249  (2) glabels-libs: Shared libraries for gLabels (LGPLv2+)
250- Fix version in previous %%changelog entry.
251- Lots and lots of aesthetic spec file changes.
252- Remove X-Fedora category from desktop-file-install invocation.
253- Add TODO to installed %%doc files.
254
255* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-5
256- Add BR: perl(XML::Parser)
257 
258* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-4
259- Mass FC6 rebuild
260
261* Wed Jul 05 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-3
262- Add BuildRequires: gettext (#197633)
263
264* Sat Feb 18 2006 Jef Spaleta <jspaleta@gmail.com> - 2.0.4-2
265- Bump for fe5 rebuild
266
267* Sat Jan 01 2006 Jef Spaleta <jspaleta@gmail.com> - 2.0.4-1
268- Update to new stable upstream version
269
270* Thu Aug 18 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-3
271- rebuild
272
273* Thu Jul 7 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-2
274- use Source0
275
276* Mon Jul 5 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-1
277- Initial fedora extras build
278
Note: See TracBrowser for help on using the repository browser.