source: projects/specs/trunk/g/glabels/glabels-vl.spec @ 11811

Revision 11811, 11.4 KB checked in by ara_t, 5 years ago (diff)

glabels: update to 3.4.1

Line 
1Name:     glabels
2Version:  3.4.1
3Release:  1%{?_dist_release}
4Summary:  A program for creating labels and business cards for GNOME
5Summary(ja):  GNOME 用のラベルと名刺を作成するためのプログラム
6
7Group:    Applications/Publishing
8License:  GPLv3+
9URL:      http://glabels.sf.net
10
11Source0:  http://dl.sf.net/%{name}/%{name}-%{version}.tar.xz
12
13#Patch0:  glabels-3.0.1-ebook.patch
14
15BuildRoot:  %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  cairo-devel >= 1.10.0
18BuildRequires:  desktop-file-utils
19BuildRequires:  evolution-data-server-devel >= 2.32.0
20BuildRequires:  gettext
21BuildRequires:  gtk3-devel >= 3.0.9
22BuildRequires:  glib2 >= 2.28.2
23BuildRequires:  libglade2-devel >= 2.6
24BuildRequires:  libgnomeui-devel >= 2.16
25BuildRequires:librsvg2-devel >= 2.32.0
26BuildRequires:  libSM-devel
27BuildRequires:  libxml2 >= 2.7.8
28BuildRequires:  pango-devel
29BuildRequires:  perl-XML-Parser
30BuildRequires:  scrollkeeper
31BuildRequires:  intltool
32BuildRequires:  gnome-doc-utils >= 0.3.2
33BuildRequires:  qrencode-devel
34BuildRequires:  zint-devel
35BuildRequires:  itstool
36
37Requires(post): desktop-file-utils
38Requires(post): /sbin/ldconfig
39Requires(post): shared-mime-info
40
41Requires(postun): desktop-file-utils
42Requires(postun): /sbin/ldconfig
43Requires(postun): shared-mime-info
44
45Requires: %{name}-libs = %{version}-%{release}
46Requires: %{name}-doc = %{version}-%{release}
47Requires: %{name}-templates = %{version}-%{release}
48
49%description
50gLabels is a lightweight program for creating labels and
51business cards for the GNOME desktop environment.
52It is designed to work with various laser/ink-jet peel-off
53label and business card sheets that you'll find at most office
54supply stores.
55#'
56
57%description -l ja
58gLabels はGNOME デスクトップ環境用のラベルや名刺を
59作成するための軽量のプログラムです。
60殆どのオフィス用品店で見つけることができる様々な
61レーザー/インクジェット用のラベルや名刺用紙に対応するよう
62設計されています。
63
64%package  devel
65Summary:  Development files for %{name}
66Summary(ja):  %{name} の開発ファイル
67License:  LGPLv3+
68Group:    Development/Libraries
69Requires: %{name}-libs = %{version}-%{release}
70
71%description  devel
72This package contains the header files and development documentation for
73libglabels.
74
75%description -l ja devel
76このパッケージは libglabels のヘッダファイルと
77開発ドキュメントを含んでいます。
78
79
80%package  libs
81License:  LGPLv3+
82Summary:  Shared liblaries for %{name}
83Summary(ja):  %{name} の共有ライブラリ
84Group:    Development/Libraries
85
86%description  libs
87This package contains the shared libraries for %{name}.
88
89%description -l ja libs
90このパッケージは %{name} の共有ライブラリを含んでいます。
91
92
93%package  doc
94License:  GFDL
95Summary:  Runtime documentation for %{name}
96Summary(ja):  %{name} の実行ドキュメント
97Group:    Development/Libraries
98Requires(post): scrollkeeper
99Requires(postun): scrollkeeper
100
101%description  doc
102This package contains the runtime documentation and manual pages for %{name}.
103
104%description -l ja doc
105このパッケージは %{name} の実行ドキュメントとマニュアルを含んでいます。
106
107
108%package  templates
109License:  MIT
110Summary:  The %{name} template database
111Summary(ja):  %{name} のテンプレートデータベース
112Group:    Development/Libraries
113## Needs the glabels-libs subpackage for proper ownership of the top-level
114## libglabels-3.0 directory in %%_datadir.
115Requires: %{name}-libs
116
117%description  templates
118This package contains the template database for %{name}.
119
120%description -l ja templates
121このパッケージは %{name} のテンプレートデータベースを含んでいます。
122
123%prep
124%setup -q
125#%patch0 -p1 -b .ebook
126
127sed -i 's/Icon=glabels-3.0.png/Icon=glabels-3.0/g' \
128        data/desktop/glabels-3.0.desktop.in
129
130%build
131%configure --enable-static=no --enable-gtk-doc
132make %{?_smp_mflags}
133
134
135%install
136rm -rf %{buildroot}
137make install DESTDIR=%{buildroot}
138
139desktop-file-install          \
140  --vendor=""         \
141  --dir %{buildroot}%{_datadir}/applications  \
142  --delete-original       \
143  %{buildroot}%{_datadir}/applications/%{name}-3.0.desktop
144
145%find_lang %{name}-3.0
146
147rm -rf %{buildroot}%{_libdir}/libglabels-3.0.la
148rm -rf %{buildroot}%{_libdir}/libglbarcode-3.0.la
149
150
151%post
152update-desktop-database &> /dev/null ||:
153update-mime-database %{_datadir}/mime &> /dev/null ||:
154
155%postun
156update-desktop-database &> /dev/null ||:
157update-mime-database %{_datadir}/mime &> /dev/null ||:
158if [ $1 -eq 0 ]; then
159  glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null ||:
160fi
161
162if [ $1 -eq 0 ] ; then
163  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
164  gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
165fi
166
167
168%post libs -p /sbin/ldconfig
169
170%postun libs -p /sbin/ldconfig
171
172
173%post doc
174scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
175
176%postun doc
177scrollkeeper-update -q ||:
178
179%posttrans
180glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null ||:
181%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
182
183%clean
184rm -rf %{buildroot}
185
186
187%files -f %{name}-3.0.lang
188%defattr(-,root,root,-)
189%doc AUTHORS ChangeLog COPYING COPYING.README_FIRST NEWS README TODO
190%{_bindir}/glabels*
191%{_datadir}/applications/glabels-3.0.desktop
192%{_datadir}/glib-2.0/schemas/org.gnome.glabels-3.gschema.xml
193%{_datadir}/glabels-3.0/
194%{_datadir}/icons/hicolor/*/
195%{_datadir}/mime/packages/glabels-3.0.xml
196%{_datadir}/appdata/glabels-3.appdata.xml
197
198%files  devel
199%defattr(-,root,root,-)
200%doc AUTHORS COPYING-LIBS
201%doc %{_datadir}/gtk-doc/html/libglabels-3.0/
202%{_includedir}/libglabels-3.0/
203%{_includedir}/libglbarcode-3.0/
204%{_libdir}/libglabels-3.0.so
205%{_libdir}/libglbarcode-3.0.so
206%{_libdir}/pkgconfig/libglabels-3.0.pc
207%{_libdir}/pkgconfig/libglbarcode-3.0.pc
208
209%files  libs
210%defattr(-,root,root,-)
211%doc AUTHORS COPYING-LIBS
212%dir %{_datadir}/libglabels-3.0/
213%{_datadir}/glabels-3.0/
214%{_libdir}/libglabels-3.0.so.*
215%{_libdir}/libglbarcode-3.0.so.*
216
217%files  doc
218%defattr(-,root,root,-)
219## Manual ("man") pages are automatically marked as %%doc by RPM.
220%doc AUTHORS COPYING-DOCS
221%doc %{_datadir}/help/*/glabels-3.0/
222%{_mandir}/man?/glabels-3*
223%{_datadir}/gtk-doc/html/libglabels-3.0/
224%{_datadir}/gtk-doc/html/libglbarcode-3.0/
225
226%files templates
227%doc AUTHORS COPYING-TEMPLATES
228%{_datadir}/libglabels-3.0/dtd/
229%{_datadir}/libglabels-3.0/templates/
230
231
232%changelog
233* Sun Oct 07 2018 Toshiaki Ara <ara_t@384.jp> - 3.4.1-1
234- new upstream release
235
236* Mon May 02 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.0-1
237- new upstream release
238
239* Sat Apr 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.2.0-1
240- new upstream release
241- deleted Patch0
242- added BuildRequires: itstool
243
244* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-3
245- add Patch0 (glabels-3.0.1-ebook.patch)
246
247* Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.1-1
248- new upstream release
249- changed source archive type bz2 to xz
250- deleted Patch0
251
252* Sun Aug 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.0-2
253- added Patch0 from Fedora
254- run gtk-update-icon-cache in %%posttrans, %%postun
255
256* Sat Sep 17 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.0-1
257- new upstream release
258- changed License: GPLv2+ to GPLv3+
259- changed %%configure option
260  - deleted unrecognized option
261  - changed --disable-static to --enable-static=no
262  - added --enable-gtk-doc
263- added BuildRequires: cairo-devel >= 1.10.0, pango-devel, qrencode-devel, zint-devel
264- changed BuildRequires: gtk2-devel >= 2.22.0 to gtk3-devel >= 3.0.9
265- made -templates sub package
266- unresolved: can't appear icon on desktop file..
267
268* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-6
269- rebuild with evolution-data-server-3.1.90
270
271* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-5
272- rebuild with evolution-data-server-3.1.4
273
274* Tue Oct 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-4
275- rebuild with evolution-data-server-2.32.0
276
277* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.8-3
278- rebuilt with rpm-4.8.1 for pkg-config
279
280* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.8-2
281- rebuild with evolution-data-server-2.30.2
282
283* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.8-1
284- new upstream release
285- add BuildRequires: gnome-doc-utils >= 0.3.2
286
287* Wed Mar 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.7-1
288- New upstream release
289- dropt Patch0
290- added BuildRequires: libSM-devel
291
292* Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.6-1
293- New upstream release
294- changed BuildRequires: gtk2 to gtk2-devel
295- added BuildRequires: intltool
296- added Patch1 from Fedora
297
298* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.5-1
299- initial build for VineSeed
300
301* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 2.2.4-1
302- Update to new upstream bug-fix release (2.2.4):
303  * Corrected button order in "Open" and "Save as" dialogs.
304  * Fixed performance problem when large number of fonts are installed.
305  * Corrected several i18n problems.
306  * Fixed "paste" bug that created phantom object views.
307  * Fixed performance problem when many objects are selected.
308  * New templates. 
309
310* Tue Aug 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2.3-2
311- fix license tag (again)
312
313* Thu Aug 21 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.3-1
314- Update to new upstream bug-fix release (2.2.3).
315- Drop glabels-batch segfault patch (fixed upstream).
316  - fix-batch-segfault.patch
317
318* Fri Aug 08 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.2-3
319- Add patch from Casey Harkins to fix a segfault in glabels-batch:
320  + fix-batch-segfault.patch
321- Resolves: bug #458473.
322
323* Mon Jul 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2.2-2
324- fix license tag
325
326* Tue Mar 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.2-1
327- Update to new upstream bug-fix release (2.2.2).
328
329* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.1-2
330- Autorebuild for GCC 4.3
331
332* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.1-1
333- Update to new upstream bug-fix release (2.2.1).
334
335* Mon Jan 14 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.0-1
336- Update to new upstream release (2.2.0 Final); Yay!
337
338* Sun Dec 16 2007 Peter Gordon <peter@thecodergeek.com> - 2.1.5-1
339- Update to new upstream development snapshot (2.1.5).
340
341* Tue Aug 21 2007 Peter Gordon <peter@thecodergeek.com> - 2.0.4-7
342- Rebuild with new BuildID-enabled binutils.
343
344* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 2.0.4-6
345- Update License tagging (GPLv2+). This necessitates a split of two
346  subpackages:
347  (1) glabels-doc: Runtime documentation for gLabels (GFDLv1.1+)
348  (2) glabels-libs: Shared libraries for gLabels (LGPLv2+)
349- Fix version in previous %%changelog entry.
350- Lots and lots of aesthetic spec file changes.
351- Remove X-Fedora category from desktop-file-install invocation.
352- Add TODO to installed %%doc files.
353
354* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-5
355- Add BR: perl(XML::Parser)
356 
357* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-4
358- Mass FC6 rebuild
359
360* Wed Jul 05 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-3
361- Add BuildRequires: gettext (#197633)
362
363* Sat Feb 18 2006 Jef Spaleta <jspaleta@gmail.com> - 2.0.4-2
364- Bump for fe5 rebuild
365
366* Sun Jan 01 2006 Jef Spaleta <jspaleta@gmail.com> - 2.0.4-1
367- Update to new stable upstream version
368
369* Thu Aug 18 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-3
370- rebuild
371
372* Thu Jul 7 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-2
373- use Source0
374
375* Tue Jul 5 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-1
376- Initial fedora extras build
377
Note: See TracBrowser for help on using the repository browser.