source: projects/specs/trunk/g/glabels/glabels-vl.spec @ 6890

Revision 6890, 11.0 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1Name:           glabels
2Version:        3.0.1
3Release:        2%{?_dist_release}
4Summary:        A program for creating labels and business cards for GNOME
5Summary(ja):    GNOME 用のラベルと名刺を作成するためのプログラム
6
7Group:          Applications/Publishing
8License:        GPLv3+
9URL:            http://glabels.sf.net
10
11Source0:        http://dl.sf.net/%{name}/%{name}-%{version}.tar.xz
12#Patch0:        glabels-fix-child-schemas.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  cairo-devel >= 1.10.0
17BuildRequires:  desktop-file-utils
18BuildRequires:  evolution-data-server-devel >= 2.32.0
19BuildRequires:  gettext
20BuildRequires:  gtk3-devel >= 3.0.9
21BuildRequires:  glib2 >= 2.28.2
22BuildRequires:  libglade2-devel >= 2.6
23BuildRequires:  libgnomeui-devel >= 2.16
24BuildRequires:librsvg2-devel >= 2.32.0
25BuildRequires:  libSM-devel
26BuildRequires:  libxml2 >= 2.7.8
27BuildRequires:  pango-devel
28BuildRequires:  perl-XML-Parser
29BuildRequires:  scrollkeeper
30BuildRequires:  intltool
31BuildRequires:  gnome-doc-utils >= 0.3.2
32BuildRequires:  qrencode-devel
33BuildRequires:  zint-devel
34
35Requires(post): desktop-file-utils
36Requires(post): /sbin/ldconfig
37Requires(post): shared-mime-info
38
39Requires(postun):       desktop-file-utils
40Requires(postun):       /sbin/ldconfig
41Requires(postun):       shared-mime-info
42
43Requires:       %{name}-libs = %{version}-%{release}
44Requires:       %{name}-doc = %{version}-%{release}
45Requires:       %{name}-templates = %{version}-%{release}
46       
47%description
48gLabels is a lightweight program for creating labels and
49business cards for the GNOME desktop environment.
50It is designed to work with various laser/ink-jet peel-off
51label and business card sheets that you'll find at most office
52supply stores.
53
54%description -l ja
55gLabels はGNOME デスクトップ環境用のラベルや名刺を
56作成するための軽量のプログラムです。
57殆どのオフィス用品店で見つけることができる様々な
58レーザー/インクジェット用のラベルや名刺用紙に対応するよう
59設計されています。
60
61%package        devel
62Summary:        Development files for %{name}
63Summary(ja):    %{name} の開発ファイル
64License:        LGPLv3+
65Group:          Development/Libraries
66Requires:       %{name}-libs = %{version}-%{release}
67
68%description    devel
69This package contains the header files and development documentation for
70libglabels.
71
72%description -l ja devel
73このパッケージは libglabels のヘッダファイルと
74開発ドキュメントを含んでいます。
75
76
77%package        libs
78License:        LGPLv3+
79Summary:        Shared liblaries for %{name}
80Summary(ja):    %{name} の共有ライブラリ
81Group:          Development/Libraries
82
83%description    libs
84This package contains the shared libraries for %{name}.
85
86%description -l ja libs
87このパッケージは %{name} の共有ライブラリを含んでいます。
88
89
90%package        doc
91License:        GFDL
92Summary:        Runtime documentation for %{name}
93Summary(ja):    %{name} の実行ドキュメント
94Group:          Development/Libraries
95Requires(post): scrollkeeper
96Requires(postun):       scrollkeeper
97
98%description    doc
99This package contains the runtime documentation and manual pages for %{name}.
100
101%description -l ja doc
102このパッケージは %{name} の実行ドキュメントとマニュアルを含んでいます。
103
104
105%package        templates
106License:        MIT
107Summary:        The %{name} template database
108Summary(ja):    %{name} のテンプレートデータベース
109Group:          Development/Libraries
110## Needs the glabels-libs subpackage for proper ownership of the top-level
111## libglabels-3.0 directory in %%_datadir.
112Requires:       %{name}-libs
113
114%description    templates
115This package contains the template database for %{name}.
116
117%description -l ja templates
118このパッケージは %{name} のテンプレートデータベースを含んでいます。
119
120%prep
121%setup -q
122#%patch0 -p1 -b .fix-child-schemas
123
124sed -i 's/Icon=glabels-3.0.png/Icon=glabels-3.0/g' \
125        data/desktop/glabels-3.0.desktop.in
126
127%build
128%configure --enable-static=no --enable-gtk-doc
129make %{?_smp_mflags}
130
131
132%install
133rm -rf %{buildroot}
134make install DESTDIR=%{buildroot}
135
136desktop-file-install                                    \
137        --vendor=""                                     \
138        --dir %{buildroot}%{_datadir}/applications      \
139        --delete-original                               \
140        %{buildroot}%{_datadir}/applications/%{name}-3.0.desktop
141
142%find_lang %{name}-3.0
143
144rm -rf %{buildroot}%{_libdir}/libglabels-3.0.la
145rm -rf %{buildroot}%{_libdir}/libglbarcode-3.0.la
146
147
148%post
149update-desktop-database &> /dev/null ||:
150update-mime-database %{_datadir}/mime &> /dev/null ||:
151
152%postun
153update-desktop-database &> /dev/null ||:
154update-mime-database %{_datadir}/mime &> /dev/null ||:
155if [ $1 -eq 0 ]; then
156        glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null ||:
157fi
158
159if [ $1 -eq 0 ] ; then
160        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
161        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
162fi
163
164
165%post   libs -p /sbin/ldconfig
166
167%postun libs -p /sbin/ldconfig
168
169
170%post   doc
171scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
172
173%postun doc
174scrollkeeper-update -q ||:
175
176%posttrans
177glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null ||:
178%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
179
180%clean
181rm -rf %{buildroot}
182
183
184%files -f %{name}-3.0.lang
185%defattr(-,root,root,-)
186%doc AUTHORS ChangeLog COPYING COPYING.README_FIRST NEWS README TODO
187%{_bindir}/glabels*
188%{_datadir}/applications/glabels-3.0.desktop
189%{_datadir}/glib-2.0/schemas/org.gnome.glabels-3.gschema.xml
190%{_datadir}/glabels-3.0/
191%{_datadir}/icons/hicolor/*/
192%{_datadir}/mime/packages/glabels-3.0.xml
193
194%files  devel
195%defattr(-,root,root,-)
196%doc AUTHORS COPYING-LIBS
197%doc %{_datadir}/gtk-doc/html/libglabels-3.0/
198%{_includedir}/libglabels-3.0/
199%{_includedir}/libglbarcode-3.0/
200%{_libdir}/libglabels-3.0.so
201%{_libdir}/libglbarcode-3.0.so
202%{_libdir}/pkgconfig/libglabels-3.0.pc
203%{_libdir}/pkgconfig/libglbarcode-3.0.pc
204
205%files  libs
206%defattr(-,root,root,-)
207%doc AUTHORS COPYING-LIBS
208%dir %{_datadir}/libglabels-3.0/
209%{_datadir}/glabels-3.0/
210%{_libdir}/libglabels-3.0.so.*
211%{_libdir}/libglbarcode-3.0.so.*
212
213%files  doc
214%defattr(-,root,root,-)
215## Manual ("man") pages are automatically marked as %%doc by RPM.
216%doc AUTHORS COPYING-DOCS
217%doc %{_datadir}/gnome/help/glabels-3.0/
218%{_mandir}/man?/glabels-3*
219%{_datadir}/gtk-doc/html/libglabels-3.0/
220%{_datadir}/gtk-doc/html/libglbarcode-3.0/
221
222%files templates
223%doc AUTHORS COPYING-TEMPLATES
224%{_datadir}/libglabels-3.0/dtd/
225%{_datadir}/libglabels-3.0/templates/
226
227
228%changelog
229* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
230- rebuild with evolution-data-server-3.6.0
231
232* Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.1-1
233- new upstream release
234- changed source archive type bz2 to xz
235- deleted Patch0
236
237* Sun Aug 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.0-2
238- added Patch0 from Fedora
239- run gtk-update-icon-cache in %%posttrans, %%postun
240
241* Sat Sep 17 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.0-1
242- new upstream release
243- changed License: GPLv2+ to GPLv3+
244- changed %%configure option
245  - deleted unrecognized option
246  - changed --disable-static to --enable-static=no
247  - added --enable-gtk-doc
248- added BuildRequires: cairo-devel >= 1.10.0, pango-devel, qrencode-devel, zint-devel
249- changed BuildRequires: gtk2-devel >= 2.22.0 to gtk3-devel >= 3.0.9
250- made -templates sub package
251- unresolved: can't appear icon on desktop file..
252
253* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-6
254- rebuild with evolution-data-server-3.1.90
255
256* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-5
257- rebuild with evolution-data-server-3.1.4
258
259* Tue Oct 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-4
260- rebuild with evolution-data-server-2.32.0
261
262* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.8-3
263- rebuilt with rpm-4.8.1 for pkg-config
264
265* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.8-2
266- rebuild with evolution-data-server-2.30.2
267
268* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.8-1
269- new upstream release
270- add BuildRequires: gnome-doc-utils >= 0.3.2
271
272* Wed Mar 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.7-1
273- New upstream release
274- dropt Patch0
275- added BuildRequires: libSM-devel
276
277* Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.6-1
278- New upstream release
279- changed BuildRequires: gtk2 to gtk2-devel
280- added BuildRequires: intltool
281- added Patch1 from Fedora
282
283* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.5-1
284- initial build for VineSeed
285
286* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 2.2.4-1
287- Update to new upstream bug-fix release (2.2.4):
288  * Corrected button order in "Open" and "Save as" dialogs.
289  * Fixed performance problem when large number of fonts are installed.
290  * Corrected several i18n problems.
291  * Fixed "paste" bug that created phantom object views.
292  * Fixed performance problem when many objects are selected.
293  * New templates. 
294
295* Tue Aug 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2.3-2
296- fix license tag (again)
297
298* Thu Aug 21 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.3-1
299- Update to new upstream bug-fix release (2.2.3).
300- Drop glabels-batch segfault patch (fixed upstream).
301  - fix-batch-segfault.patch
302
303* Fri Aug 08 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.2-3
304- Add patch from Casey Harkins to fix a segfault in glabels-batch:
305  + fix-batch-segfault.patch
306- Resolves: bug #458473.
307
308* Mon Jul 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2.2-2
309- fix license tag
310
311* Tue Mar 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.2-1
312- Update to new upstream bug-fix release (2.2.2).
313
314* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.1-2
315- Autorebuild for GCC 4.3
316
317* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.1-1
318- Update to new upstream bug-fix release (2.2.1).
319
320* Mon Jan 14 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.0-1
321- Update to new upstream release (2.2.0 Final); Yay!
322
323* Sun Dec 16 2007 Peter Gordon <peter@thecodergeek.com> - 2.1.5-1
324- Update to new upstream development snapshot (2.1.5).
325
326* Tue Aug 21 2007 Peter Gordon <peter@thecodergeek.com> - 2.0.4-7
327- Rebuild with new BuildID-enabled binutils.
328
329* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 2.0.4-6
330- Update License tagging (GPLv2+). This necessitates a split of two
331  subpackages:
332  (1) glabels-doc: Runtime documentation for gLabels (GFDLv1.1+)
333  (2) glabels-libs: Shared libraries for gLabels (LGPLv2+)
334- Fix version in previous %%changelog entry.
335- Lots and lots of aesthetic spec file changes.
336- Remove X-Fedora category from desktop-file-install invocation.
337- Add TODO to installed %%doc files.
338
339* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-5
340- Add BR: perl(XML::Parser)
341 
342* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-4
343- Mass FC6 rebuild
344
345* Wed Jul 05 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-3
346- Add BuildRequires: gettext (#197633)
347
348* Sat Feb 18 2006 Jef Spaleta <jspaleta@gmail.com> - 2.0.4-2
349- Bump for fe5 rebuild
350
351* Sat Jan 01 2006 Jef Spaleta <jspaleta@gmail.com> - 2.0.4-1
352- Update to new stable upstream version
353
354* Thu Aug 18 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-3
355- rebuild
356
357* Thu Jul 7 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-2
358- use Source0
359
360* Mon Jul 5 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-1
361- Initial fedora extras build
362
Note: See TracBrowser for help on using the repository browser.