source: projects/specs/trunk/g/glabels/glabels-vl.spec @ 10217

Revision 10217, 11.2 KB checked in by kudoh, 8 years ago (diff)

new upstream release

Line 
1Name:           glabels
2Version:        3.4.0
3Release:        1%{?_dist_release}
4Summary:        A program for creating labels and business cards for GNOME
5Summary(ja):    GNOME 用のラベルと名刺を作成するためのプログラム
6
7Group:          Applications/Publishing
8License:        GPLv3+
9URL:            http://glabels.sf.net
10
11Source0:        http://dl.sf.net/%{name}/%{name}-%{version}.tar.xz
12
13#Patch0:        glabels-3.0.1-ebook.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  cairo-devel >= 1.10.0
18BuildRequires:  desktop-file-utils
19BuildRequires:  evolution-data-server-devel >= 2.32.0
20BuildRequires:  gettext
21BuildRequires:  gtk3-devel >= 3.0.9
22BuildRequires:  glib2 >= 2.28.2
23BuildRequires:  libglade2-devel >= 2.6
24BuildRequires:  libgnomeui-devel >= 2.16
25BuildRequires:librsvg2-devel >= 2.32.0
26BuildRequires:  libSM-devel
27BuildRequires:  libxml2 >= 2.7.8
28BuildRequires:  pango-devel
29BuildRequires:  perl-XML-Parser
30BuildRequires:  scrollkeeper
31BuildRequires:  intltool
32BuildRequires:  gnome-doc-utils >= 0.3.2
33BuildRequires:  qrencode-devel
34BuildRequires:  zint-devel
35BuildRequires:  itstool
36
37Requires(post): desktop-file-utils
38Requires(post): /sbin/ldconfig
39Requires(post): shared-mime-info
40
41Requires(postun):       desktop-file-utils
42Requires(postun):       /sbin/ldconfig
43Requires(postun):       shared-mime-info
44
45Requires:       %{name}-libs = %{version}-%{release}
46Requires:       %{name}-doc = %{version}-%{release}
47Requires:       %{name}-templates = %{version}-%{release}
48       
49%description
50gLabels is a lightweight program for creating labels and
51business cards for the GNOME desktop environment.
52It is designed to work with various laser/ink-jet peel-off
53label and business card sheets that you'll find at most office
54supply stores.
55
56%description -l ja
57gLabels はGNOME デスクトップ環境用のラベルや名刺を
58作成するための軽量のプログラムです。
59殆どのオフィス用品店で見つけることができる様々な
60レーザー/インクジェット用のラベルや名刺用紙に対応するよう
61設計されています。
62
63%package        devel
64Summary:        Development files for %{name}
65Summary(ja):    %{name} の開発ファイル
66License:        LGPLv3+
67Group:          Development/Libraries
68Requires:       %{name}-libs = %{version}-%{release}
69
70%description    devel
71This package contains the header files and development documentation for
72libglabels.
73
74%description -l ja devel
75このパッケージは libglabels のヘッダファイルと
76開発ドキュメントを含んでいます。
77
78
79%package        libs
80License:        LGPLv3+
81Summary:        Shared liblaries for %{name}
82Summary(ja):    %{name} の共有ライブラリ
83Group:          Development/Libraries
84
85%description    libs
86This package contains the shared libraries for %{name}.
87
88%description -l ja libs
89このパッケージは %{name} の共有ライブラリを含んでいます。
90
91
92%package        doc
93License:        GFDL
94Summary:        Runtime documentation for %{name}
95Summary(ja):    %{name} の実行ドキュメント
96Group:          Development/Libraries
97Requires(post): scrollkeeper
98Requires(postun):       scrollkeeper
99
100%description    doc
101This package contains the runtime documentation and manual pages for %{name}.
102
103%description -l ja doc
104このパッケージは %{name} の実行ドキュメントとマニュアルを含んでいます。
105
106
107%package        templates
108License:        MIT
109Summary:        The %{name} template database
110Summary(ja):    %{name} のテンプレートデータベース
111Group:          Development/Libraries
112## Needs the glabels-libs subpackage for proper ownership of the top-level
113## libglabels-3.0 directory in %%_datadir.
114Requires:       %{name}-libs
115
116%description    templates
117This package contains the template database for %{name}.
118
119%description -l ja templates
120このパッケージは %{name} のテンプレートデータベースを含んでいます。
121
122%prep
123%setup -q
124#%patch0 -p1 -b .ebook
125
126sed -i 's/Icon=glabels-3.0.png/Icon=glabels-3.0/g' \
127        data/desktop/glabels-3.0.desktop.in
128
129%build
130%configure --enable-static=no --enable-gtk-doc
131make %{?_smp_mflags}
132
133
134%install
135rm -rf %{buildroot}
136make install DESTDIR=%{buildroot}
137
138desktop-file-install                                    \
139        --vendor=""                                     \
140        --dir %{buildroot}%{_datadir}/applications      \
141        --delete-original                               \
142        %{buildroot}%{_datadir}/applications/%{name}-3.0.desktop
143
144%find_lang %{name}-3.0
145
146rm -rf %{buildroot}%{_libdir}/libglabels-3.0.la
147rm -rf %{buildroot}%{_libdir}/libglbarcode-3.0.la
148
149
150%post
151update-desktop-database &> /dev/null ||:
152update-mime-database %{_datadir}/mime &> /dev/null ||:
153
154%postun
155update-desktop-database &> /dev/null ||:
156update-mime-database %{_datadir}/mime &> /dev/null ||:
157if [ $1 -eq 0 ]; then
158        glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null ||:
159fi
160
161if [ $1 -eq 0 ] ; then
162        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
163        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
164fi
165
166
167%post   libs -p /sbin/ldconfig
168
169%postun libs -p /sbin/ldconfig
170
171
172%post   doc
173scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
174
175%postun doc
176scrollkeeper-update -q ||:
177
178%posttrans
179glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null ||:
180%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
181
182%clean
183rm -rf %{buildroot}
184
185
186%files -f %{name}-3.0.lang
187%defattr(-,root,root,-)
188%doc AUTHORS ChangeLog COPYING COPYING.README_FIRST NEWS README TODO
189%{_bindir}/glabels*
190%{_datadir}/applications/glabels-3.0.desktop
191%{_datadir}/glib-2.0/schemas/org.gnome.glabels-3.gschema.xml
192%{_datadir}/glabels-3.0/
193%{_datadir}/icons/hicolor/*/
194%{_datadir}/mime/packages/glabels-3.0.xml
195%{_datadir}/appdata/glabels-3.appdata.xml
196
197%files  devel
198%defattr(-,root,root,-)
199%doc AUTHORS COPYING-LIBS
200%doc %{_datadir}/gtk-doc/html/libglabels-3.0/
201%{_includedir}/libglabels-3.0/
202%{_includedir}/libglbarcode-3.0/
203%{_libdir}/libglabels-3.0.so
204%{_libdir}/libglbarcode-3.0.so
205%{_libdir}/pkgconfig/libglabels-3.0.pc
206%{_libdir}/pkgconfig/libglbarcode-3.0.pc
207
208%files  libs
209%defattr(-,root,root,-)
210%doc AUTHORS COPYING-LIBS
211%dir %{_datadir}/libglabels-3.0/
212%{_datadir}/glabels-3.0/
213%{_libdir}/libglabels-3.0.so.*
214%{_libdir}/libglbarcode-3.0.so.*
215
216%files  doc
217%defattr(-,root,root,-)
218## Manual ("man") pages are automatically marked as %%doc by RPM.
219%doc AUTHORS COPYING-DOCS
220%doc %{_datadir}/help/*/glabels-3.0/
221%{_mandir}/man?/glabels-3*
222%{_datadir}/gtk-doc/html/libglabels-3.0/
223%{_datadir}/gtk-doc/html/libglbarcode-3.0/
224
225%files templates
226%doc AUTHORS COPYING-TEMPLATES
227%{_datadir}/libglabels-3.0/dtd/
228%{_datadir}/libglabels-3.0/templates/
229
230
231%changelog
232* Mon May 02 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.0-1
233- new upstream release
234
235* Sat Apr 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.2.0-1
236- new upstream release
237- deleted Patch0
238- added BuildRequires: itstool
239
240* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-3
241- add Patch0 (glabels-3.0.1-ebook.patch)
242
243* Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.1-1
244- new upstream release
245- changed source archive type bz2 to xz
246- deleted Patch0
247
248* Sun Aug 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.0-2
249- added Patch0 from Fedora
250- run gtk-update-icon-cache in %%posttrans, %%postun
251
252* Sat Sep 17 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.0-1
253- new upstream release
254- changed License: GPLv2+ to GPLv3+
255- changed %%configure option
256  - deleted unrecognized option
257  - changed --disable-static to --enable-static=no
258  - added --enable-gtk-doc
259- added BuildRequires: cairo-devel >= 1.10.0, pango-devel, qrencode-devel, zint-devel
260- changed BuildRequires: gtk2-devel >= 2.22.0 to gtk3-devel >= 3.0.9
261- made -templates sub package
262- unresolved: can't appear icon on desktop file..
263
264* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-6
265- rebuild with evolution-data-server-3.1.90
266
267* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-5
268- rebuild with evolution-data-server-3.1.4
269
270* Tue Oct 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.8-4
271- rebuild with evolution-data-server-2.32.0
272
273* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.8-3
274- rebuilt with rpm-4.8.1 for pkg-config
275
276* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.8-2
277- rebuild with evolution-data-server-2.30.2
278
279* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.8-1
280- new upstream release
281- add BuildRequires: gnome-doc-utils >= 0.3.2
282
283* Wed Mar 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.7-1
284- New upstream release
285- dropt Patch0
286- added BuildRequires: libSM-devel
287
288* Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.6-1
289- New upstream release
290- changed BuildRequires: gtk2 to gtk2-devel
291- added BuildRequires: intltool
292- added Patch1 from Fedora
293
294* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.2.5-1
295- initial build for VineSeed
296
297* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 2.2.4-1
298- Update to new upstream bug-fix release (2.2.4):
299  * Corrected button order in "Open" and "Save as" dialogs.
300  * Fixed performance problem when large number of fonts are installed.
301  * Corrected several i18n problems.
302  * Fixed "paste" bug that created phantom object views.
303  * Fixed performance problem when many objects are selected.
304  * New templates. 
305
306* Tue Aug 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2.3-2
307- fix license tag (again)
308
309* Thu Aug 21 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.3-1
310- Update to new upstream bug-fix release (2.2.3).
311- Drop glabels-batch segfault patch (fixed upstream).
312  - fix-batch-segfault.patch
313
314* Fri Aug 08 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.2-3
315- Add patch from Casey Harkins to fix a segfault in glabels-batch:
316  + fix-batch-segfault.patch
317- Resolves: bug #458473.
318
319* Mon Jul 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2.2-2
320- fix license tag
321
322* Tue Mar 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.2-1
323- Update to new upstream bug-fix release (2.2.2).
324
325* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.1-2
326- Autorebuild for GCC 4.3
327
328* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.1-1
329- Update to new upstream bug-fix release (2.2.1).
330
331* Mon Jan 14 2008 Peter Gordon <peter@thecodergeek.com> - 2.2.0-1
332- Update to new upstream release (2.2.0 Final); Yay!
333
334* Sun Dec 16 2007 Peter Gordon <peter@thecodergeek.com> - 2.1.5-1
335- Update to new upstream development snapshot (2.1.5).
336
337* Tue Aug 21 2007 Peter Gordon <peter@thecodergeek.com> - 2.0.4-7
338- Rebuild with new BuildID-enabled binutils.
339
340* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 2.0.4-6
341- Update License tagging (GPLv2+). This necessitates a split of two
342  subpackages:
343  (1) glabels-doc: Runtime documentation for gLabels (GFDLv1.1+)
344  (2) glabels-libs: Shared libraries for gLabels (LGPLv2+)
345- Fix version in previous %%changelog entry.
346- Lots and lots of aesthetic spec file changes.
347- Remove X-Fedora category from desktop-file-install invocation.
348- Add TODO to installed %%doc files.
349
350* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-5
351- Add BR: perl(XML::Parser)
352 
353* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-4
354- Mass FC6 rebuild
355
356* Wed Jul 05 2006 Peter Gordon <peter@thecodergeek.com> - 2.0.4-3
357- Add BuildRequires: gettext (#197633)
358
359* Sat Feb 18 2006 Jef Spaleta <jspaleta@gmail.com> - 2.0.4-2
360- Bump for fe5 rebuild
361
362* Sun Jan 01 2006 Jef Spaleta <jspaleta@gmail.com> - 2.0.4-1
363- Update to new stable upstream version
364
365* Thu Aug 18 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-3
366- rebuild
367
368* Thu Jul 7 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-2
369- use Source0
370
371* Tue Jul 5 2005 Jef Spaleta <jspaleta@gmail.com> - 2.0.3-1
372- Initial fedora extras build
373
Note: See TracBrowser for help on using the repository browser.