source: projects/specs/trunk/g/git/git-vl.spec @ 8694

Revision 8694, 25.0 KB checked in by iwaim, 10 years ago (diff)

git 2.0.1-2

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:           git
8Version:        2.0.1
9Release:        2%{?_dist_release}
10Summary:        Core git tools
11Summary(ja):    Core git ツール
12License:        GPLv2
13Group:          Development/Tools
14URL:            http://git-scm.com/
15Source:         http://git-core.googlecode.com/files/%{name}-%{version}.tar.xz
16Source1:        vine-default-git.el
17Source2:        git.xinetd
18Source3:        git.conf.httpd
19Source4:        gitweb.conf.in
20Source10:       %{name}-install.sh
21Source11:       %{name}-remove.sh
22Source12:       git-init.el
23Patch0:         git-1.5-gitweb-home-link.patch
24
25# Security
26# none
27
28BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel,
29BuildRequires:  expat-devel, gettext, asciidoc
30BuildRequires:  pcre-devel
31BuildRequires:  xmlto
32BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
33
34Requires:       perl-Git = %{version}-%{release}
35Requires:       zlib
36Provides:       git-core = %{version}-%{release}
37Obsoletes:      git-core <= 1.5.4.3
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       iwaim
42
43%description
44Git is a fast, scalable, distributed revision control system with an
45unusually rich command set that provides both high-level operations
46and full access to internals.
47
48The git rpm installs the core tools with minimal dependencies.  To
49install all git packages, including tools for integrating with other
50SCMs, install the git-all meta-package.
51
52%package all
53Summary:        Meta-package to pull in all git tools
54Summary(ja):    すべての git ツール
55Group:          Development/Tools
56Requires:       git = %{version}-%{release}
57Requires:       git-svn = %{version}-%{release}
58Requires:       git-cvs = %{version}-%{release}
59%if "%{?_dist_release}" != "vl4" && %{with arch}
60Requires:       git-arch = %{version}-%{release}
61%endif
62Requires:       git-email = %{version}-%{release}
63Requires:       gitk = %{version}-%{release}
64Requires:       git-gui = %{version}-%{release}
65Requires:       perl-Git = %{version}-%{release}
66Requires:       emacs-git = %{version}-%{release}
67Requires:       git-contrib = %{version}-%{release}
68Obsoletes:      git <= 1.5.4.3
69
70%description all
71Git is a fast, scalable, distributed revision control system with an
72unusually rich command set that provides both high-level operations
73and full access to internals.
74
75This is a dummy package which brings in all subpackages.
76
77%package daemon
78Summary:        Git protocol daemon
79Summary(ja):    Git プロトコルデーモン
80Group:          Development/Tools
81Requires:       git = %{version}-%{release}
82%description daemon
83The git daemon for supporting git:// access to git repositories
84
85%package -n gitweb
86Summary:        Simple web interface to git repositories
87Summary(ja):    git リポジトリへのシンプルな Web インタフェース
88Group:          Development/Tools
89Requires:       git = %{version}-%{release}
90
91%description -n gitweb
92Simple web interface to track changes in git repositories
93
94
95%package svn
96Summary:        Git tools for importing Subversion repositories
97Summary(ja):    Subversion リポジトリを git へインポートするためのツール
98Group:          Development/Tools
99Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
100Requires:       perl(SVN::Core)
101%description svn
102Git tools for importing Subversion repositories.
103
104%package cvs
105Summary:        Git tools for importing CVS repositories
106Summary(ja):    CVS リポジトリを git へインポートするためのツール
107Group:          Development/Tools
108Requires:       git = %{version}-%{release}, cvs, cvsps
109%description cvs
110Git tools for importing CVS repositories.
111
112%package contrib
113Summary:        Git contrib tools
114Group:          Development/Tools
115Requires:       git = %{version}-%{release}
116%description contrib
117Git contrib tools
118
119%if "%{?_dist_release}" != "vl4" && %{with arch}
120%package arch
121Summary:        Git tools for importing Arch repositories
122Summary(ja):    Arch リポジトリを git へインポートするためのツール
123Group:          Development/Tools
124Requires:       git = %{version}-%{release}, tla
125%description arch
126Git tools for importing Arch repositories.
127%endif
128
129%package email
130Summary:        Git tools for sending email
131Summary(ja):    Eメールを送るための git ツール
132Group:          Development/Tools
133Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
134%description email
135Git tools for sending email.
136
137%package gui
138Summary:        Git GUI tool
139Summary(ja):    Git の GUI ツール
140Group:          Development/Tools
141Requires:       git = %{version}-%{release}, tk
142%description gui
143Git GUI tool.
144
145%package -n gitk
146Summary:        Git revision tree visualiser
147Summary(ja):    Git リビジョンツリー可視化ツール
148Group:          Development/Tools
149Requires:       git = %{version}-%{release}, tk
150%description -n gitk
151Git revision tree visualiser.
152
153%package -n perl-Git
154Summary:        Perl interface to Git
155Summary(ja):    Git の perl インタフェース
156Group:          Development/Libraries
157Requires:       git = %{version}-%{release}, perl(Error)
158%if "%{?_dist_release}" == "vl4"
159Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
160%else
161Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
162%endif
163#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
164
165%description -n perl-Git
166Perl interface to Git.
167
168%package -n emacs-git
169Summary:       Git version control system support for Emacs
170Summary(ja):   Emacs の Git サポート
171Group:         Applications/Editors
172Requires:      git = %{version}-%{release}, emacsen-common
173
174%description -n emacs-git
175%{summary}.
176
177%package devel
178Summary:        Header files for git-core
179Summary(ja):    git-core 用ヘッダファイル
180Group:          Development/Libraries
181
182%description devel
183Header files for git-core.
184
185%prep
186%setup -q
187%patch0 -p1
188%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
189
190# Filter bogus perl requires
191cat << \EOF > %{name}-req
192#!/bin/sh
193%{__perl_requires} $* |\
194sed -e '/perl(packed-refs)/d'
195EOF
196
197%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
198chmod +x %{__perl_requires}     
199
200%build
201make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
202     ETC_GITCONFIG=/etc/gitconfig \
203     USE_LIBPCRE=1 \
204     GITWEB_PROJECTROOT=/var/lib/git \
205     gitwebdir=/var/www/git \
206     prefix=%{_prefix} all %{!?_without_docs: doc}
207
208%install
209rm -rf $RPM_BUILD_ROOT
210make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
211     prefix=%{_prefix} mandir=%{_mandir} \
212     ETC_GITCONFIG=/etc/gitconfig \
213     USE_LIBPCRE=1 \
214     NO_PYTHON=1 \
215     GITWEB_PROJECTROOT=/var/lib/git \
216     gitwebdir=/var/www/git \
217     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
218
219# perl-Git
220# Error.pm provide by perl-Error package
221rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
222
223# emacs-git
224mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
225#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
226#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
227mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
228mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
229
230# install el files
231install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
232
233# install vine-default file
234install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
235
236# install  script( bytecompile el and install elc , remove )   
237
238%_installemacsenscript git %{SOURCE10}
239
240%_removeemacsenscript  git %{SOURCE11}
241
242mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
243mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
244install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
245perl -p \
246     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
247     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
248     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
249
250## for gitweb sub package
251mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
252install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
253sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
254    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
255
256find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
257find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
258find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
259
260(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
261(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
262%if %{!?_without_docs:1}0
263(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
264%else
265rm -rf $RPM_BUILD_ROOT%{_mandir}
266%endif
267mkdir -p $RPM_BUILD_ROOT/srv/git
268
269mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
270install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
271
272install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
273
274# header files and lib
275install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
276install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
277install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
278install libgit.a $RPM_BUILD_ROOT%{_libdir}
279install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
280
281
282%clean
283rm -rf $RPM_BUILD_ROOT
284
285%post -n emacs-git
286
287# bytecompile and install
288
289if [ "$1" = 2 ]; then
290
291%_emacsenPackageRemove git
292
293fi
294
295%_addemacsenlist git
296
297%_emacsenPackageInstall git
298
299%preun -n emacs-git
300
301if [ "$1" = 0 ]; then
302
303%_emacsenPackageRemove git
304
305%_removeemacsenlist git
306
307fi
308
309
310%files -f bin-man-doc-files
311%defattr(-,root,root)
312%{_bindir}/git
313%{_bindir}/git-receive-pack
314%{_bindir}/git-upload-archive
315%{_bindir}/git-upload-pack
316%{_bindir}/git-shell
317%{_datadir}/git-core/
318%doc README COPYING Documentation/*.txt contrib/hooks
319%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
320%{!?_without_docs: %doc Documentation/howto Documentation/technical}
321%{_sysconfdir}/bash_completion.d
322
323
324%files svn
325%defattr(-,root,root)
326%{_libexecdir}/git-core/*svn*
327%doc Documentation/*svn*.txt
328%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
329%{!?_without_docs: %doc Documentation/*svn*.html }
330
331%files cvs
332%defattr(-,root,root)
333%doc Documentation/*git-cvs*.txt
334%{_bindir}/git-cvsserver
335%{_libexecdir}/git-core/*cvs*
336%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
337%{!?_without_docs: %doc Documentation/*git-cvs*.html }
338
339%files contrib
340%defattr(-,root,root)
341%doc diff-highlight/README.diff-highlight
342%{_bindir}/diff-highlight
343
344%if "%{?_dist_release}" != "vl4" && %{with arch}
345%files arch
346%defattr(-,root,root)
347%doc Documentation/git-archimport.txt
348%{_libexecdir}/git-core/git-archimport
349%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
350%{!?_without_docs: %doc Documentation/git-archimport.html }
351%endif
352
353%files email
354%defattr(-,root,root)
355%doc Documentation/*email*.txt
356%{_libexecdir}/git-core/*email*
357%{!?_without_docs: %{_mandir}/man1/*email*.1*}
358%{!?_without_docs: %doc Documentation/*email*.html }
359
360%files gui
361%defattr(-,root,root)
362%{_libexecdir}/git-core/git-gui*
363%{_libexecdir}/git-core/git-citool
364%{_datadir}/git-gui/
365%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
366%{!?_without_docs: %doc Documentation/git-gui.html}
367%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
368%{!?_without_docs: %doc Documentation/git-citool.html}
369
370%files -n gitk
371%defattr(-,root,root)
372%doc Documentation/*gitk*.txt
373%{_bindir}/gitk
374%{_datadir}/gitk
375%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
376%{!?_without_docs: %doc Documentation/*gitk*.html }
377
378%files -n perl-Git -f perl-files
379%defattr(-,root,root)
380
381%files -n emacs-git
382%defattr(-,root,root)
383%{_datadir}/emacs/site-lisp/git
384#%{_libdir}/emacsen-common/packages/install/git
385#%{_libdir}/emacsen-common/packages/remove/git
386%{emacsen_pkgdir}/install/git
387%{emacsen_pkgdir}/remove/git
388
389%files daemon
390%defattr(-,root,root)
391%{_var}/lib/git
392%{_libexecdir}/git-core/git-daemon
393%config(noreplace)%{_sysconfdir}/xinetd.d/git
394/srv/git
395
396%files -n gitweb
397%defattr(-,root,root)
398%doc gitweb/README
399/var/www/git/
400%config(noreplace)%{_sysconfdir}/gitweb.conf
401%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
402
403%files devel
404%defattr(644,root,root,755)
405%{_includedir}/git
406%{_libdir}/libgit.a
407%{_libdir}/libgit_xdiff.a
408
409
410%files all
411# No files for you!
412
413%changelog
414* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
415- build with Perl 5.16
416
417* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
418- update to 2.0.1
419- add "%%bcond_with arch": no create git-arch sub package by default
420
421* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
422- update to 1.9.2
423
424* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
425- update to 1.8.5.2
426
427* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
428- update to 1.8.4.4
429- new sub package: contrib
430
431* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
432- new upstream release
433
434* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
435- new upstream release
436
437* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
438- new upstream release
439
440* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
441- new upstream release
442
443* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
444- new upstream release
445
446* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
447- new upstream release
448
449* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
450- new upstream release
451- enable libpcre support, add BR: pcre-devel
452- add /etc/gitweb.conf
453- add /var/lib/git for PROJECTROOT
454
455* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
456- new upstream release
457
458* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
459- new upstream release
460
461* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
462- new upstream release
463
464* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
465- new upstream release
466
467* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
468- build with perl 5.12.3
469
470* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
471- new upstream release
472- build with openssl 1.0.0c for VineSeed
473
474* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
475- new upstream release: include security fix: CVE-2010-3906
476
477* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
478- new upstream release
479- drop CVE-2010-2542 patch (Patch100): upstream fixed
480- apply vine-default
481 - rename Source1: git-init.el -> vine-default-git.el
482 - add new git-init.el file (Source12)
483 - update git-install.sh
484- update %%build and %%install section for gitweb subpackage
485- add README in gitweb subpackage
486
487* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
488- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
489
490* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
491- new upstream release
492- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
493- disable building of unused python remote helper libs
494
495* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
496- new upstream release with security fix
497- drop patch10 (included in new release)
498
499* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
500- new upstream release
501- add patch10 git daemon extra arg parsing fix
502
503* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
504- fix install script for Emacs Lisp: <BTS:VineLinux:685>
505 - update git-install.sh (Source10) using contributed patch
506
507* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
508- new upstream release
509
510* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
511- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
512- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
513- fix summary and description in daemon sub package
514
515* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
516- drop Error.pm: provide by perl-Error package
517
518* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
519- new upstream relase
520- update URL tag
521- add Requires: perl(SVN::Core) for svn subpackage
522
523* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
524- add git-shell in git package
525- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
526
527* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
528- added BuildRequires: xmlto
529
530* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
531- new upstream release
532- add devel subpackage (see [wishes:0165])
533
534* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
535- new upstream release
536
537* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
538- new upstream release
539
540* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
541- new upstream release
542
543* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
544- use %%emacsen_pkgdir macro
545
546* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
547- new upstream release
548
549* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
550- initial build for Vine Linux
551
552* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
553- git-1.5.6.4
554
555* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
556- git-1.5.6
557
558* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
559- use tar.bz2 instead of tar.gz
560
561* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
562- git-1.5.5.3
563
564* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
565- git-1.5.5.2
566
567* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
568- git-1.5.5.1
569
570* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
571- git-1.5.5
572
573* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
574- Remove the last two requires on git-core.
575
576* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
577- Remove a patch that's already upstream.
578
579* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
580- git-1.5.4.5
581
582* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
583- Own /etc/bash_completion.d in case bash-completion isn't installed.
584
585* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
586- Include the sample hooks from contrib/hooks as docs (bug 321151).
587- Install the bash completion script from contrib (bug 433255).
588- Include the html docs in the 'core' package again (bug 434271).
589
590* Wed Mar 19 2008 James Bowes 1.5.4.4-2
591- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
592
593* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
594- git-1.5.4.4
595
596* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
597- rebuild for new perl (again)
598
599* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
600- Do not silently overwrite /etc/httpd/conf.d/git.conf
601
602* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
603- git-1.5.4.3
604- Include Kristian Høgsberg's changes to rename git-core to
605  git and git to git-all.
606
607* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
608- git-1.5.4.2
609
610* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
611- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
612  gitweb rss feeds point be commitdiffs instead of commit
613
614* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
615- git-1.5.4.1
616
617* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
618- rebuild for new perl
619
620* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
621- Add BuidRequires on gettext.
622
623* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
624- git-1.5.4
625
626* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
627- git-1.5.3.8
628
629* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
630- Have git metapackage require explicit versions (bug 247214)
631
632* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
633- git-1.5.3.7
634
635* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
636- git-1.5.3.6
637- git-core requires perl(Error) (bug 367861)
638- git-svn requires perl(Term:ReadKey) (bug 261361)
639- git-email requires perl-Git (bug 333061)
640
641* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
642- git-Perl requires Error package
643
644* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
645- git-1.5.3.4
646
647* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
648- git-1.5.3.3
649
650* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
651- git-1.5.3.2
652
653* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
654- Include git-gui and git-citool docs
655
656* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
657- git-1.5.3.1-1
658
659* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
660- git-1.5.2.5-1
661
662* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
663- git-1.5.2.4-1
664
665* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
666- Add git-daemon and gitweb packages
667
668* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
669- Add emacs-git package (#235431)
670
671* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
672- git-1.5.2.2
673
674* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
675- git-1.5.2.1
676
677* Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
678- Added lib files for git-gui
679- Added Documentation/technical (As needed by Git Users Manual)
680
681* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
682- Added howto files
683
684* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
685- git-1.5.0.6
686
687* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
688- git-1.5.0.5
689
690* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
691- git-1.5.0.3
692
693* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
694- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
695
696* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
697- git-1.5.0.2
698
699* Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
700- Update core package description (Git isn't as stupid as it used to be)
701
702* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
703- Add git-gui and git-citool.
704
705* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
706- no need to install manpages executable (bz 216790)
707- use bytes for git-cvsserver
708
709* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
710- git-1.4.4.2
711
712* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
713- rebuild against the new curl
714
715* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
716- git-1.4.2.4
717
718* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
719- git-1.4.2.3
720
721* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
722- git-1.4.2.1
723
724* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
725- git-1.4.2
726
727* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
728- git-1.4.1
729
730* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
731- git-1.4.0
732
733* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
734- git-1.3.3
735- enable git-email building, prereqs have been relaxed
736
737* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
738- git-1.3.2
739
740* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
741- git-1.3.1
742
743* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
744- git-1.3.0
745
746* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
747- git-1.2.6
748
749* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
750- git-1.2.5
751
752* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
753- git-1.2.4
754
755* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
756- git-1.2.3
757
758* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
759- git-1.2.2
760
761* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
762- git-1.2.1
763
764* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
765- git-1.2.0
766
767* Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
768- git-1.1.6
769
770* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
771- git-1.1.4
772
773* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
774- git-1.1.2
775
776* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
777- git-1.1.1
778
779* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
780- Update to latest git-1.1.0 (drop git-email for now)
781- Now creates multiple packages:
782-        git-core, git-svn, git-cvs, git-arch, gitk
783
784* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
785- Change subpackage names to git-<name> instead of git-core-<name>
786- Create empty root package which brings in all subpackages
787- Rename git-tk -> gitk
788
789* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
790- zlib dependency fix
791- Minor cleanups from split
792- Move arch import to separate package as well
793
794* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
795- Move programs with non-standard dependencies (svn, cvs, email)
796  into separate packages
797
798* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
799- parallelize build
800- COPTS -> CFLAGS
801
802* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
803- update to 0.99.6
804
805* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
806- Linus noticed that less is required, added to the dependencies
807
808* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
809- Updated dependencies
810- Don't assume manpages are gzipped
811
812* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
813- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
814- use RPM_OPT_FLAGS in spec file, drop patch0
815
816* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
817- use dist tag to differentiate between branches
818- use rpm optflags by default (patch0)
819- own %{_datadir}/git-core/
820
821* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
822- update spec file to fix Buildroot, Requires, and drop Vendor
823
824* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
825- Redid the description
826- Cut overlong make line, loosened changelog a bit
827- I think Junio (or perhaps OSDL?) should be vendor...
828
829* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
830- Add the man pages, and the --without docs build option
831
832* Wed Jul 7 2005 Chris Wright <chris@osdl.org>
833- initial git spec file
Note: See TracBrowser for help on using the repository browser.