source: projects/specs/trunk/g/git/git-vl.spec @ 521

Revision 521, 21.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4# Pass --without docs to rpmbuild if you don't want the documentation
5Name:           git
6Version:        1.6.3.3
7Release:        1%{?_dist_release}
8Summary:        Core git tools
9Summary(ja):    Core git ツール
10License:        GPLv2
11Group:          Development/Tools
12URL:            http://git-scm.com/
13Source:         http://kernel.org/pub/software/scm/git/%{name}-%{version}.tar.bz2
14Source1:        git-init.el
15Source2:        git.xinetd
16Source3:        git.conf.httpd
17Source10:       %{name}-install.sh
18Source11:       %{name}-remove.sh
19Patch0:         git-1.5-gitweb-home-link.patch
20# Patch10:      git-1.6_git-daemon-fix.patch
21
22BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel,
23BuildRequires:  expat-devel, gettext, asciidoc
24BuildRequires:  xmlto
25BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
26
27Requires:       perl-Git = %{version}-%{release}
28Requires:       zlib
29Provides:       git-core = %{version}-%{release}
30Obsoletes:      git-core <= 1.5.4.3
31
32%description
33Git is a fast, scalable, distributed revision control system with an
34unusually rich command set that provides both high-level operations
35and full access to internals.
36
37The git rpm installs the core tools with minimal dependencies.  To
38install all git packages, including tools for integrating with other
39SCMs, install the git-all meta-package.
40
41%package all
42Summary:        Meta-package to pull in all git tools
43Summary(ja):    すべての git ツール
44Group:          Development/Tools
45Requires:       git = %{version}-%{release}
46Requires:       git-svn = %{version}-%{release}
47Requires:       git-cvs = %{version}-%{release}
48%if "%{?_dist_release}" != "vl4"
49Requires:       git-arch = %{version}-%{release}
50%endif
51Requires:       git-email = %{version}-%{release}
52Requires:       gitk = %{version}-%{release}
53Requires:       git-gui = %{version}-%{release}
54Requires:       perl-Git = %{version}-%{release}
55Requires:       emacs-git = %{version}-%{release}
56Obsoletes:      git <= 1.5.4.3
57
58%description all
59Git is a fast, scalable, distributed revision control system with an
60unusually rich command set that provides both high-level operations
61and full access to internals.
62
63This is a dummy package which brings in all subpackages.
64
65%package daemon
66Summary:        Git protocol daemon
67Summary(ja):    Git プロトコルデーモン
68Group:          Development/Tools
69Requires:       git = %{version}-%{release}
70%description daemon
71The git daemon for supporting git:// access to git repositories
72
73%package -n gitweb
74Summary:        Simple web interface to git repositories
75Summary(ja):    git リポジトリへのシンプルな Web インタフェース
76Group:          Development/Tools
77Requires:       git = %{version}-%{release}
78
79%description -n gitweb
80Simple web interface to track changes in git repositories
81
82
83%package svn
84Summary:        Git tools for importing Subversion repositories
85Summary(ja):    Subversion リポジトリを git へインポートするためのツール
86Group:          Development/Tools
87Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
88Requires:       perl(SVN::Core)
89%description svn
90Git tools for importing Subversion repositories.
91
92%package cvs
93Summary:        Git tools for importing CVS repositories
94Summary(ja):    CVS リポジトリを git へインポートするためのツール
95Group:          Development/Tools
96Requires:       git = %{version}-%{release}, cvs, cvsps
97%description cvs
98Git tools for importing CVS repositories.
99
100%if "%{?_dist_release}" != "vl4"
101%package arch
102Summary:        Git tools for importing Arch repositories
103Summary(ja):    Arch リポジトリを git へインポートするためのツール
104Group:          Development/Tools
105Requires:       git = %{version}-%{release}, tla
106%description arch
107Git tools for importing Arch repositories.
108%endif
109
110%package email
111Summary:        Git tools for sending email
112Summary(ja):    Eメールを送るための git ツール
113Group:          Development/Tools
114Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
115%description email
116Git tools for sending email.
117
118%package gui
119Summary:        Git GUI tool
120Summary(ja):    Git の GUI ツール
121Group:          Development/Tools
122Requires:       git = %{version}-%{release}, tk
123%description gui
124Git GUI tool.
125
126%package -n gitk
127Summary:        Git revision tree visualiser
128Summary(ja):    Git リビジョンツリー可視化ツール
129Group:          Development/Tools
130Requires:       git = %{version}-%{release}, tk
131%description -n gitk
132Git revision tree visualiser.
133
134%package -n perl-Git
135Summary:        Perl interface to Git
136Summary(ja):    Git の perl インタフェース
137Group:          Development/Libraries
138Requires:       git = %{version}-%{release}, perl(Error)
139%if "%{?_dist_release}" == "vl4"
140Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
141%else
142Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
143%endif
144#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
145
146%description -n perl-Git
147Perl interface to Git.
148
149%package -n emacs-git
150Summary:       Git version control system support for Emacs
151Summary(ja):   Emacs の Git サポート
152Group:         Applications/Editors
153Requires:      git = %{version}-%{release}, emacsen-common
154
155%description -n emacs-git
156%{summary}.
157
158%package devel
159Summary:        Header files for git-core
160Summary(ja):    git-core 用ヘッダファイル
161Group:          Development/Libraries
162
163%description devel
164Header files for git-core.
165
166%prep
167%setup -q
168%patch0 -p1
169
170# %patch10 -p1 -b .git-daemon-fix
171
172%build
173make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
174     ETC_GITCONFIG=/etc/gitconfig \
175     prefix=%{_prefix} all %{!?_without_docs: doc}
176
177%install
178rm -rf $RPM_BUILD_ROOT
179make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
180     prefix=%{_prefix} mandir=%{_mandir} \
181     ETC_GITCONFIG=/etc/gitconfig \
182     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
183
184# perl-Git
185# Error.pm provide by perl-Error package
186rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
187
188# emacs-git
189mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
190#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
191#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
192mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
193mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
194
195# install el files
196install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
197
198# install site-start file
199install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
200
201# install  script( bytecompile el and install elc , remove )   
202
203%_installemacsenscript git %{SOURCE10}
204
205%_removeemacsenscript  git %{SOURCE11}
206
207mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
208install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
209mkdir -p $RPM_BUILD_ROOT/var/www/git
210install -m 644 -t $RPM_BUILD_ROOT/var/www/git gitweb/*.png gitweb/*.css
211install -m 755 -t $RPM_BUILD_ROOT/var/www/git gitweb/gitweb.cgi
212mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
213install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
214
215find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
216find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
217find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
218
219(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
220(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
221%if %{!?_without_docs:1}0
222(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
223%else
224rm -rf $RPM_BUILD_ROOT%{_mandir}
225%endif
226mkdir -p $RPM_BUILD_ROOT/srv/git
227
228mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
229install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
230
231# header files and lib
232install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
233install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
234install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
235install libgit.a $RPM_BUILD_ROOT%{_libdir}
236install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
237
238
239%clean
240rm -rf $RPM_BUILD_ROOT
241
242%post -n emacs-git
243
244# bytecompile and install
245
246if [ "$1" = 2 ]; then
247
248%_emacsenPackageRemove git
249
250fi
251
252%_addemacsenlist git
253
254%_emacsenPackageInstall git
255
256%preun -n emacs-git
257
258if [ "$1" = 0 ]; then
259
260%_emacsenPackageRemove git
261
262%_removeemacsenlist git
263
264fi
265
266
267%files -f bin-man-doc-files
268%defattr(-,root,root)
269%{_bindir}/git
270%{_bindir}/git-receive-pack
271%{_bindir}/git-upload-archive
272%{_bindir}/git-upload-pack
273%{_bindir}/git-shell
274%{_datadir}/git-core/
275%doc README COPYING Documentation/*.txt contrib/hooks
276%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
277%{!?_without_docs: %doc Documentation/howto Documentation/technical}
278%{_sysconfdir}/bash_completion.d
279
280
281%files svn
282%defattr(-,root,root)
283%{_libexecdir}/git-core/*svn*
284%doc Documentation/*svn*.txt
285%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
286%{!?_without_docs: %doc Documentation/*svn*.html }
287
288%files cvs
289%defattr(-,root,root)
290%doc Documentation/*git-cvs*.txt
291%{_bindir}/git-cvsserver
292%{_libexecdir}/git-core/*cvs*
293%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
294%{!?_without_docs: %doc Documentation/*git-cvs*.html }
295
296%if "%{?_dist_release}" != "vl4"
297%files arch
298%defattr(-,root,root)
299%doc Documentation/git-archimport.txt
300%{_libexecdir}/git-core/git-archimport
301%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
302%{!?_without_docs: %doc Documentation/git-archimport.html }
303%endif
304
305%files email
306%defattr(-,root,root)
307%doc Documentation/*email*.txt
308%{_libexecdir}/git-core/*email*
309%{!?_without_docs: %{_mandir}/man1/*email*.1*}
310%{!?_without_docs: %doc Documentation/*email*.html }
311
312%files gui
313%defattr(-,root,root)
314%{_libexecdir}/git-core/git-gui*
315%{_libexecdir}/git-core/git-citool
316%{_datadir}/git-gui/
317%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
318%{!?_without_docs: %doc Documentation/git-gui.html}
319%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
320%{!?_without_docs: %doc Documentation/git-citool.html}
321
322%files -n gitk
323%defattr(-,root,root)
324%doc Documentation/*gitk*.txt
325%{_bindir}/gitk
326%{_datadir}/gitk
327%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
328%{!?_without_docs: %doc Documentation/*gitk*.html }
329
330%files -n perl-Git -f perl-files
331%defattr(-,root,root)
332
333%files -n emacs-git
334%defattr(-,root,root)
335%{_datadir}/emacs/site-lisp/git
336#%{_libdir}/emacsen-common/packages/install/git
337#%{_libdir}/emacsen-common/packages/remove/git
338%{emacsen_pkgdir}/install/git
339%{emacsen_pkgdir}/remove/git
340
341%files daemon
342%defattr(-,root,root)
343%{_libexecdir}/git-core/git-daemon
344%config(noreplace)%{_sysconfdir}/xinetd.d/git
345/srv/git
346
347%files -n gitweb
348%defattr(-,root,root)
349/var/www/git/
350%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
351
352%files devel
353%defattr(644,root,root,755)
354%{_includedir}/git
355%{_libdir}/libgit.a
356%{_libdir}/libgit_xdiff.a
357
358
359%files all
360# No files for you!
361
362%changelog
363* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
364- new upstream release with security fix
365- drop patch10 (included in new release)
366
367* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
368- new upstream release
369- add patch10 git daemon extra arg parsing fix
370
371* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
372- fix install script for Emacs Lisp: <BTS:VineLinux:685>
373 - update git-install.sh (Source10) using contributed patch
374
375* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
376- new upstream release
377
378* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
379- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
380- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
381- fix summary and description in daemon sub package
382
383* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
384- drop Error.pm: provide by perl-Error package
385
386* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
387- new upstream relase
388- update URL tag
389- add Requires: perl(SVN::Core) for svn subpackage
390
391* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
392- add git-shell in git package
393- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
394
395* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
396- added BuildRequires: xmlto
397
398* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
399- new upstream release
400- add devel subpackage (see [wishes:0165])
401
402* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
403- new upstream release
404
405* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
406- new upstream release
407
408* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
409- new upstream release
410
411* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
412- use %%emacsen_pkgdir macro
413
414* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
415- new upstream release
416
417* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
418- initial build for Vine Linux
419
420* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
421- git-1.5.6.4
422
423* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
424- git-1.5.6
425
426* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
427- use tar.bz2 instead of tar.gz
428
429* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
430- git-1.5.5.3
431
432* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
433- git-1.5.5.2
434
435* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
436- git-1.5.5.1
437
438* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
439- git-1.5.5
440
441* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
442- Remove the last two requires on git-core.
443
444* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
445- Remove a patch that's already upstream.
446
447* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
448- git-1.5.4.5
449
450* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
451- Own /etc/bash_completion.d in case bash-completion isn't installed.
452
453* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
454- Include the sample hooks from contrib/hooks as docs (bug 321151).
455- Install the bash completion script from contrib (bug 433255).
456- Include the html docs in the 'core' package again (bug 434271).
457
458* Wed Mar 19 2008 James Bowes 1.5.4.4-2
459- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
460
461* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
462- git-1.5.4.4
463
464* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
465- rebuild for new perl (again)
466
467* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
468- Do not silently overwrite /etc/httpd/conf.d/git.conf
469
470* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
471- git-1.5.4.3
472- Include Kristian Høgsberg's changes to rename git-core to
473  git and git to git-all.
474
475* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
476- git-1.5.4.2
477
478* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
479- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
480  gitweb rss feeds point be commitdiffs instead of commit
481
482* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
483- git-1.5.4.1
484
485* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
486- rebuild for new perl
487
488* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
489- Add BuidRequires on gettext.
490
491* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
492- git-1.5.4
493
494* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
495- git-1.5.3.8
496
497* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
498- Have git metapackage require explicit versions (bug 247214)
499
500* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
501- git-1.5.3.7
502
503* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
504- git-1.5.3.6
505- git-core requires perl(Error) (bug 367861)
506- git-svn requires perl(Term:ReadKey) (bug 261361)
507- git-email requires perl-Git (bug 333061)
508
509* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
510- git-Perl requires Error package
511
512* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
513- git-1.5.3.4
514
515* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
516- git-1.5.3.3
517
518* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
519- git-1.5.3.2
520
521* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
522- Include git-gui and git-citool docs
523
524* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
525- git-1.5.3.1-1
526
527* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
528- git-1.5.2.5-1
529
530* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
531- git-1.5.2.4-1
532
533* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
534- Add git-daemon and gitweb packages
535
536* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
537- Add emacs-git package (#235431)
538
539* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
540- git-1.5.2.2
541
542* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
543- git-1.5.2.1
544
545* Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
546- Added lib files for git-gui
547- Added Documentation/technical (As needed by Git Users Manual)
548
549* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
550- Added howto files
551
552* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
553- git-1.5.0.6
554
555* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
556- git-1.5.0.5
557
558* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
559- git-1.5.0.3
560
561* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
562- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
563
564* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
565- git-1.5.0.2
566
567* Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
568- Update core package description (Git isn't as stupid as it used to be)
569
570* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
571- Add git-gui and git-citool.
572
573* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
574- no need to install manpages executable (bz 216790)
575- use bytes for git-cvsserver
576
577* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
578- git-1.4.4.2
579
580* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
581- rebuild against the new curl
582
583* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
584- git-1.4.2.4
585
586* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
587- git-1.4.2.3
588
589* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
590- git-1.4.2.1
591
592* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
593- git-1.4.2
594
595* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
596- git-1.4.1
597
598* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
599- git-1.4.0
600
601* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
602- git-1.3.3
603- enable git-email building, prereqs have been relaxed
604
605* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
606- git-1.3.2
607
608* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
609- git-1.3.1
610
611* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
612- git-1.3.0
613
614* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
615- git-1.2.6
616
617* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
618- git-1.2.5
619
620* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
621- git-1.2.4
622
623* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
624- git-1.2.3
625
626* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
627- git-1.2.2
628
629* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
630- git-1.2.1
631
632* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
633- git-1.2.0
634
635* Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
636- git-1.1.6
637
638* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
639- git-1.1.4
640
641* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
642- git-1.1.2
643
644* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
645- git-1.1.1
646
647* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
648- Update to latest git-1.1.0 (drop git-email for now)
649- Now creates multiple packages:
650-        git-core, git-svn, git-cvs, git-arch, gitk
651
652* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
653- Change subpackage names to git-<name> instead of git-core-<name>
654- Create empty root package which brings in all subpackages
655- Rename git-tk -> gitk
656
657* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
658- zlib dependency fix
659- Minor cleanups from split
660- Move arch import to separate package as well
661
662* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
663- Move programs with non-standard dependencies (svn, cvs, email)
664  into separate packages
665
666* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
667- parallelize build
668- COPTS -> CFLAGS
669
670* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
671- update to 0.99.6
672
673* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
674- Linus noticed that less is required, added to the dependencies
675
676* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
677- Updated dependencies
678- Don't assume manpages are gzipped
679
680* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
681- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
682- use RPM_OPT_FLAGS in spec file, drop patch0
683
684* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
685- use dist tag to differentiate between branches
686- use rpm optflags by default (patch0)
687- own %{_datadir}/git-core/
688
689* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
690- update spec file to fix Buildroot, Requires, and drop Vendor
691
692* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
693- Redid the description
694- Cut overlong make line, loosened changelog a bit
695- I think Junio (or perhaps OSDL?) should be vendor...
696
697* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
698- Add the man pages, and the --without docs build option
699
700* Wed Jul 7 2005 Chris Wright <chris@osdl.org>
701- initial git spec file
Note: See TracBrowser for help on using the repository browser.