source: projects/specs/trunk/g/git/git-vl.spec @ 8365

Revision 8365, 24.6 KB checked in by daisuke, 10 years ago (diff)

git: update to 1.9.2

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4# Pass --without docs to rpmbuild if you don't want the documentation
5Name:           git
6Version:        1.9.2
7Release:        1%{?_dist_release}
8Summary:        Core git tools
9Summary(ja):    Core git ツール
10License:        GPLv2
11Group:          Development/Tools
12URL:            http://git-scm.com/
13Source:         http://git-core.googlecode.com/files/%{name}-%{version}.tar.bz2
14Source1:        vine-default-git.el
15Source2:        git.xinetd
16Source3:        git.conf.httpd
17Source4:        gitweb.conf.in
18Source10:       %{name}-install.sh
19Source11:       %{name}-remove.sh
20Source12:       git-init.el
21Patch0:         git-1.5-gitweb-home-link.patch
22
23# Security
24# none
25
26BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel,
27BuildRequires:  expat-devel, gettext, asciidoc
28BuildRequires:  pcre-devel
29BuildRequires:  xmlto
30BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
31
32Requires:       perl-Git = %{version}-%{release}
33Requires:       zlib
34Provides:       git-core = %{version}-%{release}
35Obsoletes:      git-core <= 1.5.4.3
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39Packager:       iwaim
40
41%description
42Git is a fast, scalable, distributed revision control system with an
43unusually rich command set that provides both high-level operations
44and full access to internals.
45
46The git rpm installs the core tools with minimal dependencies.  To
47install all git packages, including tools for integrating with other
48SCMs, install the git-all meta-package.
49
50%package all
51Summary:        Meta-package to pull in all git tools
52Summary(ja):    すべての git ツール
53Group:          Development/Tools
54Requires:       git = %{version}-%{release}
55Requires:       git-svn = %{version}-%{release}
56Requires:       git-cvs = %{version}-%{release}
57%if "%{?_dist_release}" != "vl4"
58Requires:       git-arch = %{version}-%{release}
59%endif
60Requires:       git-email = %{version}-%{release}
61Requires:       gitk = %{version}-%{release}
62Requires:       git-gui = %{version}-%{release}
63Requires:       perl-Git = %{version}-%{release}
64Requires:       emacs-git = %{version}-%{release}
65Requires:       git-contrib = %{version}-%{release}
66Obsoletes:      git <= 1.5.4.3
67
68%description all
69Git is a fast, scalable, distributed revision control system with an
70unusually rich command set that provides both high-level operations
71and full access to internals.
72
73This is a dummy package which brings in all subpackages.
74
75%package daemon
76Summary:        Git protocol daemon
77Summary(ja):    Git プロトコルデーモン
78Group:          Development/Tools
79Requires:       git = %{version}-%{release}
80%description daemon
81The git daemon for supporting git:// access to git repositories
82
83%package -n gitweb
84Summary:        Simple web interface to git repositories
85Summary(ja):    git リポジトリへのシンプルな Web インタフェース
86Group:          Development/Tools
87Requires:       git = %{version}-%{release}
88
89%description -n gitweb
90Simple web interface to track changes in git repositories
91
92
93%package svn
94Summary:        Git tools for importing Subversion repositories
95Summary(ja):    Subversion リポジトリを git へインポートするためのツール
96Group:          Development/Tools
97Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
98Requires:       perl(SVN::Core)
99%description svn
100Git tools for importing Subversion repositories.
101
102%package cvs
103Summary:        Git tools for importing CVS repositories
104Summary(ja):    CVS リポジトリを git へインポートするためのツール
105Group:          Development/Tools
106Requires:       git = %{version}-%{release}, cvs, cvsps
107%description cvs
108Git tools for importing CVS repositories.
109
110%package contrib
111Summary:        Git contrib tools
112Group:          Development/Tools
113Requires:       git = %{version}-%{release}
114%description contrib
115Git contrib tools
116
117%if "%{?_dist_release}" != "vl4"
118%package arch
119Summary:        Git tools for importing Arch repositories
120Summary(ja):    Arch リポジトリを git へインポートするためのツール
121Group:          Development/Tools
122Requires:       git = %{version}-%{release}, tla
123%description arch
124Git tools for importing Arch repositories.
125%endif
126
127%package email
128Summary:        Git tools for sending email
129Summary(ja):    Eメールを送るための git ツール
130Group:          Development/Tools
131Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
132%description email
133Git tools for sending email.
134
135%package gui
136Summary:        Git GUI tool
137Summary(ja):    Git の GUI ツール
138Group:          Development/Tools
139Requires:       git = %{version}-%{release}, tk
140%description gui
141Git GUI tool.
142
143%package -n gitk
144Summary:        Git revision tree visualiser
145Summary(ja):    Git リビジョンツリー可視化ツール
146Group:          Development/Tools
147Requires:       git = %{version}-%{release}, tk
148%description -n gitk
149Git revision tree visualiser.
150
151%package -n perl-Git
152Summary:        Perl interface to Git
153Summary(ja):    Git の perl インタフェース
154Group:          Development/Libraries
155Requires:       git = %{version}-%{release}, perl(Error)
156%if "%{?_dist_release}" == "vl4"
157Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
158%else
159Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
160%endif
161#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
162
163%description -n perl-Git
164Perl interface to Git.
165
166%package -n emacs-git
167Summary:       Git version control system support for Emacs
168Summary(ja):   Emacs の Git サポート
169Group:         Applications/Editors
170Requires:      git = %{version}-%{release}, emacsen-common
171
172%description -n emacs-git
173%{summary}.
174
175%package devel
176Summary:        Header files for git-core
177Summary(ja):    git-core 用ヘッダファイル
178Group:          Development/Libraries
179
180%description devel
181Header files for git-core.
182
183%prep
184%setup -q
185%patch0 -p1
186%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
187
188# Filter bogus perl requires
189cat << \EOF > %{name}-req
190#!/bin/sh
191%{__perl_requires} $* |\
192sed -e '/perl(packed-refs)/d'
193EOF
194
195%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
196chmod +x %{__perl_requires}     
197
198%build
199make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
200     ETC_GITCONFIG=/etc/gitconfig \
201     USE_LIBPCRE=1 \
202     GITWEB_PROJECTROOT=/var/lib/git \
203     gitwebdir=/var/www/git \
204     prefix=%{_prefix} all %{!?_without_docs: doc}
205
206%install
207rm -rf $RPM_BUILD_ROOT
208make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
209     prefix=%{_prefix} mandir=%{_mandir} \
210     ETC_GITCONFIG=/etc/gitconfig \
211     USE_LIBPCRE=1 \
212     NO_PYTHON=1 \
213     GITWEB_PROJECTROOT=/var/lib/git \
214     gitwebdir=/var/www/git \
215     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
216
217# perl-Git
218# Error.pm provide by perl-Error package
219rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
220
221# emacs-git
222mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
223#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
224#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
225mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
226mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
227
228# install el files
229install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
230
231# install vine-default file
232install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
233
234# install  script( bytecompile el and install elc , remove )   
235
236%_installemacsenscript git %{SOURCE10}
237
238%_removeemacsenscript  git %{SOURCE11}
239
240mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
241mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
242install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
243perl -p \
244     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
245     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
246     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
247
248## for gitweb sub package
249mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
250install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
251sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
252    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
253
254find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
255find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
256find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
257
258(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
259(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
260%if %{!?_without_docs:1}0
261(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
262%else
263rm -rf $RPM_BUILD_ROOT%{_mandir}
264%endif
265mkdir -p $RPM_BUILD_ROOT/srv/git
266
267mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
268install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
269
270install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
271
272# header files and lib
273install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
274install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
275install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
276install libgit.a $RPM_BUILD_ROOT%{_libdir}
277install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
278
279
280%clean
281rm -rf $RPM_BUILD_ROOT
282
283%post -n emacs-git
284
285# bytecompile and install
286
287if [ "$1" = 2 ]; then
288
289%_emacsenPackageRemove git
290
291fi
292
293%_addemacsenlist git
294
295%_emacsenPackageInstall git
296
297%preun -n emacs-git
298
299if [ "$1" = 0 ]; then
300
301%_emacsenPackageRemove git
302
303%_removeemacsenlist git
304
305fi
306
307
308%files -f bin-man-doc-files
309%defattr(-,root,root)
310%{_bindir}/git
311%{_bindir}/git-receive-pack
312%{_bindir}/git-upload-archive
313%{_bindir}/git-upload-pack
314%{_bindir}/git-shell
315%{_datadir}/git-core/
316%doc README COPYING Documentation/*.txt contrib/hooks
317%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
318%{!?_without_docs: %doc Documentation/howto Documentation/technical}
319%{_sysconfdir}/bash_completion.d
320
321
322%files svn
323%defattr(-,root,root)
324%{_libexecdir}/git-core/*svn*
325%doc Documentation/*svn*.txt
326%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
327%{!?_without_docs: %doc Documentation/*svn*.html }
328
329%files cvs
330%defattr(-,root,root)
331%doc Documentation/*git-cvs*.txt
332%{_bindir}/git-cvsserver
333%{_libexecdir}/git-core/*cvs*
334%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
335%{!?_without_docs: %doc Documentation/*git-cvs*.html }
336
337%files contrib
338%defattr(-,root,root)
339%doc diff-highlight/README.diff-highlight
340%{_bindir}/diff-highlight
341
342%if "%{?_dist_release}" != "vl4"
343%files arch
344%defattr(-,root,root)
345%doc Documentation/git-archimport.txt
346%{_libexecdir}/git-core/git-archimport
347%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
348%{!?_without_docs: %doc Documentation/git-archimport.html }
349%endif
350
351%files email
352%defattr(-,root,root)
353%doc Documentation/*email*.txt
354%{_libexecdir}/git-core/*email*
355%{!?_without_docs: %{_mandir}/man1/*email*.1*}
356%{!?_without_docs: %doc Documentation/*email*.html }
357
358%files gui
359%defattr(-,root,root)
360%{_libexecdir}/git-core/git-gui*
361%{_libexecdir}/git-core/git-citool
362%{_datadir}/git-gui/
363%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
364%{!?_without_docs: %doc Documentation/git-gui.html}
365%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
366%{!?_without_docs: %doc Documentation/git-citool.html}
367
368%files -n gitk
369%defattr(-,root,root)
370%doc Documentation/*gitk*.txt
371%{_bindir}/gitk
372%{_datadir}/gitk
373%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
374%{!?_without_docs: %doc Documentation/*gitk*.html }
375
376%files -n perl-Git -f perl-files
377%defattr(-,root,root)
378
379%files -n emacs-git
380%defattr(-,root,root)
381%{_datadir}/emacs/site-lisp/git
382#%{_libdir}/emacsen-common/packages/install/git
383#%{_libdir}/emacsen-common/packages/remove/git
384%{emacsen_pkgdir}/install/git
385%{emacsen_pkgdir}/remove/git
386
387%files daemon
388%defattr(-,root,root)
389%{_var}/lib/git
390%{_libexecdir}/git-core/git-daemon
391%config(noreplace)%{_sysconfdir}/xinetd.d/git
392/srv/git
393
394%files -n gitweb
395%defattr(-,root,root)
396%doc gitweb/README
397/var/www/git/
398%config(noreplace)%{_sysconfdir}/gitweb.conf
399%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
400
401%files devel
402%defattr(644,root,root,755)
403%{_includedir}/git
404%{_libdir}/libgit.a
405%{_libdir}/libgit_xdiff.a
406
407
408%files all
409# No files for you!
410
411%changelog
412* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
413- update to 1.8.5.2
414
415* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
416- update to 1.8.4.4
417- new sub package: contrib
418
419* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
420- new upstream release
421
422* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
423- new upstream release
424
425* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
426- new upstream release
427
428* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
429- new upstream release
430
431* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
432- new upstream release
433
434* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
435- new upstream release
436
437* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
438- new upstream release
439- enable libpcre support, add BR: pcre-devel
440- add /etc/gitweb.conf
441- add /var/lib/git for PROJECTROOT
442
443* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
444- new upstream release
445
446* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
447- new upstream release
448
449* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
450- new upstream release
451
452* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
453- new upstream release
454
455* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
456- build with perl 5.12.3
457
458* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
459- new upstream release
460- build with openssl 1.0.0c for VineSeed
461
462* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
463- new upstream release: include security fix: CVE-2010-3906
464
465* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
466- new upstream release
467- drop CVE-2010-2542 patch (Patch100): upstream fixed
468- apply vine-default
469 - rename Source1: git-init.el -> vine-default-git.el
470 - add new git-init.el file (Source12)
471 - update git-install.sh
472- update %%build and %%install section for gitweb subpackage
473- add README in gitweb subpackage
474
475* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
476- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
477
478* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
479- new upstream release
480- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
481- disable building of unused python remote helper libs
482
483* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
484- new upstream release with security fix
485- drop patch10 (included in new release)
486
487* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
488- new upstream release
489- add patch10 git daemon extra arg parsing fix
490
491* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
492- fix install script for Emacs Lisp: <BTS:VineLinux:685>
493 - update git-install.sh (Source10) using contributed patch
494
495* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
496- new upstream release
497
498* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
499- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
500- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
501- fix summary and description in daemon sub package
502
503* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
504- drop Error.pm: provide by perl-Error package
505
506* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
507- new upstream relase
508- update URL tag
509- add Requires: perl(SVN::Core) for svn subpackage
510
511* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
512- add git-shell in git package
513- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
514
515* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
516- added BuildRequires: xmlto
517
518* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
519- new upstream release
520- add devel subpackage (see [wishes:0165])
521
522* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
523- new upstream release
524
525* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
526- new upstream release
527
528* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
529- new upstream release
530
531* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
532- use %%emacsen_pkgdir macro
533
534* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
535- new upstream release
536
537* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
538- initial build for Vine Linux
539
540* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
541- git-1.5.6.4
542
543* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
544- git-1.5.6
545
546* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
547- use tar.bz2 instead of tar.gz
548
549* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
550- git-1.5.5.3
551
552* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
553- git-1.5.5.2
554
555* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
556- git-1.5.5.1
557
558* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
559- git-1.5.5
560
561* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
562- Remove the last two requires on git-core.
563
564* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
565- Remove a patch that's already upstream.
566
567* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
568- git-1.5.4.5
569
570* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
571- Own /etc/bash_completion.d in case bash-completion isn't installed.
572
573* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
574- Include the sample hooks from contrib/hooks as docs (bug 321151).
575- Install the bash completion script from contrib (bug 433255).
576- Include the html docs in the 'core' package again (bug 434271).
577
578* Wed Mar 19 2008 James Bowes 1.5.4.4-2
579- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
580
581* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
582- git-1.5.4.4
583
584* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
585- rebuild for new perl (again)
586
587* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
588- Do not silently overwrite /etc/httpd/conf.d/git.conf
589
590* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
591- git-1.5.4.3
592- Include Kristian Høgsberg's changes to rename git-core to
593  git and git to git-all.
594
595* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
596- git-1.5.4.2
597
598* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
599- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
600  gitweb rss feeds point be commitdiffs instead of commit
601
602* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
603- git-1.5.4.1
604
605* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
606- rebuild for new perl
607
608* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
609- Add BuidRequires on gettext.
610
611* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
612- git-1.5.4
613
614* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
615- git-1.5.3.8
616
617* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
618- Have git metapackage require explicit versions (bug 247214)
619
620* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
621- git-1.5.3.7
622
623* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
624- git-1.5.3.6
625- git-core requires perl(Error) (bug 367861)
626- git-svn requires perl(Term:ReadKey) (bug 261361)
627- git-email requires perl-Git (bug 333061)
628
629* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
630- git-Perl requires Error package
631
632* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
633- git-1.5.3.4
634
635* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
636- git-1.5.3.3
637
638* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
639- git-1.5.3.2
640
641* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
642- Include git-gui and git-citool docs
643
644* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
645- git-1.5.3.1-1
646
647* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
648- git-1.5.2.5-1
649
650* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
651- git-1.5.2.4-1
652
653* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
654- Add git-daemon and gitweb packages
655
656* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
657- Add emacs-git package (#235431)
658
659* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
660- git-1.5.2.2
661
662* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
663- git-1.5.2.1
664
665* Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
666- Added lib files for git-gui
667- Added Documentation/technical (As needed by Git Users Manual)
668
669* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
670- Added howto files
671
672* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
673- git-1.5.0.6
674
675* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
676- git-1.5.0.5
677
678* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
679- git-1.5.0.3
680
681* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
682- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
683
684* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
685- git-1.5.0.2
686
687* Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
688- Update core package description (Git isn't as stupid as it used to be)
689
690* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
691- Add git-gui and git-citool.
692
693* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
694- no need to install manpages executable (bz 216790)
695- use bytes for git-cvsserver
696
697* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
698- git-1.4.4.2
699
700* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
701- rebuild against the new curl
702
703* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
704- git-1.4.2.4
705
706* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
707- git-1.4.2.3
708
709* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
710- git-1.4.2.1
711
712* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
713- git-1.4.2
714
715* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
716- git-1.4.1
717
718* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
719- git-1.4.0
720
721* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
722- git-1.3.3
723- enable git-email building, prereqs have been relaxed
724
725* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
726- git-1.3.2
727
728* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
729- git-1.3.1
730
731* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
732- git-1.3.0
733
734* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
735- git-1.2.6
736
737* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
738- git-1.2.5
739
740* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
741- git-1.2.4
742
743* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
744- git-1.2.3
745
746* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
747- git-1.2.2
748
749* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
750- git-1.2.1
751
752* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
753- git-1.2.0
754
755* Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
756- git-1.1.6
757
758* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
759- git-1.1.4
760
761* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
762- git-1.1.2
763
764* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
765- git-1.1.1
766
767* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
768- Update to latest git-1.1.0 (drop git-email for now)
769- Now creates multiple packages:
770-        git-core, git-svn, git-cvs, git-arch, gitk
771
772* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
773- Change subpackage names to git-<name> instead of git-core-<name>
774- Create empty root package which brings in all subpackages
775- Rename git-tk -> gitk
776
777* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
778- zlib dependency fix
779- Minor cleanups from split
780- Move arch import to separate package as well
781
782* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
783- Move programs with non-standard dependencies (svn, cvs, email)
784  into separate packages
785
786* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
787- parallelize build
788- COPTS -> CFLAGS
789
790* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
791- update to 0.99.6
792
793* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
794- Linus noticed that less is required, added to the dependencies
795
796* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
797- Updated dependencies
798- Don't assume manpages are gzipped
799
800* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
801- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
802- use RPM_OPT_FLAGS in spec file, drop patch0
803
804* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
805- use dist tag to differentiate between branches
806- use rpm optflags by default (patch0)
807- own %{_datadir}/git-core/
808
809* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
810- update spec file to fix Buildroot, Requires, and drop Vendor
811
812* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
813- Redid the description
814- Cut overlong make line, loosened changelog a bit
815- I think Junio (or perhaps OSDL?) should be vendor...
816
817* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
818- Add the man pages, and the --without docs build option
819
820* Wed Jul 7 2005 Chris Wright <chris@osdl.org>
821- initial git spec file
Note: See TracBrowser for help on using the repository browser.