source: projects/specs/trunk/g/git/git-vl.spec @ 8100

Revision 8100, 24.4 KB checked in by iwaim, 10 years ago (diff)

git 1.8.5.2-1

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4# Pass --without docs to rpmbuild if you don't want the documentation
5Name:           git
6Version:        1.8.5.2
7Release:        1%{?_dist_release}
8Summary:        Core git tools
9Summary(ja):    Core git ツール
10License:        GPLv2
11Group:          Development/Tools
12URL:            http://git-scm.com/
13Source:         http://git-core.googlecode.com/files/%{name}-%{version}.tar.gz
14Source1:        vine-default-git.el
15Source2:        git.xinetd
16Source3:        git.conf.httpd
17Source4:        gitweb.conf.in
18Source10:       %{name}-install.sh
19Source11:       %{name}-remove.sh
20Source12:       git-init.el
21Patch0:         git-1.5-gitweb-home-link.patch
22
23# Security
24# none
25
26BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel,
27BuildRequires:  expat-devel, gettext, asciidoc
28BuildRequires:  pcre-devel
29BuildRequires:  xmlto
30BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
31
32Requires:       perl-Git = %{version}-%{release}
33Requires:       zlib
34Provides:       git-core = %{version}-%{release}
35Obsoletes:      git-core <= 1.5.4.3
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39Packager:       iwaim
40
41%description
42Git is a fast, scalable, distributed revision control system with an
43unusually rich command set that provides both high-level operations
44and full access to internals.
45
46The git rpm installs the core tools with minimal dependencies.  To
47install all git packages, including tools for integrating with other
48SCMs, install the git-all meta-package.
49
50%package all
51Summary:        Meta-package to pull in all git tools
52Summary(ja):    すべての git ツール
53Group:          Development/Tools
54Requires:       git = %{version}-%{release}
55Requires:       git-svn = %{version}-%{release}
56Requires:       git-cvs = %{version}-%{release}
57%if "%{?_dist_release}" != "vl4"
58Requires:       git-arch = %{version}-%{release}
59%endif
60Requires:       git-email = %{version}-%{release}
61Requires:       gitk = %{version}-%{release}
62Requires:       git-gui = %{version}-%{release}
63Requires:       perl-Git = %{version}-%{release}
64Requires:       emacs-git = %{version}-%{release}
65Requires:       git-contrib = %{version}-%{release}
66Obsoletes:      git <= 1.5.4.3
67
68%description all
69Git is a fast, scalable, distributed revision control system with an
70unusually rich command set that provides both high-level operations
71and full access to internals.
72
73This is a dummy package which brings in all subpackages.
74
75%package daemon
76Summary:        Git protocol daemon
77Summary(ja):    Git プロトコルデーモン
78Group:          Development/Tools
79Requires:       git = %{version}-%{release}
80%description daemon
81The git daemon for supporting git:// access to git repositories
82
83%package -n gitweb
84Summary:        Simple web interface to git repositories
85Summary(ja):    git リポジトリへのシンプルな Web インタフェース
86Group:          Development/Tools
87Requires:       git = %{version}-%{release}
88
89%description -n gitweb
90Simple web interface to track changes in git repositories
91
92
93%package svn
94Summary:        Git tools for importing Subversion repositories
95Summary(ja):    Subversion リポジトリを git へインポートするためのツール
96Group:          Development/Tools
97Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
98Requires:       perl(SVN::Core)
99%description svn
100Git tools for importing Subversion repositories.
101
102%package cvs
103Summary:        Git tools for importing CVS repositories
104Summary(ja):    CVS リポジトリを git へインポートするためのツール
105Group:          Development/Tools
106Requires:       git = %{version}-%{release}, cvs, cvsps
107%description cvs
108Git tools for importing CVS repositories.
109
110%package contrib
111Summary:        Git contrib tools
112Group:          Development/Tools
113Requires:       git = %{version}-%{release}
114%description contrib
115Git contrib tools
116
117%if "%{?_dist_release}" != "vl4"
118%package arch
119Summary:        Git tools for importing Arch repositories
120Summary(ja):    Arch リポジトリを git へインポートするためのツール
121Group:          Development/Tools
122Requires:       git = %{version}-%{release}, tla
123%description arch
124Git tools for importing Arch repositories.
125%endif
126
127%package email
128Summary:        Git tools for sending email
129Summary(ja):    Eメールを送るための git ツール
130Group:          Development/Tools
131Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
132%description email
133Git tools for sending email.
134
135%package gui
136Summary:        Git GUI tool
137Summary(ja):    Git の GUI ツール
138Group:          Development/Tools
139Requires:       git = %{version}-%{release}, tk
140%description gui
141Git GUI tool.
142
143%package -n gitk
144Summary:        Git revision tree visualiser
145Summary(ja):    Git リビジョンツリー可視化ツール
146Group:          Development/Tools
147Requires:       git = %{version}-%{release}, tk
148%description -n gitk
149Git revision tree visualiser.
150
151%package -n perl-Git
152Summary:        Perl interface to Git
153Summary(ja):    Git の perl インタフェース
154Group:          Development/Libraries
155Requires:       git = %{version}-%{release}, perl(Error)
156%if "%{?_dist_release}" == "vl4"
157Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
158%else
159Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
160%endif
161#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
162
163%description -n perl-Git
164Perl interface to Git.
165
166%package -n emacs-git
167Summary:       Git version control system support for Emacs
168Summary(ja):   Emacs の Git サポート
169Group:         Applications/Editors
170Requires:      git = %{version}-%{release}, emacsen-common
171
172%description -n emacs-git
173%{summary}.
174
175%package devel
176Summary:        Header files for git-core
177Summary(ja):    git-core 用ヘッダファイル
178Group:          Development/Libraries
179
180%description devel
181Header files for git-core.
182
183%prep
184%setup -q
185%patch0 -p1
186%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
187
188%build
189make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
190     ETC_GITCONFIG=/etc/gitconfig \
191     USE_LIBPCRE=1 \
192     GITWEB_PROJECTROOT=/var/lib/git \
193     gitwebdir=/var/www/git \
194     prefix=%{_prefix} all %{!?_without_docs: doc}
195
196%install
197rm -rf $RPM_BUILD_ROOT
198make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
199     prefix=%{_prefix} mandir=%{_mandir} \
200     ETC_GITCONFIG=/etc/gitconfig \
201     USE_LIBPCRE=1 \
202     NO_PYTHON=1 \
203     GITWEB_PROJECTROOT=/var/lib/git \
204     gitwebdir=/var/www/git \
205     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
206
207# perl-Git
208# Error.pm provide by perl-Error package
209rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
210
211# emacs-git
212mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
213#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
214#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
215mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
216mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
217
218# install el files
219install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
220
221# install vine-default file
222install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
223
224# install  script( bytecompile el and install elc , remove )   
225
226%_installemacsenscript git %{SOURCE10}
227
228%_removeemacsenscript  git %{SOURCE11}
229
230mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
231mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
232install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
233perl -p \
234     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
235     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
236     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
237
238## for gitweb sub package
239mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
240install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
241sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
242    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
243
244find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
245find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
246find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
247
248(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
249(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
250%if %{!?_without_docs:1}0
251(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
252%else
253rm -rf $RPM_BUILD_ROOT%{_mandir}
254%endif
255mkdir -p $RPM_BUILD_ROOT/srv/git
256
257mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
258install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
259
260install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
261
262# header files and lib
263install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
264install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
265install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
266install libgit.a $RPM_BUILD_ROOT%{_libdir}
267install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
268
269
270%clean
271rm -rf $RPM_BUILD_ROOT
272
273%post -n emacs-git
274
275# bytecompile and install
276
277if [ "$1" = 2 ]; then
278
279%_emacsenPackageRemove git
280
281fi
282
283%_addemacsenlist git
284
285%_emacsenPackageInstall git
286
287%preun -n emacs-git
288
289if [ "$1" = 0 ]; then
290
291%_emacsenPackageRemove git
292
293%_removeemacsenlist git
294
295fi
296
297
298%files -f bin-man-doc-files
299%defattr(-,root,root)
300%{_bindir}/git
301%{_bindir}/git-receive-pack
302%{_bindir}/git-upload-archive
303%{_bindir}/git-upload-pack
304%{_bindir}/git-shell
305%{_datadir}/git-core/
306%doc README COPYING Documentation/*.txt contrib/hooks
307%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
308%{!?_without_docs: %doc Documentation/howto Documentation/technical}
309%{_sysconfdir}/bash_completion.d
310
311
312%files svn
313%defattr(-,root,root)
314%{_libexecdir}/git-core/*svn*
315%doc Documentation/*svn*.txt
316%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
317%{!?_without_docs: %doc Documentation/*svn*.html }
318
319%files cvs
320%defattr(-,root,root)
321%doc Documentation/*git-cvs*.txt
322%{_bindir}/git-cvsserver
323%{_libexecdir}/git-core/*cvs*
324%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
325%{!?_without_docs: %doc Documentation/*git-cvs*.html }
326
327%files contrib
328%defattr(-,root,root)
329%doc diff-highlight/README.diff-highlight
330%{_bindir}/diff-highlight
331
332%if "%{?_dist_release}" != "vl4"
333%files arch
334%defattr(-,root,root)
335%doc Documentation/git-archimport.txt
336%{_libexecdir}/git-core/git-archimport
337%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
338%{!?_without_docs: %doc Documentation/git-archimport.html }
339%endif
340
341%files email
342%defattr(-,root,root)
343%doc Documentation/*email*.txt
344%{_libexecdir}/git-core/*email*
345%{!?_without_docs: %{_mandir}/man1/*email*.1*}
346%{!?_without_docs: %doc Documentation/*email*.html }
347
348%files gui
349%defattr(-,root,root)
350%{_libexecdir}/git-core/git-gui*
351%{_libexecdir}/git-core/git-citool
352%{_datadir}/git-gui/
353%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
354%{!?_without_docs: %doc Documentation/git-gui.html}
355%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
356%{!?_without_docs: %doc Documentation/git-citool.html}
357
358%files -n gitk
359%defattr(-,root,root)
360%doc Documentation/*gitk*.txt
361%{_bindir}/gitk
362%{_datadir}/gitk
363%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
364%{!?_without_docs: %doc Documentation/*gitk*.html }
365
366%files -n perl-Git -f perl-files
367%defattr(-,root,root)
368
369%files -n emacs-git
370%defattr(-,root,root)
371%{_datadir}/emacs/site-lisp/git
372#%{_libdir}/emacsen-common/packages/install/git
373#%{_libdir}/emacsen-common/packages/remove/git
374%{emacsen_pkgdir}/install/git
375%{emacsen_pkgdir}/remove/git
376
377%files daemon
378%defattr(-,root,root)
379%{_var}/lib/git
380%{_libexecdir}/git-core/git-daemon
381%config(noreplace)%{_sysconfdir}/xinetd.d/git
382/srv/git
383
384%files -n gitweb
385%defattr(-,root,root)
386%doc gitweb/README
387/var/www/git/
388%config(noreplace)%{_sysconfdir}/gitweb.conf
389%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
390
391%files devel
392%defattr(644,root,root,755)
393%{_includedir}/git
394%{_libdir}/libgit.a
395%{_libdir}/libgit_xdiff.a
396
397
398%files all
399# No files for you!
400
401%changelog
402* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
403- update to 1.8.5.2
404
405* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
406- update to 1.8.4.4
407- new sub package: contrib
408
409* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
410- new upstream release
411
412* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
413- new upstream release
414
415* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
416- new upstream release
417
418* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
419- new upstream release
420
421* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
422- new upstream release
423
424* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
425- new upstream release
426
427* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
428- new upstream release
429- enable libpcre support, add BR: pcre-devel
430- add /etc/gitweb.conf
431- add /var/lib/git for PROJECTROOT
432
433* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
434- new upstream release
435
436* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
437- new upstream release
438
439* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
440- new upstream release
441
442* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
443- new upstream release
444
445* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
446- build with perl 5.12.3
447
448* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
449- new upstream release
450- build with openssl 1.0.0c for VineSeed
451
452* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
453- new upstream release: include security fix: CVE-2010-3906
454
455* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
456- new upstream release
457- drop CVE-2010-2542 patch (Patch100): upstream fixed
458- apply vine-default
459 - rename Source1: git-init.el -> vine-default-git.el
460 - add new git-init.el file (Source12)
461 - update git-install.sh
462- update %%build and %%install section for gitweb subpackage
463- add README in gitweb subpackage
464
465* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
466- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
467
468* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
469- new upstream release
470- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
471- disable building of unused python remote helper libs
472
473* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
474- new upstream release with security fix
475- drop patch10 (included in new release)
476
477* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
478- new upstream release
479- add patch10 git daemon extra arg parsing fix
480
481* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
482- fix install script for Emacs Lisp: <BTS:VineLinux:685>
483 - update git-install.sh (Source10) using contributed patch
484
485* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
486- new upstream release
487
488* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
489- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
490- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
491- fix summary and description in daemon sub package
492
493* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
494- drop Error.pm: provide by perl-Error package
495
496* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
497- new upstream relase
498- update URL tag
499- add Requires: perl(SVN::Core) for svn subpackage
500
501* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
502- add git-shell in git package
503- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
504
505* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
506- added BuildRequires: xmlto
507
508* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
509- new upstream release
510- add devel subpackage (see [wishes:0165])
511
512* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
513- new upstream release
514
515* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
516- new upstream release
517
518* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
519- new upstream release
520
521* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
522- use %%emacsen_pkgdir macro
523
524* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
525- new upstream release
526
527* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
528- initial build for Vine Linux
529
530* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
531- git-1.5.6.4
532
533* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
534- git-1.5.6
535
536* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
537- use tar.bz2 instead of tar.gz
538
539* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
540- git-1.5.5.3
541
542* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
543- git-1.5.5.2
544
545* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
546- git-1.5.5.1
547
548* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
549- git-1.5.5
550
551* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
552- Remove the last two requires on git-core.
553
554* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
555- Remove a patch that's already upstream.
556
557* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
558- git-1.5.4.5
559
560* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
561- Own /etc/bash_completion.d in case bash-completion isn't installed.
562
563* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
564- Include the sample hooks from contrib/hooks as docs (bug 321151).
565- Install the bash completion script from contrib (bug 433255).
566- Include the html docs in the 'core' package again (bug 434271).
567
568* Wed Mar 19 2008 James Bowes 1.5.4.4-2
569- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
570
571* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
572- git-1.5.4.4
573
574* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
575- rebuild for new perl (again)
576
577* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
578- Do not silently overwrite /etc/httpd/conf.d/git.conf
579
580* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
581- git-1.5.4.3
582- Include Kristian Høgsberg's changes to rename git-core to
583  git and git to git-all.
584
585* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
586- git-1.5.4.2
587
588* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
589- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
590  gitweb rss feeds point be commitdiffs instead of commit
591
592* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
593- git-1.5.4.1
594
595* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
596- rebuild for new perl
597
598* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
599- Add BuidRequires on gettext.
600
601* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
602- git-1.5.4
603
604* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
605- git-1.5.3.8
606
607* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
608- Have git metapackage require explicit versions (bug 247214)
609
610* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
611- git-1.5.3.7
612
613* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
614- git-1.5.3.6
615- git-core requires perl(Error) (bug 367861)
616- git-svn requires perl(Term:ReadKey) (bug 261361)
617- git-email requires perl-Git (bug 333061)
618
619* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
620- git-Perl requires Error package
621
622* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
623- git-1.5.3.4
624
625* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
626- git-1.5.3.3
627
628* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
629- git-1.5.3.2
630
631* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
632- Include git-gui and git-citool docs
633
634* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
635- git-1.5.3.1-1
636
637* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
638- git-1.5.2.5-1
639
640* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
641- git-1.5.2.4-1
642
643* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
644- Add git-daemon and gitweb packages
645
646* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
647- Add emacs-git package (#235431)
648
649* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
650- git-1.5.2.2
651
652* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
653- git-1.5.2.1
654
655* Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
656- Added lib files for git-gui
657- Added Documentation/technical (As needed by Git Users Manual)
658
659* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
660- Added howto files
661
662* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
663- git-1.5.0.6
664
665* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
666- git-1.5.0.5
667
668* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
669- git-1.5.0.3
670
671* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
672- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
673
674* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
675- git-1.5.0.2
676
677* Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
678- Update core package description (Git isn't as stupid as it used to be)
679
680* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
681- Add git-gui and git-citool.
682
683* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
684- no need to install manpages executable (bz 216790)
685- use bytes for git-cvsserver
686
687* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
688- git-1.4.4.2
689
690* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
691- rebuild against the new curl
692
693* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
694- git-1.4.2.4
695
696* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
697- git-1.4.2.3
698
699* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
700- git-1.4.2.1
701
702* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
703- git-1.4.2
704
705* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
706- git-1.4.1
707
708* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
709- git-1.4.0
710
711* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
712- git-1.3.3
713- enable git-email building, prereqs have been relaxed
714
715* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
716- git-1.3.2
717
718* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
719- git-1.3.1
720
721* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
722- git-1.3.0
723
724* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
725- git-1.2.6
726
727* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
728- git-1.2.5
729
730* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
731- git-1.2.4
732
733* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
734- git-1.2.3
735
736* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
737- git-1.2.2
738
739* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
740- git-1.2.1
741
742* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
743- git-1.2.0
744
745* Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
746- git-1.1.6
747
748* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
749- git-1.1.4
750
751* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
752- git-1.1.2
753
754* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
755- git-1.1.1
756
757* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
758- Update to latest git-1.1.0 (drop git-email for now)
759- Now creates multiple packages:
760-        git-core, git-svn, git-cvs, git-arch, gitk
761
762* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
763- Change subpackage names to git-<name> instead of git-core-<name>
764- Create empty root package which brings in all subpackages
765- Rename git-tk -> gitk
766
767* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
768- zlib dependency fix
769- Minor cleanups from split
770- Move arch import to separate package as well
771
772* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
773- Move programs with non-standard dependencies (svn, cvs, email)
774  into separate packages
775
776* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
777- parallelize build
778- COPTS -> CFLAGS
779
780* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
781- update to 0.99.6
782
783* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
784- Linus noticed that less is required, added to the dependencies
785
786* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
787- Updated dependencies
788- Don't assume manpages are gzipped
789
790* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
791- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
792- use RPM_OPT_FLAGS in spec file, drop patch0
793
794* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
795- use dist tag to differentiate between branches
796- use rpm optflags by default (patch0)
797- own %{_datadir}/git-core/
798
799* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
800- update spec file to fix Buildroot, Requires, and drop Vendor
801
802* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
803- Redid the description
804- Cut overlong make line, loosened changelog a bit
805- I think Junio (or perhaps OSDL?) should be vendor...
806
807* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
808- Add the man pages, and the --without docs build option
809
810* Wed Jul 7 2005 Chris Wright <chris@osdl.org>
811- initial git spec file
Note: See TracBrowser for help on using the repository browser.