source: projects/specs/trunk/g/git/git-vl.spec @ 7320

Revision 7320, 23.5 KB checked in by iwaim, 12 years ago (diff)

git 1.8.1-1

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4# Pass --without docs to rpmbuild if you don't want the documentation
5Name:           git
6Version:        1.8.1
7Release:        1%{?_dist_release}
8Summary:        Core git tools
9Summary(ja):    Core git ツール
10License:        GPLv2
11Group:          Development/Tools
12URL:            http://git-scm.com/
13Source:         http://git-core.googlecode.com/files/%{name}-%{version}.tar.gz
14Source1:        vine-default-git.el
15Source2:        git.xinetd
16Source3:        git.conf.httpd
17Source4:        gitweb.conf.in
18Source10:       %{name}-install.sh
19Source11:       %{name}-remove.sh
20Source12:       git-init.el
21Patch0:         git-1.5-gitweb-home-link.patch
22
23# Security
24# none
25
26BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel,
27BuildRequires:  expat-devel, gettext, asciidoc
28BuildRequires:  pcre-devel
29BuildRequires:  xmlto
30BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
31
32Requires:       perl-Git = %{version}-%{release}
33Requires:       zlib
34Provides:       git-core = %{version}-%{release}
35Obsoletes:      git-core <= 1.5.4.3
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39Packager:       iwaim
40
41%description
42Git is a fast, scalable, distributed revision control system with an
43unusually rich command set that provides both high-level operations
44and full access to internals.
45
46The git rpm installs the core tools with minimal dependencies.  To
47install all git packages, including tools for integrating with other
48SCMs, install the git-all meta-package.
49
50%package all
51Summary:        Meta-package to pull in all git tools
52Summary(ja):    すべての git ツール
53Group:          Development/Tools
54Requires:       git = %{version}-%{release}
55Requires:       git-svn = %{version}-%{release}
56Requires:       git-cvs = %{version}-%{release}
57%if "%{?_dist_release}" != "vl4"
58Requires:       git-arch = %{version}-%{release}
59%endif
60Requires:       git-email = %{version}-%{release}
61Requires:       gitk = %{version}-%{release}
62Requires:       git-gui = %{version}-%{release}
63Requires:       perl-Git = %{version}-%{release}
64Requires:       emacs-git = %{version}-%{release}
65Obsoletes:      git <= 1.5.4.3
66
67%description all
68Git is a fast, scalable, distributed revision control system with an
69unusually rich command set that provides both high-level operations
70and full access to internals.
71
72This is a dummy package which brings in all subpackages.
73
74%package daemon
75Summary:        Git protocol daemon
76Summary(ja):    Git プロトコルデーモン
77Group:          Development/Tools
78Requires:       git = %{version}-%{release}
79%description daemon
80The git daemon for supporting git:// access to git repositories
81
82%package -n gitweb
83Summary:        Simple web interface to git repositories
84Summary(ja):    git リポジトリへのシンプルな Web インタフェース
85Group:          Development/Tools
86Requires:       git = %{version}-%{release}
87
88%description -n gitweb
89Simple web interface to track changes in git repositories
90
91
92%package svn
93Summary:        Git tools for importing Subversion repositories
94Summary(ja):    Subversion リポジトリを git へインポートするためのツール
95Group:          Development/Tools
96Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
97Requires:       perl(SVN::Core)
98%description svn
99Git tools for importing Subversion repositories.
100
101%package cvs
102Summary:        Git tools for importing CVS repositories
103Summary(ja):    CVS リポジトリを git へインポートするためのツール
104Group:          Development/Tools
105Requires:       git = %{version}-%{release}, cvs, cvsps
106%description cvs
107Git tools for importing CVS repositories.
108
109%if "%{?_dist_release}" != "vl4"
110%package arch
111Summary:        Git tools for importing Arch repositories
112Summary(ja):    Arch リポジトリを git へインポートするためのツール
113Group:          Development/Tools
114Requires:       git = %{version}-%{release}, tla
115%description arch
116Git tools for importing Arch repositories.
117%endif
118
119%package email
120Summary:        Git tools for sending email
121Summary(ja):    Eメールを送るための git ツール
122Group:          Development/Tools
123Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
124%description email
125Git tools for sending email.
126
127%package gui
128Summary:        Git GUI tool
129Summary(ja):    Git の GUI ツール
130Group:          Development/Tools
131Requires:       git = %{version}-%{release}, tk
132%description gui
133Git GUI tool.
134
135%package -n gitk
136Summary:        Git revision tree visualiser
137Summary(ja):    Git リビジョンツリー可視化ツール
138Group:          Development/Tools
139Requires:       git = %{version}-%{release}, tk
140%description -n gitk
141Git revision tree visualiser.
142
143%package -n perl-Git
144Summary:        Perl interface to Git
145Summary(ja):    Git の perl インタフェース
146Group:          Development/Libraries
147Requires:       git = %{version}-%{release}, perl(Error)
148%if "%{?_dist_release}" == "vl4"
149Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
150%else
151Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
152%endif
153#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
154
155%description -n perl-Git
156Perl interface to Git.
157
158%package -n emacs-git
159Summary:       Git version control system support for Emacs
160Summary(ja):   Emacs の Git サポート
161Group:         Applications/Editors
162Requires:      git = %{version}-%{release}, emacsen-common
163
164%description -n emacs-git
165%{summary}.
166
167%package devel
168Summary:        Header files for git-core
169Summary(ja):    git-core 用ヘッダファイル
170Group:          Development/Libraries
171
172%description devel
173Header files for git-core.
174
175%prep
176%setup -q
177%patch0 -p1
178
179%build
180make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
181     ETC_GITCONFIG=/etc/gitconfig \
182     USE_LIBPCRE=1 \
183     GITWEB_PROJECTROOT=/var/lib/git \
184     gitwebdir=/var/www/git \
185     prefix=%{_prefix} all %{!?_without_docs: doc}
186
187%install
188rm -rf $RPM_BUILD_ROOT
189make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
190     prefix=%{_prefix} mandir=%{_mandir} \
191     ETC_GITCONFIG=/etc/gitconfig \
192     USE_LIBPCRE=1 \
193     NO_PYTHON=1 \
194     GITWEB_PROJECTROOT=/var/lib/git \
195     gitwebdir=/var/www/git \
196     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
197
198# perl-Git
199# Error.pm provide by perl-Error package
200rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
201
202# emacs-git
203mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
204#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
205#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
206mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
207mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
208
209# install el files
210install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
211
212# install vine-default file
213install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
214
215# install  script( bytecompile el and install elc , remove )   
216
217%_installemacsenscript git %{SOURCE10}
218
219%_removeemacsenscript  git %{SOURCE11}
220
221mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
222mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
223install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
224perl -p \
225     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
226     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
227     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
228
229## for gitweb sub package
230mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
231install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
232sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
233    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
234
235find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
236find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
237find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
238
239(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
240(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
241%if %{!?_without_docs:1}0
242(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
243%else
244rm -rf $RPM_BUILD_ROOT%{_mandir}
245%endif
246mkdir -p $RPM_BUILD_ROOT/srv/git
247
248mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
249install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
250
251# header files and lib
252install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
253install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
254install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
255install libgit.a $RPM_BUILD_ROOT%{_libdir}
256install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
257
258
259%clean
260rm -rf $RPM_BUILD_ROOT
261
262%post -n emacs-git
263
264# bytecompile and install
265
266if [ "$1" = 2 ]; then
267
268%_emacsenPackageRemove git
269
270fi
271
272%_addemacsenlist git
273
274%_emacsenPackageInstall git
275
276%preun -n emacs-git
277
278if [ "$1" = 0 ]; then
279
280%_emacsenPackageRemove git
281
282%_removeemacsenlist git
283
284fi
285
286
287%files -f bin-man-doc-files
288%defattr(-,root,root)
289%{_bindir}/git
290%{_bindir}/git-receive-pack
291%{_bindir}/git-upload-archive
292%{_bindir}/git-upload-pack
293%{_bindir}/git-shell
294%{_datadir}/git-core/
295%doc README COPYING Documentation/*.txt contrib/hooks
296%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
297%{!?_without_docs: %doc Documentation/howto Documentation/technical}
298%{_sysconfdir}/bash_completion.d
299
300
301%files svn
302%defattr(-,root,root)
303%{_libexecdir}/git-core/*svn*
304%doc Documentation/*svn*.txt
305%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
306%{!?_without_docs: %doc Documentation/*svn*.html }
307
308%files cvs
309%defattr(-,root,root)
310%doc Documentation/*git-cvs*.txt
311%{_bindir}/git-cvsserver
312%{_libexecdir}/git-core/*cvs*
313%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
314%{!?_without_docs: %doc Documentation/*git-cvs*.html }
315
316%if "%{?_dist_release}" != "vl4"
317%files arch
318%defattr(-,root,root)
319%doc Documentation/git-archimport.txt
320%{_libexecdir}/git-core/git-archimport
321%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
322%{!?_without_docs: %doc Documentation/git-archimport.html }
323%endif
324
325%files email
326%defattr(-,root,root)
327%doc Documentation/*email*.txt
328%{_libexecdir}/git-core/*email*
329%{!?_without_docs: %{_mandir}/man1/*email*.1*}
330%{!?_without_docs: %doc Documentation/*email*.html }
331
332%files gui
333%defattr(-,root,root)
334%{_libexecdir}/git-core/git-gui*
335%{_libexecdir}/git-core/git-citool
336%{_datadir}/git-gui/
337%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
338%{!?_without_docs: %doc Documentation/git-gui.html}
339%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
340%{!?_without_docs: %doc Documentation/git-citool.html}
341
342%files -n gitk
343%defattr(-,root,root)
344%doc Documentation/*gitk*.txt
345%{_bindir}/gitk
346%{_datadir}/gitk
347%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
348%{!?_without_docs: %doc Documentation/*gitk*.html }
349
350%files -n perl-Git -f perl-files
351%defattr(-,root,root)
352
353%files -n emacs-git
354%defattr(-,root,root)
355%{_datadir}/emacs/site-lisp/git
356#%{_libdir}/emacsen-common/packages/install/git
357#%{_libdir}/emacsen-common/packages/remove/git
358%{emacsen_pkgdir}/install/git
359%{emacsen_pkgdir}/remove/git
360
361%files daemon
362%defattr(-,root,root)
363%{_var}/lib/git
364%{_libexecdir}/git-core/git-daemon
365%config(noreplace)%{_sysconfdir}/xinetd.d/git
366/srv/git
367
368%files -n gitweb
369%defattr(-,root,root)
370%doc gitweb/README
371/var/www/git/
372%config(noreplace)%{_sysconfdir}/gitweb.conf
373%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
374
375%files devel
376%defattr(644,root,root,755)
377%{_includedir}/git
378%{_libdir}/libgit.a
379%{_libdir}/libgit_xdiff.a
380
381
382%files all
383# No files for you!
384
385%changelog
386* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
387- new upstream release
388
389* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
390- new upstream release
391
392* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
393- new upstream release
394
395* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
396- new upstream release
397- enable libpcre support, add BR: pcre-devel
398- add /etc/gitweb.conf
399- add /var/lib/git for PROJECTROOT
400
401* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
402- new upstream release
403
404* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
405- new upstream release
406
407* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
408- new upstream release
409
410* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
411- new upstream release
412
413* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
414- build with perl 5.12.3
415
416* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
417- new upstream release
418- build with openssl 1.0.0c for VineSeed
419
420* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
421- new upstream release: include security fix: CVE-2010-3906
422
423* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
424- new upstream release
425- drop CVE-2010-2542 patch (Patch100): upstream fixed
426- apply vine-default
427 - rename Source1: git-init.el -> vine-default-git.el
428 - add new git-init.el file (Source12)
429 - update git-install.sh
430- update %%build and %%install section for gitweb subpackage
431- add README in gitweb subpackage
432
433* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
434- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
435
436* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
437- new upstream release
438- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
439- disable building of unused python remote helper libs
440
441* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
442- new upstream release with security fix
443- drop patch10 (included in new release)
444
445* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
446- new upstream release
447- add patch10 git daemon extra arg parsing fix
448
449* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
450- fix install script for Emacs Lisp: <BTS:VineLinux:685>
451 - update git-install.sh (Source10) using contributed patch
452
453* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
454- new upstream release
455
456* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
457- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
458- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
459- fix summary and description in daemon sub package
460
461* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
462- drop Error.pm: provide by perl-Error package
463
464* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
465- new upstream relase
466- update URL tag
467- add Requires: perl(SVN::Core) for svn subpackage
468
469* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
470- add git-shell in git package
471- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
472
473* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
474- added BuildRequires: xmlto
475
476* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
477- new upstream release
478- add devel subpackage (see [wishes:0165])
479
480* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
481- new upstream release
482
483* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
484- new upstream release
485
486* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
487- new upstream release
488
489* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
490- use %%emacsen_pkgdir macro
491
492* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
493- new upstream release
494
495* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
496- initial build for Vine Linux
497
498* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
499- git-1.5.6.4
500
501* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
502- git-1.5.6
503
504* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
505- use tar.bz2 instead of tar.gz
506
507* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
508- git-1.5.5.3
509
510* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
511- git-1.5.5.2
512
513* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
514- git-1.5.5.1
515
516* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
517- git-1.5.5
518
519* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
520- Remove the last two requires on git-core.
521
522* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
523- Remove a patch that's already upstream.
524
525* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
526- git-1.5.4.5
527
528* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
529- Own /etc/bash_completion.d in case bash-completion isn't installed.
530
531* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
532- Include the sample hooks from contrib/hooks as docs (bug 321151).
533- Install the bash completion script from contrib (bug 433255).
534- Include the html docs in the 'core' package again (bug 434271).
535
536* Wed Mar 19 2008 James Bowes 1.5.4.4-2
537- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
538
539* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
540- git-1.5.4.4
541
542* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
543- rebuild for new perl (again)
544
545* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
546- Do not silently overwrite /etc/httpd/conf.d/git.conf
547
548* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
549- git-1.5.4.3
550- Include Kristian Høgsberg's changes to rename git-core to
551  git and git to git-all.
552
553* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
554- git-1.5.4.2
555
556* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
557- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
558  gitweb rss feeds point be commitdiffs instead of commit
559
560* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
561- git-1.5.4.1
562
563* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
564- rebuild for new perl
565
566* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
567- Add BuidRequires on gettext.
568
569* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
570- git-1.5.4
571
572* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
573- git-1.5.3.8
574
575* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
576- Have git metapackage require explicit versions (bug 247214)
577
578* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
579- git-1.5.3.7
580
581* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
582- git-1.5.3.6
583- git-core requires perl(Error) (bug 367861)
584- git-svn requires perl(Term:ReadKey) (bug 261361)
585- git-email requires perl-Git (bug 333061)
586
587* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
588- git-Perl requires Error package
589
590* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
591- git-1.5.3.4
592
593* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
594- git-1.5.3.3
595
596* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
597- git-1.5.3.2
598
599* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
600- Include git-gui and git-citool docs
601
602* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
603- git-1.5.3.1-1
604
605* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
606- git-1.5.2.5-1
607
608* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
609- git-1.5.2.4-1
610
611* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
612- Add git-daemon and gitweb packages
613
614* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
615- Add emacs-git package (#235431)
616
617* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
618- git-1.5.2.2
619
620* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
621- git-1.5.2.1
622
623* Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
624- Added lib files for git-gui
625- Added Documentation/technical (As needed by Git Users Manual)
626
627* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
628- Added howto files
629
630* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
631- git-1.5.0.6
632
633* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
634- git-1.5.0.5
635
636* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
637- git-1.5.0.3
638
639* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
640- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
641
642* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
643- git-1.5.0.2
644
645* Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
646- Update core package description (Git isn't as stupid as it used to be)
647
648* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
649- Add git-gui and git-citool.
650
651* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
652- no need to install manpages executable (bz 216790)
653- use bytes for git-cvsserver
654
655* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
656- git-1.4.4.2
657
658* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
659- rebuild against the new curl
660
661* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
662- git-1.4.2.4
663
664* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
665- git-1.4.2.3
666
667* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
668- git-1.4.2.1
669
670* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
671- git-1.4.2
672
673* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
674- git-1.4.1
675
676* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
677- git-1.4.0
678
679* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
680- git-1.3.3
681- enable git-email building, prereqs have been relaxed
682
683* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
684- git-1.3.2
685
686* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
687- git-1.3.1
688
689* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
690- git-1.3.0
691
692* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
693- git-1.2.6
694
695* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
696- git-1.2.5
697
698* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
699- git-1.2.4
700
701* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
702- git-1.2.3
703
704* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
705- git-1.2.2
706
707* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
708- git-1.2.1
709
710* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
711- git-1.2.0
712
713* Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
714- git-1.1.6
715
716* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
717- git-1.1.4
718
719* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
720- git-1.1.2
721
722* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
723- git-1.1.1
724
725* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
726- Update to latest git-1.1.0 (drop git-email for now)
727- Now creates multiple packages:
728-        git-core, git-svn, git-cvs, git-arch, gitk
729
730* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
731- Change subpackage names to git-<name> instead of git-core-<name>
732- Create empty root package which brings in all subpackages
733- Rename git-tk -> gitk
734
735* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
736- zlib dependency fix
737- Minor cleanups from split
738- Move arch import to separate package as well
739
740* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
741- Move programs with non-standard dependencies (svn, cvs, email)
742  into separate packages
743
744* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
745- parallelize build
746- COPTS -> CFLAGS
747
748* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
749- update to 0.99.6
750
751* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
752- Linus noticed that less is required, added to the dependencies
753
754* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
755- Updated dependencies
756- Don't assume manpages are gzipped
757
758* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
759- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
760- use RPM_OPT_FLAGS in spec file, drop patch0
761
762* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
763- use dist tag to differentiate between branches
764- use rpm optflags by default (patch0)
765- own %{_datadir}/git-core/
766
767* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
768- update spec file to fix Buildroot, Requires, and drop Vendor
769
770* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
771- Redid the description
772- Cut overlong make line, loosened changelog a bit
773- I think Junio (or perhaps OSDL?) should be vendor...
774
775* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
776- Add the man pages, and the --without docs build option
777
778* Wed Jul 7 2005 Chris Wright <chris@osdl.org>
779- initial git spec file
Note: See TracBrowser for help on using the repository browser.