source: projects/specs/trunk/g/git/git-vl.spec @ 3132

Revision 3132, 22.2 KB checked in by iwaim, 13 years ago (diff)

git-1.7.3.5-2vl6

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4# Pass --without docs to rpmbuild if you don't want the documentation
5Name:           git
6Version:        1.7.3.5
7Release:        2%{?_dist_release}
8Summary:        Core git tools
9Summary(ja):    Core git ツール
10License:        GPLv2
11Group:          Development/Tools
12URL:            http://git-scm.com/
13Source:         http://kernel.org/pub/software/scm/git/%{name}-%{version}.tar.bz2
14Source1:        vine-default-git.el
15Source2:        git.xinetd
16Source3:        git.conf.httpd
17Source10:       %{name}-install.sh
18Source11:       %{name}-remove.sh
19Source12:       git-init.el
20Patch0:         git-1.5-gitweb-home-link.patch
21
22# Security
23# none
24
25BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel,
26BuildRequires:  expat-devel, gettext, asciidoc
27BuildRequires:  xmlto
28BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
29
30Requires:       perl-Git = %{version}-%{release}
31Requires:       zlib
32Provides:       git-core = %{version}-%{release}
33Obsoletes:      git-core <= 1.5.4.3
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37Packager:       iwaim
38
39%description
40Git is a fast, scalable, distributed revision control system with an
41unusually rich command set that provides both high-level operations
42and full access to internals.
43
44The git rpm installs the core tools with minimal dependencies.  To
45install all git packages, including tools for integrating with other
46SCMs, install the git-all meta-package.
47
48%package all
49Summary:        Meta-package to pull in all git tools
50Summary(ja):    すべての git ツール
51Group:          Development/Tools
52Requires:       git = %{version}-%{release}
53Requires:       git-svn = %{version}-%{release}
54Requires:       git-cvs = %{version}-%{release}
55%if "%{?_dist_release}" != "vl4"
56Requires:       git-arch = %{version}-%{release}
57%endif
58Requires:       git-email = %{version}-%{release}
59Requires:       gitk = %{version}-%{release}
60Requires:       git-gui = %{version}-%{release}
61Requires:       perl-Git = %{version}-%{release}
62Requires:       emacs-git = %{version}-%{release}
63Obsoletes:      git <= 1.5.4.3
64
65%description all
66Git is a fast, scalable, distributed revision control system with an
67unusually rich command set that provides both high-level operations
68and full access to internals.
69
70This is a dummy package which brings in all subpackages.
71
72%package daemon
73Summary:        Git protocol daemon
74Summary(ja):    Git プロトコルデーモン
75Group:          Development/Tools
76Requires:       git = %{version}-%{release}
77%description daemon
78The git daemon for supporting git:// access to git repositories
79
80%package -n gitweb
81Summary:        Simple web interface to git repositories
82Summary(ja):    git リポジトリへのシンプルな Web インタフェース
83Group:          Development/Tools
84Requires:       git = %{version}-%{release}
85
86%description -n gitweb
87Simple web interface to track changes in git repositories
88
89
90%package svn
91Summary:        Git tools for importing Subversion repositories
92Summary(ja):    Subversion リポジトリを git へインポートするためのツール
93Group:          Development/Tools
94Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
95Requires:       perl(SVN::Core)
96%description svn
97Git tools for importing Subversion repositories.
98
99%package cvs
100Summary:        Git tools for importing CVS repositories
101Summary(ja):    CVS リポジトリを git へインポートするためのツール
102Group:          Development/Tools
103Requires:       git = %{version}-%{release}, cvs, cvsps
104%description cvs
105Git tools for importing CVS repositories.
106
107%if "%{?_dist_release}" != "vl4"
108%package arch
109Summary:        Git tools for importing Arch repositories
110Summary(ja):    Arch リポジトリを git へインポートするためのツール
111Group:          Development/Tools
112Requires:       git = %{version}-%{release}, tla
113%description arch
114Git tools for importing Arch repositories.
115%endif
116
117%package email
118Summary:        Git tools for sending email
119Summary(ja):    Eメールを送るための git ツール
120Group:          Development/Tools
121Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
122%description email
123Git tools for sending email.
124
125%package gui
126Summary:        Git GUI tool
127Summary(ja):    Git の GUI ツール
128Group:          Development/Tools
129Requires:       git = %{version}-%{release}, tk
130%description gui
131Git GUI tool.
132
133%package -n gitk
134Summary:        Git revision tree visualiser
135Summary(ja):    Git リビジョンツリー可視化ツール
136Group:          Development/Tools
137Requires:       git = %{version}-%{release}, tk
138%description -n gitk
139Git revision tree visualiser.
140
141%package -n perl-Git
142Summary:        Perl interface to Git
143Summary(ja):    Git の perl インタフェース
144Group:          Development/Libraries
145Requires:       git = %{version}-%{release}, perl(Error)
146%if "%{?_dist_release}" == "vl4"
147Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
148%else
149Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
150%endif
151#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
152
153%description -n perl-Git
154Perl interface to Git.
155
156%package -n emacs-git
157Summary:       Git version control system support for Emacs
158Summary(ja):   Emacs の Git サポート
159Group:         Applications/Editors
160Requires:      git = %{version}-%{release}, emacsen-common
161
162%description -n emacs-git
163%{summary}.
164
165%package devel
166Summary:        Header files for git-core
167Summary(ja):    git-core 用ヘッダファイル
168Group:          Development/Libraries
169
170%description devel
171Header files for git-core.
172
173%prep
174%setup -q
175%patch0 -p1
176
177%build
178make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
179     ETC_GITCONFIG=/etc/gitconfig \
180     gitwebdir=/var/www/git \
181     prefix=%{_prefix} all %{!?_without_docs: doc}
182
183%install
184rm -rf $RPM_BUILD_ROOT
185make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
186     prefix=%{_prefix} mandir=%{_mandir} \
187     ETC_GITCONFIG=/etc/gitconfig \
188     NO_PYTHON=1 \
189     gitwebdir=/var/www/git \
190     INSTALLDIRS=vendor install install-gitweb %{!?_without_docs: install-doc}
191
192# perl-Git
193# Error.pm provide by perl-Error package
194rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
195
196# emacs-git
197mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
198#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
199#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
200mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
201mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
202
203# install el files
204install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
205
206# install vine-default file
207install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
208
209# install  script( bytecompile el and install elc , remove )   
210
211%_installemacsenscript git %{SOURCE10}
212
213%_removeemacsenscript  git %{SOURCE11}
214
215mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
216install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
217
218## for gitweb sub package
219mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
220install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
221
222find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
223find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
224find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
225
226(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
227(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
228%if %{!?_without_docs:1}0
229(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
230%else
231rm -rf $RPM_BUILD_ROOT%{_mandir}
232%endif
233mkdir -p $RPM_BUILD_ROOT/srv/git
234
235mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
236install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
237
238# header files and lib
239install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
240install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
241install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
242install libgit.a $RPM_BUILD_ROOT%{_libdir}
243install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
244
245
246%clean
247rm -rf $RPM_BUILD_ROOT
248
249%post -n emacs-git
250
251# bytecompile and install
252
253if [ "$1" = 2 ]; then
254
255%_emacsenPackageRemove git
256
257fi
258
259%_addemacsenlist git
260
261%_emacsenPackageInstall git
262
263%preun -n emacs-git
264
265if [ "$1" = 0 ]; then
266
267%_emacsenPackageRemove git
268
269%_removeemacsenlist git
270
271fi
272
273
274%files -f bin-man-doc-files
275%defattr(-,root,root)
276%{_bindir}/git
277%{_bindir}/git-receive-pack
278%{_bindir}/git-upload-archive
279%{_bindir}/git-upload-pack
280%{_bindir}/git-shell
281%{_datadir}/git-core/
282%doc README COPYING Documentation/*.txt contrib/hooks
283%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
284%{!?_without_docs: %doc Documentation/howto Documentation/technical}
285%{_sysconfdir}/bash_completion.d
286
287
288%files svn
289%defattr(-,root,root)
290%{_libexecdir}/git-core/*svn*
291%doc Documentation/*svn*.txt
292%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
293%{!?_without_docs: %doc Documentation/*svn*.html }
294
295%files cvs
296%defattr(-,root,root)
297%doc Documentation/*git-cvs*.txt
298%{_bindir}/git-cvsserver
299%{_libexecdir}/git-core/*cvs*
300%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
301%{!?_without_docs: %doc Documentation/*git-cvs*.html }
302
303%if "%{?_dist_release}" != "vl4"
304%files arch
305%defattr(-,root,root)
306%doc Documentation/git-archimport.txt
307%{_libexecdir}/git-core/git-archimport
308%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
309%{!?_without_docs: %doc Documentation/git-archimport.html }
310%endif
311
312%files email
313%defattr(-,root,root)
314%doc Documentation/*email*.txt
315%{_libexecdir}/git-core/*email*
316%{!?_without_docs: %{_mandir}/man1/*email*.1*}
317%{!?_without_docs: %doc Documentation/*email*.html }
318
319%files gui
320%defattr(-,root,root)
321%{_libexecdir}/git-core/git-gui*
322%{_libexecdir}/git-core/git-citool
323%{_datadir}/git-gui/
324%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
325%{!?_without_docs: %doc Documentation/git-gui.html}
326%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
327%{!?_without_docs: %doc Documentation/git-citool.html}
328
329%files -n gitk
330%defattr(-,root,root)
331%doc Documentation/*gitk*.txt
332%{_bindir}/gitk
333%{_datadir}/gitk
334%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
335%{!?_without_docs: %doc Documentation/*gitk*.html }
336
337%files -n perl-Git -f perl-files
338%defattr(-,root,root)
339
340%files -n emacs-git
341%defattr(-,root,root)
342%{_datadir}/emacs/site-lisp/git
343#%{_libdir}/emacsen-common/packages/install/git
344#%{_libdir}/emacsen-common/packages/remove/git
345%{emacsen_pkgdir}/install/git
346%{emacsen_pkgdir}/remove/git
347
348%files daemon
349%defattr(-,root,root)
350%{_libexecdir}/git-core/git-daemon
351%config(noreplace)%{_sysconfdir}/xinetd.d/git
352/srv/git
353
354%files -n gitweb
355%defattr(-,root,root)
356%doc gitweb/README
357/var/www/git/
358%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
359
360%files devel
361%defattr(644,root,root,755)
362%{_includedir}/git
363%{_libdir}/libgit.a
364%{_libdir}/libgit_xdiff.a
365
366
367%files all
368# No files for you!
369
370%changelog
371* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
372- build with perl 5.12.3
373
374* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
375- new upstream release
376- build with openssl 1.0.0c for VineSeed
377
378* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
379- new upstream release: include security fix: CVE-2010-3906
380
381* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
382- new upstream release
383- drop CVE-2010-2542 patch (Patch100): upstream fixed
384- apply vine-default
385 - rename Source1: git-init.el -> vine-default-git.el
386 - add new git-init.el file (Source12)
387 - update git-install.sh
388- update %%build and %%install section for gitweb subpackage
389- add README in gitweb subpackage
390
391* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
392- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
393
394* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
395- new upstream release
396- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
397- disable building of unused python remote helper libs
398
399* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
400- new upstream release with security fix
401- drop patch10 (included in new release)
402
403* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
404- new upstream release
405- add patch10 git daemon extra arg parsing fix
406
407* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
408- fix install script for Emacs Lisp: <BTS:VineLinux:685>
409 - update git-install.sh (Source10) using contributed patch
410
411* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
412- new upstream release
413
414* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
415- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
416- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
417- fix summary and description in daemon sub package
418
419* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
420- drop Error.pm: provide by perl-Error package
421
422* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
423- new upstream relase
424- update URL tag
425- add Requires: perl(SVN::Core) for svn subpackage
426
427* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
428- add git-shell in git package
429- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
430
431* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
432- added BuildRequires: xmlto
433
434* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
435- new upstream release
436- add devel subpackage (see [wishes:0165])
437
438* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
439- new upstream release
440
441* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
442- new upstream release
443
444* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
445- new upstream release
446
447* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
448- use %%emacsen_pkgdir macro
449
450* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
451- new upstream release
452
453* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
454- initial build for Vine Linux
455
456* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
457- git-1.5.6.4
458
459* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
460- git-1.5.6
461
462* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
463- use tar.bz2 instead of tar.gz
464
465* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
466- git-1.5.5.3
467
468* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
469- git-1.5.5.2
470
471* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
472- git-1.5.5.1
473
474* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
475- git-1.5.5
476
477* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
478- Remove the last two requires on git-core.
479
480* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
481- Remove a patch that's already upstream.
482
483* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
484- git-1.5.4.5
485
486* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
487- Own /etc/bash_completion.d in case bash-completion isn't installed.
488
489* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
490- Include the sample hooks from contrib/hooks as docs (bug 321151).
491- Install the bash completion script from contrib (bug 433255).
492- Include the html docs in the 'core' package again (bug 434271).
493
494* Wed Mar 19 2008 James Bowes 1.5.4.4-2
495- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
496
497* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
498- git-1.5.4.4
499
500* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
501- rebuild for new perl (again)
502
503* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
504- Do not silently overwrite /etc/httpd/conf.d/git.conf
505
506* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
507- git-1.5.4.3
508- Include Kristian Høgsberg's changes to rename git-core to
509  git and git to git-all.
510
511* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
512- git-1.5.4.2
513
514* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
515- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
516  gitweb rss feeds point be commitdiffs instead of commit
517
518* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
519- git-1.5.4.1
520
521* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
522- rebuild for new perl
523
524* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
525- Add BuidRequires on gettext.
526
527* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
528- git-1.5.4
529
530* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
531- git-1.5.3.8
532
533* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
534- Have git metapackage require explicit versions (bug 247214)
535
536* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
537- git-1.5.3.7
538
539* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
540- git-1.5.3.6
541- git-core requires perl(Error) (bug 367861)
542- git-svn requires perl(Term:ReadKey) (bug 261361)
543- git-email requires perl-Git (bug 333061)
544
545* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
546- git-Perl requires Error package
547
548* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
549- git-1.5.3.4
550
551* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
552- git-1.5.3.3
553
554* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
555- git-1.5.3.2
556
557* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
558- Include git-gui and git-citool docs
559
560* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
561- git-1.5.3.1-1
562
563* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
564- git-1.5.2.5-1
565
566* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
567- git-1.5.2.4-1
568
569* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
570- Add git-daemon and gitweb packages
571
572* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
573- Add emacs-git package (#235431)
574
575* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
576- git-1.5.2.2
577
578* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
579- git-1.5.2.1
580
581* Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
582- Added lib files for git-gui
583- Added Documentation/technical (As needed by Git Users Manual)
584
585* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
586- Added howto files
587
588* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
589- git-1.5.0.6
590
591* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
592- git-1.5.0.5
593
594* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
595- git-1.5.0.3
596
597* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
598- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
599
600* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
601- git-1.5.0.2
602
603* Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
604- Update core package description (Git isn't as stupid as it used to be)
605
606* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
607- Add git-gui and git-citool.
608
609* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
610- no need to install manpages executable (bz 216790)
611- use bytes for git-cvsserver
612
613* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
614- git-1.4.4.2
615
616* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
617- rebuild against the new curl
618
619* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
620- git-1.4.2.4
621
622* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
623- git-1.4.2.3
624
625* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
626- git-1.4.2.1
627
628* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
629- git-1.4.2
630
631* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
632- git-1.4.1
633
634* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
635- git-1.4.0
636
637* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
638- git-1.3.3
639- enable git-email building, prereqs have been relaxed
640
641* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
642- git-1.3.2
643
644* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
645- git-1.3.1
646
647* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
648- git-1.3.0
649
650* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
651- git-1.2.6
652
653* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
654- git-1.2.5
655
656* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
657- git-1.2.4
658
659* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
660- git-1.2.3
661
662* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
663- git-1.2.2
664
665* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
666- git-1.2.1
667
668* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
669- git-1.2.0
670
671* Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
672- git-1.1.6
673
674* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
675- git-1.1.4
676
677* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
678- git-1.1.2
679
680* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
681- git-1.1.1
682
683* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
684- Update to latest git-1.1.0 (drop git-email for now)
685- Now creates multiple packages:
686-        git-core, git-svn, git-cvs, git-arch, gitk
687
688* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
689- Change subpackage names to git-<name> instead of git-core-<name>
690- Create empty root package which brings in all subpackages
691- Rename git-tk -> gitk
692
693* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
694- zlib dependency fix
695- Minor cleanups from split
696- Move arch import to separate package as well
697
698* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
699- Move programs with non-standard dependencies (svn, cvs, email)
700  into separate packages
701
702* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
703- parallelize build
704- COPTS -> CFLAGS
705
706* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
707- update to 0.99.6
708
709* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
710- Linus noticed that less is required, added to the dependencies
711
712* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
713- Updated dependencies
714- Don't assume manpages are gzipped
715
716* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
717- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
718- use RPM_OPT_FLAGS in spec file, drop patch0
719
720* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
721- use dist tag to differentiate between branches
722- use rpm optflags by default (patch0)
723- own %{_datadir}/git-core/
724
725* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
726- update spec file to fix Buildroot, Requires, and drop Vendor
727
728* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
729- Redid the description
730- Cut overlong make line, loosened changelog a bit
731- I think Junio (or perhaps OSDL?) should be vendor...
732
733* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
734- Add the man pages, and the --without docs build option
735
736* Wed Jul 7 2005 Chris Wright <chris@osdl.org>
737- initial git spec file
Note: See TracBrowser for help on using the repository browser.