source: projects/specs/trunk/g/git/git-vl.spec @ 1966

Revision 1966, 21.7 KB checked in by iwaim, 14 years ago (diff)

git 1.7.1-2

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4# Pass --without docs to rpmbuild if you don't want the documentation
5Name:           git
6Version:        1.7.1
7Release:        2%{?_dist_release}
8Summary:        Core git tools
9Summary(ja):    Core git ツール
10License:        GPLv2
11Group:          Development/Tools
12URL:            http://git-scm.com/
13Source:         http://kernel.org/pub/software/scm/git/%{name}-%{version}.tar.bz2
14Source1:        git-init.el
15Source2:        git.xinetd
16Source3:        git.conf.httpd
17Source10:       %{name}-install.sh
18Source11:       %{name}-remove.sh
19Patch0:         git-1.5-gitweb-home-link.patch
20# Patch10:      git-1.6_git-daemon-fix.patch
21
22# Security
23Patch100:       git-1.7.x-CVE-2010-2542.patch
24
25BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel,
26BuildRequires:  expat-devel, gettext, asciidoc
27BuildRequires:  xmlto
28BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
29
30Requires:       perl-Git = %{version}-%{release}
31Requires:       zlib
32Provides:       git-core = %{version}-%{release}
33Obsoletes:      git-core <= 1.5.4.3
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37# Packager:     
38
39%description
40Git is a fast, scalable, distributed revision control system with an
41unusually rich command set that provides both high-level operations
42and full access to internals.
43
44The git rpm installs the core tools with minimal dependencies.  To
45install all git packages, including tools for integrating with other
46SCMs, install the git-all meta-package.
47
48%package all
49Summary:        Meta-package to pull in all git tools
50Summary(ja):    すべての git ツール
51Group:          Development/Tools
52Requires:       git = %{version}-%{release}
53Requires:       git-svn = %{version}-%{release}
54Requires:       git-cvs = %{version}-%{release}
55%if "%{?_dist_release}" != "vl4"
56Requires:       git-arch = %{version}-%{release}
57%endif
58Requires:       git-email = %{version}-%{release}
59Requires:       gitk = %{version}-%{release}
60Requires:       git-gui = %{version}-%{release}
61Requires:       perl-Git = %{version}-%{release}
62Requires:       emacs-git = %{version}-%{release}
63Obsoletes:      git <= 1.5.4.3
64
65%description all
66Git is a fast, scalable, distributed revision control system with an
67unusually rich command set that provides both high-level operations
68and full access to internals.
69
70This is a dummy package which brings in all subpackages.
71
72%package daemon
73Summary:        Git protocol daemon
74Summary(ja):    Git プロトコルデーモン
75Group:          Development/Tools
76Requires:       git = %{version}-%{release}
77%description daemon
78The git daemon for supporting git:// access to git repositories
79
80%package -n gitweb
81Summary:        Simple web interface to git repositories
82Summary(ja):    git リポジトリへのシンプルな Web インタフェース
83Group:          Development/Tools
84Requires:       git = %{version}-%{release}
85
86%description -n gitweb
87Simple web interface to track changes in git repositories
88
89
90%package svn
91Summary:        Git tools for importing Subversion repositories
92Summary(ja):    Subversion リポジトリを git へインポートするためのツール
93Group:          Development/Tools
94Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
95Requires:       perl(SVN::Core)
96%description svn
97Git tools for importing Subversion repositories.
98
99%package cvs
100Summary:        Git tools for importing CVS repositories
101Summary(ja):    CVS リポジトリを git へインポートするためのツール
102Group:          Development/Tools
103Requires:       git = %{version}-%{release}, cvs, cvsps
104%description cvs
105Git tools for importing CVS repositories.
106
107%if "%{?_dist_release}" != "vl4"
108%package arch
109Summary:        Git tools for importing Arch repositories
110Summary(ja):    Arch リポジトリを git へインポートするためのツール
111Group:          Development/Tools
112Requires:       git = %{version}-%{release}, tla
113%description arch
114Git tools for importing Arch repositories.
115%endif
116
117%package email
118Summary:        Git tools for sending email
119Summary(ja):    Eメールを送るための git ツール
120Group:          Development/Tools
121Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
122%description email
123Git tools for sending email.
124
125%package gui
126Summary:        Git GUI tool
127Summary(ja):    Git の GUI ツール
128Group:          Development/Tools
129Requires:       git = %{version}-%{release}, tk
130%description gui
131Git GUI tool.
132
133%package -n gitk
134Summary:        Git revision tree visualiser
135Summary(ja):    Git リビジョンツリー可視化ツール
136Group:          Development/Tools
137Requires:       git = %{version}-%{release}, tk
138%description -n gitk
139Git revision tree visualiser.
140
141%package -n perl-Git
142Summary:        Perl interface to Git
143Summary(ja):    Git の perl インタフェース
144Group:          Development/Libraries
145Requires:       git = %{version}-%{release}, perl(Error)
146%if "%{?_dist_release}" == "vl4"
147Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
148%else
149Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
150%endif
151#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
152
153%description -n perl-Git
154Perl interface to Git.
155
156%package -n emacs-git
157Summary:       Git version control system support for Emacs
158Summary(ja):   Emacs の Git サポート
159Group:         Applications/Editors
160Requires:      git = %{version}-%{release}, emacsen-common
161
162%description -n emacs-git
163%{summary}.
164
165%package devel
166Summary:        Header files for git-core
167Summary(ja):    git-core 用ヘッダファイル
168Group:          Development/Libraries
169
170%description devel
171Header files for git-core.
172
173%prep
174%setup -q
175%patch0 -p1
176
177# %patch10 -p1 -b .git-daemon-fix
178
179%patch100 -p1 -b .CVE-2010-2542
180
181%build
182make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
183     ETC_GITCONFIG=/etc/gitconfig \
184     prefix=%{_prefix} all %{!?_without_docs: doc}
185
186%install
187rm -rf $RPM_BUILD_ROOT
188make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
189     prefix=%{_prefix} mandir=%{_mandir} \
190     ETC_GITCONFIG=/etc/gitconfig \
191     NO_PYTHON=1 \
192     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
193
194# perl-Git
195# Error.pm provide by perl-Error package
196rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
197
198# emacs-git
199mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
200#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
201#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
202mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
203mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
204
205# install el files
206install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
207
208# install site-start file
209install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
210
211# install  script( bytecompile el and install elc , remove )   
212
213%_installemacsenscript git %{SOURCE10}
214
215%_removeemacsenscript  git %{SOURCE11}
216
217mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
218install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
219mkdir -p $RPM_BUILD_ROOT/var/www/git
220install -m 644 -t $RPM_BUILD_ROOT/var/www/git gitweb/*.png gitweb/*.css
221install -m 755 -t $RPM_BUILD_ROOT/var/www/git gitweb/gitweb.cgi
222mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
223install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
224
225find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
226find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
227find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
228
229(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
230(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
231%if %{!?_without_docs:1}0
232(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
233%else
234rm -rf $RPM_BUILD_ROOT%{_mandir}
235%endif
236mkdir -p $RPM_BUILD_ROOT/srv/git
237
238mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
239install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
240
241# header files and lib
242install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
243install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
244install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
245install libgit.a $RPM_BUILD_ROOT%{_libdir}
246install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
247
248
249%clean
250rm -rf $RPM_BUILD_ROOT
251
252%post -n emacs-git
253
254# bytecompile and install
255
256if [ "$1" = 2 ]; then
257
258%_emacsenPackageRemove git
259
260fi
261
262%_addemacsenlist git
263
264%_emacsenPackageInstall git
265
266%preun -n emacs-git
267
268if [ "$1" = 0 ]; then
269
270%_emacsenPackageRemove git
271
272%_removeemacsenlist git
273
274fi
275
276
277%files -f bin-man-doc-files
278%defattr(-,root,root)
279%{_bindir}/git
280%{_bindir}/git-receive-pack
281%{_bindir}/git-upload-archive
282%{_bindir}/git-upload-pack
283%{_bindir}/git-shell
284%{_datadir}/git-core/
285%doc README COPYING Documentation/*.txt contrib/hooks
286%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
287%{!?_without_docs: %doc Documentation/howto Documentation/technical}
288%{_sysconfdir}/bash_completion.d
289
290
291%files svn
292%defattr(-,root,root)
293%{_libexecdir}/git-core/*svn*
294%doc Documentation/*svn*.txt
295%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
296%{!?_without_docs: %doc Documentation/*svn*.html }
297
298%files cvs
299%defattr(-,root,root)
300%doc Documentation/*git-cvs*.txt
301%{_bindir}/git-cvsserver
302%{_libexecdir}/git-core/*cvs*
303%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
304%{!?_without_docs: %doc Documentation/*git-cvs*.html }
305
306%if "%{?_dist_release}" != "vl4"
307%files arch
308%defattr(-,root,root)
309%doc Documentation/git-archimport.txt
310%{_libexecdir}/git-core/git-archimport
311%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
312%{!?_without_docs: %doc Documentation/git-archimport.html }
313%endif
314
315%files email
316%defattr(-,root,root)
317%doc Documentation/*email*.txt
318%{_libexecdir}/git-core/*email*
319%{!?_without_docs: %{_mandir}/man1/*email*.1*}
320%{!?_without_docs: %doc Documentation/*email*.html }
321
322%files gui
323%defattr(-,root,root)
324%{_libexecdir}/git-core/git-gui*
325%{_libexecdir}/git-core/git-citool
326%{_datadir}/git-gui/
327%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
328%{!?_without_docs: %doc Documentation/git-gui.html}
329%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
330%{!?_without_docs: %doc Documentation/git-citool.html}
331
332%files -n gitk
333%defattr(-,root,root)
334%doc Documentation/*gitk*.txt
335%{_bindir}/gitk
336%{_datadir}/gitk
337%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
338%{!?_without_docs: %doc Documentation/*gitk*.html }
339
340%files -n perl-Git -f perl-files
341%defattr(-,root,root)
342
343%files -n emacs-git
344%defattr(-,root,root)
345%{_datadir}/emacs/site-lisp/git
346#%{_libdir}/emacsen-common/packages/install/git
347#%{_libdir}/emacsen-common/packages/remove/git
348%{emacsen_pkgdir}/install/git
349%{emacsen_pkgdir}/remove/git
350
351%files daemon
352%defattr(-,root,root)
353%{_libexecdir}/git-core/git-daemon
354%config(noreplace)%{_sysconfdir}/xinetd.d/git
355/srv/git
356
357%files -n gitweb
358%defattr(-,root,root)
359/var/www/git/
360%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
361
362%files devel
363%defattr(644,root,root,755)
364%{_includedir}/git
365%{_libdir}/libgit.a
366%{_libdir}/libgit_xdiff.a
367
368
369%files all
370# No files for you!
371
372%changelog
373* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
374- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
375
376* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
377- new upstream release
378- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
379- disable building of unused python remote helper libs
380
381* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
382- new upstream release with security fix
383- drop patch10 (included in new release)
384
385* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
386- new upstream release
387- add patch10 git daemon extra arg parsing fix
388
389* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
390- fix install script for Emacs Lisp: <BTS:VineLinux:685>
391 - update git-install.sh (Source10) using contributed patch
392
393* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
394- new upstream release
395
396* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
397- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
398- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
399- fix summary and description in daemon sub package
400
401* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
402- drop Error.pm: provide by perl-Error package
403
404* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
405- new upstream relase
406- update URL tag
407- add Requires: perl(SVN::Core) for svn subpackage
408
409* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
410- add git-shell in git package
411- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
412
413* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
414- added BuildRequires: xmlto
415
416* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
417- new upstream release
418- add devel subpackage (see [wishes:0165])
419
420* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
421- new upstream release
422
423* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
424- new upstream release
425
426* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
427- new upstream release
428
429* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
430- use %%emacsen_pkgdir macro
431
432* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
433- new upstream release
434
435* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
436- initial build for Vine Linux
437
438* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
439- git-1.5.6.4
440
441* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
442- git-1.5.6
443
444* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
445- use tar.bz2 instead of tar.gz
446
447* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
448- git-1.5.5.3
449
450* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
451- git-1.5.5.2
452
453* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
454- git-1.5.5.1
455
456* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
457- git-1.5.5
458
459* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
460- Remove the last two requires on git-core.
461
462* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
463- Remove a patch that's already upstream.
464
465* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
466- git-1.5.4.5
467
468* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
469- Own /etc/bash_completion.d in case bash-completion isn't installed.
470
471* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
472- Include the sample hooks from contrib/hooks as docs (bug 321151).
473- Install the bash completion script from contrib (bug 433255).
474- Include the html docs in the 'core' package again (bug 434271).
475
476* Wed Mar 19 2008 James Bowes 1.5.4.4-2
477- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
478
479* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
480- git-1.5.4.4
481
482* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
483- rebuild for new perl (again)
484
485* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
486- Do not silently overwrite /etc/httpd/conf.d/git.conf
487
488* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
489- git-1.5.4.3
490- Include Kristian Høgsberg's changes to rename git-core to
491  git and git to git-all.
492
493* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
494- git-1.5.4.2
495
496* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
497- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
498  gitweb rss feeds point be commitdiffs instead of commit
499
500* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
501- git-1.5.4.1
502
503* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
504- rebuild for new perl
505
506* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
507- Add BuidRequires on gettext.
508
509* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
510- git-1.5.4
511
512* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
513- git-1.5.3.8
514
515* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
516- Have git metapackage require explicit versions (bug 247214)
517
518* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
519- git-1.5.3.7
520
521* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
522- git-1.5.3.6
523- git-core requires perl(Error) (bug 367861)
524- git-svn requires perl(Term:ReadKey) (bug 261361)
525- git-email requires perl-Git (bug 333061)
526
527* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
528- git-Perl requires Error package
529
530* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
531- git-1.5.3.4
532
533* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
534- git-1.5.3.3
535
536* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
537- git-1.5.3.2
538
539* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
540- Include git-gui and git-citool docs
541
542* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
543- git-1.5.3.1-1
544
545* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
546- git-1.5.2.5-1
547
548* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
549- git-1.5.2.4-1
550
551* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
552- Add git-daemon and gitweb packages
553
554* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
555- Add emacs-git package (#235431)
556
557* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
558- git-1.5.2.2
559
560* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
561- git-1.5.2.1
562
563* Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
564- Added lib files for git-gui
565- Added Documentation/technical (As needed by Git Users Manual)
566
567* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
568- Added howto files
569
570* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
571- git-1.5.0.6
572
573* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
574- git-1.5.0.5
575
576* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
577- git-1.5.0.3
578
579* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
580- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
581
582* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
583- git-1.5.0.2
584
585* Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
586- Update core package description (Git isn't as stupid as it used to be)
587
588* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
589- Add git-gui and git-citool.
590
591* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
592- no need to install manpages executable (bz 216790)
593- use bytes for git-cvsserver
594
595* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
596- git-1.4.4.2
597
598* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
599- rebuild against the new curl
600
601* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
602- git-1.4.2.4
603
604* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
605- git-1.4.2.3
606
607* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
608- git-1.4.2.1
609
610* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
611- git-1.4.2
612
613* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
614- git-1.4.1
615
616* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
617- git-1.4.0
618
619* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
620- git-1.3.3
621- enable git-email building, prereqs have been relaxed
622
623* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
624- git-1.3.2
625
626* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
627- git-1.3.1
628
629* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
630- git-1.3.0
631
632* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
633- git-1.2.6
634
635* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
636- git-1.2.5
637
638* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
639- git-1.2.4
640
641* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
642- git-1.2.3
643
644* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
645- git-1.2.2
646
647* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
648- git-1.2.1
649
650* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
651- git-1.2.0
652
653* Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
654- git-1.1.6
655
656* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
657- git-1.1.4
658
659* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
660- git-1.1.2
661
662* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
663- git-1.1.1
664
665* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
666- Update to latest git-1.1.0 (drop git-email for now)
667- Now creates multiple packages:
668-        git-core, git-svn, git-cvs, git-arch, gitk
669
670* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
671- Change subpackage names to git-<name> instead of git-core-<name>
672- Create empty root package which brings in all subpackages
673- Rename git-tk -> gitk
674
675* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
676- zlib dependency fix
677- Minor cleanups from split
678- Move arch import to separate package as well
679
680* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
681- Move programs with non-standard dependencies (svn, cvs, email)
682  into separate packages
683
684* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
685- parallelize build
686- COPTS -> CFLAGS
687
688* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
689- update to 0.99.6
690
691* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
692- Linus noticed that less is required, added to the dependencies
693
694* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
695- Updated dependencies
696- Don't assume manpages are gzipped
697
698* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
699- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
700- use RPM_OPT_FLAGS in spec file, drop patch0
701
702* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
703- use dist tag to differentiate between branches
704- use rpm optflags by default (patch0)
705- own %{_datadir}/git-core/
706
707* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
708- update spec file to fix Buildroot, Requires, and drop Vendor
709
710* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
711- Redid the description
712- Cut overlong make line, loosened changelog a bit
713- I think Junio (or perhaps OSDL?) should be vendor...
714
715* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
716- Add the man pages, and the --without docs build option
717
718* Wed Jul 7 2005 Chris Wright <chris@osdl.org>
719- initial git spec file
Note: See TracBrowser for help on using the repository browser.