source: projects/specs/trunk/g/git/git-vl.spec @ 1192

Revision 1192, 21.4 KB checked in by iwaim, 14 years ago (diff)

git 1.7.1-1

Line 
1%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4# Pass --without docs to rpmbuild if you don't want the documentation
5Name:           git
6Version:        1.7.1
7Release:        1%{?_dist_release}
8Summary:        Core git tools
9Summary(ja):    Core git ツール
10License:        GPLv2
11Group:          Development/Tools
12URL:            http://git-scm.com/
13Source:         http://kernel.org/pub/software/scm/git/%{name}-%{version}.tar.bz2
14Source1:        git-init.el
15Source2:        git.xinetd
16Source3:        git.conf.httpd
17Source10:       %{name}-install.sh
18Source11:       %{name}-remove.sh
19Patch0:         git-1.5-gitweb-home-link.patch
20# Patch10:      git-1.6_git-daemon-fix.patch
21
22BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel,
23BuildRequires:  expat-devel, gettext, asciidoc
24BuildRequires:  xmlto
25BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
26
27Requires:       perl-Git = %{version}-%{release}
28Requires:       zlib
29Provides:       git-core = %{version}-%{release}
30Obsoletes:      git-core <= 1.5.4.3
31
32%description
33Git is a fast, scalable, distributed revision control system with an
34unusually rich command set that provides both high-level operations
35and full access to internals.
36
37The git rpm installs the core tools with minimal dependencies.  To
38install all git packages, including tools for integrating with other
39SCMs, install the git-all meta-package.
40
41%package all
42Summary:        Meta-package to pull in all git tools
43Summary(ja):    すべての git ツール
44Group:          Development/Tools
45Requires:       git = %{version}-%{release}
46Requires:       git-svn = %{version}-%{release}
47Requires:       git-cvs = %{version}-%{release}
48%if "%{?_dist_release}" != "vl4"
49Requires:       git-arch = %{version}-%{release}
50%endif
51Requires:       git-email = %{version}-%{release}
52Requires:       gitk = %{version}-%{release}
53Requires:       git-gui = %{version}-%{release}
54Requires:       perl-Git = %{version}-%{release}
55Requires:       emacs-git = %{version}-%{release}
56Obsoletes:      git <= 1.5.4.3
57
58%description all
59Git is a fast, scalable, distributed revision control system with an
60unusually rich command set that provides both high-level operations
61and full access to internals.
62
63This is a dummy package which brings in all subpackages.
64
65%package daemon
66Summary:        Git protocol daemon
67Summary(ja):    Git プロトコルデーモン
68Group:          Development/Tools
69Requires:       git = %{version}-%{release}
70%description daemon
71The git daemon for supporting git:// access to git repositories
72
73%package -n gitweb
74Summary:        Simple web interface to git repositories
75Summary(ja):    git リポジトリへのシンプルな Web インタフェース
76Group:          Development/Tools
77Requires:       git = %{version}-%{release}
78
79%description -n gitweb
80Simple web interface to track changes in git repositories
81
82
83%package svn
84Summary:        Git tools for importing Subversion repositories
85Summary(ja):    Subversion リポジトリを git へインポートするためのツール
86Group:          Development/Tools
87Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
88Requires:       perl(SVN::Core)
89%description svn
90Git tools for importing Subversion repositories.
91
92%package cvs
93Summary:        Git tools for importing CVS repositories
94Summary(ja):    CVS リポジトリを git へインポートするためのツール
95Group:          Development/Tools
96Requires:       git = %{version}-%{release}, cvs, cvsps
97%description cvs
98Git tools for importing CVS repositories.
99
100%if "%{?_dist_release}" != "vl4"
101%package arch
102Summary:        Git tools for importing Arch repositories
103Summary(ja):    Arch リポジトリを git へインポートするためのツール
104Group:          Development/Tools
105Requires:       git = %{version}-%{release}, tla
106%description arch
107Git tools for importing Arch repositories.
108%endif
109
110%package email
111Summary:        Git tools for sending email
112Summary(ja):    Eメールを送るための git ツール
113Group:          Development/Tools
114Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
115%description email
116Git tools for sending email.
117
118%package gui
119Summary:        Git GUI tool
120Summary(ja):    Git の GUI ツール
121Group:          Development/Tools
122Requires:       git = %{version}-%{release}, tk
123%description gui
124Git GUI tool.
125
126%package -n gitk
127Summary:        Git revision tree visualiser
128Summary(ja):    Git リビジョンツリー可視化ツール
129Group:          Development/Tools
130Requires:       git = %{version}-%{release}, tk
131%description -n gitk
132Git revision tree visualiser.
133
134%package -n perl-Git
135Summary:        Perl interface to Git
136Summary(ja):    Git の perl インタフェース
137Group:          Development/Libraries
138Requires:       git = %{version}-%{release}, perl(Error)
139%if "%{?_dist_release}" == "vl4"
140Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
141%else
142Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
143%endif
144#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
145
146%description -n perl-Git
147Perl interface to Git.
148
149%package -n emacs-git
150Summary:       Git version control system support for Emacs
151Summary(ja):   Emacs の Git サポート
152Group:         Applications/Editors
153Requires:      git = %{version}-%{release}, emacsen-common
154
155%description -n emacs-git
156%{summary}.
157
158%package devel
159Summary:        Header files for git-core
160Summary(ja):    git-core 用ヘッダファイル
161Group:          Development/Libraries
162
163%description devel
164Header files for git-core.
165
166%prep
167%setup -q
168%patch0 -p1
169
170# %patch10 -p1 -b .git-daemon-fix
171
172%build
173make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
174     ETC_GITCONFIG=/etc/gitconfig \
175     prefix=%{_prefix} all %{!?_without_docs: doc}
176
177%install
178rm -rf $RPM_BUILD_ROOT
179make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
180     prefix=%{_prefix} mandir=%{_mandir} \
181     ETC_GITCONFIG=/etc/gitconfig \
182     NO_PYTHON=1 \
183     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
184
185# perl-Git
186# Error.pm provide by perl-Error package
187rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
188
189# emacs-git
190mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
191#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
192#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
193mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
194mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
195
196# install el files
197install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
198
199# install site-start file
200install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
201
202# install  script( bytecompile el and install elc , remove )   
203
204%_installemacsenscript git %{SOURCE10}
205
206%_removeemacsenscript  git %{SOURCE11}
207
208mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
209install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
210mkdir -p $RPM_BUILD_ROOT/var/www/git
211install -m 644 -t $RPM_BUILD_ROOT/var/www/git gitweb/*.png gitweb/*.css
212install -m 755 -t $RPM_BUILD_ROOT/var/www/git gitweb/gitweb.cgi
213mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
214install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
215
216find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
217find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
218find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
219
220(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
221(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
222%if %{!?_without_docs:1}0
223(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
224%else
225rm -rf $RPM_BUILD_ROOT%{_mandir}
226%endif
227mkdir -p $RPM_BUILD_ROOT/srv/git
228
229mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
230install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
231
232# header files and lib
233install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
234install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
235install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
236install libgit.a $RPM_BUILD_ROOT%{_libdir}
237install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
238
239
240%clean
241rm -rf $RPM_BUILD_ROOT
242
243%post -n emacs-git
244
245# bytecompile and install
246
247if [ "$1" = 2 ]; then
248
249%_emacsenPackageRemove git
250
251fi
252
253%_addemacsenlist git
254
255%_emacsenPackageInstall git
256
257%preun -n emacs-git
258
259if [ "$1" = 0 ]; then
260
261%_emacsenPackageRemove git
262
263%_removeemacsenlist git
264
265fi
266
267
268%files -f bin-man-doc-files
269%defattr(-,root,root)
270%{_bindir}/git
271%{_bindir}/git-receive-pack
272%{_bindir}/git-upload-archive
273%{_bindir}/git-upload-pack
274%{_bindir}/git-shell
275%{_datadir}/git-core/
276%doc README COPYING Documentation/*.txt contrib/hooks
277%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
278%{!?_without_docs: %doc Documentation/howto Documentation/technical}
279%{_sysconfdir}/bash_completion.d
280
281
282%files svn
283%defattr(-,root,root)
284%{_libexecdir}/git-core/*svn*
285%doc Documentation/*svn*.txt
286%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
287%{!?_without_docs: %doc Documentation/*svn*.html }
288
289%files cvs
290%defattr(-,root,root)
291%doc Documentation/*git-cvs*.txt
292%{_bindir}/git-cvsserver
293%{_libexecdir}/git-core/*cvs*
294%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
295%{!?_without_docs: %doc Documentation/*git-cvs*.html }
296
297%if "%{?_dist_release}" != "vl4"
298%files arch
299%defattr(-,root,root)
300%doc Documentation/git-archimport.txt
301%{_libexecdir}/git-core/git-archimport
302%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
303%{!?_without_docs: %doc Documentation/git-archimport.html }
304%endif
305
306%files email
307%defattr(-,root,root)
308%doc Documentation/*email*.txt
309%{_libexecdir}/git-core/*email*
310%{!?_without_docs: %{_mandir}/man1/*email*.1*}
311%{!?_without_docs: %doc Documentation/*email*.html }
312
313%files gui
314%defattr(-,root,root)
315%{_libexecdir}/git-core/git-gui*
316%{_libexecdir}/git-core/git-citool
317%{_datadir}/git-gui/
318%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
319%{!?_without_docs: %doc Documentation/git-gui.html}
320%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
321%{!?_without_docs: %doc Documentation/git-citool.html}
322
323%files -n gitk
324%defattr(-,root,root)
325%doc Documentation/*gitk*.txt
326%{_bindir}/gitk
327%{_datadir}/gitk
328%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
329%{!?_without_docs: %doc Documentation/*gitk*.html }
330
331%files -n perl-Git -f perl-files
332%defattr(-,root,root)
333
334%files -n emacs-git
335%defattr(-,root,root)
336%{_datadir}/emacs/site-lisp/git
337#%{_libdir}/emacsen-common/packages/install/git
338#%{_libdir}/emacsen-common/packages/remove/git
339%{emacsen_pkgdir}/install/git
340%{emacsen_pkgdir}/remove/git
341
342%files daemon
343%defattr(-,root,root)
344%{_libexecdir}/git-core/git-daemon
345%config(noreplace)%{_sysconfdir}/xinetd.d/git
346/srv/git
347
348%files -n gitweb
349%defattr(-,root,root)
350/var/www/git/
351%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
352
353%files devel
354%defattr(644,root,root,755)
355%{_includedir}/git
356%{_libdir}/libgit.a
357%{_libdir}/libgit_xdiff.a
358
359
360%files all
361# No files for you!
362
363%changelog
364* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
365- new upstream release
366- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
367- disable building of unused python remote helper libs
368
369* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
370- new upstream release with security fix
371- drop patch10 (included in new release)
372
373* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
374- new upstream release
375- add patch10 git daemon extra arg parsing fix
376
377* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
378- fix install script for Emacs Lisp: <BTS:VineLinux:685>
379 - update git-install.sh (Source10) using contributed patch
380
381* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
382- new upstream release
383
384* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
385- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
386- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
387- fix summary and description in daemon sub package
388
389* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
390- drop Error.pm: provide by perl-Error package
391
392* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
393- new upstream relase
394- update URL tag
395- add Requires: perl(SVN::Core) for svn subpackage
396
397* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
398- add git-shell in git package
399- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
400
401* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
402- added BuildRequires: xmlto
403
404* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
405- new upstream release
406- add devel subpackage (see [wishes:0165])
407
408* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
409- new upstream release
410
411* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
412- new upstream release
413
414* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
415- new upstream release
416
417* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
418- use %%emacsen_pkgdir macro
419
420* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
421- new upstream release
422
423* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
424- initial build for Vine Linux
425
426* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
427- git-1.5.6.4
428
429* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
430- git-1.5.6
431
432* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
433- use tar.bz2 instead of tar.gz
434
435* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
436- git-1.5.5.3
437
438* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
439- git-1.5.5.2
440
441* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
442- git-1.5.5.1
443
444* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
445- git-1.5.5
446
447* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
448- Remove the last two requires on git-core.
449
450* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
451- Remove a patch that's already upstream.
452
453* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
454- git-1.5.4.5
455
456* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
457- Own /etc/bash_completion.d in case bash-completion isn't installed.
458
459* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
460- Include the sample hooks from contrib/hooks as docs (bug 321151).
461- Install the bash completion script from contrib (bug 433255).
462- Include the html docs in the 'core' package again (bug 434271).
463
464* Wed Mar 19 2008 James Bowes 1.5.4.4-2
465- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
466
467* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
468- git-1.5.4.4
469
470* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
471- rebuild for new perl (again)
472
473* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
474- Do not silently overwrite /etc/httpd/conf.d/git.conf
475
476* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
477- git-1.5.4.3
478- Include Kristian Høgsberg's changes to rename git-core to
479  git and git to git-all.
480
481* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
482- git-1.5.4.2
483
484* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
485- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
486  gitweb rss feeds point be commitdiffs instead of commit
487
488* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
489- git-1.5.4.1
490
491* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
492- rebuild for new perl
493
494* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
495- Add BuidRequires on gettext.
496
497* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
498- git-1.5.4
499
500* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
501- git-1.5.3.8
502
503* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
504- Have git metapackage require explicit versions (bug 247214)
505
506* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
507- git-1.5.3.7
508
509* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
510- git-1.5.3.6
511- git-core requires perl(Error) (bug 367861)
512- git-svn requires perl(Term:ReadKey) (bug 261361)
513- git-email requires perl-Git (bug 333061)
514
515* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
516- git-Perl requires Error package
517
518* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
519- git-1.5.3.4
520
521* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
522- git-1.5.3.3
523
524* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
525- git-1.5.3.2
526
527* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
528- Include git-gui and git-citool docs
529
530* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
531- git-1.5.3.1-1
532
533* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
534- git-1.5.2.5-1
535
536* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
537- git-1.5.2.4-1
538
539* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
540- Add git-daemon and gitweb packages
541
542* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
543- Add emacs-git package (#235431)
544
545* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
546- git-1.5.2.2
547
548* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
549- git-1.5.2.1
550
551* Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
552- Added lib files for git-gui
553- Added Documentation/technical (As needed by Git Users Manual)
554
555* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
556- Added howto files
557
558* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
559- git-1.5.0.6
560
561* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
562- git-1.5.0.5
563
564* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
565- git-1.5.0.3
566
567* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
568- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
569
570* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
571- git-1.5.0.2
572
573* Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
574- Update core package description (Git isn't as stupid as it used to be)
575
576* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
577- Add git-gui and git-citool.
578
579* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
580- no need to install manpages executable (bz 216790)
581- use bytes for git-cvsserver
582
583* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
584- git-1.4.4.2
585
586* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
587- rebuild against the new curl
588
589* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
590- git-1.4.2.4
591
592* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
593- git-1.4.2.3
594
595* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
596- git-1.4.2.1
597
598* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
599- git-1.4.2
600
601* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
602- git-1.4.1
603
604* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
605- git-1.4.0
606
607* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
608- git-1.3.3
609- enable git-email building, prereqs have been relaxed
610
611* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
612- git-1.3.2
613
614* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
615- git-1.3.1
616
617* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
618- git-1.3.0
619
620* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
621- git-1.2.6
622
623* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
624- git-1.2.5
625
626* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
627- git-1.2.4
628
629* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
630- git-1.2.3
631
632* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
633- git-1.2.2
634
635* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
636- git-1.2.1
637
638* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
639- git-1.2.0
640
641* Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
642- git-1.1.6
643
644* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
645- git-1.1.4
646
647* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
648- git-1.1.2
649
650* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
651- git-1.1.1
652
653* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
654- Update to latest git-1.1.0 (drop git-email for now)
655- Now creates multiple packages:
656-        git-core, git-svn, git-cvs, git-arch, gitk
657
658* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
659- Change subpackage names to git-<name> instead of git-core-<name>
660- Create empty root package which brings in all subpackages
661- Rename git-tk -> gitk
662
663* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
664- zlib dependency fix
665- Minor cleanups from split
666- Move arch import to separate package as well
667
668* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
669- Move programs with non-standard dependencies (svn, cvs, email)
670  into separate packages
671
672* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
673- parallelize build
674- COPTS -> CFLAGS
675
676* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
677- update to 0.99.6
678
679* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
680- Linus noticed that less is required, added to the dependencies
681
682* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
683- Updated dependencies
684- Don't assume manpages are gzipped
685
686* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
687- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
688- use RPM_OPT_FLAGS in spec file, drop patch0
689
690* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
691- use dist tag to differentiate between branches
692- use rpm optflags by default (patch0)
693- own %{_datadir}/git-core/
694
695* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
696- update spec file to fix Buildroot, Requires, and drop Vendor
697
698* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
699- Redid the description
700- Cut overlong make line, loosened changelog a bit
701- I think Junio (or perhaps OSDL?) should be vendor...
702
703* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
704- Add the man pages, and the --without docs build option
705
706* Wed Jul 7 2005 Chris Wright <chris@osdl.org>
707- initial git spec file
Note: See TracBrowser for help on using the repository browser.