source: projects/specs/trunk/g/git/git-vl.spec @ 12391

Revision 12391, 27.9 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

dkms-2.8.1-1

fribidi-1.0.9-1

git-2.26.2-1

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:           git
8Version:        2.26.2
9Release:        1%{?_dist_release}
10Summary:        Core git tools
11Summary(ja):    Core git ツール
12Group:          Development/Tools
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       iwaim
16
17License:        GPLv2
18URL:            http://git-scm.com/
19Source0:        https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
20Source1:        vine-default-git.el
21Source2:        git.xinetd
22Source3:        git.conf.httpd
23Source4:        gitweb.conf.in
24Source10:       %{name}-install.sh
25Source11:       %{name}-remove.sh
26Source12:       git-init.el
27Patch0:         git-1.5-gitweb-home-link.patch
28Patch1000:      git-curl-disable-http2.patch
29       
30# Security
31# none
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel
36BuildRequires:  expat-devel, gettext, asciidoc
37BuildRequires:  pcre-devel
38BuildRequires:  xmlto
39
40# git-credential-gnome-keyring
41BuildRequires:  glib2-devel libgnome-keyring-devel
42
43Requires:       perl-Git = %{version}-%{release}
44Requires:       zlib
45Provides:       git-core = %{version}-%{release}
46Obsoletes:      git-core <= 1.5.4.3
47
48%description
49Git is a fast, scalable, distributed revision control system with an
50unusually rich command set that provides both high-level operations
51and full access to internals.
52
53The git rpm installs the core tools with minimal dependencies.  To
54install all git packages, including tools for integrating with other
55SCMs, install the git-all meta-package.
56
57%package all
58Summary:        Meta-package to pull in all git tools
59Summary(ja):    すべての git ツール
60Group:          Development/Tools
61Requires:       git = %{version}-%{release}
62Requires:       git-svn = %{version}-%{release}
63Requires:       git-cvs = %{version}-%{release}
64%if "%{?_dist_release}" != "vl4" && %{with arch}
65Requires:       git-arch = %{version}-%{release}
66%endif
67Requires:       git-email = %{version}-%{release}
68Requires:       gitk = %{version}-%{release}
69Requires:       git-gui = %{version}-%{release}
70Requires:       perl-Git = %{version}-%{release}
71Requires:       emacs-git = %{version}-%{release}
72Requires:       git-contrib = %{version}-%{release}
73Obsoletes:      git <= 1.5.4.3
74
75%description all
76Git is a fast, scalable, distributed revision control system with an
77unusually rich command set that provides both high-level operations
78and full access to internals.
79
80This is a dummy package which brings in all subpackages.
81
82%package daemon
83Summary:        Git protocol daemon
84Summary(ja):    Git プロトコルデーモン
85Group:          Development/Tools
86Requires:       git = %{version}-%{release}
87%description daemon
88The git daemon for supporting git:// access to git repositories
89
90%package -n gitweb
91Summary:        Simple web interface to git repositories
92Summary(ja):    git リポジトリへのシンプルな Web インタフェース
93Group:          Development/Tools
94Requires:       git = %{version}-%{release}
95
96%description -n gitweb
97Simple web interface to track changes in git repositories
98
99
100%package svn
101Summary:        Git tools for importing Subversion repositories
102Summary(ja):    Subversion リポジトリを git へインポートするためのツール
103Group:          Development/Tools
104Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
105Requires:       perl(SVN::Core)
106%description svn
107Git tools for importing Subversion repositories.
108
109%package cvs
110Summary:        Git tools for importing CVS repositories
111Summary(ja):    CVS リポジトリを git へインポートするためのツール
112Group:          Development/Tools
113Requires:       git = %{version}-%{release}, cvs, cvsps
114%description cvs
115Git tools for importing CVS repositories.
116
117%package contrib
118Summary:        Git contrib tools
119Group:          Development/Tools
120Requires:       git = %{version}-%{release}
121%description contrib
122Git contrib tools
123
124%if "%{?_dist_release}" != "vl4" && %{with arch}
125%package arch
126Summary:        Git tools for importing Arch repositories
127Summary(ja):    Arch リポジトリを git へインポートするためのツール
128Group:          Development/Tools
129Requires:       git = %{version}-%{release}, tla
130%description arch
131Git tools for importing Arch repositories.
132%endif
133
134%package email
135Summary:        Git tools for sending email
136Summary(ja):    Eメールを送るための git ツール
137Group:          Development/Tools
138Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
139%description email
140Git tools for sending email.
141
142%package gui
143Summary:        Git GUI tool
144Summary(ja):    Git の GUI ツール
145Group:          Development/Tools
146Requires:       git = %{version}-%{release}, tk
147%description gui
148Git GUI tool.
149
150%package -n gitk
151Summary:        Git revision tree visualiser
152Summary(ja):    Git リビジョンツリー可視化ツール
153Group:          Development/Tools
154Requires:       git = %{version}-%{release}, tk
155%description -n gitk
156Git revision tree visualiser.
157
158%package -n perl-Git
159Summary:        Perl interface to Git
160Summary(ja):    Git の perl インタフェース
161Group:          Development/Libraries
162Requires:       git = %{version}-%{release}, perl(Error), perl-MailTools
163%if "%{?_dist_release}" == "vl4"
164Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
165%else
166Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
167%endif
168#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
169
170%description -n perl-Git
171Perl interface to Git.
172
173%package -n emacs-git
174Summary:       Git version control system support for Emacs
175Summary(ja):   Emacs の Git サポート
176Group:         Applications/Editors
177Requires:      git = %{version}-%{release}, emacsen-common
178
179%description -n emacs-git
180%{summary}.
181
182%package devel
183Summary:        Header files for git-core
184Summary(ja):    git-core 用ヘッダファイル
185Group:          Development/Libraries
186
187%description devel
188Header files for git-core.
189
190%prep
191%setup -q
192%patch0 -p1
193%patch1000 -p1
194
195# for pcre-8.12
196%if %{?_dist_release} == "vl6"
197%{__perl} -pi -e "s|#include <pcre.h>|#include <pcre/pcre.h>|" grep.h
198%endif
199
200%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
201
202# Filter bogus perl requires
203cat << \EOF > %{name}-req
204#!/bin/sh
205%{__perl_requires} $* |\
206sed -e '/perl(packed-refs)/d'
207EOF
208
209%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
210chmod +x %{__perl_requires}
211
212%build
213make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
214     ETC_GITCONFIG=/etc/gitconfig \
215     USE_LIBPCRE1=1 \
216     GITWEB_PROJECTROOT=/var/lib/git \
217     gitwebdir=/var/www/git \
218     prefix=%{_prefix} all %{!?_without_docs: doc}
219
220pushd contrib/diff-highlight
221make diff-highlight
222popd
223
224%install
225rm -rf $RPM_BUILD_ROOT
226make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
227     prefix=%{_prefix} mandir=%{_mandir} \
228     perllibdir=%{perl_vendorlib} \
229     ETC_GITCONFIG=/etc/gitconfig \
230     USE_LIBPCRE1=1 \
231     NO_PYTHON=1 \
232     GITWEB_PROJECTROOT=/var/lib/git \
233     gitwebdir=/var/www/git \
234     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
235
236pushd contrib/credential/gnome-keyring
237make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
238popd
239
240# arch
241%if %{without arch}
242rm -f Documentation/git-archimport.txt
243rm -f %{buildroot}%{_libexecdir}/git-core/git-archimport
244rm -f %{buildroot}%{_mandir}/man1/git-archimport.1*
245rm -f %{buildroot}/Documentation/git-archimport.html
246%endif
247
248
249# perl-Git
250rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/FromCPAN
251
252# emacs-git
253mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
254#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
255#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
256mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
257mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
258
259# install el files
260install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
261
262# install vine-default file
263install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
264
265# install  script( bytecompile el and install elc , remove )
266
267%_installemacsenscript git %{SOURCE10}
268
269%_removeemacsenscript  git %{SOURCE11}
270
271mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
272mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
273install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
274perl -p \
275     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
276     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
277     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
278
279## for gitweb sub package
280mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
281install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
282sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
283    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
284
285find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
286find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
287find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
288
289(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
290(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
291%if %{!?_without_docs:1}0
292(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
293%else
294rm -rf $RPM_BUILD_ROOT%{_mandir}
295%endif
296mkdir -p $RPM_BUILD_ROOT/srv/git
297
298mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
299install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
300
301install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
302
303# header files and lib
304install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
305install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
306install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
307install -m0755 -d $RPM_BUILD_ROOT%{_libdir}
308install libgit.a $RPM_BUILD_ROOT%{_libdir}/
309install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
310
311# git-credential-gnome-keyring
312pushd contrib/credential/gnome-keyring
313%__install -m0755 git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libexecdir}/git-core
314popd
315
316%find_lang %{name}
317
318%clean
319rm -rf $RPM_BUILD_ROOT
320
321%post -n emacs-git
322
323# bytecompile and install
324
325if [ "$1" = 2 ]; then
326
327%_emacsenPackageRemove git
328
329fi
330
331%_addemacsenlist git
332
333%_emacsenPackageInstall git
334
335%preun -n emacs-git
336
337if [ "$1" = 0 ]; then
338
339%_emacsenPackageRemove git
340
341%_removeemacsenlist git
342
343fi
344
345
346%files -f bin-man-doc-files -f %{name}.lang
347%defattr(-,root,root)
348%{_bindir}/git
349%{_bindir}/git-receive-pack
350%{_bindir}/git-upload-archive
351%{_bindir}/git-upload-pack
352%{_bindir}/git-shell
353%{_datadir}/git-core/
354%exclude %{_libexecdir}/git-core/git-credential-gnome-keyring
355%license COPYING
356%doc README.md Documentation/*.txt contrib/hooks
357%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
358%{!?_without_docs: %doc Documentation/howto Documentation/technical}
359%{_sysconfdir}/bash_completion.d
360
361
362%files svn
363%defattr(-,root,root)
364%{_libexecdir}/git-core/*svn*
365%doc Documentation/*svn*.txt
366%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
367%{!?_without_docs: %doc Documentation/*svn*.html }
368
369%files cvs
370%defattr(-,root,root)
371%doc Documentation/*git-cvs*.txt
372%{_bindir}/git-cvsserver
373%{_libexecdir}/git-core/*cvs*
374%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
375%{!?_without_docs: %doc Documentation/*git-cvs*.html }
376
377%files contrib
378%defattr(-,root,root)
379%doc contrib/diff-highlight/README.diff-highlight
380%{_bindir}/diff-highlight
381%{_libexecdir}/git-core/git-credential-gnome-keyring
382
383%if "%{?_dist_release}" != "vl4" && %{with arch}
384%files arch
385%defattr(-,root,root)
386%doc Documentation/git-archimport.txt
387%{_libexecdir}/git-core/git-archimport
388%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
389%{!?_without_docs: %doc Documentation/git-archimport.html }
390%endif
391
392%files email
393%defattr(-,root,root)
394%doc Documentation/*email*.txt
395%{_libexecdir}/git-core/*email*
396%{!?_without_docs: %{_mandir}/man1/*email*.1*}
397%{!?_without_docs: %doc Documentation/*email*.html }
398
399%files gui
400%defattr(-,root,root)
401%{_libexecdir}/git-core/git-gui*
402%{_libexecdir}/git-core/git-citool
403%{_datadir}/git-gui/
404%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
405%{!?_without_docs: %doc Documentation/git-gui.html}
406%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
407%{!?_without_docs: %doc Documentation/git-citool.html}
408
409%files -n gitk
410%defattr(-,root,root)
411%doc Documentation/*gitk*.txt
412%{_bindir}/gitk
413%{_datadir}/gitk
414%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
415%{!?_without_docs: %doc Documentation/*gitk*.html }
416
417%files -n perl-Git -f perl-files
418%defattr(-,root,root)
419
420%files -n emacs-git
421%defattr(-,root,root)
422%{_datadir}/emacs/site-lisp/git
423#%{_libdir}/emacsen-common/packages/install/git
424#%{_libdir}/emacsen-common/packages/remove/git
425%{emacsen_pkgdir}/install/git
426%{emacsen_pkgdir}/remove/git
427
428%files daemon
429%defattr(-,root,root)
430%{_var}/lib/git
431%{_libexecdir}/git-core/git-daemon
432%config(noreplace)%{_sysconfdir}/xinetd.d/git
433/srv/git
434
435%files -n gitweb
436%defattr(-,root,root)
437%doc gitweb/README
438/var/www/git/
439%config(noreplace)%{_sysconfdir}/gitweb.conf
440%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
441
442%files devel
443%defattr(644,root,root,755)
444%{_includedir}/git
445%{_libdir}/libgit.a
446%{_libdir}/libgit_xdiff.a
447
448
449%files all
450# No files for you!
451
452%changelog
453* Fri May 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.26.2-1
454- updated to 2.26.2.
455
456* Mon Apr 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.26.1-1
457- updated to 2.26.1.
458
459* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.24.1-1
460- updated to 2.24.1.
461
462* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.21.0-1
463- updated to 2.21.0.
464- rebuilt with perl-5.26.
465
466* Mon Nov 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.19.1-2
467- added Patch1000 to disable HTTP/2.
468
469* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.19.1-1
470- updated to 2.19.1.
471
472* Wed Jan 17 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 2.15.1-1
473- update to 2.15.1
474
475* Tue Aug 15 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.14.1-1
476- update to 2.14.1
477
478* Sun Jul  9 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.2-1
479- update to 2.13.2
480
481* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.0-1
482- update to 2.13.0
483
484* Sun Mar 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.12.0-1
485- update to 2.12.0
486
487* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.1-1
488- update to 2.11.1
489
490* Tue Dec 20 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.0-1
491- update to 2.11.0
492
493* Fri Nov 18 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.10.2-2
494- include git-credential-gnome-keyring in contrib subpackage
495
496* Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
497- update to 2.10.2
498- fix build error using pcre-8.12 (Vine6)
499
500* Sun May  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
501- update to 2.8.2.
502
503* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
504- update to 2.6.6.
505
506* Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
507- update to 2.6.4
508- add locale files
509
510* Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
511- update to 2.2.1
512
513* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
514- build with Perl 5.16
515
516* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
517- update to 2.0.1
518- add "%%bcond_with arch": no create git-arch sub package by default
519
520* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
521- update to 1.9.2
522
523* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
524- update to 1.8.5.2
525
526* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
527- update to 1.8.4.4
528- new sub package: contrib
529
530* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
531- new upstream release
532
533* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
534- new upstream release
535
536* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
537- new upstream release
538
539* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
540- new upstream release
541
542* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
543- new upstream release
544
545* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
546- new upstream release
547
548* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
549- new upstream release
550- enable libpcre support, add BR: pcre-devel
551- add /etc/gitweb.conf
552- add /var/lib/git for PROJECTROOT
553
554* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
555- new upstream release
556
557* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
558- new upstream release
559
560* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
561- new upstream release
562
563* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
564- new upstream release
565
566* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
567- build with perl 5.12.3
568
569* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
570- new upstream release
571- build with openssl 1.0.0c for VineSeed
572
573* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
574- new upstream release: include security fix: CVE-2010-3906
575
576* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
577- new upstream release
578- drop CVE-2010-2542 patch (Patch100): upstream fixed
579- apply vine-default
580 - rename Source1: git-init.el -> vine-default-git.el
581 - add new git-init.el file (Source12)
582 - update git-install.sh
583- update %%build and %%install section for gitweb subpackage
584- add README in gitweb subpackage
585
586* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
587- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
588
589* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
590- new upstream release
591- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
592- disable building of unused python remote helper libs
593
594* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
595- new upstream release with security fix
596- drop patch10 (included in new release)
597
598* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
599- new upstream release
600- add patch10 git daemon extra arg parsing fix
601
602* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
603- fix install script for Emacs Lisp: <BTS:VineLinux:685>
604 - update git-install.sh (Source10) using contributed patch
605
606* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
607- new upstream release
608
609* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
610- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
611- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
612- fix summary and description in daemon sub package
613
614* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
615- drop Error.pm: provide by perl-Error package
616
617* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
618- new upstream relase
619- update URL tag
620- add Requires: perl(SVN::Core) for svn subpackage
621
622* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
623- add git-shell in git package
624- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
625
626* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
627- added BuildRequires: xmlto
628
629* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
630- new upstream release
631- add devel subpackage (see [wishes:0165])
632
633* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
634- new upstream release
635
636* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
637- new upstream release
638
639* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
640- new upstream release
641
642* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
643- use %%emacsen_pkgdir macro
644
645* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
646- new upstream release
647
648* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
649- initial build for Vine Linux
650
651* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
652- git-1.5.6.4
653
654* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
655- git-1.5.6
656
657* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
658- use tar.bz2 instead of tar.gz
659
660* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
661- git-1.5.5.3
662
663* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
664- git-1.5.5.2
665
666* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
667- git-1.5.5.1
668
669* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
670- git-1.5.5
671
672* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
673- Remove the last two requires on git-core.
674
675* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
676- Remove a patch that's already upstream.
677
678* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
679- git-1.5.4.5
680
681* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
682- Own /etc/bash_completion.d in case bash-completion isn't installed.
683
684* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
685- Include the sample hooks from contrib/hooks as docs (bug 321151).
686- Install the bash completion script from contrib (bug 433255).
687- Include the html docs in the 'core' package again (bug 434271).
688
689* Wed Mar 19 2008 James Bowes 1.5.4.4-2
690- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
691
692* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
693- git-1.5.4.4
694
695* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
696- rebuild for new perl (again)
697
698* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
699- Do not silently overwrite /etc/httpd/conf.d/git.conf
700
701* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
702- git-1.5.4.3
703- Include Kristian Høgsberg's changes to rename git-core to
704  git and git to git-all.
705
706* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
707- git-1.5.4.2
708
709* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
710- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
711  gitweb rss feeds point be commitdiffs instead of commit
712
713* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
714- git-1.5.4.1
715
716* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
717- rebuild for new perl
718
719* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
720- Add BuidRequires on gettext.
721
722* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
723- git-1.5.4
724
725* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
726- git-1.5.3.8
727
728* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
729- Have git metapackage require explicit versions (bug 247214)
730
731* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
732- git-1.5.3.7
733
734* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
735- git-1.5.3.6
736- git-core requires perl(Error) (bug 367861)
737- git-svn requires perl(Term:ReadKey) (bug 261361)
738- git-email requires perl-Git (bug 333061)
739
740* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
741- git-Perl requires Error package
742
743* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
744- git-1.5.3.4
745
746* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
747- git-1.5.3.3
748
749* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
750- git-1.5.3.2
751
752* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
753- Include git-gui and git-citool docs
754
755* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
756- git-1.5.3.1-1
757
758* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
759- git-1.5.2.5-1
760
761* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
762- git-1.5.2.4-1
763
764* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
765- Add git-daemon and gitweb packages
766
767* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
768- Add emacs-git package (#235431)
769
770* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
771- git-1.5.2.2
772
773* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
774- git-1.5.2.1
775
776* Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
777- Added lib files for git-gui
778- Added Documentation/technical (As needed by Git Users Manual)
779
780* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
781- Added howto files
782
783* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
784- git-1.5.0.6
785
786* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
787- git-1.5.0.5
788
789* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
790- git-1.5.0.3
791
792* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
793- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
794
795* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
796- git-1.5.0.2
797
798* Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
799- Update core package description (Git isn't as stupid as it used to be)
800
801* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
802- Add git-gui and git-citool.
803
804* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
805- no need to install manpages executable (bz 216790)
806- use bytes for git-cvsserver
807
808* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
809- git-1.4.4.2
810
811* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
812- rebuild against the new curl
813
814* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
815- git-1.4.2.4
816
817* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
818- git-1.4.2.3
819
820* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
821- git-1.4.2.1
822
823* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
824- git-1.4.2
825
826* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
827- git-1.4.1
828
829* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
830- git-1.4.0
831
832* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
833- git-1.3.3
834- enable git-email building, prereqs have been relaxed
835
836* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
837- git-1.3.2
838
839* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
840- git-1.3.1
841
842* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
843- git-1.3.0
844
845* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
846- git-1.2.6
847
848* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
849- git-1.2.5
850
851* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
852- git-1.2.4
853
854* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
855- git-1.2.3
856
857* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
858- git-1.2.2
859
860* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
861- git-1.2.1
862
863* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
864- git-1.2.0
865
866* Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
867- git-1.1.6
868
869* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
870- git-1.1.4
871
872* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
873- git-1.1.2
874
875* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
876- git-1.1.1
877
878* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
879- Update to latest git-1.1.0 (drop git-email for now)
880- Now creates multiple packages:
881-        git-core, git-svn, git-cvs, git-arch, gitk
882
883* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
884- Change subpackage names to git-<name> instead of git-core-<name>
885- Create empty root package which brings in all subpackages
886- Rename git-tk -> gitk
887
888* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
889- zlib dependency fix
890- Minor cleanups from split
891- Move arch import to separate package as well
892
893* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
894- Move programs with non-standard dependencies (svn, cvs, email)
895  into separate packages
896
897* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
898- parallelize build
899- COPTS -> CFLAGS
900
901* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
902- update to 0.99.6
903
904* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
905- Linus noticed that less is required, added to the dependencies
906
907* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
908- Updated dependencies
909- Don't assume manpages are gzipped
910
911* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
912- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
913- use RPM_OPT_FLAGS in spec file, drop patch0
914
915* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
916- use dist tag to differentiate between branches
917- use rpm optflags by default (patch0)
918- own %{_datadir}/git-core/
919
920* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
921- update spec file to fix Buildroot, Requires, and drop Vendor
922
923* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
924- Redid the description
925- Cut overlong make line, loosened changelog a bit
926- I think Junio (or perhaps OSDL?) should be vendor...
927
928* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
929- Add the man pages, and the --without docs build option
930
931* Thu Jul 7 2005 Chris Wright <chris@osdl.org>
932- initial git spec file
Note: See TracBrowser for help on using the repository browser.