source: projects/specs/trunk/g/git/git-vl.spec @ 12316

Revision 12316, 27.6 KB checked in by tomop, 4 years ago (diff)

updated 22 packages

actdiag-0.5.4-1

blockdiag-1.5.4-1

clamav-0.102.1-1

ghostscript-9.27-3

git-2.24.1-1

incron-0.5.12-4

iputils-20190709-2

libsass-3.6.3-1

libxslt-1.1.34-1

nginx-1.16.1-4

nsd-4.2.4-1

nwdiag-1.0.4-1

oniguruma-6.9.4-1

php73-7.3.12-1

python-funcparserlib-0.3.6-1

python-webcolors-1.10-1

samba-4.10.10-1

seqdiag-0.9.6-1

strongswan-5.8.1-1

trousers-0.3.14-1

unbound-1.9.6-1

unrar-free-0.0.1.20140707-1

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:    git
8Version: 2.24.1
9Release: 1%{?_dist_release}
10Summary: Core git tools
11Summary(ja): Core git ツール
12License:  GPLv2
13Group:    Development/Tools
14URL:      http://git-scm.com/
15Source0:  https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
16Source1:  vine-default-git.el
17Source2:  git.xinetd
18Source3:  git.conf.httpd
19Source4:  gitweb.conf.in
20Source10: %{name}-install.sh
21Source11: %{name}-remove.sh
22Source12: git-init.el
23Patch0:   git-1.5-gitweb-home-link.patch
24Patch1000: git-curl-disable-http2.patch
25       
26# Security
27# none
28
29BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel
30BuildRequires:  expat-devel, gettext, asciidoc
31BuildRequires:  pcre-devel
32BuildRequires:  xmlto
33
34# git-credential-gnome-keyring
35BuildRequires:  glib2-devel libgnome-keyring-devel
36
37BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
38
39Requires:       perl-Git = %{version}-%{release}
40Requires:       zlib
41Provides:       git-core = %{version}-%{release}
42Obsoletes:      git-core <= 1.5.4.3
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager:       iwaim
47
48%description
49Git is a fast, scalable, distributed revision control system with an
50unusually rich command set that provides both high-level operations
51and full access to internals.
52
53The git rpm installs the core tools with minimal dependencies.  To
54install all git packages, including tools for integrating with other
55SCMs, install the git-all meta-package.
56
57%package all
58Summary:        Meta-package to pull in all git tools
59Summary(ja):    すべての git ツール
60Group:          Development/Tools
61Requires:       git = %{version}-%{release}
62Requires:       git-svn = %{version}-%{release}
63Requires:       git-cvs = %{version}-%{release}
64%if "%{?_dist_release}" != "vl4" && %{with arch}
65Requires:       git-arch = %{version}-%{release}
66%endif
67Requires:       git-email = %{version}-%{release}
68Requires:       gitk = %{version}-%{release}
69Requires:       git-gui = %{version}-%{release}
70Requires:       perl-Git = %{version}-%{release}
71Requires:       emacs-git = %{version}-%{release}
72Requires:       git-contrib = %{version}-%{release}
73Obsoletes:      git <= 1.5.4.3
74
75%description all
76Git is a fast, scalable, distributed revision control system with an
77unusually rich command set that provides both high-level operations
78and full access to internals.
79
80This is a dummy package which brings in all subpackages.
81
82%package daemon
83Summary:        Git protocol daemon
84Summary(ja):    Git プロトコルデーモン
85Group:          Development/Tools
86Requires:       git = %{version}-%{release}
87%description daemon
88The git daemon for supporting git:// access to git repositories
89
90%package -n gitweb
91Summary:        Simple web interface to git repositories
92Summary(ja):    git リポジトリへのシンプルな Web インタフェース
93Group:          Development/Tools
94Requires:       git = %{version}-%{release}
95
96%description -n gitweb
97Simple web interface to track changes in git repositories
98
99
100%package svn
101Summary:        Git tools for importing Subversion repositories
102Summary(ja):    Subversion リポジトリを git へインポートするためのツール
103Group:          Development/Tools
104Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
105Requires:       perl(SVN::Core)
106%description svn
107Git tools for importing Subversion repositories.
108
109%package cvs
110Summary:        Git tools for importing CVS repositories
111Summary(ja):    CVS リポジトリを git へインポートするためのツール
112Group:          Development/Tools
113Requires:       git = %{version}-%{release}, cvs, cvsps
114%description cvs
115Git tools for importing CVS repositories.
116
117%package contrib
118Summary:        Git contrib tools
119Group:          Development/Tools
120Requires:       git = %{version}-%{release}
121%description contrib
122Git contrib tools
123
124%if "%{?_dist_release}" != "vl4" && %{with arch}
125%package arch
126Summary:        Git tools for importing Arch repositories
127Summary(ja):    Arch リポジトリを git へインポートするためのツール
128Group:          Development/Tools
129Requires:       git = %{version}-%{release}, tla
130%description arch
131Git tools for importing Arch repositories.
132%endif
133
134%package email
135Summary:        Git tools for sending email
136Summary(ja):    Eメールを送るための git ツール
137Group:          Development/Tools
138Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
139%description email
140Git tools for sending email.
141
142%package gui
143Summary:        Git GUI tool
144Summary(ja):    Git の GUI ツール
145Group:          Development/Tools
146Requires:       git = %{version}-%{release}, tk
147%description gui
148Git GUI tool.
149
150%package -n gitk
151Summary:        Git revision tree visualiser
152Summary(ja):    Git リビジョンツリー可視化ツール
153Group:          Development/Tools
154Requires:       git = %{version}-%{release}, tk
155%description -n gitk
156Git revision tree visualiser.
157
158%package -n perl-Git
159Summary:        Perl interface to Git
160Summary(ja):    Git の perl インタフェース
161Group:          Development/Libraries
162Requires:       git = %{version}-%{release}, perl(Error), perl-MailTools
163%if "%{?_dist_release}" == "vl4"
164Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
165%else
166Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
167%endif
168#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
169
170%description -n perl-Git
171Perl interface to Git.
172
173%package -n emacs-git
174Summary:       Git version control system support for Emacs
175Summary(ja):   Emacs の Git サポート
176Group:         Applications/Editors
177Requires:      git = %{version}-%{release}, emacsen-common
178
179%description -n emacs-git
180%{summary}.
181
182%package devel
183Summary:        Header files for git-core
184Summary(ja):    git-core 用ヘッダファイル
185Group:          Development/Libraries
186
187%description devel
188Header files for git-core.
189
190%prep
191%setup -q
192%patch0 -p1
193%patch1000 -p1
194
195# for pcre-8.12
196%if %{?_dist_release} == "vl6"
197%{__perl} -pi -e "s|#include <pcre.h>|#include <pcre/pcre.h>|" grep.h
198%endif
199
200%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
201
202# Filter bogus perl requires
203cat << \EOF > %{name}-req
204#!/bin/sh
205%{__perl_requires} $* |\
206sed -e '/perl(packed-refs)/d'
207EOF
208
209%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
210chmod +x %{__perl_requires}
211
212%build
213make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
214     ETC_GITCONFIG=/etc/gitconfig \
215     USE_LIBPCRE1=1 \
216     GITWEB_PROJECTROOT=/var/lib/git \
217     gitwebdir=/var/www/git \
218     prefix=%{_prefix} all %{!?_without_docs: doc}
219
220pushd contrib/diff-highlight
221make diff-highlight
222popd
223
224%install
225rm -rf $RPM_BUILD_ROOT
226make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
227     prefix=%{_prefix} mandir=%{_mandir} \
228     perllibdir=%{perl_vendorlib} \
229     ETC_GITCONFIG=/etc/gitconfig \
230     USE_LIBPCRE1=1 \
231     NO_PYTHON=1 \
232     GITWEB_PROJECTROOT=/var/lib/git \
233     gitwebdir=/var/www/git \
234     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
235
236pushd contrib/credential/gnome-keyring
237make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
238popd
239
240# arch
241%if %{without arch}
242rm -f Documentation/git-archimport.txt
243rm -f %{buildroot}%{_libexecdir}/git-core/git-archimport
244rm -f %{buildroot}%{_mandir}/man1/git-archimport.1*
245rm -f %{buildroot}/Documentation/git-archimport.html
246%endif
247
248
249# perl-Git
250rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/FromCPAN
251
252# emacs-git
253mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
254#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
255#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
256mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
257mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
258
259# install el files
260install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
261
262# install vine-default file
263install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
264
265# install  script( bytecompile el and install elc , remove )
266
267%_installemacsenscript git %{SOURCE10}
268
269%_removeemacsenscript  git %{SOURCE11}
270
271mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
272mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
273install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
274perl -p \
275     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
276     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
277     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
278
279## for gitweb sub package
280mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
281install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
282sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
283    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
284
285find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
286find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
287find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
288
289(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
290(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
291%if %{!?_without_docs:1}0
292(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
293%else
294rm -rf $RPM_BUILD_ROOT%{_mandir}
295%endif
296mkdir -p $RPM_BUILD_ROOT/srv/git
297
298mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
299install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
300
301install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
302
303# header files and lib
304install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
305install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
306install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
307install -m0755 -d $RPM_BUILD_ROOT%{_libdir}
308install libgit.a $RPM_BUILD_ROOT%{_libdir}/
309install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
310
311# git-credential-gnome-keyring
312pushd contrib/credential/gnome-keyring
313%__install -m0755 git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libexecdir}/git-core
314popd
315
316%find_lang %{name}
317
318%clean
319rm -rf $RPM_BUILD_ROOT
320
321%post -n emacs-git
322
323# bytecompile and install
324
325if [ "$1" = 2 ]; then
326
327%_emacsenPackageRemove git
328
329fi
330
331%_addemacsenlist git
332
333%_emacsenPackageInstall git
334
335%preun -n emacs-git
336
337if [ "$1" = 0 ]; then
338
339%_emacsenPackageRemove git
340
341%_removeemacsenlist git
342
343fi
344
345
346%files -f bin-man-doc-files -f %{name}.lang
347%defattr(-,root,root)
348%{_bindir}/git
349%{_bindir}/git-receive-pack
350%{_bindir}/git-upload-archive
351%{_bindir}/git-upload-pack
352%{_bindir}/git-shell
353%{_datadir}/git-core/
354%exclude %{_libexecdir}/git-core/git-credential-gnome-keyring
355%license COPYING
356%doc README.md Documentation/*.txt contrib/hooks
357%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
358%{!?_without_docs: %doc Documentation/howto Documentation/technical}
359%{_sysconfdir}/bash_completion.d
360
361
362%files svn
363%defattr(-,root,root)
364%{_libexecdir}/git-core/*svn*
365%doc Documentation/*svn*.txt
366%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
367%{!?_without_docs: %doc Documentation/*svn*.html }
368
369%files cvs
370%defattr(-,root,root)
371%doc Documentation/*git-cvs*.txt
372%{_bindir}/git-cvsserver
373%{_libexecdir}/git-core/*cvs*
374%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
375%{!?_without_docs: %doc Documentation/*git-cvs*.html }
376
377%files contrib
378%defattr(-,root,root)
379%doc contrib/diff-highlight/README.diff-highlight
380%{_bindir}/diff-highlight
381%{_libexecdir}/git-core/git-credential-gnome-keyring
382
383%if "%{?_dist_release}" != "vl4" && %{with arch}
384%files arch
385%defattr(-,root,root)
386%doc Documentation/git-archimport.txt
387%{_libexecdir}/git-core/git-archimport
388%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
389%{!?_without_docs: %doc Documentation/git-archimport.html }
390%endif
391
392%files email
393%defattr(-,root,root)
394%doc Documentation/*email*.txt
395%{_libexecdir}/git-core/*email*
396%{!?_without_docs: %{_mandir}/man1/*email*.1*}
397%{!?_without_docs: %doc Documentation/*email*.html }
398
399%files gui
400%defattr(-,root,root)
401%{_libexecdir}/git-core/git-gui*
402%{_libexecdir}/git-core/git-citool
403%{_datadir}/git-gui/
404%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
405%{!?_without_docs: %doc Documentation/git-gui.html}
406%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
407%{!?_without_docs: %doc Documentation/git-citool.html}
408
409%files -n gitk
410%defattr(-,root,root)
411%doc Documentation/*gitk*.txt
412%{_bindir}/gitk
413%{_datadir}/gitk
414%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
415%{!?_without_docs: %doc Documentation/*gitk*.html }
416
417%files -n perl-Git -f perl-files
418%defattr(-,root,root)
419
420%files -n emacs-git
421%defattr(-,root,root)
422%{_datadir}/emacs/site-lisp/git
423#%{_libdir}/emacsen-common/packages/install/git
424#%{_libdir}/emacsen-common/packages/remove/git
425%{emacsen_pkgdir}/install/git
426%{emacsen_pkgdir}/remove/git
427
428%files daemon
429%defattr(-,root,root)
430%{_var}/lib/git
431%{_libexecdir}/git-core/git-daemon
432%config(noreplace)%{_sysconfdir}/xinetd.d/git
433/srv/git
434
435%files -n gitweb
436%defattr(-,root,root)
437%doc gitweb/README
438/var/www/git/
439%config(noreplace)%{_sysconfdir}/gitweb.conf
440%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
441
442%files devel
443%defattr(644,root,root,755)
444%{_includedir}/git
445%{_libdir}/libgit.a
446%{_libdir}/libgit_xdiff.a
447
448
449%files all
450# No files for you!
451
452%changelog
453* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.24.1-1
454- updated to 2.24.1.
455
456* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.21.0-1
457- updated to 2.21.0.
458- rebuilt with perl-5.26.
459
460* Mon Nov 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.19.1-2
461- added Patch1000 to disable HTTP/2.
462
463* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.19.1-1
464- updated to 2.19.1.
465
466* Wed Jan 17 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 2.15.1-1
467- update to 2.15.1
468
469* Tue Aug 15 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.14.1-1
470- update to 2.14.1
471
472* Sun Jul  9 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.2-1
473- update to 2.13.2
474
475* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.0-1
476- update to 2.13.0
477
478* Sun Mar 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.12.0-1
479- update to 2.12.0
480
481* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.1-1
482- update to 2.11.1
483
484* Tue Dec 20 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.0-1
485- update to 2.11.0
486
487* Fri Nov 18 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.10.2-2
488- include git-credential-gnome-keyring in contrib subpackage
489
490* Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
491- update to 2.10.2
492- fix build error using pcre-8.12 (Vine6)
493
494* Sun May  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
495- update to 2.8.2.
496
497* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
498- update to 2.6.6.
499
500* Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
501- update to 2.6.4
502- add locale files
503
504* Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
505- update to 2.2.1
506
507* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
508- build with Perl 5.16
509
510* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
511- update to 2.0.1
512- add "%%bcond_with arch": no create git-arch sub package by default
513
514* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
515- update to 1.9.2
516
517* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
518- update to 1.8.5.2
519
520* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
521- update to 1.8.4.4
522- new sub package: contrib
523
524* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
525- new upstream release
526
527* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
528- new upstream release
529
530* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
531- new upstream release
532
533* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
534- new upstream release
535
536* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
537- new upstream release
538
539* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
540- new upstream release
541
542* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
543- new upstream release
544- enable libpcre support, add BR: pcre-devel
545- add /etc/gitweb.conf
546- add /var/lib/git for PROJECTROOT
547
548* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
549- new upstream release
550
551* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
552- new upstream release
553
554* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
555- new upstream release
556
557* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
558- new upstream release
559
560* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
561- build with perl 5.12.3
562
563* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
564- new upstream release
565- build with openssl 1.0.0c for VineSeed
566
567* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
568- new upstream release: include security fix: CVE-2010-3906
569
570* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
571- new upstream release
572- drop CVE-2010-2542 patch (Patch100): upstream fixed
573- apply vine-default
574 - rename Source1: git-init.el -> vine-default-git.el
575 - add new git-init.el file (Source12)
576 - update git-install.sh
577- update %%build and %%install section for gitweb subpackage
578- add README in gitweb subpackage
579
580* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
581- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
582
583* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
584- new upstream release
585- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
586- disable building of unused python remote helper libs
587
588* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
589- new upstream release with security fix
590- drop patch10 (included in new release)
591
592* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
593- new upstream release
594- add patch10 git daemon extra arg parsing fix
595
596* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
597- fix install script for Emacs Lisp: <BTS:VineLinux:685>
598 - update git-install.sh (Source10) using contributed patch
599
600* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
601- new upstream release
602
603* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
604- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
605- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
606- fix summary and description in daemon sub package
607
608* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
609- drop Error.pm: provide by perl-Error package
610
611* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
612- new upstream relase
613- update URL tag
614- add Requires: perl(SVN::Core) for svn subpackage
615
616* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
617- add git-shell in git package
618- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
619
620* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
621- added BuildRequires: xmlto
622
623* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
624- new upstream release
625- add devel subpackage (see [wishes:0165])
626
627* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
628- new upstream release
629
630* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
631- new upstream release
632
633* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
634- new upstream release
635
636* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
637- use %%emacsen_pkgdir macro
638
639* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
640- new upstream release
641
642* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
643- initial build for Vine Linux
644
645* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
646- git-1.5.6.4
647
648* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
649- git-1.5.6
650
651* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
652- use tar.bz2 instead of tar.gz
653
654* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
655- git-1.5.5.3
656
657* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
658- git-1.5.5.2
659
660* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
661- git-1.5.5.1
662
663* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
664- git-1.5.5
665
666* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
667- Remove the last two requires on git-core.
668
669* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
670- Remove a patch that's already upstream.
671
672* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
673- git-1.5.4.5
674
675* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
676- Own /etc/bash_completion.d in case bash-completion isn't installed.
677
678* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
679- Include the sample hooks from contrib/hooks as docs (bug 321151).
680- Install the bash completion script from contrib (bug 433255).
681- Include the html docs in the 'core' package again (bug 434271).
682
683* Wed Mar 19 2008 James Bowes 1.5.4.4-2
684- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
685
686* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
687- git-1.5.4.4
688
689* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
690- rebuild for new perl (again)
691
692* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
693- Do not silently overwrite /etc/httpd/conf.d/git.conf
694
695* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
696- git-1.5.4.3
697- Include Kristian Høgsberg's changes to rename git-core to
698  git and git to git-all.
699
700* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
701- git-1.5.4.2
702
703* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
704- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
705  gitweb rss feeds point be commitdiffs instead of commit
706
707* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
708- git-1.5.4.1
709
710* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
711- rebuild for new perl
712
713* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
714- Add BuidRequires on gettext.
715
716* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
717- git-1.5.4
718
719* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
720- git-1.5.3.8
721
722* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
723- Have git metapackage require explicit versions (bug 247214)
724
725* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
726- git-1.5.3.7
727
728* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
729- git-1.5.3.6
730- git-core requires perl(Error) (bug 367861)
731- git-svn requires perl(Term:ReadKey) (bug 261361)
732- git-email requires perl-Git (bug 333061)
733
734* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
735- git-Perl requires Error package
736
737* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
738- git-1.5.3.4
739
740* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
741- git-1.5.3.3
742
743* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
744- git-1.5.3.2
745
746* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
747- Include git-gui and git-citool docs
748
749* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
750- git-1.5.3.1-1
751
752* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
753- git-1.5.2.5-1
754
755* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
756- git-1.5.2.4-1
757
758* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
759- Add git-daemon and gitweb packages
760
761* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
762- Add emacs-git package (#235431)
763
764* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
765- git-1.5.2.2
766
767* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
768- git-1.5.2.1
769
770* Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
771- Added lib files for git-gui
772- Added Documentation/technical (As needed by Git Users Manual)
773
774* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
775- Added howto files
776
777* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
778- git-1.5.0.6
779
780* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
781- git-1.5.0.5
782
783* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
784- git-1.5.0.3
785
786* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
787- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
788
789* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
790- git-1.5.0.2
791
792* Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
793- Update core package description (Git isn't as stupid as it used to be)
794
795* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
796- Add git-gui and git-citool.
797
798* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
799- no need to install manpages executable (bz 216790)
800- use bytes for git-cvsserver
801
802* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
803- git-1.4.4.2
804
805* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
806- rebuild against the new curl
807
808* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
809- git-1.4.2.4
810
811* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
812- git-1.4.2.3
813
814* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
815- git-1.4.2.1
816
817* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
818- git-1.4.2
819
820* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
821- git-1.4.1
822
823* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
824- git-1.4.0
825
826* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
827- git-1.3.3
828- enable git-email building, prereqs have been relaxed
829
830* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
831- git-1.3.2
832
833* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
834- git-1.3.1
835
836* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
837- git-1.3.0
838
839* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
840- git-1.2.6
841
842* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
843- git-1.2.5
844
845* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
846- git-1.2.4
847
848* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
849- git-1.2.3
850
851* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
852- git-1.2.2
853
854* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
855- git-1.2.1
856
857* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
858- git-1.2.0
859
860* Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
861- git-1.1.6
862
863* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
864- git-1.1.4
865
866* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
867- git-1.1.2
868
869* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
870- git-1.1.1
871
872* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
873- Update to latest git-1.1.0 (drop git-email for now)
874- Now creates multiple packages:
875-        git-core, git-svn, git-cvs, git-arch, gitk
876
877* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
878- Change subpackage names to git-<name> instead of git-core-<name>
879- Create empty root package which brings in all subpackages
880- Rename git-tk -> gitk
881
882* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
883- zlib dependency fix
884- Minor cleanups from split
885- Move arch import to separate package as well
886
887* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
888- Move programs with non-standard dependencies (svn, cvs, email)
889  into separate packages
890
891* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
892- parallelize build
893- COPTS -> CFLAGS
894
895* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
896- update to 0.99.6
897
898* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
899- Linus noticed that less is required, added to the dependencies
900
901* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
902- Updated dependencies
903- Don't assume manpages are gzipped
904
905* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
906- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
907- use RPM_OPT_FLAGS in spec file, drop patch0
908
909* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
910- use dist tag to differentiate between branches
911- use rpm optflags by default (patch0)
912- own %{_datadir}/git-core/
913
914* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
915- update spec file to fix Buildroot, Requires, and drop Vendor
916
917* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
918- Redid the description
919- Cut overlong make line, loosened changelog a bit
920- I think Junio (or perhaps OSDL?) should be vendor...
921
922* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
923- Add the man pages, and the --without docs build option
924
925* Thu Jul 7 2005 Chris Wright <chris@osdl.org>
926- initial git spec file
Note: See TracBrowser for help on using the repository browser.