source: projects/specs/trunk/g/git/git-vl.spec @ 11900

Revision 11900, 27.4 KB checked in by tomop, 6 years ago (diff)

git-2.19.1-2

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:    git
8Version: 2.19.1
9Release: 2%{?_dist_release}
10Summary: Core git tools
11Summary(ja): Core git ツール
12License:  GPLv2
13Group:    Development/Tools
14URL:      http://git-scm.com/
15Source0:  https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
16Source1:  vine-default-git.el
17Source2:  git.xinetd
18Source3:  git.conf.httpd
19Source4:  gitweb.conf.in
20Source10: %{name}-install.sh
21Source11: %{name}-remove.sh
22Source12: git-init.el
23Patch0:   git-1.5-gitweb-home-link.patch
24Patch1000: git-curl-disable-http2.patch
25       
26# Security
27# none
28
29BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel
30BuildRequires:  expat-devel, gettext, asciidoc
31BuildRequires:  pcre-devel
32BuildRequires:  xmlto
33
34# git-credential-gnome-keyring
35BuildRequires:  glib2-devel libgnome-keyring-devel
36
37BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
38
39Requires:       perl-Git = %{version}-%{release}
40Requires:       zlib
41Provides:       git-core = %{version}-%{release}
42Obsoletes:      git-core <= 1.5.4.3
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager:       iwaim
47
48%description
49Git is a fast, scalable, distributed revision control system with an
50unusually rich command set that provides both high-level operations
51and full access to internals.
52
53The git rpm installs the core tools with minimal dependencies.  To
54install all git packages, including tools for integrating with other
55SCMs, install the git-all meta-package.
56
57%package all
58Summary:        Meta-package to pull in all git tools
59Summary(ja):    すべての git ツール
60Group:          Development/Tools
61Requires:       git = %{version}-%{release}
62Requires:       git-svn = %{version}-%{release}
63Requires:       git-cvs = %{version}-%{release}
64%if "%{?_dist_release}" != "vl4" && %{with arch}
65Requires:       git-arch = %{version}-%{release}
66%endif
67Requires:       git-email = %{version}-%{release}
68Requires:       gitk = %{version}-%{release}
69Requires:       git-gui = %{version}-%{release}
70Requires:       perl-Git = %{version}-%{release}
71Requires:       emacs-git = %{version}-%{release}
72Requires:       git-contrib = %{version}-%{release}
73Obsoletes:      git <= 1.5.4.3
74
75%description all
76Git is a fast, scalable, distributed revision control system with an
77unusually rich command set that provides both high-level operations
78and full access to internals.
79
80This is a dummy package which brings in all subpackages.
81
82%package daemon
83Summary:        Git protocol daemon
84Summary(ja):    Git プロトコルデーモン
85Group:          Development/Tools
86Requires:       git = %{version}-%{release}
87%description daemon
88The git daemon for supporting git:// access to git repositories
89
90%package -n gitweb
91Summary:        Simple web interface to git repositories
92Summary(ja):    git リポジトリへのシンプルな Web インタフェース
93Group:          Development/Tools
94Requires:       git = %{version}-%{release}
95
96%description -n gitweb
97Simple web interface to track changes in git repositories
98
99
100%package svn
101Summary:        Git tools for importing Subversion repositories
102Summary(ja):    Subversion リポジトリを git へインポートするためのツール
103Group:          Development/Tools
104Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
105Requires:       perl(SVN::Core)
106%description svn
107Git tools for importing Subversion repositories.
108
109%package cvs
110Summary:        Git tools for importing CVS repositories
111Summary(ja):    CVS リポジトリを git へインポートするためのツール
112Group:          Development/Tools
113Requires:       git = %{version}-%{release}, cvs, cvsps
114%description cvs
115Git tools for importing CVS repositories.
116
117%package contrib
118Summary:        Git contrib tools
119Group:          Development/Tools
120Requires:       git = %{version}-%{release}
121%description contrib
122Git contrib tools
123
124%if "%{?_dist_release}" != "vl4" && %{with arch}
125%package arch
126Summary:        Git tools for importing Arch repositories
127Summary(ja):    Arch リポジトリを git へインポートするためのツール
128Group:          Development/Tools
129Requires:       git = %{version}-%{release}, tla
130%description arch
131Git tools for importing Arch repositories.
132%endif
133
134%package email
135Summary:        Git tools for sending email
136Summary(ja):    Eメールを送るための git ツール
137Group:          Development/Tools
138Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
139%description email
140Git tools for sending email.
141
142%package gui
143Summary:        Git GUI tool
144Summary(ja):    Git の GUI ツール
145Group:          Development/Tools
146Requires:       git = %{version}-%{release}, tk
147%description gui
148Git GUI tool.
149
150%package -n gitk
151Summary:        Git revision tree visualiser
152Summary(ja):    Git リビジョンツリー可視化ツール
153Group:          Development/Tools
154Requires:       git = %{version}-%{release}, tk
155%description -n gitk
156Git revision tree visualiser.
157
158%package -n perl-Git
159Summary:        Perl interface to Git
160Summary(ja):    Git の perl インタフェース
161Group:          Development/Libraries
162Requires:       git = %{version}-%{release}, perl(Error), perl-MailTools
163%if "%{?_dist_release}" == "vl4"
164Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
165%else
166Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
167%endif
168#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
169
170%description -n perl-Git
171Perl interface to Git.
172
173%package -n emacs-git
174Summary:       Git version control system support for Emacs
175Summary(ja):   Emacs の Git サポート
176Group:         Applications/Editors
177Requires:      git = %{version}-%{release}, emacsen-common
178
179%description -n emacs-git
180%{summary}.
181
182%package devel
183Summary:        Header files for git-core
184Summary(ja):    git-core 用ヘッダファイル
185Group:          Development/Libraries
186
187%description devel
188Header files for git-core.
189
190%prep
191%setup -q
192%patch0 -p1
193%patch1000 -p1
194
195# for pcre-8.12
196%if %{?_dist_release} == "vl6"
197%{__perl} -pi -e "s|#include <pcre.h>|#include <pcre/pcre.h>|" grep.h
198%endif
199
200%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
201
202# Filter bogus perl requires
203cat << \EOF > %{name}-req
204#!/bin/sh
205%{__perl_requires} $* |\
206sed -e '/perl(packed-refs)/d'
207EOF
208
209%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
210chmod +x %{__perl_requires}
211
212%build
213make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
214     ETC_GITCONFIG=/etc/gitconfig \
215     USE_LIBPCRE1=1 \
216     GITWEB_PROJECTROOT=/var/lib/git \
217     gitwebdir=/var/www/git \
218     prefix=%{_prefix} all %{!?_without_docs: doc}
219
220pushd contrib/diff-highlight
221make diff-highlight
222popd
223
224%install
225rm -rf $RPM_BUILD_ROOT
226make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
227     prefix=%{_prefix} mandir=%{_mandir} \
228     perllibdir=%{perl_vendorlib} \
229     ETC_GITCONFIG=/etc/gitconfig \
230     USE_LIBPCRE1=1 \
231     NO_PYTHON=1 \
232     GITWEB_PROJECTROOT=/var/lib/git \
233     gitwebdir=/var/www/git \
234     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
235
236pushd contrib/credential/gnome-keyring
237make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
238popd
239
240# arch
241%if %{without arch}
242rm -f Documentation/git-archimport.txt
243rm -f %{buildroot}%{_libexecdir}/git-core/git-archimport
244rm -f %{buildroot}%{_mandir}/man1/git-archimport.1*
245rm -f %{buildroot}/Documentation/git-archimport.html
246%endif
247
248
249# perl-Git
250rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/FromCPAN
251
252# emacs-git
253mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
254#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
255#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
256mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
257mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
258
259# install el files
260install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
261
262# install vine-default file
263install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
264
265# install  script( bytecompile el and install elc , remove )
266
267%_installemacsenscript git %{SOURCE10}
268
269%_removeemacsenscript  git %{SOURCE11}
270
271mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
272mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
273install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
274perl -p \
275     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
276     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
277     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
278
279## for gitweb sub package
280mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
281install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
282sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
283    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
284
285find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
286find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
287find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
288
289(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
290(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
291%if %{!?_without_docs:1}0
292(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
293%else
294rm -rf $RPM_BUILD_ROOT%{_mandir}
295%endif
296mkdir -p $RPM_BUILD_ROOT/srv/git
297
298mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
299install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
300
301install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
302
303# header files and lib
304install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
305install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
306install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
307install -m0755 -d $RPM_BUILD_ROOT%{_libdir}
308install libgit.a $RPM_BUILD_ROOT%{_libdir}/
309install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
310
311# git-credential-gnome-keyring
312pushd contrib/credential/gnome-keyring
313%__install -m0755 git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libexecdir}/git-core
314popd
315
316%find_lang %{name}
317
318%clean
319rm -rf $RPM_BUILD_ROOT
320
321%post -n emacs-git
322
323# bytecompile and install
324
325if [ "$1" = 2 ]; then
326
327%_emacsenPackageRemove git
328
329fi
330
331%_addemacsenlist git
332
333%_emacsenPackageInstall git
334
335%preun -n emacs-git
336
337if [ "$1" = 0 ]; then
338
339%_emacsenPackageRemove git
340
341%_removeemacsenlist git
342
343fi
344
345
346%files -f bin-man-doc-files -f %{name}.lang
347%defattr(-,root,root)
348%{_bindir}/git
349%{_bindir}/git-receive-pack
350%{_bindir}/git-upload-archive
351%{_bindir}/git-upload-pack
352%{_bindir}/git-shell
353%{_datadir}/git-core/
354%exclude %{_libexecdir}/git-core/git-credential-gnome-keyring
355%doc README.md COPYING Documentation/*.txt contrib/hooks
356%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
357%{!?_without_docs: %doc Documentation/howto Documentation/technical}
358%{_sysconfdir}/bash_completion.d
359
360
361%files svn
362%defattr(-,root,root)
363%{_libexecdir}/git-core/*svn*
364%doc Documentation/*svn*.txt
365%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
366%{!?_without_docs: %doc Documentation/*svn*.html }
367
368%files cvs
369%defattr(-,root,root)
370%doc Documentation/*git-cvs*.txt
371%{_bindir}/git-cvsserver
372%{_libexecdir}/git-core/*cvs*
373%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
374%{!?_without_docs: %doc Documentation/*git-cvs*.html }
375
376%files contrib
377%defattr(-,root,root)
378%doc contrib/diff-highlight/README.diff-highlight
379%{_bindir}/diff-highlight
380%{_libexecdir}/git-core/git-credential-gnome-keyring
381
382%if "%{?_dist_release}" != "vl4" && %{with arch}
383%files arch
384%defattr(-,root,root)
385%doc Documentation/git-archimport.txt
386%{_libexecdir}/git-core/git-archimport
387%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
388%{!?_without_docs: %doc Documentation/git-archimport.html }
389%endif
390
391%files email
392%defattr(-,root,root)
393%doc Documentation/*email*.txt
394%{_libexecdir}/git-core/*email*
395%{!?_without_docs: %{_mandir}/man1/*email*.1*}
396%{!?_without_docs: %doc Documentation/*email*.html }
397
398%files gui
399%defattr(-,root,root)
400%{_libexecdir}/git-core/git-gui*
401%{_libexecdir}/git-core/git-citool
402%{_datadir}/git-gui/
403%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
404%{!?_without_docs: %doc Documentation/git-gui.html}
405%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
406%{!?_without_docs: %doc Documentation/git-citool.html}
407
408%files -n gitk
409%defattr(-,root,root)
410%doc Documentation/*gitk*.txt
411%{_bindir}/gitk
412%{_datadir}/gitk
413%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
414%{!?_without_docs: %doc Documentation/*gitk*.html }
415
416%files -n perl-Git -f perl-files
417%defattr(-,root,root)
418
419%files -n emacs-git
420%defattr(-,root,root)
421%{_datadir}/emacs/site-lisp/git
422#%{_libdir}/emacsen-common/packages/install/git
423#%{_libdir}/emacsen-common/packages/remove/git
424%{emacsen_pkgdir}/install/git
425%{emacsen_pkgdir}/remove/git
426
427%files daemon
428%defattr(-,root,root)
429%{_var}/lib/git
430%{_libexecdir}/git-core/git-daemon
431%config(noreplace)%{_sysconfdir}/xinetd.d/git
432/srv/git
433
434%files -n gitweb
435%defattr(-,root,root)
436%doc gitweb/README
437/var/www/git/
438%config(noreplace)%{_sysconfdir}/gitweb.conf
439%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
440
441%files devel
442%defattr(644,root,root,755)
443%{_includedir}/git
444%{_libdir}/libgit.a
445%{_libdir}/libgit_xdiff.a
446
447
448%files all
449# No files for you!
450
451%changelog
452* Mon Nov 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.19.1-2
453- added Patch1000 to disable HTTP/2.
454
455* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.19.1-1
456- updated to 2.19.1.
457
458* Wed Jan 17 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 2.15.1-1
459- update to 2.15.1
460
461* Tue Aug 15 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.14.1-1
462- update to 2.14.1
463
464* Sun Jul  9 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.2-1
465- update to 2.13.2
466
467* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.0-1
468- update to 2.13.0
469
470* Sun Mar 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.12.0-1
471- update to 2.12.0
472
473* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.1-1
474- update to 2.11.1
475
476* Tue Dec 20 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.0-1
477- update to 2.11.0
478
479* Fri Nov 18 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.10.2-2
480- include git-credential-gnome-keyring in contrib subpackage
481
482* Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
483- update to 2.10.2
484- fix build error using pcre-8.12 (Vine6)
485
486* Sun May  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
487- update to 2.8.2.
488
489* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
490- update to 2.6.6.
491
492* Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
493- update to 2.6.4
494- add locale files
495
496* Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
497- update to 2.2.1
498
499* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
500- build with Perl 5.16
501
502* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
503- update to 2.0.1
504- add "%%bcond_with arch": no create git-arch sub package by default
505
506* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
507- update to 1.9.2
508
509* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
510- update to 1.8.5.2
511
512* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
513- update to 1.8.4.4
514- new sub package: contrib
515
516* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
517- new upstream release
518
519* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
520- new upstream release
521
522* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
523- new upstream release
524
525* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
526- new upstream release
527
528* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
529- new upstream release
530
531* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
532- new upstream release
533
534* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
535- new upstream release
536- enable libpcre support, add BR: pcre-devel
537- add /etc/gitweb.conf
538- add /var/lib/git for PROJECTROOT
539
540* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
541- new upstream release
542
543* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
544- new upstream release
545
546* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
547- new upstream release
548
549* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
550- new upstream release
551
552* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
553- build with perl 5.12.3
554
555* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
556- new upstream release
557- build with openssl 1.0.0c for VineSeed
558
559* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
560- new upstream release: include security fix: CVE-2010-3906
561
562* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
563- new upstream release
564- drop CVE-2010-2542 patch (Patch100): upstream fixed
565- apply vine-default
566 - rename Source1: git-init.el -> vine-default-git.el
567 - add new git-init.el file (Source12)
568 - update git-install.sh
569- update %%build and %%install section for gitweb subpackage
570- add README in gitweb subpackage
571
572* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
573- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
574
575* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
576- new upstream release
577- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
578- disable building of unused python remote helper libs
579
580* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
581- new upstream release with security fix
582- drop patch10 (included in new release)
583
584* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
585- new upstream release
586- add patch10 git daemon extra arg parsing fix
587
588* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
589- fix install script for Emacs Lisp: <BTS:VineLinux:685>
590 - update git-install.sh (Source10) using contributed patch
591
592* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
593- new upstream release
594
595* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
596- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
597- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
598- fix summary and description in daemon sub package
599
600* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
601- drop Error.pm: provide by perl-Error package
602
603* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
604- new upstream relase
605- update URL tag
606- add Requires: perl(SVN::Core) for svn subpackage
607
608* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
609- add git-shell in git package
610- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
611
612* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
613- added BuildRequires: xmlto
614
615* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
616- new upstream release
617- add devel subpackage (see [wishes:0165])
618
619* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
620- new upstream release
621
622* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
623- new upstream release
624
625* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
626- new upstream release
627
628* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
629- use %%emacsen_pkgdir macro
630
631* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
632- new upstream release
633
634* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
635- initial build for Vine Linux
636
637* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
638- git-1.5.6.4
639
640* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
641- git-1.5.6
642
643* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
644- use tar.bz2 instead of tar.gz
645
646* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
647- git-1.5.5.3
648
649* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
650- git-1.5.5.2
651
652* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
653- git-1.5.5.1
654
655* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
656- git-1.5.5
657
658* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
659- Remove the last two requires on git-core.
660
661* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
662- Remove a patch that's already upstream.
663
664* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
665- git-1.5.4.5
666
667* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
668- Own /etc/bash_completion.d in case bash-completion isn't installed.
669
670* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
671- Include the sample hooks from contrib/hooks as docs (bug 321151).
672- Install the bash completion script from contrib (bug 433255).
673- Include the html docs in the 'core' package again (bug 434271).
674
675* Wed Mar 19 2008 James Bowes 1.5.4.4-2
676- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
677
678* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
679- git-1.5.4.4
680
681* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
682- rebuild for new perl (again)
683
684* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
685- Do not silently overwrite /etc/httpd/conf.d/git.conf
686
687* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
688- git-1.5.4.3
689- Include Kristian Høgsberg's changes to rename git-core to
690  git and git to git-all.
691
692* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
693- git-1.5.4.2
694
695* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
696- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
697  gitweb rss feeds point be commitdiffs instead of commit
698
699* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
700- git-1.5.4.1
701
702* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
703- rebuild for new perl
704
705* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
706- Add BuidRequires on gettext.
707
708* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
709- git-1.5.4
710
711* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
712- git-1.5.3.8
713
714* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
715- Have git metapackage require explicit versions (bug 247214)
716
717* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
718- git-1.5.3.7
719
720* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
721- git-1.5.3.6
722- git-core requires perl(Error) (bug 367861)
723- git-svn requires perl(Term:ReadKey) (bug 261361)
724- git-email requires perl-Git (bug 333061)
725
726* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
727- git-Perl requires Error package
728
729* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
730- git-1.5.3.4
731
732* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
733- git-1.5.3.3
734
735* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
736- git-1.5.3.2
737
738* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
739- Include git-gui and git-citool docs
740
741* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
742- git-1.5.3.1-1
743
744* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
745- git-1.5.2.5-1
746
747* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
748- git-1.5.2.4-1
749
750* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
751- Add git-daemon and gitweb packages
752
753* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
754- Add emacs-git package (#235431)
755
756* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
757- git-1.5.2.2
758
759* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
760- git-1.5.2.1
761
762* Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
763- Added lib files for git-gui
764- Added Documentation/technical (As needed by Git Users Manual)
765
766* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
767- Added howto files
768
769* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
770- git-1.5.0.6
771
772* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
773- git-1.5.0.5
774
775* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
776- git-1.5.0.3
777
778* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
779- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
780
781* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
782- git-1.5.0.2
783
784* Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
785- Update core package description (Git isn't as stupid as it used to be)
786
787* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
788- Add git-gui and git-citool.
789
790* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
791- no need to install manpages executable (bz 216790)
792- use bytes for git-cvsserver
793
794* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
795- git-1.4.4.2
796
797* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
798- rebuild against the new curl
799
800* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
801- git-1.4.2.4
802
803* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
804- git-1.4.2.3
805
806* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
807- git-1.4.2.1
808
809* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
810- git-1.4.2
811
812* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
813- git-1.4.1
814
815* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
816- git-1.4.0
817
818* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
819- git-1.3.3
820- enable git-email building, prereqs have been relaxed
821
822* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
823- git-1.3.2
824
825* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
826- git-1.3.1
827
828* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
829- git-1.3.0
830
831* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
832- git-1.2.6
833
834* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
835- git-1.2.5
836
837* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
838- git-1.2.4
839
840* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
841- git-1.2.3
842
843* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
844- git-1.2.2
845
846* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
847- git-1.2.1
848
849* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
850- git-1.2.0
851
852* Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
853- git-1.1.6
854
855* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
856- git-1.1.4
857
858* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
859- git-1.1.2
860
861* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
862- git-1.1.1
863
864* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
865- Update to latest git-1.1.0 (drop git-email for now)
866- Now creates multiple packages:
867-        git-core, git-svn, git-cvs, git-arch, gitk
868
869* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
870- Change subpackage names to git-<name> instead of git-core-<name>
871- Create empty root package which brings in all subpackages
872- Rename git-tk -> gitk
873
874* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
875- zlib dependency fix
876- Minor cleanups from split
877- Move arch import to separate package as well
878
879* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
880- Move programs with non-standard dependencies (svn, cvs, email)
881  into separate packages
882
883* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
884- parallelize build
885- COPTS -> CFLAGS
886
887* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
888- update to 0.99.6
889
890* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
891- Linus noticed that less is required, added to the dependencies
892
893* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
894- Updated dependencies
895- Don't assume manpages are gzipped
896
897* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
898- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
899- use RPM_OPT_FLAGS in spec file, drop patch0
900
901* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
902- use dist tag to differentiate between branches
903- use rpm optflags by default (patch0)
904- own %{_datadir}/git-core/
905
906* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
907- update spec file to fix Buildroot, Requires, and drop Vendor
908
909* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
910- Redid the description
911- Cut overlong make line, loosened changelog a bit
912- I think Junio (or perhaps OSDL?) should be vendor...
913
914* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
915- Add the man pages, and the --without docs build option
916
917* Thu Jul 7 2005 Chris Wright <chris@osdl.org>
918- initial git spec file
Note: See TracBrowser for help on using the repository browser.