source: projects/specs/trunk/g/git/git-vl.spec @ 11429

Revision 11429, 26.8 KB checked in by iwaim, 6 years ago (diff)

git 2.15.1-1

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:    git
8Version: 2.15.1
9Release: 1%{?_dist_release}
10Summary: Core git tools
11Summary(ja): Core git ツール
12License:  GPLv2
13Group:    Development/Tools
14URL:      http://git-scm.com/
15Source0:  https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
16Source1:  vine-default-git.el
17Source2:  git.xinetd
18Source3:  git.conf.httpd
19Source4:  gitweb.conf.in
20Source10: %{name}-install.sh
21Source11: %{name}-remove.sh
22Source12: git-init.el
23Patch0:   git-1.5-gitweb-home-link.patch
24
25# Security
26# none
27
28BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel
29BuildRequires:  expat-devel, gettext, asciidoc
30BuildRequires:  pcre-devel
31BuildRequires:  xmlto
32
33# git-credential-gnome-keyring
34BuildRequires:  glib2-devel libgnome-keyring-devel
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
37
38Requires:       perl-Git = %{version}-%{release}
39Requires:       zlib
40Provides:       git-core = %{version}-%{release}
41Obsoletes:      git-core <= 1.5.4.3
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       iwaim
46
47%description
48Git is a fast, scalable, distributed revision control system with an
49unusually rich command set that provides both high-level operations
50and full access to internals.
51
52The git rpm installs the core tools with minimal dependencies.  To
53install all git packages, including tools for integrating with other
54SCMs, install the git-all meta-package.
55
56%package all
57Summary:        Meta-package to pull in all git tools
58Summary(ja):    すべての git ツール
59Group:          Development/Tools
60Requires:       git = %{version}-%{release}
61Requires:       git-svn = %{version}-%{release}
62Requires:       git-cvs = %{version}-%{release}
63%if "%{?_dist_release}" != "vl4" && %{with arch}
64Requires:       git-arch = %{version}-%{release}
65%endif
66Requires:       git-email = %{version}-%{release}
67Requires:       gitk = %{version}-%{release}
68Requires:       git-gui = %{version}-%{release}
69Requires:       perl-Git = %{version}-%{release}
70Requires:       emacs-git = %{version}-%{release}
71Requires:       git-contrib = %{version}-%{release}
72Obsoletes:      git <= 1.5.4.3
73
74%description all
75Git is a fast, scalable, distributed revision control system with an
76unusually rich command set that provides both high-level operations
77and full access to internals.
78
79This is a dummy package which brings in all subpackages.
80
81%package daemon
82Summary:        Git protocol daemon
83Summary(ja):    Git プロトコルデーモン
84Group:          Development/Tools
85Requires:       git = %{version}-%{release}
86%description daemon
87The git daemon for supporting git:// access to git repositories
88
89%package -n gitweb
90Summary:        Simple web interface to git repositories
91Summary(ja):    git リポジトリへのシンプルな Web インタフェース
92Group:          Development/Tools
93Requires:       git = %{version}-%{release}
94
95%description -n gitweb
96Simple web interface to track changes in git repositories
97
98
99%package svn
100Summary:        Git tools for importing Subversion repositories
101Summary(ja):    Subversion リポジトリを git へインポートするためのツール
102Group:          Development/Tools
103Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
104Requires:       perl(SVN::Core)
105%description svn
106Git tools for importing Subversion repositories.
107
108%package cvs
109Summary:        Git tools for importing CVS repositories
110Summary(ja):    CVS リポジトリを git へインポートするためのツール
111Group:          Development/Tools
112Requires:       git = %{version}-%{release}, cvs, cvsps
113%description cvs
114Git tools for importing CVS repositories.
115
116%package contrib
117Summary:        Git contrib tools
118Group:          Development/Tools
119Requires:       git = %{version}-%{release}
120%description contrib
121Git contrib tools
122
123%if "%{?_dist_release}" != "vl4" && %{with arch}
124%package arch
125Summary:        Git tools for importing Arch repositories
126Summary(ja):    Arch リポジトリを git へインポートするためのツール
127Group:          Development/Tools
128Requires:       git = %{version}-%{release}, tla
129%description arch
130Git tools for importing Arch repositories.
131%endif
132
133%package email
134Summary:        Git tools for sending email
135Summary(ja):    Eメールを送るための git ツール
136Group:          Development/Tools
137Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
138%description email
139Git tools for sending email.
140
141%package gui
142Summary:        Git GUI tool
143Summary(ja):    Git の GUI ツール
144Group:          Development/Tools
145Requires:       git = %{version}-%{release}, tk
146%description gui
147Git GUI tool.
148
149%package -n gitk
150Summary:        Git revision tree visualiser
151Summary(ja):    Git リビジョンツリー可視化ツール
152Group:          Development/Tools
153Requires:       git = %{version}-%{release}, tk
154%description -n gitk
155Git revision tree visualiser.
156
157%package -n perl-Git
158Summary:        Perl interface to Git
159Summary(ja):    Git の perl インタフェース
160Group:          Development/Libraries
161Requires:       git = %{version}-%{release}, perl(Error)
162%if "%{?_dist_release}" == "vl4"
163Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
164%else
165Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
166%endif
167#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
168
169%description -n perl-Git
170Perl interface to Git.
171
172%package -n emacs-git
173Summary:       Git version control system support for Emacs
174Summary(ja):   Emacs の Git サポート
175Group:         Applications/Editors
176Requires:      git = %{version}-%{release}, emacsen-common
177
178%description -n emacs-git
179%{summary}.
180
181%package devel
182Summary:        Header files for git-core
183Summary(ja):    git-core 用ヘッダファイル
184Group:          Development/Libraries
185
186%description devel
187Header files for git-core.
188
189%prep
190%setup -q
191%patch0 -p1
192
193# for pcre-8.12
194%if %{?_dist_release} == "vl6"
195%{__perl} -pi -e "s|#include <pcre.h>|#include <pcre/pcre.h>|" grep.h
196%endif
197
198%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
199
200# Filter bogus perl requires
201cat << \EOF > %{name}-req
202#!/bin/sh
203%{__perl_requires} $* |\
204sed -e '/perl(packed-refs)/d'
205EOF
206
207%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
208chmod +x %{__perl_requires}
209
210%build
211make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
212     ETC_GITCONFIG=/etc/gitconfig \
213     USE_LIBPCRE=1 \
214     GITWEB_PROJECTROOT=/var/lib/git \
215     gitwebdir=/var/www/git \
216     prefix=%{_prefix} all %{!?_without_docs: doc}
217
218pushd contrib/diff-highlight
219make diff-highlight
220popd
221
222%install
223rm -rf $RPM_BUILD_ROOT
224make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
225     prefix=%{_prefix} mandir=%{_mandir} \
226     ETC_GITCONFIG=/etc/gitconfig \
227     USE_LIBPCRE=1 \
228     NO_PYTHON=1 \
229     GITWEB_PROJECTROOT=/var/lib/git \
230     gitwebdir=/var/www/git \
231     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
232
233pushd contrib/credential/gnome-keyring
234make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
235popd
236
237# perl-Git
238# Error.pm provide by perl-Error package
239rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
240
241# emacs-git
242mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
243#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
244#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
245mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
246mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
247
248# install el files
249install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
250
251# install vine-default file
252install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
253
254# install  script( bytecompile el and install elc , remove )
255
256%_installemacsenscript git %{SOURCE10}
257
258%_removeemacsenscript  git %{SOURCE11}
259
260mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
261mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
262install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
263perl -p \
264     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
265     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
266     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
267
268## for gitweb sub package
269mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
270install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
271sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
272    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
273
274find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
275find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
276find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
277
278(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
279(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
280%if %{!?_without_docs:1}0
281(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
282%else
283rm -rf $RPM_BUILD_ROOT%{_mandir}
284%endif
285mkdir -p $RPM_BUILD_ROOT/srv/git
286
287mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
288install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
289
290install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
291
292# header files and lib
293install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
294install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
295install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
296install libgit.a $RPM_BUILD_ROOT%{_libdir}
297install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
298
299# git-credential-gnome-keyring
300pushd contrib/credential/gnome-keyring
301%__install -m0755 git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libexecdir}/git-core
302popd
303
304%find_lang %{name}
305
306%clean
307rm -rf $RPM_BUILD_ROOT
308
309%post -n emacs-git
310
311# bytecompile and install
312
313if [ "$1" = 2 ]; then
314
315%_emacsenPackageRemove git
316
317fi
318
319%_addemacsenlist git
320
321%_emacsenPackageInstall git
322
323%preun -n emacs-git
324
325if [ "$1" = 0 ]; then
326
327%_emacsenPackageRemove git
328
329%_removeemacsenlist git
330
331fi
332
333
334%files -f bin-man-doc-files -f %{name}.lang
335%defattr(-,root,root)
336%{_bindir}/git
337%{_bindir}/git-receive-pack
338%{_bindir}/git-upload-archive
339%{_bindir}/git-upload-pack
340%{_bindir}/git-shell
341%{_datadir}/git-core/
342%exclude %{_libexecdir}/git-core/git-credential-gnome-keyring
343%doc README.md COPYING Documentation/*.txt contrib/hooks
344%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
345%{!?_without_docs: %doc Documentation/howto Documentation/technical}
346%{_sysconfdir}/bash_completion.d
347
348
349%files svn
350%defattr(-,root,root)
351%{_libexecdir}/git-core/*svn*
352%doc Documentation/*svn*.txt
353%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
354%{!?_without_docs: %doc Documentation/*svn*.html }
355
356%files cvs
357%defattr(-,root,root)
358%doc Documentation/*git-cvs*.txt
359%{_bindir}/git-cvsserver
360%{_libexecdir}/git-core/*cvs*
361%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
362%{!?_without_docs: %doc Documentation/*git-cvs*.html }
363
364%files contrib
365%defattr(-,root,root)
366%doc contrib/diff-highlight/README.diff-highlight
367%{_bindir}/diff-highlight
368%{_libexecdir}/git-core/git-credential-gnome-keyring
369
370%if "%{?_dist_release}" != "vl4" && %{with arch}
371%files arch
372%defattr(-,root,root)
373%doc Documentation/git-archimport.txt
374%{_libexecdir}/git-core/git-archimport
375%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
376%{!?_without_docs: %doc Documentation/git-archimport.html }
377%endif
378
379%files email
380%defattr(-,root,root)
381%doc Documentation/*email*.txt
382%{_libexecdir}/git-core/*email*
383%{!?_without_docs: %{_mandir}/man1/*email*.1*}
384%{!?_without_docs: %doc Documentation/*email*.html }
385
386%files gui
387%defattr(-,root,root)
388%{_libexecdir}/git-core/git-gui*
389%{_libexecdir}/git-core/git-citool
390%{_datadir}/git-gui/
391%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
392%{!?_without_docs: %doc Documentation/git-gui.html}
393%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
394%{!?_without_docs: %doc Documentation/git-citool.html}
395
396%files -n gitk
397%defattr(-,root,root)
398%doc Documentation/*gitk*.txt
399%{_bindir}/gitk
400%{_datadir}/gitk
401%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
402%{!?_without_docs: %doc Documentation/*gitk*.html }
403
404%files -n perl-Git -f perl-files
405%defattr(-,root,root)
406
407%files -n emacs-git
408%defattr(-,root,root)
409%{_datadir}/emacs/site-lisp/git
410#%{_libdir}/emacsen-common/packages/install/git
411#%{_libdir}/emacsen-common/packages/remove/git
412%{emacsen_pkgdir}/install/git
413%{emacsen_pkgdir}/remove/git
414
415%files daemon
416%defattr(-,root,root)
417%{_var}/lib/git
418%{_libexecdir}/git-core/git-daemon
419%config(noreplace)%{_sysconfdir}/xinetd.d/git
420/srv/git
421
422%files -n gitweb
423%defattr(-,root,root)
424%doc gitweb/README
425/var/www/git/
426%config(noreplace)%{_sysconfdir}/gitweb.conf
427%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
428
429%files devel
430%defattr(644,root,root,755)
431%{_includedir}/git
432%{_libdir}/libgit.a
433%{_libdir}/libgit_xdiff.a
434
435
436%files all
437# No files for you!
438
439%changelog
440* Wed Jan 17 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 2.15.1-1
441- update to 2.15.1
442
443* Tue Aug 15 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.14.1-1
444- update to 2.14.1
445
446* Sun Jul  9 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.2-1
447- update to 2.13.2
448
449* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.0-1
450- update to 2.13.0
451
452* Sun Mar 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.12.0-1
453- update to 2.12.0
454
455* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.1-1
456- update to 2.11.1
457
458* Tue Dec 20 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.0-1
459- update to 2.11.0
460
461* Fri Nov 18 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.10.2-2
462- include git-credential-gnome-keyring in contrib subpackage
463
464* Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
465- update to 2.10.2
466- fix build error using pcre-8.12 (Vine6)
467
468* Sun May  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
469- update to 2.8.2.
470
471* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
472- update to 2.6.6.
473
474* Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
475- update to 2.6.4
476- add locale files
477
478* Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
479- update to 2.2.1
480
481* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
482- build with Perl 5.16
483
484* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
485- update to 2.0.1
486- add "%%bcond_with arch": no create git-arch sub package by default
487
488* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
489- update to 1.9.2
490
491* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
492- update to 1.8.5.2
493
494* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
495- update to 1.8.4.4
496- new sub package: contrib
497
498* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
499- new upstream release
500
501* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
502- new upstream release
503
504* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
505- new upstream release
506
507* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
508- new upstream release
509
510* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
511- new upstream release
512
513* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
514- new upstream release
515
516* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
517- new upstream release
518- enable libpcre support, add BR: pcre-devel
519- add /etc/gitweb.conf
520- add /var/lib/git for PROJECTROOT
521
522* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
523- new upstream release
524
525* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
526- new upstream release
527
528* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
529- new upstream release
530
531* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
532- new upstream release
533
534* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
535- build with perl 5.12.3
536
537* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
538- new upstream release
539- build with openssl 1.0.0c for VineSeed
540
541* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
542- new upstream release: include security fix: CVE-2010-3906
543
544* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
545- new upstream release
546- drop CVE-2010-2542 patch (Patch100): upstream fixed
547- apply vine-default
548 - rename Source1: git-init.el -> vine-default-git.el
549 - add new git-init.el file (Source12)
550 - update git-install.sh
551- update %%build and %%install section for gitweb subpackage
552- add README in gitweb subpackage
553
554* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
555- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
556
557* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
558- new upstream release
559- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
560- disable building of unused python remote helper libs
561
562* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
563- new upstream release with security fix
564- drop patch10 (included in new release)
565
566* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
567- new upstream release
568- add patch10 git daemon extra arg parsing fix
569
570* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
571- fix install script for Emacs Lisp: <BTS:VineLinux:685>
572 - update git-install.sh (Source10) using contributed patch
573
574* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
575- new upstream release
576
577* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
578- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
579- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
580- fix summary and description in daemon sub package
581
582* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
583- drop Error.pm: provide by perl-Error package
584
585* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
586- new upstream relase
587- update URL tag
588- add Requires: perl(SVN::Core) for svn subpackage
589
590* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
591- add git-shell in git package
592- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
593
594* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
595- added BuildRequires: xmlto
596
597* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
598- new upstream release
599- add devel subpackage (see [wishes:0165])
600
601* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
602- new upstream release
603
604* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
605- new upstream release
606
607* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
608- new upstream release
609
610* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
611- use %%emacsen_pkgdir macro
612
613* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
614- new upstream release
615
616* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
617- initial build for Vine Linux
618
619* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
620- git-1.5.6.4
621
622* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
623- git-1.5.6
624
625* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
626- use tar.bz2 instead of tar.gz
627
628* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
629- git-1.5.5.3
630
631* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
632- git-1.5.5.2
633
634* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
635- git-1.5.5.1
636
637* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
638- git-1.5.5
639
640* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
641- Remove the last two requires on git-core.
642
643* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
644- Remove a patch that's already upstream.
645
646* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
647- git-1.5.4.5
648
649* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
650- Own /etc/bash_completion.d in case bash-completion isn't installed.
651
652* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
653- Include the sample hooks from contrib/hooks as docs (bug 321151).
654- Install the bash completion script from contrib (bug 433255).
655- Include the html docs in the 'core' package again (bug 434271).
656
657* Wed Mar 19 2008 James Bowes 1.5.4.4-2
658- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
659
660* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
661- git-1.5.4.4
662
663* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
664- rebuild for new perl (again)
665
666* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
667- Do not silently overwrite /etc/httpd/conf.d/git.conf
668
669* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
670- git-1.5.4.3
671- Include Kristian Høgsberg's changes to rename git-core to
672  git and git to git-all.
673
674* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
675- git-1.5.4.2
676
677* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
678- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
679  gitweb rss feeds point be commitdiffs instead of commit
680
681* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
682- git-1.5.4.1
683
684* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
685- rebuild for new perl
686
687* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
688- Add BuidRequires on gettext.
689
690* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
691- git-1.5.4
692
693* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
694- git-1.5.3.8
695
696* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
697- Have git metapackage require explicit versions (bug 247214)
698
699* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
700- git-1.5.3.7
701
702* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
703- git-1.5.3.6
704- git-core requires perl(Error) (bug 367861)
705- git-svn requires perl(Term:ReadKey) (bug 261361)
706- git-email requires perl-Git (bug 333061)
707
708* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
709- git-Perl requires Error package
710
711* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
712- git-1.5.3.4
713
714* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
715- git-1.5.3.3
716
717* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
718- git-1.5.3.2
719
720* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
721- Include git-gui and git-citool docs
722
723* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
724- git-1.5.3.1-1
725
726* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
727- git-1.5.2.5-1
728
729* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
730- git-1.5.2.4-1
731
732* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
733- Add git-daemon and gitweb packages
734
735* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
736- Add emacs-git package (#235431)
737
738* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
739- git-1.5.2.2
740
741* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
742- git-1.5.2.1
743
744* Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
745- Added lib files for git-gui
746- Added Documentation/technical (As needed by Git Users Manual)
747
748* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
749- Added howto files
750
751* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
752- git-1.5.0.6
753
754* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
755- git-1.5.0.5
756
757* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
758- git-1.5.0.3
759
760* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
761- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
762
763* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
764- git-1.5.0.2
765
766* Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
767- Update core package description (Git isn't as stupid as it used to be)
768
769* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
770- Add git-gui and git-citool.
771
772* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
773- no need to install manpages executable (bz 216790)
774- use bytes for git-cvsserver
775
776* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
777- git-1.4.4.2
778
779* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
780- rebuild against the new curl
781
782* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
783- git-1.4.2.4
784
785* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
786- git-1.4.2.3
787
788* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
789- git-1.4.2.1
790
791* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
792- git-1.4.2
793
794* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
795- git-1.4.1
796
797* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
798- git-1.4.0
799
800* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
801- git-1.3.3
802- enable git-email building, prereqs have been relaxed
803
804* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
805- git-1.3.2
806
807* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
808- git-1.3.1
809
810* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
811- git-1.3.0
812
813* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
814- git-1.2.6
815
816* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
817- git-1.2.5
818
819* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
820- git-1.2.4
821
822* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
823- git-1.2.3
824
825* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
826- git-1.2.2
827
828* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
829- git-1.2.1
830
831* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
832- git-1.2.0
833
834* Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
835- git-1.1.6
836
837* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
838- git-1.1.4
839
840* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
841- git-1.1.2
842
843* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
844- git-1.1.1
845
846* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
847- Update to latest git-1.1.0 (drop git-email for now)
848- Now creates multiple packages:
849-        git-core, git-svn, git-cvs, git-arch, gitk
850
851* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
852- Change subpackage names to git-<name> instead of git-core-<name>
853- Create empty root package which brings in all subpackages
854- Rename git-tk -> gitk
855
856* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
857- zlib dependency fix
858- Minor cleanups from split
859- Move arch import to separate package as well
860
861* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
862- Move programs with non-standard dependencies (svn, cvs, email)
863  into separate packages
864
865* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
866- parallelize build
867- COPTS -> CFLAGS
868
869* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
870- update to 0.99.6
871
872* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
873- Linus noticed that less is required, added to the dependencies
874
875* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
876- Updated dependencies
877- Don't assume manpages are gzipped
878
879* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
880- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
881- use RPM_OPT_FLAGS in spec file, drop patch0
882
883* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
884- use dist tag to differentiate between branches
885- use rpm optflags by default (patch0)
886- own %{_datadir}/git-core/
887
888* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
889- update spec file to fix Buildroot, Requires, and drop Vendor
890
891* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
892- Redid the description
893- Cut overlong make line, loosened changelog a bit
894- I think Junio (or perhaps OSDL?) should be vendor...
895
896* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
897- Add the man pages, and the --without docs build option
898
899* Thu Jul 7 2005 Chris Wright <chris@osdl.org>
900- initial git spec file
Note: See TracBrowser for help on using the repository browser.