source: projects/specs/trunk/g/git/git-vl.spec @ 11145

Revision 11145, 26.6 KB checked in by iwaim, 7 years ago (diff)

git 2.13.2-1

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:    git
8Version: 2.13.2
9Release: 1%{?_dist_release}
10Summary: Core git tools
11Summary(ja): Core git ツール
12License:  GPLv2
13Group:    Development/Tools
14URL:      http://git-scm.com/
15Source0:  https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
16Source1:  vine-default-git.el
17Source2:  git.xinetd
18Source3:  git.conf.httpd
19Source4:  gitweb.conf.in
20Source10: %{name}-install.sh
21Source11: %{name}-remove.sh
22Source12: git-init.el
23Patch0:   git-1.5-gitweb-home-link.patch
24
25# Security
26# none
27
28BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel
29BuildRequires:  expat-devel, gettext, asciidoc
30BuildRequires:  pcre-devel
31BuildRequires:  xmlto
32
33# git-credential-gnome-keyring
34BuildRequires:  glib2-devel libgnome-keyring-devel
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
37
38Requires:       perl-Git = %{version}-%{release}
39Requires:       zlib
40Provides:       git-core = %{version}-%{release}
41Obsoletes:      git-core <= 1.5.4.3
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       iwaim
46
47%description
48Git is a fast, scalable, distributed revision control system with an
49unusually rich command set that provides both high-level operations
50and full access to internals.
51
52The git rpm installs the core tools with minimal dependencies.  To
53install all git packages, including tools for integrating with other
54SCMs, install the git-all meta-package.
55
56%package all
57Summary:        Meta-package to pull in all git tools
58Summary(ja):    すべての git ツール
59Group:          Development/Tools
60Requires:       git = %{version}-%{release}
61Requires:       git-svn = %{version}-%{release}
62Requires:       git-cvs = %{version}-%{release}
63%if "%{?_dist_release}" != "vl4" && %{with arch}
64Requires:       git-arch = %{version}-%{release}
65%endif
66Requires:       git-email = %{version}-%{release}
67Requires:       gitk = %{version}-%{release}
68Requires:       git-gui = %{version}-%{release}
69Requires:       perl-Git = %{version}-%{release}
70Requires:       emacs-git = %{version}-%{release}
71Requires:       git-contrib = %{version}-%{release}
72Obsoletes:      git <= 1.5.4.3
73
74%description all
75Git is a fast, scalable, distributed revision control system with an
76unusually rich command set that provides both high-level operations
77and full access to internals.
78
79This is a dummy package which brings in all subpackages.
80
81%package daemon
82Summary:        Git protocol daemon
83Summary(ja):    Git プロトコルデーモン
84Group:          Development/Tools
85Requires:       git = %{version}-%{release}
86%description daemon
87The git daemon for supporting git:// access to git repositories
88
89%package -n gitweb
90Summary:        Simple web interface to git repositories
91Summary(ja):    git リポジトリへのシンプルな Web インタフェース
92Group:          Development/Tools
93Requires:       git = %{version}-%{release}
94
95%description -n gitweb
96Simple web interface to track changes in git repositories
97
98
99%package svn
100Summary:        Git tools for importing Subversion repositories
101Summary(ja):    Subversion リポジトリを git へインポートするためのツール
102Group:          Development/Tools
103Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
104Requires:       perl(SVN::Core)
105%description svn
106Git tools for importing Subversion repositories.
107
108%package cvs
109Summary:        Git tools for importing CVS repositories
110Summary(ja):    CVS リポジトリを git へインポートするためのツール
111Group:          Development/Tools
112Requires:       git = %{version}-%{release}, cvs, cvsps
113%description cvs
114Git tools for importing CVS repositories.
115
116%package contrib
117Summary:        Git contrib tools
118Group:          Development/Tools
119Requires:       git = %{version}-%{release}
120%description contrib
121Git contrib tools
122
123%if "%{?_dist_release}" != "vl4" && %{with arch}
124%package arch
125Summary:        Git tools for importing Arch repositories
126Summary(ja):    Arch リポジトリを git へインポートするためのツール
127Group:          Development/Tools
128Requires:       git = %{version}-%{release}, tla
129%description arch
130Git tools for importing Arch repositories.
131%endif
132
133%package email
134Summary:        Git tools for sending email
135Summary(ja):    Eメールを送るための git ツール
136Group:          Development/Tools
137Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
138%description email
139Git tools for sending email.
140
141%package gui
142Summary:        Git GUI tool
143Summary(ja):    Git の GUI ツール
144Group:          Development/Tools
145Requires:       git = %{version}-%{release}, tk
146%description gui
147Git GUI tool.
148
149%package -n gitk
150Summary:        Git revision tree visualiser
151Summary(ja):    Git リビジョンツリー可視化ツール
152Group:          Development/Tools
153Requires:       git = %{version}-%{release}, tk
154%description -n gitk
155Git revision tree visualiser.
156
157%package -n perl-Git
158Summary:        Perl interface to Git
159Summary(ja):    Git の perl インタフェース
160Group:          Development/Libraries
161Requires:       git = %{version}-%{release}, perl(Error)
162%if "%{?_dist_release}" == "vl4"
163Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
164%else
165Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
166%endif
167#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
168
169%description -n perl-Git
170Perl interface to Git.
171
172%package -n emacs-git
173Summary:       Git version control system support for Emacs
174Summary(ja):   Emacs の Git サポート
175Group:         Applications/Editors
176Requires:      git = %{version}-%{release}, emacsen-common
177
178%description -n emacs-git
179%{summary}.
180
181%package devel
182Summary:        Header files for git-core
183Summary(ja):    git-core 用ヘッダファイル
184Group:          Development/Libraries
185
186%description devel
187Header files for git-core.
188
189%prep
190%setup -q
191%patch0 -p1
192
193# for pcre-8.12
194%if %{?_dist_release} == "vl6"
195%{__perl} -pi -e "s|#include <pcre.h>|#include <pcre/pcre.h>|" grep.h
196%endif
197
198%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
199
200# Filter bogus perl requires
201cat << \EOF > %{name}-req
202#!/bin/sh
203%{__perl_requires} $* |\
204sed -e '/perl(packed-refs)/d'
205EOF
206
207%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
208chmod +x %{__perl_requires}
209
210%build
211make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
212     ETC_GITCONFIG=/etc/gitconfig \
213     USE_LIBPCRE=1 \
214     GITWEB_PROJECTROOT=/var/lib/git \
215     gitwebdir=/var/www/git \
216     prefix=%{_prefix} all %{!?_without_docs: doc}
217
218%install
219rm -rf $RPM_BUILD_ROOT
220make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
221     prefix=%{_prefix} mandir=%{_mandir} \
222     ETC_GITCONFIG=/etc/gitconfig \
223     USE_LIBPCRE=1 \
224     NO_PYTHON=1 \
225     GITWEB_PROJECTROOT=/var/lib/git \
226     gitwebdir=/var/www/git \
227     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
228
229pushd contrib/credential/gnome-keyring
230make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
231popd
232
233# perl-Git
234# Error.pm provide by perl-Error package
235rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
236
237# emacs-git
238mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
239#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
240#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
241mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
242mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
243
244# install el files
245install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
246
247# install vine-default file
248install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
249
250# install  script( bytecompile el and install elc , remove )
251
252%_installemacsenscript git %{SOURCE10}
253
254%_removeemacsenscript  git %{SOURCE11}
255
256mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
257mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
258install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
259perl -p \
260     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
261     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
262     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
263
264## for gitweb sub package
265mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
266install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
267sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
268    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
269
270find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
271find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
272find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
273
274(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
275(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
276%if %{!?_without_docs:1}0
277(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
278%else
279rm -rf $RPM_BUILD_ROOT%{_mandir}
280%endif
281mkdir -p $RPM_BUILD_ROOT/srv/git
282
283mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
284install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
285
286install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
287
288# header files and lib
289install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
290install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
291install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
292install libgit.a $RPM_BUILD_ROOT%{_libdir}
293install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
294
295# git-credential-gnome-keyring
296pushd contrib/credential/gnome-keyring
297%__install -m0755 git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libexecdir}/git-core
298popd
299
300%find_lang %{name}
301
302%clean
303rm -rf $RPM_BUILD_ROOT
304
305%post -n emacs-git
306
307# bytecompile and install
308
309if [ "$1" = 2 ]; then
310
311%_emacsenPackageRemove git
312
313fi
314
315%_addemacsenlist git
316
317%_emacsenPackageInstall git
318
319%preun -n emacs-git
320
321if [ "$1" = 0 ]; then
322
323%_emacsenPackageRemove git
324
325%_removeemacsenlist git
326
327fi
328
329
330%files -f bin-man-doc-files -f %{name}.lang
331%defattr(-,root,root)
332%{_bindir}/git
333%{_bindir}/git-receive-pack
334%{_bindir}/git-upload-archive
335%{_bindir}/git-upload-pack
336%{_bindir}/git-shell
337%{_datadir}/git-core/
338%exclude %{_libexecdir}/git-core/git-credential-gnome-keyring
339%doc README.md COPYING Documentation/*.txt contrib/hooks
340%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
341%{!?_without_docs: %doc Documentation/howto Documentation/technical}
342%{_sysconfdir}/bash_completion.d
343
344
345%files svn
346%defattr(-,root,root)
347%{_libexecdir}/git-core/*svn*
348%doc Documentation/*svn*.txt
349%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
350%{!?_without_docs: %doc Documentation/*svn*.html }
351
352%files cvs
353%defattr(-,root,root)
354%doc Documentation/*git-cvs*.txt
355%{_bindir}/git-cvsserver
356%{_libexecdir}/git-core/*cvs*
357%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
358%{!?_without_docs: %doc Documentation/*git-cvs*.html }
359
360%files contrib
361%defattr(-,root,root)
362%doc contrib/diff-highlight/README.diff-highlight
363%{_bindir}/diff-highlight
364%{_libexecdir}/git-core/git-credential-gnome-keyring
365
366%if "%{?_dist_release}" != "vl4" && %{with arch}
367%files arch
368%defattr(-,root,root)
369%doc Documentation/git-archimport.txt
370%{_libexecdir}/git-core/git-archimport
371%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
372%{!?_without_docs: %doc Documentation/git-archimport.html }
373%endif
374
375%files email
376%defattr(-,root,root)
377%doc Documentation/*email*.txt
378%{_libexecdir}/git-core/*email*
379%{!?_without_docs: %{_mandir}/man1/*email*.1*}
380%{!?_without_docs: %doc Documentation/*email*.html }
381
382%files gui
383%defattr(-,root,root)
384%{_libexecdir}/git-core/git-gui*
385%{_libexecdir}/git-core/git-citool
386%{_datadir}/git-gui/
387%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
388%{!?_without_docs: %doc Documentation/git-gui.html}
389%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
390%{!?_without_docs: %doc Documentation/git-citool.html}
391
392%files -n gitk
393%defattr(-,root,root)
394%doc Documentation/*gitk*.txt
395%{_bindir}/gitk
396%{_datadir}/gitk
397%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
398%{!?_without_docs: %doc Documentation/*gitk*.html }
399
400%files -n perl-Git -f perl-files
401%defattr(-,root,root)
402
403%files -n emacs-git
404%defattr(-,root,root)
405%{_datadir}/emacs/site-lisp/git
406#%{_libdir}/emacsen-common/packages/install/git
407#%{_libdir}/emacsen-common/packages/remove/git
408%{emacsen_pkgdir}/install/git
409%{emacsen_pkgdir}/remove/git
410
411%files daemon
412%defattr(-,root,root)
413%{_var}/lib/git
414%{_libexecdir}/git-core/git-daemon
415%config(noreplace)%{_sysconfdir}/xinetd.d/git
416/srv/git
417
418%files -n gitweb
419%defattr(-,root,root)
420%doc gitweb/README
421/var/www/git/
422%config(noreplace)%{_sysconfdir}/gitweb.conf
423%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
424
425%files devel
426%defattr(644,root,root,755)
427%{_includedir}/git
428%{_libdir}/libgit.a
429%{_libdir}/libgit_xdiff.a
430
431
432%files all
433# No files for you!
434
435%changelog
436* Sun Jul  9 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.2-1
437- update to 2.13.2
438
439* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.0-1
440- update to 2.13.0
441
442* Sun Mar 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.12.0-1
443- update to 2.12.0
444
445* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.1-1
446- update to 2.11.1
447
448* Tue Dec 20 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.0-1
449- update to 2.11.0
450
451* Fri Nov 18 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.10.2-2
452- include git-credential-gnome-keyring in contrib subpackage
453
454* Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
455- update to 2.10.2
456- fix build error using pcre-8.12 (Vine6)
457
458* Sun May  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
459- update to 2.8.2.
460
461* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
462- update to 2.6.6.
463
464* Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
465- update to 2.6.4
466- add locale files
467
468* Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
469- update to 2.2.1
470
471* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
472- build with Perl 5.16
473
474* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
475- update to 2.0.1
476- add "%%bcond_with arch": no create git-arch sub package by default
477
478* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
479- update to 1.9.2
480
481* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
482- update to 1.8.5.2
483
484* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
485- update to 1.8.4.4
486- new sub package: contrib
487
488* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
489- new upstream release
490
491* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
492- new upstream release
493
494* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
495- new upstream release
496
497* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
498- new upstream release
499
500* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
501- new upstream release
502
503* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
504- new upstream release
505
506* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
507- new upstream release
508- enable libpcre support, add BR: pcre-devel
509- add /etc/gitweb.conf
510- add /var/lib/git for PROJECTROOT
511
512* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
513- new upstream release
514
515* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
516- new upstream release
517
518* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
519- new upstream release
520
521* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
522- new upstream release
523
524* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
525- build with perl 5.12.3
526
527* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
528- new upstream release
529- build with openssl 1.0.0c for VineSeed
530
531* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
532- new upstream release: include security fix: CVE-2010-3906
533
534* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
535- new upstream release
536- drop CVE-2010-2542 patch (Patch100): upstream fixed
537- apply vine-default
538 - rename Source1: git-init.el -> vine-default-git.el
539 - add new git-init.el file (Source12)
540 - update git-install.sh
541- update %%build and %%install section for gitweb subpackage
542- add README in gitweb subpackage
543
544* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
545- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
546
547* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
548- new upstream release
549- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
550- disable building of unused python remote helper libs
551
552* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
553- new upstream release with security fix
554- drop patch10 (included in new release)
555
556* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
557- new upstream release
558- add patch10 git daemon extra arg parsing fix
559
560* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
561- fix install script for Emacs Lisp: <BTS:VineLinux:685>
562 - update git-install.sh (Source10) using contributed patch
563
564* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
565- new upstream release
566
567* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
568- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
569- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
570- fix summary and description in daemon sub package
571
572* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
573- drop Error.pm: provide by perl-Error package
574
575* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
576- new upstream relase
577- update URL tag
578- add Requires: perl(SVN::Core) for svn subpackage
579
580* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
581- add git-shell in git package
582- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
583
584* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
585- added BuildRequires: xmlto
586
587* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
588- new upstream release
589- add devel subpackage (see [wishes:0165])
590
591* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
592- new upstream release
593
594* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
595- new upstream release
596
597* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
598- new upstream release
599
600* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
601- use %%emacsen_pkgdir macro
602
603* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
604- new upstream release
605
606* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
607- initial build for Vine Linux
608
609* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
610- git-1.5.6.4
611
612* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
613- git-1.5.6
614
615* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
616- use tar.bz2 instead of tar.gz
617
618* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
619- git-1.5.5.3
620
621* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
622- git-1.5.5.2
623
624* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
625- git-1.5.5.1
626
627* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
628- git-1.5.5
629
630* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
631- Remove the last two requires on git-core.
632
633* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
634- Remove a patch that's already upstream.
635
636* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
637- git-1.5.4.5
638
639* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
640- Own /etc/bash_completion.d in case bash-completion isn't installed.
641
642* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
643- Include the sample hooks from contrib/hooks as docs (bug 321151).
644- Install the bash completion script from contrib (bug 433255).
645- Include the html docs in the 'core' package again (bug 434271).
646
647* Wed Mar 19 2008 James Bowes 1.5.4.4-2
648- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
649
650* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
651- git-1.5.4.4
652
653* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
654- rebuild for new perl (again)
655
656* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
657- Do not silently overwrite /etc/httpd/conf.d/git.conf
658
659* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
660- git-1.5.4.3
661- Include Kristian Høgsberg's changes to rename git-core to
662  git and git to git-all.
663
664* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
665- git-1.5.4.2
666
667* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
668- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
669  gitweb rss feeds point be commitdiffs instead of commit
670
671* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
672- git-1.5.4.1
673
674* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
675- rebuild for new perl
676
677* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
678- Add BuidRequires on gettext.
679
680* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
681- git-1.5.4
682
683* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
684- git-1.5.3.8
685
686* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
687- Have git metapackage require explicit versions (bug 247214)
688
689* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
690- git-1.5.3.7
691
692* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
693- git-1.5.3.6
694- git-core requires perl(Error) (bug 367861)
695- git-svn requires perl(Term:ReadKey) (bug 261361)
696- git-email requires perl-Git (bug 333061)
697
698* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
699- git-Perl requires Error package
700
701* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
702- git-1.5.3.4
703
704* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
705- git-1.5.3.3
706
707* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
708- git-1.5.3.2
709
710* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
711- Include git-gui and git-citool docs
712
713* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
714- git-1.5.3.1-1
715
716* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
717- git-1.5.2.5-1
718
719* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
720- git-1.5.2.4-1
721
722* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
723- Add git-daemon and gitweb packages
724
725* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
726- Add emacs-git package (#235431)
727
728* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
729- git-1.5.2.2
730
731* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
732- git-1.5.2.1
733
734* Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
735- Added lib files for git-gui
736- Added Documentation/technical (As needed by Git Users Manual)
737
738* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
739- Added howto files
740
741* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
742- git-1.5.0.6
743
744* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
745- git-1.5.0.5
746
747* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
748- git-1.5.0.3
749
750* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
751- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
752
753* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
754- git-1.5.0.2
755
756* Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
757- Update core package description (Git isn't as stupid as it used to be)
758
759* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
760- Add git-gui and git-citool.
761
762* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
763- no need to install manpages executable (bz 216790)
764- use bytes for git-cvsserver
765
766* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
767- git-1.4.4.2
768
769* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
770- rebuild against the new curl
771
772* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
773- git-1.4.2.4
774
775* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
776- git-1.4.2.3
777
778* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
779- git-1.4.2.1
780
781* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
782- git-1.4.2
783
784* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
785- git-1.4.1
786
787* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
788- git-1.4.0
789
790* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
791- git-1.3.3
792- enable git-email building, prereqs have been relaxed
793
794* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
795- git-1.3.2
796
797* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
798- git-1.3.1
799
800* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
801- git-1.3.0
802
803* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
804- git-1.2.6
805
806* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
807- git-1.2.5
808
809* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
810- git-1.2.4
811
812* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
813- git-1.2.3
814
815* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
816- git-1.2.2
817
818* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
819- git-1.2.1
820
821* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
822- git-1.2.0
823
824* Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
825- git-1.1.6
826
827* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
828- git-1.1.4
829
830* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
831- git-1.1.2
832
833* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
834- git-1.1.1
835
836* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
837- Update to latest git-1.1.0 (drop git-email for now)
838- Now creates multiple packages:
839-        git-core, git-svn, git-cvs, git-arch, gitk
840
841* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
842- Change subpackage names to git-<name> instead of git-core-<name>
843- Create empty root package which brings in all subpackages
844- Rename git-tk -> gitk
845
846* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
847- zlib dependency fix
848- Minor cleanups from split
849- Move arch import to separate package as well
850
851* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
852- Move programs with non-standard dependencies (svn, cvs, email)
853  into separate packages
854
855* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
856- parallelize build
857- COPTS -> CFLAGS
858
859* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
860- update to 0.99.6
861
862* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
863- Linus noticed that less is required, added to the dependencies
864
865* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
866- Updated dependencies
867- Don't assume manpages are gzipped
868
869* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
870- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
871- use RPM_OPT_FLAGS in spec file, drop patch0
872
873* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
874- use dist tag to differentiate between branches
875- use rpm optflags by default (patch0)
876- own %{_datadir}/git-core/
877
878* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
879- update spec file to fix Buildroot, Requires, and drop Vendor
880
881* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
882- Redid the description
883- Cut overlong make line, loosened changelog a bit
884- I think Junio (or perhaps OSDL?) should be vendor...
885
886* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
887- Add the man pages, and the --without docs build option
888
889* Thu Jul 7 2005 Chris Wright <chris@osdl.org>
890- initial git spec file
Note: See TracBrowser for help on using the repository browser.