source: projects/specs/trunk/g/giflib/giflib-vl.spec @ 7801

Revision 7801, 10.4 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.11.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:     A library for manipulating GIF format image files.
4Summary(ja): GIF 形式の画像ファイルを扱うライブラリ
5Name: giflib
6Version: 4.2.3
7Release: 1%{_dist_release}
8License: MIT
9URL: http://sourceforge.net/projects/giflib/
10Source: http://jaist.dl.sourceforge.net/sourceforge/giflib/%{name}-%{version}.tar.bz2
11Group: System Environment/Libraries
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14Obsoletes: libungif < 4.1.6-1
15Provides:  libungif = %{version}-%{release}
16
17
18%description
19The giflib package contains a shared library of functions for
20loading and saving GIF format image files. It is API and ABI compatible
21with libungif, the library which supported uncompressed GIFs while the
22Unisys LZW patent was in effect.
23
24Install the giflib package if you need to write programs that use GIF files.
25You should also install the giflib-utils package if you need some simple
26utilities to manipulate GIFs.
27
28%description -l ja
29giflib パッケージには GIF 形式の画像ファイルを読み書きするために必要な
30共有ライブラリが収録されています。この giflib は、Unisys LZW 特許が有効で
31あった時期に、非圧縮形式の GIF ファイルを扱うために使われていたライブラリで
32ある libungif と API / ABI 互換性があります。
33
34GIF ファイルを扱うプログラムを作成される場合は giflib パッケージを
35インストールして下さい。また、GIF ファイルを操作する簡単なユーティリティが
36必要な場合には giflib-utils パッケージも一緒にインストールする必要があります。
37
38
39%package devel
40Summary: Development tools for programs which will use the giflib library.
41Summary(ja): giflib ライブラリを使うプログラム用開発ツール
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Obsoletes: libungif-devel < 4.1.6-1
45Provides:  libungif-devel = %{version}-%{release}
46
47%description devel
48This package contains the static libraries, header files and
49documentation necessary for development of programs that will use the
50giflib library to load and save GIF format image files.
51
52You should install this package if you need to develop programs which
53will use libungif library functions.  You'll also need to install the
54giflib package.
55
56%description devel -l ja
57このパッケージには giflib ライブラリを使って GIF 形式の画像ファイルを
58読み書きするプログラムの開発に必要なスタティックライブラリ、ヘッダファイル
59そしてドキュメントが収められています。
60
61giflib ライブラリ関数を使うプログラム開発を行う場合は
62このパッケージをインストールする必要があります。
63giflib パッケージも同時にインストールして下さい。
64
65
66%package utils
67Summary: Programs for manipulating GIF format image files.
68Summary(ja): GIF 形式の画像ファイルを扱うプログラム
69Group: Applications/Graphics
70Requires: %{name} = %{version}-%{release}
71Obsoletes: libungif-progs < 4.1.6-1
72
73%description utils
74The giflib-utils package contains various programs for manipulating
75GIF format image files.
76
77Install this package if you need to manipulate GIF format image files.
78You'll also need to install the giflib package.
79
80%description utils -l ja
81giflib-utils パッケージには GIF 形式の画像ファイルを扱う
82様々なプログラムが収められています。
83
84GIF 形式の画像ファイルを扱う必要があるならこのパッケージを
85インストールして下さい。giflib パッケージも同時にインストールする
86必要があります。
87
88
89## to build compat32 for x86_64 architecture support
90%package -n compat32-%{name}
91Summary:     A library for manipulating GIF format image files.
92Summary(ja): GIF 形式の画像ファイルを扱うライブラリ
93Group: System Environment/Libraries
94Obsoletes: compat32-libungif <= %{version}-%{release}
95Provides: compat32-libungif = %{version}-%{release}
96
97%description -n compat32-%{name}
98The giflib package contains a shared library of functions for
99loading and saving GIF format image files. It is API and ABI compatible
100with libungif, the library which supported uncompressed GIFs while the
101Unisys LZW patent was in effect.
102
103Install the giflib package if you need to write programs that use GIF files.
104You should also install the giflib-utils package if you need some simple
105utilities to manipulate GIFs.
106
107
108%package -n compat32-%{name}-devel
109Summary: Development tools for programs which will use the giflib library.
110Summary(ja): giflib ライブラリを使うプログラム用開発ツール
111Group: Development/Libraries
112Obsoletes: compat32-libungif-devel < 4.1.6-1
113Provides: compat32-libungif-devel = %{version}-%{release}
114
115%description -n compat32-%{name}-devel
116This package contains the static libraries, header files and
117documentation necessary for development of programs that will use the
118giflib library to load and save GIF format image files.
119
120You should install this package if you need to develop programs which
121will use giflib library functions.  You'll also need to install the
122giflib package.
123
124
125%prep
126%setup -q -n %{name}-%{version}
127
128
129%build
130sed -i "s|allhtml manpages|manpages|" doc/Makefile.am
131./autogen.sh
132%configure
133make all
134
135MAJOR=`echo '%{version}' | sed 's/\([0-9]\+\)\..*/\1/'`
136%{__cc} $RPM_OPT_FLAGS -shared -Wl,-soname,libungif.so.$MAJOR -Llib/.libs -lgif -o libungif.so.%{version}
137
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142%makeinstall
143install -m 0755 -p libungif.so.%{version} $RPM_BUILD_ROOT%{_libdir}
144ln -sf libungif.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libungif.so.4
145ln -sf libungif.so.4 ${RPM_BUILD_ROOT}%{_libdir}/libungif.so
146
147chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so*
148chmod 644 $RPM_BUILD_ROOT%{_libdir}/*.a
149chmod 644 COPYING README NEWS
150chmod 644 ChangeLog TODO BUGS AUTHORS
151chmod 644 doc/* util/giffiltr.c util/gifspnge.c
152
153## remove unuse files
154rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
155
156
157%post -p /sbin/ldconfig
158
159
160%postun -p /sbin/ldconfig
161
162
163%if %{build_compat32}
164%post -n compat32-%{name} -p /sbin/ldconfig
165%postun -n compat32-%{name} -p /sbin/ldconfig
166%endif
167
168
169%clean
170rm -rf $RPM_BUILD_ROOT
171
172
173%files
174%defattr(-,root,root)
175%doc COPYING README NEWS
176%doc ChangeLog TODO BUGS AUTHORS
177%{_libdir}/lib*.so.*
178
179%files devel
180%defattr(-,root,root)
181%doc doc/* util/giffiltr.c util/gifspnge.c
182%{_libdir}/lib*.so
183%{_includedir}/*.h
184
185%files utils
186%defattr(-,root,root)
187%{_bindir}/*
188
189## to build compat32 for x86_64 architecture support
190%if %{build_compat32}
191%files -n compat32-%{name}
192%defattr(-,root,root)
193%{_libdir}/lib*.so.*
194
195%files -n compat32-%{name}-devel
196%defattr(-,root,root)
197%{_libdir}/lib*.so
198%endif
199
200
201%changelog
202* Sun Sep 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.3-1
203- new upstream release
204
205* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 4.1.6-4
206- rebuilt with rpm-4.8.1-3
207
208* Sat Feb 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.6-3
209- rebuild with new environment
210- remove static lib
211
212* Thu Aug 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.6-2
213- Obsolete specific version of libungif
214
215* Sun Jan 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.6-1
216- switch from the obsoleted libungif to the ongoing giflib
217  due to LZW's patent expiration which happend a few years ago
218
219* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.4-2vl5
220- removed *.la
221- spec in utf-8
222
223* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-1vl5
224- applied new versioning policy
225- updated URL
226
227* Sun Feb 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-0vl1
228- new upstream release
229
230* Sat Sep 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.3-3vl3
231- changed libungif-progs Group to Applications/Graphics
232
233* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.3-3vl2
234- added compat32-* packages for x86_64 architecture support
235
236* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.3-3vl1
237- new upstream release
238- not generate libungif.so.3* any more
239- fixed spec file based on 4.1.3-3 from Fedora development
240- s/Copyright/License/
241- updated URL
242
243* Fri Dec 13 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.0-13vl1
244- based on 4.1.0-13 from Rawhide
245  - Clean up spec file
246  - Fix build with current auto* tools
247
248* Sat Jul 14 2001 <sagami@vinelinux.org>
249- 4.1.0-9vl1
250- follow up with 4.1.0-9 which has a fix to build against new libtool
251
252* Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
253- 4.1.0-7vl2
254- build with netpbm
255
256* Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
257- 4.1.0-7vl1
258- based on 4.1.0-7 from Rawhide
259- added Japanese summary and description
260
261* Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
262- Make the subpackages require the base package (Bug #14697)
263- update URL
264- add fixes from the homepage
265
266* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
267- automatic rebuild
268
269* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
270- FHS adjustments (release 5)
271
272* Mon Feb 14 2000 Elliot Lee <sopwith@redhat.com> 4.1.0-4
273- Add giflibcvs-small2crash.patch, which changes lib/dgif_lib.c to be
274  whatever is currently in the libungif CVS, thus fixing bug number 9315.
275
276* Sat Feb  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
277- strip libraries
278- update URL
279- some specfile tweaks
280
281* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
282- auto rebuild in the new build environment (release 2)
283
284* Sun Mar 14 1999 Preston Brown <pbrown@redhat.com>
285- include libungif 4.1.0 as standard library, with 3.1.0 backwards compat.
286
287* Mon Jan 11 1999 Cristian Gafton <gafton@redhat.com>
288- build for 6.0
289- call libtoolize to make sure it will build on the arm
290
291* Sat Oct 31 1998 Jeff Johnson <jbj@redhat.com>
292- package for RH 5.2.
293
294* Mon Sep 14 1998 Arne Coucheron <arneco@online.no>
295  [3.1.0-3]
296- major cleanups and changes to the spec file
297
298* Mon Sep 7 1998 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
299- Upgrade to version 3.1.0 (which incorporates the patches in 3.0-4)
300- Updated Source: and URL: to reflect change in directories/pages.
301
302* Tue May 26 1998 Dick Porter <dick@cymru.net>
303- Fixed some "warning: cast to pointer from integer of different size" on Alpha
304
305* Tue May 5 1998 Marc Ewing <marc@redhat.com>
306- Made it obsolete giflib and provide libgif.so and giflib (previous
307  giflib packages were built incorrectly and packages built against
308  it require libgif.so but work fine with this package)
309- cleaned buildroot
310- Removed Toshio as packager so he doesn't get yelled at when Red Hat
311  breaks it :-)
312
313* Fri Apr 24 1998 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
314- Initial revision of libungif, a giflib derivative modified to not use LZW
315  compression.
Note: See TracBrowser for help on using the repository browser.