source: projects/specs/trunk/g/giflib/giflib-vl.spec @ 12189

Revision 12189, 10.0 KB checked in by tomop, 5 years ago (diff)

updated image libs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:     A library for manipulating GIF format image files.
4Summary(ja): GIF 形式の画像ファイルを扱うライブラリ
5Name: giflib
6Version: 5.2.1
7Release: 1%{_dist_release}
8License: MIT
9URL: http://sourceforge.net/projects/giflib/
10Source: http://jaist.dl.sourceforge.net/sourceforge/giflib/%{name}-%{version}.tar.gz
11Group: System Environment/Libraries
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Vendor: Project Vine
14Distribution: Vine Linux
15
16Obsoletes: libungif < 4.1.6-1
17Provides:  libungif = %{version}-%{release}
18
19
20%description
21The giflib package contains a shared library of functions for
22loading and saving GIF format image files. It is API and ABI compatible
23with libungif, the library which supported uncompressed GIFs while the
24Unisys LZW patent was in effect.
25
26Install the giflib package if you need to write programs that use GIF files.
27You should also install the giflib-utils package if you need some simple
28utilities to manipulate GIFs.
29
30%description -l ja
31giflib パッケージには GIF 形式の画像ファイルを読み書きするために必要な
32共有ライブラリが収録されています。この giflib は、Unisys LZW 特許が有効で
33あった時期に、非圧縮形式の GIF ファイルを扱うために使われていたライブラリで
34ある libungif と API / ABI 互換性があります。
35
36GIF ファイルを扱うプログラムを作成される場合は giflib パッケージを
37インストールして下さい。また、GIF ファイルを操作する簡単なユーティリティが
38必要な場合には giflib-utils パッケージも一緒にインストールする必要があります。
39
40
41%package devel
42Summary: Development tools for programs which will use the giflib library.
43Summary(ja): giflib ライブラリを使うプログラム用開発ツール
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Obsoletes: libungif-devel < 4.1.6-1
47Provides:  libungif-devel = %{version}-%{release}
48
49%description devel
50This package contains the static libraries, header files and
51documentation necessary for development of programs that will use the
52giflib library to load and save GIF format image files.
53
54You should install this package if you need to develop programs which
55will use libungif library functions.  You'll also need to install the
56giflib package.
57
58%description devel -l ja
59このパッケージには giflib ライブラリを使って GIF 形式の画像ファイルを
60読み書きするプログラムの開発に必要なスタティックライブラリ、ヘッダファイル
61そしてドキュメントが収められています。
62
63giflib ライブラリ関数を使うプログラム開発を行う場合は
64このパッケージをインストールする必要があります。
65giflib パッケージも同時にインストールして下さい。
66
67
68%package utils
69Summary: Programs for manipulating GIF format image files.
70Summary(ja): GIF 形式の画像ファイルを扱うプログラム
71Group: Applications/Graphics
72Requires: %{name} = %{version}-%{release}
73Obsoletes: libungif-progs < 4.1.6-1
74
75%description utils
76The giflib-utils package contains various programs for manipulating
77GIF format image files.
78
79Install this package if you need to manipulate GIF format image files.
80You'll also need to install the giflib package.
81
82%description utils -l ja
83giflib-utils パッケージには GIF 形式の画像ファイルを扱う
84様々なプログラムが収められています。
85
86GIF 形式の画像ファイルを扱う必要があるならこのパッケージを
87インストールして下さい。giflib パッケージも同時にインストールする
88必要があります。
89
90
91## to build compat32 for x86_64 architecture support
92%package -n compat32-%{name}
93Summary:     A library for manipulating GIF format image files.
94Summary(ja): GIF 形式の画像ファイルを扱うライブラリ
95Group: System Environment/Libraries
96Obsoletes: compat32-libungif <= %{version}-%{release}
97Provides: compat32-libungif = %{version}-%{release}
98
99%description -n compat32-%{name}
100The giflib package contains a shared library of functions for
101loading and saving GIF format image files. It is API and ABI compatible
102with libungif, the library which supported uncompressed GIFs while the
103Unisys LZW patent was in effect.
104
105Install the giflib package if you need to write programs that use GIF files.
106You should also install the giflib-utils package if you need some simple
107utilities to manipulate GIFs.
108
109
110%package -n compat32-%{name}-devel
111Summary: Development tools for programs which will use the giflib library.
112Summary(ja): giflib ライブラリを使うプログラム用開発ツール
113Group: Development/Libraries
114Obsoletes: compat32-libungif-devel < 4.1.6-1
115Provides: compat32-libungif-devel = %{version}-%{release}
116
117%description -n compat32-%{name}-devel
118This package contains the static libraries, header files and
119documentation necessary for development of programs that will use the
120giflib library to load and save GIF format image files.
121
122You should install this package if you need to develop programs which
123will use giflib library functions.  You'll also need to install the
124giflib package.
125
126
127%prep
128%setup -q -n %{name}-%{version}
129
130
131%build
132CFLAGS="%{optflags} -fPIC" \
133LDFLAGS="%{?__global_ldflags}" \
134%make_build
135
136%install
137rm -rf $RPM_BUILD_ROOT
138%make_install PREFIX="%{_prefix}" LIBDIR="%{_libdir}"
139
140## remove unused files
141rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
142
143%post -p /sbin/ldconfig
144
145
146%postun -p /sbin/ldconfig
147
148
149%if %{build_compat32}
150%post -n compat32-%{name} -p /sbin/ldconfig
151%postun -n compat32-%{name} -p /sbin/ldconfig
152%endif
153
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158
159%files
160%defattr(-,root,root)
161%license COPYING
162%doc ChangeLog README NEWS
163%{_libdir}/lib*.so.*
164
165%files devel
166%defattr(-,root,root)
167%doc doc/*
168%{_libdir}/lib*.so
169%{_includedir}/*.h
170
171%files utils
172%defattr(-,root,root)
173%{_bindir}/*
174%{_mandir}/man1/*.1*
175
176## to build compat32 for x86_64 architecture support
177%if %{build_compat32}
178%files -n compat32-%{name}
179%defattr(-,root,root)
180%{_libdir}/lib*.so.*
181
182%files -n compat32-%{name}-devel
183%defattr(-,root,root)
184%{_libdir}/lib*.so
185%endif
186
187
188%changelog
189* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.1-1
190- new upstream release.
191
192* Sun Sep 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.3-1
193- new upstream release
194
195* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 4.1.6-4
196- rebuilt with rpm-4.8.1-3
197
198* Sat Feb 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.6-3
199- rebuild with new environment
200- remove static lib
201
202* Thu Aug 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.6-2
203- Obsolete specific version of libungif
204
205* Sun Jan 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.6-1
206- switch from the obsoleted libungif to the ongoing giflib
207  due to LZW's patent expiration which happend a few years ago
208
209* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.4-2vl5
210- removed *.la
211- spec in utf-8
212
213* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-1vl5
214- applied new versioning policy
215- updated URL
216
217* Sun Feb 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-0vl1
218- new upstream release
219
220* Sat Sep 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.3-3vl3
221- changed libungif-progs Group to Applications/Graphics
222
223* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.3-3vl2
224- added compat32-* packages for x86_64 architecture support
225
226* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.3-3vl1
227- new upstream release
228- not generate libungif.so.3* any more
229- fixed spec file based on 4.1.3-3 from Fedora development
230- s/Copyright/License/
231- updated URL
232
233* Fri Dec 13 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.0-13vl1
234- based on 4.1.0-13 from Rawhide
235  - Clean up spec file
236  - Fix build with current auto* tools
237
238* Sat Jul 14 2001 <sagami@vinelinux.org>
239- 4.1.0-9vl1
240- follow up with 4.1.0-9 which has a fix to build against new libtool
241
242* Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
243- 4.1.0-7vl2
244- build with netpbm
245
246* Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
247- 4.1.0-7vl1
248- based on 4.1.0-7 from Rawhide
249- added Japanese summary and description
250
251* Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
252- Make the subpackages require the base package (Bug #14697)
253- update URL
254- add fixes from the homepage
255
256* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
257- automatic rebuild
258
259* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
260- FHS adjustments (release 5)
261
262* Mon Feb 14 2000 Elliot Lee <sopwith@redhat.com> 4.1.0-4
263- Add giflibcvs-small2crash.patch, which changes lib/dgif_lib.c to be
264  whatever is currently in the libungif CVS, thus fixing bug number 9315.
265
266* Sat Feb  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
267- strip libraries
268- update URL
269- some specfile tweaks
270
271* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
272- auto rebuild in the new build environment (release 2)
273
274* Sun Mar 14 1999 Preston Brown <pbrown@redhat.com>
275- include libungif 4.1.0 as standard library, with 3.1.0 backwards compat.
276
277* Mon Jan 11 1999 Cristian Gafton <gafton@redhat.com>
278- build for 6.0
279- call libtoolize to make sure it will build on the arm
280
281* Sat Oct 31 1998 Jeff Johnson <jbj@redhat.com>
282- package for RH 5.2.
283
284* Mon Sep 14 1998 Arne Coucheron <arneco@online.no>
285  [3.1.0-3]
286- major cleanups and changes to the spec file
287
288* Mon Sep 7 1998 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
289- Upgrade to version 3.1.0 (which incorporates the patches in 3.0-4)
290- Updated Source: and URL: to reflect change in directories/pages.
291
292* Tue May 26 1998 Dick Porter <dick@cymru.net>
293- Fixed some "warning: cast to pointer from integer of different size" on Alpha
294
295* Tue May 5 1998 Marc Ewing <marc@redhat.com>
296- Made it obsolete giflib and provide libgif.so and giflib (previous
297  giflib packages were built incorrectly and packages built against
298  it require libgif.so but work fine with this package)
299- cleaned buildroot
300- Removed Toshio as packager so he doesn't get yelled at when Red Hat
301  breaks it :-)
302
303* Fri Apr 24 1998 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
304- Initial revision of libungif, a giflib derivative modified to not use LZW
305  compression.
Note: See TracBrowser for help on using the repository browser.