source: projects/specs/trunk/g/gettext/gettext-vl.spec @ 8181

Revision 8181, 12.4 KB checked in by kenta, 10 years ago (diff)
  • gettext
    • new upstream release
Line 
1%define libtoolize :
2
3%define src_ver 0.18.3.2
4%define so_ver 0.18.3
5
6Summary: GNU libraries and utilities for producing multi-lingual messages.
7Summary(ja): マルチリンガルメッセージを生成するためのGNU ライブラリ/ユーティリティ
8Name: gettext
9Version: %{src_ver}
10Release: 1%{?_dist_release}
11License: GPLv3 and LGPLv2+
12Group: Development/Tools
13Source: ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
14URL: http://www.gnu.org/software/gettext/
15Source2: msghack.py
16Source3: msghack.1
17
18# Patch5: gettext-0.17-open-args.patch
19# Patch6: gettext-0.17-autopoint-CVS-441481.patch
20# Patch7: gettext-0.17-rpathFix.patch
21# Patch8: gettext-xgettext-python-unicode-surrogate-473946.patch
22
23BuildRequires: libtool, bison, gcc-c++
24BuildRequires: expat-devel
25BuildRequires: libacl-devel, libcroco-devel
26
27Requires(post): /sbin/install-info
28Requires(preun): /sbin/install-info
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30
31Packager: daisuke
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36The GNU gettext package provides a set of tools and documentation for
37producing multi-lingual messages in programs.  Tools include a set of
38conventions about how programs should be written to support message
39catalogs, a directory and file naming organization for the message
40catalogs, a runtime library which supports the retrieval of translated
41messages, and stand-alone programs for handling the translatable and
42the already translated strings.  Gettext provides an easy to use
43library and tools for creating, using, and modifying natural language
44catalogs and is a powerful and simple method for internationalizing
45programs.
46
47%description -l ja
48GNU gettext パッケージはプログラム中でマルチリンガルメッセージを生成する
49ためのツールと文書を提供します. ツールはメッセージカタログをサポートするために
50プログラムがどのように書かれるべきかの申し合わせと, メッセージカタログのための
51ディレクトリとファイル名の組織化と, 翻訳されたメッセージの埋め合わせを
52サポートするためのランタイムライブラリと, 翻訳可能でかつすでに翻訳された文字列
53を取り扱う独立したプログラムを含みます. gettext は簡単に使えるライブラリ
54と自然言語のカタログを生成, 使用, 修正するツールと, 国際化プログラム
55のための強力かつシンプルな方法を提供します.
56
57%package devel
58Summary: Development files for gettext
59Summary(ja): gettext 用開発ファイル
60Group: Development/Tools
61License: LGPLv2+
62Requires: %{name} = %{version}-%{release}
63Requires: %{name}-libs = %{version}-%{release}
64Requires(post): /sbin/install-info
65Requires(preun): /sbin/install-info
66
67
68%description devel
69This package contains all development related files necessary for
70developing or compiling applications/libraries that needs
71internationalization capability. You also need this package if you
72want to add gettext support for your project.
73
74%description devel -l ja
75このパッケージには、マルチリンガル機能を持つアプリケーションや
76ライブラリを開発・コンパイルするのに必要な開発関連ファイルが収録
77されています。
78
79
80%package libs
81Summary: Libraries for gettext
82Summary(ja): gettext 用共有ライブラリ
83Group: System Environment/Libraries
84License: LGPLv2+
85
86
87%description libs
88This package contains libraries used internationalization support.
89
90%description libs -l ja
91このパッケージには国際化サポートに必要な共有ライブラリが収録されています。
92
93
94%prep
95%setup -q
96# %patch5 -p0 -b .5-open-args~
97# %patch6 -p0 -b .6-autopoint~
98# %patch7 -p0 -b .rpathFix~
99# %patch8 -p0 -b .unicode~
100
101
102%build
103## running autoreconf for automake-1.11.1
104autoreconf -fi
105[ -f  /usr/share/automake/depcomp ] && cp -f /usr/share/automake/{depcomp,ylwrap} . || :
106%configure --without-included-gettext --enable-nls \
107        --enable-shared --disable-static --with-pic=yes \
108        --disable-csharp --disable-java
109make %{?_smp_mflags}
110
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115# Fix busted no-emacs install for $lispdir/po-mode.el
116%makeinstall lispdir=%{buildroot}/usr/share/emacs/site-lisp \
117    aclocaldir=%{buildroot}/usr/share/aclocal
118
119# delete po-mode
120%{__rm} -rf %{buildroot}/usr/share/emacs/site-lisp
121
122mkdir -p %{buildroot}/bin
123mv %{buildroot}/%{_bindir}/gettext %{buildroot}/bin
124ln -s ../../bin/gettext %{buildroot}/%{_bindir}/gettext
125install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/%{_bindir}/msghack
126install -pm 644 %SOURCE3 ${RPM_BUILD_ROOT}/%{_mandir}/man1/msghack.1
127
128pushd %{buildroot}
129rm -f .%{_infodir}/dir .%{_includedir}/libintl.h
130popd
131
132%find_lang %{name}-runtime
133%find_lang %{name}-tools
134cat %{name}-*.lang > %{name}.lang
135
136# remove unpackaged files from the buildroot
137rm -rf $RPM_BUILD_ROOT/usr/share/doc
138rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
139rm -f $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
140
141%__rm -rf %{buildroot}%{_docdir}/%{name}
142
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147
148%post
149/sbin/ldconfig
150/sbin/install-info %{_infodir}/gettext.info.gz %{_infodir}/dir || :
151
152
153%preun
154if [ "$1" = 0 ]; then
155    /sbin/install-info --delete %{_infodir}/gettext.info.gz %{_infodir}/dir || :
156fi
157exit 0
158
159%postun -p /sbin/ldconfig
160
161
162%post devel
163/sbin/ldconfig
164/sbin/install-info %{_infodir}/autosprintf.info %{_infodir}/dir || :
165
166%preun devel
167if [ "$1" = 0 ]; then
168    /sbin/install-info --delete %{_infodir}/autosprintf.info %{_infodir}/dir || :
169fi
170
171%postun devel -p /sbin/ldconfig
172
173
174%post libs -p /sbin/ldconfig
175%postun libs -p /sbin/ldconfig
176
177
178%files -f gettext.lang
179%defattr(-,root,root,-)
180%doc gettext-runtime/ABOUT-NLS AUTHORS gettext-runtime/BUGS
181%doc COPYING ChangeLog gettext-tools/misc/DISCLAIM README
182%doc NEWS THANKS
183%doc gettext-runtime/man/*.1.html
184%doc gettext-runtime/intl/COPYING*
185/bin/*
186%{_bindir}/*
187%{_libdir}/libgettextlib-%{so_ver}.so
188%{_libdir}/libgettextsrc-%{so_ver}.so
189%{_infodir}/gettext*
190%{_mandir}/man1/*
191%{_libdir}/gettext
192%{_datadir}/gettext/archive.dir.tar.xz
193%{_datadir}/gettext/styles
194
195%files devel
196%defattr(-,root,root,-)
197%doc gettext-runtime/man/*.3.html ChangeLog
198%{_datadir}/gettext/ABOUT-NLS
199%{_datadir}/gettext/projects/
200%{_datadir}/gettext/config.rpath
201%{_datadir}/gettext/*.h
202%{_datadir}/gettext/intl
203%{_datadir}/gettext/po
204%{_datadir}/gettext/msgunfmt.tcl
205%{_datadir}/aclocal/*
206%{_includedir}/*
207%{_infodir}/autosprintf*
208%{_libdir}/libasprintf.so
209%{_libdir}/libgettextpo.so
210%{_libdir}/libgettextlib.so
211%{_libdir}/libgettextsrc.so
212%{_libdir}/preloadable_libintl.so
213%{_mandir}/man3/*
214%{_datadir}/%{name}/javaversion.class
215%doc gettext-runtime/intl-java/javadoc*
216
217
218%files libs
219%defattr(-,root,root,-)
220
221%{_libdir}/libasprintf.so.*
222%{_libdir}/libgettextpo.so.*
223
224
225%changelog
226* Tue Jan 14 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 0.18.3.2-1
227- new upstream release
228
229* Sun Jul 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.3-1
230- new upstream release
231
232* Thu Mar 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.2.1-1
233- new upstream release
234
235* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 0.18.1.1-1
236- new upstream release
237- drop old patches
238- update msghack.py from fc14
239- add BRs: libacl-devel, libcroco-devel
240- fix files list
241
242* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
243- split to po-mode package: [VineSeed:20076]
244- update Packager value: update format
245- running autoreconf for automake-1.11.1 in %%build
246
247* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
248- correct some output messages on po-mode-install.sh
249- use %%emacsen_pkgdir
250
251* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
252- we better not to use BuildConflicts very often :-P
253  instead we pass --disable-java to configure here
254- add --enable-shared --disable-static --without-included-gettext to configure
255- remove .la files
256- add -devel and --libs subpackages
257
258* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
259- apply vine-default
260  - update po-mode-init.el (Source1)
261  - update po-mode-install.sh (Source3)
262  - update po-mode-remove.sh (Source4)
263  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
264- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
265
266* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
267- new upstream release
268
269* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
270- applied new versioning policy, spec in utf-8
271
272* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
273- changelog update missing
274
275* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
276- new upstream release
277
278* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
279- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
280
281* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
282- add BuildConflicts: libgcj34-devel not to depend on libgcj34
283
284* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
285- add BuildConflicts: libgcj-devel not to depend on libgcj
286- add BuildRequires: emacsen (if emacsen_pkg is enabled)
287- remove unneeded files at the %%install
288
289* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
290- rebuilt without libgcj package
291
292* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
293- modified emacsen-common path
294
295* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
296- new upstream release
297- updated Source3
298- added --disable-csharp
299
300* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
301- remove dependency to libgcj
302
303* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
304- new upstream release
305
306* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
307- build without libgcj package
308- create po-mode package for Emacsen
309
310* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
311- based on Redhat Rawhide 0.12.1-1
312- dropped all patches (Rawhide does so)
313- Source100(ja.po) is much older than source, dropped
314- s/Copyright/License/
315
316* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
317- new upstream release
318
319* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
320- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
321
322* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
323- sync with RH6.2
324
325* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
326- minor configure tweaks for ia64
327
328* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
329- add --comments to msghack
330
331* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
332- fix bug #9240 - gettextize has the right aclocal patch
333
334* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
335- add the --diff and --dummy options
336
337* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
338- add the --missing option to msghack
339
340* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
341- updated msghack not to merge in fuzzies in the master catalogs
342
343* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
344- update ja.po
345
346* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
347- use message.c.diff-2
348
349* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
350- updated msghack to understand --append
351
352* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
353- updated msghack to correctly deal with sorting files
354
355* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
356- added multibyte patch for msgmerge
357
358* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
359- ja locale support from JaPO Project
360
361* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
362- msghack updates
363
364* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
365- auto rebuild in the new build environment (release 8)
366
367* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
368- added patch for misc hacks to facilitate rpm translations
369
370* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
371- patch to allow to build on ARM
372
373* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
374- add Emacs po-mode.el files.
375
376* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
377- include the aclocal support files
378
379* Fri Sep  4 1998 Bill Nottingham <notting@redhat.com>
380- remove devel package (functionality is in glibc)
381
382* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
383- update to 0.10.35.
384
385* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
386- add gettextize.
387- create devel package for libintl.a and libgettext.h.
388
389* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
390- translations modified for de, fr, tr
391
392* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
393- added info handling
394- added misc-patch (skip emacs-lisp modofications)
395
396* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
397- removed locale.aliases as we get it from glibc now
398- uses a buildroot
399
400* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
401- Built against glibc
Note: See TracBrowser for help on using the repository browser.