source: projects/specs/trunk/g/gettext/gettext-vl.spec @ 12485

Revision 12485, 14.4 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

ethtool-5.8-1

gettext-0.21-1

rsync-3.2.3-1

squid-4.13-1

Line 
1%define libtoolize :
2
3%define src_ver 0.21
4%define so_ver 0.21
5%define short_ver 0.21
6
7Summary: GNU libraries and utilities for producing multi-lingual messages.
8Summary(ja): マルチリンガルメッセージを生成するためのGNU ライブラリ/ユーティリティ
9Name: gettext
10Version: %{src_ver}
11Release: 1%{?_dist_release}
12Group: programming
13Packager: daisuke
14Vendor: Project Vine
15Distribution: Vine Linux
16
17License: GPLv3+ and LGPLv2+ and GFDL
18Source: https://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.xz
19URL: http://www.gnu.org/software/gettext/
20Source2: msghack.py
21Source3: msghack.1
22
23Patch1: gettext-msgmerge-for-msgfmt.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27BuildRequires: libtool, bison, gcc-c++
28# following suggested by DEPENDENCIES:
29BuildRequires: ncurses-devel
30BuildRequires: libxml2-devel
31BuildRequires: glib2-devel
32BuildRequires: libacl-devel
33BuildRequires: libunistring-devel
34# ensure 'ARCHIVE_FORMAT=dirxz'
35BuildRequires: xz
36
37Requires(post): /sbin/install-info
38Requires(preun): /sbin/install-info
39
40%description
41The GNU gettext package provides a set of tools and documentation for
42producing multi-lingual messages in programs.  Tools include a set of
43conventions about how programs should be written to support message
44catalogs, a directory and file naming organization for the message
45catalogs, a runtime library which supports the retrieval of translated
46messages, and stand-alone programs for handling the translatable and
47the already translated strings.  Gettext provides an easy to use
48library and tools for creating, using, and modifying natural language
49catalogs and is a powerful and simple method for internationalizing
50programs.
51
52%description -l ja
53GNU gettext パッケージはプログラム中でマルチリンガルメッセージを生成する
54ためのツールと文書を提供します. ツールはメッセージカタログをサポートするために
55プログラムがどのように書かれるべきかの申し合わせと, メッセージカタログのための
56ディレクトリとファイル名の組織化と, 翻訳されたメッセージの埋め合わせを
57サポートするためのランタイムライブラリと, 翻訳可能でかつすでに翻訳された文字列
58を取り扱う独立したプログラムを含みます. gettext は簡単に使えるライブラリ
59と自然言語のカタログを生成, 使用, 修正するツールと, 国際化プログラム
60のための強力かつシンプルな方法を提供します.
61
62
63%package devel
64Summary: Development files for gettext
65Summary(ja): gettext 用開発ファイル
66Group: programming
67# autopoint is GPLv3+
68# libasprintf is LGPLv2+
69# libgettextpo is GPLv3+
70License: LGPLv2+ and GPLv3+ and GFDL
71Requires: %{name} = %{version}-%{release}
72Requires: %{name}-libs = %{version}-%{release}
73Requires: xz
74Requires: diffutils
75Requires(post): /sbin/install-info
76Requires(preun): /sbin/install-info
77
78%description devel
79This package contains all development related files necessary for
80developing or compiling applications/libraries that needs
81internationalization capability. You also need this package if you
82want to add gettext support for your project.
83
84%description devel -l ja
85このパッケージには、マルチリンガル機能を持つアプリケーションや
86ライブラリを開発・コンパイルするのに必要な開発関連ファイルが収録
87されています。
88
89
90%package libs
91Summary: Libraries for gettext
92Summary(ja): gettext 用共有ライブラリ
93Group: system
94# libasprintf is LGPLv2+
95# libgettextpo is GPLv3+
96License: LGPLv2+ and GPLv3+
97
98%description libs
99This package contains libraries used internationalization support.
100
101%description libs -l ja
102このパッケージには国際化サポートに必要な共有ライブラリが収録されています。
103
104
105%prep
106%setup -q
107
108# Defeat libtextstyle attempt to bundle libxml2.  The comments
109# indicate this is done because the libtextstyle authors do not want
110# applications using their code to suffer startup delays due to the
111# relocations.  This is not a sufficient reason for Fedora.
112sed -e 's/\(gl_cv_libxml_force_included=\)yes/\1no/' \
113    -i libtextstyle/configure
114
115
116%build
117## running autoreconf for automake-1.11.1
118autoreconf -fi
119[ -f  /usr/share/automake/depcomp ] && cp -f /usr/share/automake/{depcomp,ylwrap} . || :
120
121# libxml2-devel package has an extra "libxml2" path component.
122export CPPFLAGS="-I%{_includedir}/libxml2"
123# Side effect of unbundling libxml2 from libtextstyle.
124export LIBS="-lxml2"
125
126%configure --without-included-gettext --enable-nls \
127        --enable-shared --disable-static --disable-rpath \
128        --with-pic=yes \
129        --disable-csharp --disable-java \
130    --with-xz
131
132# Eliminate hardcoded rpaths; workaround libtool reordering -Wl,--as-needed
133# after all the libraries.
134sed -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
135    -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
136    -e 's|CC=.g..|& -Wl,--as-needed|' \
137    -i $(find . -name libtool)
138
139make %{?_smp_mflags}
140
141
142%install
143rm -rf $RPM_BUILD_ROOT
144
145# Fix busted no-emacs install for $lispdir/po-mode.el
146%makeinstall lispdir=%{buildroot}/usr/share/emacs/site-lisp \
147    aclocaldir=%{buildroot}/usr/share/aclocal
148
149# delete po-mode
150%{__rm} -rf %{buildroot}/usr/share/emacs/site-lisp
151
152mkdir -p %{buildroot}/bin
153mv %{buildroot}/%{_bindir}/gettext %{buildroot}/bin
154ln -s ../../bin/gettext %{buildroot}/%{_bindir}/gettext
155install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/%{_bindir}/msghack
156install -pm 644 %SOURCE3 ${RPM_BUILD_ROOT}/%{_mandir}/man1/msghack.1
157
158pushd %{buildroot}
159rm -f .%{_infodir}/dir .%{_includedir}/libintl.h
160popd
161
162%find_lang %{name}-runtime
163%find_lang %{name}-tools
164cat %{name}-*.lang > %{name}.lang
165
166# remove unpackaged files from the buildroot
167rm -rf $RPM_BUILD_ROOT/usr/share/doc
168rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
169rm -f $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
170
171%__rm -rf %{buildroot}%{_docdir}/%{name}
172
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177
178%post
179/sbin/ldconfig
180/sbin/install-info %{_infodir}/gettext.info.gz %{_infodir}/dir || :
181
182
183%preun
184if [ "$1" = 0 ]; then
185    /sbin/install-info --delete %{_infodir}/gettext.info.gz %{_infodir}/dir || :
186fi
187exit 0
188
189%postun -p /sbin/ldconfig
190
191
192%post devel
193/sbin/ldconfig
194/sbin/install-info %{_infodir}/autosprintf.info %{_infodir}/dir || :
195/sbin/install-info %{_infodir}/libtextstyle.info %{_infodir}/dir || :
196
197%preun devel
198if [ "$1" = 0 ]; then
199    /sbin/install-info --delete %{_infodir}/autosprintf.info %{_infodir}/dir || :
200    /sbin/install-info --delete %{_infodir}/libtextstyle.info %{_infodir}/dir || :
201fi
202
203%postun devel -p /sbin/ldconfig
204
205
206%post libs -p /sbin/ldconfig
207%postun libs -p /sbin/ldconfig
208
209
210%files -f gettext.lang
211%defattr(-,root,root,-)
212%license COPYING
213%doc gettext-runtime/ABOUT-NLS AUTHORS gettext-runtime/BUGS
214%doc ChangeLog* gettext-tools/misc/DISCLAIM README
215%doc NEWS THANKS
216%doc gettext-runtime/man/*.1.html
217%doc gettext-runtime/intl/COPYING*
218/bin/*
219%{_bindir}/*
220%{_libdir}/libgettextlib-%{so_ver}.so
221%{_libdir}/libgettextsrc-%{so_ver}.so
222%{_infodir}/gettext*
223%{_mandir}/man1/*
224%{_libdir}/gettext
225%{_datadir}/gettext/archive.dir.tar.xz
226%{_datadir}/gettext/styles
227%{_datadir}/gettext-%{short_ver}
228
229%files devel
230%defattr(-,root,root,-)
231%doc gettext-runtime/man/*.3.html ChangeLog
232%{_datadir}/gettext/ABOUT-NLS
233%{_datadir}/gettext/projects/
234%{_datadir}/gettext/config.rpath
235%{_datadir}/gettext/*.h
236%{_datadir}/gettext/po
237%{_datadir}/gettext/msgunfmt.tcl
238%{_datadir}/aclocal/*
239%{_includedir}/*
240%{_infodir}/autosprintf*
241%{_infodir}/libtextstyle*
242%{_libdir}/libasprintf.so
243%{_libdir}/libgettextpo.so
244%{_libdir}/libgettextlib.so
245%{_libdir}/libgettextsrc.so
246%{_libdir}/libtextstyle.so
247%{_libdir}/preloadable_libintl.so
248%{_mandir}/man3/*
249%{_datadir}/%{name}/javaversion.class
250%doc gettext-runtime/intl-java/javadoc*
251
252
253%files libs
254%defattr(-,root,root,-)
255%{_libdir}/libasprintf.so.*
256%{_libdir}/libgettextpo.so.*
257%{_libdir}/libtextstyle.so.*
258
259
260%changelog
261* Sun Sep 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.21-1
262- new upstream release.
263- updated Source2 and 3 for python3.
264- dropped Patch1.
265
266* Tue Sep 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.20.1-2
267- moved libtextstyle.so.* to gettext-libs.
268
269* Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.20.1-1
270- new upstream release.
271- imported Patch1 from rawhide.
272
273* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.19.8.1-2
274- rebuild with gcc-5.4.0
275
276* Wed Jun 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.19.8.1-1
277- new upstream release
278
279* Thu May 19 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.19.7-1
280- new upstream release
281
282* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.19.6-1
283- new upstream release
284
285* Sun Nov  2 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.18.3.2-2
286- moved devel package to Development/Libraries Group
287
288* Tue Jan 14 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 0.18.3.2-1
289- new upstream release
290
291* Sun Jul 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.3-1
292- new upstream release
293
294* Thu Mar 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.2.1-1
295- new upstream release
296
297* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 0.18.1.1-1
298- new upstream release
299- drop old patches
300- update msghack.py from fc14
301- add BRs: libacl-devel, libcroco-devel
302- fix files list
303
304* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
305- split to po-mode package: [VineSeed:20076]
306- update Packager value: update format
307- running autoreconf for automake-1.11.1 in %%build
308
309* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
310- correct some output messages on po-mode-install.sh
311- use %%emacsen_pkgdir
312
313* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
314- we better not to use BuildConflicts very often :-P
315  instead we pass --disable-java to configure here
316- add --enable-shared --disable-static --without-included-gettext to configure
317- remove .la files
318- add -devel and --libs subpackages
319
320* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
321- apply vine-default
322  - update po-mode-init.el (Source1)
323  - update po-mode-install.sh (Source3)
324  - update po-mode-remove.sh (Source4)
325  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
326- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
327
328* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
329- new upstream release
330
331* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
332- applied new versioning policy, spec in utf-8
333
334* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
335- changelog update missing
336
337* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
338- new upstream release
339
340* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
341- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
342
343* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
344- add BuildConflicts: libgcj34-devel not to depend on libgcj34
345
346* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
347- add BuildConflicts: libgcj-devel not to depend on libgcj
348- add BuildRequires: emacsen (if emacsen_pkg is enabled)
349- remove unneeded files at the %%install
350
351* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
352- rebuilt without libgcj package
353
354* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
355- modified emacsen-common path
356
357* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
358- new upstream release
359- updated Source3
360- added --disable-csharp
361
362* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
363- remove dependency to libgcj
364
365* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
366- new upstream release
367
368* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
369- build without libgcj package
370- create po-mode package for Emacsen
371
372* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
373- based on Redhat Rawhide 0.12.1-1
374- dropped all patches (Rawhide does so)
375- Source100(ja.po) is much older than source, dropped
376- s/Copyright/License/
377
378* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
379- new upstream release
380
381* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
382- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
383
384* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
385- sync with RH6.2
386
387* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
388- minor configure tweaks for ia64
389
390* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
391- add --comments to msghack
392
393* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
394- fix bug #9240 - gettextize has the right aclocal patch
395
396* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
397- add the --diff and --dummy options
398
399* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
400- add the --missing option to msghack
401
402* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
403- updated msghack not to merge in fuzzies in the master catalogs
404
405* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
406- update ja.po
407
408* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
409- use message.c.diff-2
410
411* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
412- updated msghack to understand --append
413
414* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
415- updated msghack to correctly deal with sorting files
416
417* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
418- added multibyte patch for msgmerge
419
420* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
421- ja locale support from JaPO Project
422
423* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
424- msghack updates
425
426* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
427- auto rebuild in the new build environment (release 8)
428
429* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
430- added patch for misc hacks to facilitate rpm translations
431
432* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
433- patch to allow to build on ARM
434
435* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
436- add Emacs po-mode.el files.
437
438* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
439- include the aclocal support files
440
441* Fri Sep  4 1998 Bill Nottingham <notting@redhat.com>
442- remove devel package (functionality is in glibc)
443
444* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
445- update to 0.10.35.
446
447* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
448- add gettextize.
449- create devel package for libintl.a and libgettext.h.
450
451* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
452- translations modified for de, fr, tr
453
454* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
455- added info handling
456- added misc-patch (skip emacs-lisp modofications)
457
458* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
459- removed locale.aliases as we get it from glibc now
460- uses a buildroot
461
462* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
463- Built against glibc
Note: See TracBrowser for help on using the repository browser.