source: projects/specs/trunk/g/gettext/gettext-vl.spec @ 12217

Revision 12217, 13.1 KB checked in by tomop, 5 years ago (diff)

gettext-0.20.1-2

Line 
1%define libtoolize :
2
3%define src_ver 0.20.1
4%define so_ver 0.20.1
5%define short_ver 0.20
6
7Summary: GNU libraries and utilities for producing multi-lingual messages.
8Summary(ja): マルチリンガルメッセージを生成するためのGNU ライブラリ/ユーティリティ
9Name: gettext
10Version: %{src_ver}
11Release: 2%{?_dist_release}
12License: GPLv3 and LGPLv2+
13Group: Development/Tools
14Source: ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.xz
15URL: http://www.gnu.org/software/gettext/
16Source2: msghack.py
17Source3: msghack.1
18
19Patch1: gettext-msgmerge-for-msgfmt.patch
20
21BuildRequires: libtool, bison, gcc-c++
22BuildRequires: expat-devel
23BuildRequires: libacl-devel, libcroco-devel
24
25Requires(post): /sbin/install-info
26Requires(preun): /sbin/install-info
27Buildroot: %{_tmppath}/%{name}-%{version}-root
28
29Packager: daisuke
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34The GNU gettext package provides a set of tools and documentation for
35producing multi-lingual messages in programs.  Tools include a set of
36conventions about how programs should be written to support message
37catalogs, a directory and file naming organization for the message
38catalogs, a runtime library which supports the retrieval of translated
39messages, and stand-alone programs for handling the translatable and
40the already translated strings.  Gettext provides an easy to use
41library and tools for creating, using, and modifying natural language
42catalogs and is a powerful and simple method for internationalizing
43programs.
44
45%description -l ja
46GNU gettext パッケージはプログラム中でマルチリンガルメッセージを生成する
47ためのツールと文書を提供します. ツールはメッセージカタログをサポートするために
48プログラムがどのように書かれるべきかの申し合わせと, メッセージカタログのための
49ディレクトリとファイル名の組織化と, 翻訳されたメッセージの埋め合わせを
50サポートするためのランタイムライブラリと, 翻訳可能でかつすでに翻訳された文字列
51を取り扱う独立したプログラムを含みます. gettext は簡単に使えるライブラリ
52と自然言語のカタログを生成, 使用, 修正するツールと, 国際化プログラム
53のための強力かつシンプルな方法を提供します.
54
55%package devel
56Summary: Development files for gettext
57Summary(ja): gettext 用開発ファイル
58Group: Development/Libraries
59License: LGPLv2+
60Requires: %{name} = %{version}-%{release}
61Requires: %{name}-libs = %{version}-%{release}
62Requires(post): /sbin/install-info
63Requires(preun): /sbin/install-info
64
65
66%description devel
67This package contains all development related files necessary for
68developing or compiling applications/libraries that needs
69internationalization capability. You also need this package if you
70want to add gettext support for your project.
71
72%description devel -l ja
73このパッケージには、マルチリンガル機能を持つアプリケーションや
74ライブラリを開発・コンパイルするのに必要な開発関連ファイルが収録
75されています。
76
77
78%package libs
79Summary: Libraries for gettext
80Summary(ja): gettext 用共有ライブラリ
81Group: System Environment/Libraries
82License: LGPLv2+
83
84
85%description libs
86This package contains libraries used internationalization support.
87
88%description libs -l ja
89このパッケージには国際化サポートに必要な共有ライブラリが収録されています。
90
91
92%prep
93%setup -q
94%patch1 -p1
95
96
97%build
98## running autoreconf for automake-1.11.1
99autoreconf -fi
100[ -f  /usr/share/automake/depcomp ] && cp -f /usr/share/automake/{depcomp,ylwrap} . || :
101%configure --without-included-gettext --enable-nls \
102        --enable-shared --disable-static --with-pic=yes \
103        --disable-csharp --disable-java
104make %{?_smp_mflags}
105
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110# Fix busted no-emacs install for $lispdir/po-mode.el
111%makeinstall lispdir=%{buildroot}/usr/share/emacs/site-lisp \
112    aclocaldir=%{buildroot}/usr/share/aclocal
113
114# delete po-mode
115%{__rm} -rf %{buildroot}/usr/share/emacs/site-lisp
116
117mkdir -p %{buildroot}/bin
118mv %{buildroot}/%{_bindir}/gettext %{buildroot}/bin
119ln -s ../../bin/gettext %{buildroot}/%{_bindir}/gettext
120install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/%{_bindir}/msghack
121install -pm 644 %SOURCE3 ${RPM_BUILD_ROOT}/%{_mandir}/man1/msghack.1
122
123pushd %{buildroot}
124rm -f .%{_infodir}/dir .%{_includedir}/libintl.h
125popd
126
127%find_lang %{name}-runtime
128%find_lang %{name}-tools
129cat %{name}-*.lang > %{name}.lang
130
131# remove unpackaged files from the buildroot
132rm -rf $RPM_BUILD_ROOT/usr/share/doc
133rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
134rm -f $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
135
136%__rm -rf %{buildroot}%{_docdir}/%{name}
137
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142
143%post
144/sbin/ldconfig
145/sbin/install-info %{_infodir}/gettext.info.gz %{_infodir}/dir || :
146
147
148%preun
149if [ "$1" = 0 ]; then
150    /sbin/install-info --delete %{_infodir}/gettext.info.gz %{_infodir}/dir || :
151fi
152exit 0
153
154%postun -p /sbin/ldconfig
155
156
157%post devel
158/sbin/ldconfig
159/sbin/install-info %{_infodir}/autosprintf.info %{_infodir}/dir || :
160/sbin/install-info %{_infodir}/libtextstyle.info %{_infodir}/dir || :
161
162%preun devel
163if [ "$1" = 0 ]; then
164    /sbin/install-info --delete %{_infodir}/autosprintf.info %{_infodir}/dir || :
165    /sbin/install-info --delete %{_infodir}/libtextstyle.info %{_infodir}/dir || :
166fi
167
168%postun devel -p /sbin/ldconfig
169
170
171%post libs -p /sbin/ldconfig
172%postun libs -p /sbin/ldconfig
173
174
175%files -f gettext.lang
176%defattr(-,root,root,-)
177%license COPYING
178%doc gettext-runtime/ABOUT-NLS AUTHORS gettext-runtime/BUGS
179%doc ChangeLog* gettext-tools/misc/DISCLAIM README
180%doc NEWS THANKS
181%doc gettext-runtime/man/*.1.html
182%doc gettext-runtime/intl/COPYING*
183/bin/*
184%{_bindir}/*
185%{_libdir}/libgettextlib-%{so_ver}.so
186%{_libdir}/libgettextsrc-%{so_ver}.so
187%{_infodir}/gettext*
188%{_mandir}/man1/*
189%{_libdir}/gettext
190%{_datadir}/gettext/archive.dir.tar.xz
191%{_datadir}/gettext/styles
192%{_datadir}/gettext-%{short_ver}
193
194%files devel
195%defattr(-,root,root,-)
196%doc gettext-runtime/man/*.3.html ChangeLog
197%{_datadir}/gettext/ABOUT-NLS
198%{_datadir}/gettext/projects/
199%{_datadir}/gettext/config.rpath
200%{_datadir}/gettext/*.h
201%{_datadir}/gettext/po
202%{_datadir}/gettext/msgunfmt.tcl
203%{_datadir}/aclocal/*
204%{_includedir}/*
205%{_infodir}/autosprintf*
206%{_infodir}/libtextstyle*
207%{_libdir}/libasprintf.so
208%{_libdir}/libgettextpo.so
209%{_libdir}/libgettextlib.so
210%{_libdir}/libgettextsrc.so
211%{_libdir}/libtextstyle.so
212%{_libdir}/preloadable_libintl.so
213%{_mandir}/man3/*
214%{_datadir}/%{name}/javaversion.class
215%doc gettext-runtime/intl-java/javadoc*
216
217
218%files libs
219%defattr(-,root,root,-)
220%{_libdir}/libasprintf.so.*
221%{_libdir}/libgettextpo.so.*
222%{_libdir}/libtextstyle.so.*
223
224
225%changelog
226* Tue Sep 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.20.1-2
227- moved libtextstyle.so.* to gettext-libs.
228
229* Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.20.1-1
230- new upstream release.
231- imported Patch1 from rawhide.
232
233* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.19.8.1-2
234- rebuild with gcc-5.4.0
235
236* Wed Jun 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.19.8.1-1
237- new upstream release
238
239* Thu May 19 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.19.7-1
240- new upstream release
241
242* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.19.6-1
243- new upstream release
244
245* Sun Nov  2 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.18.3.2-2
246- moved devel package to Development/Libraries Group
247
248* Tue Jan 14 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 0.18.3.2-1
249- new upstream release
250
251* Sun Jul 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.3-1
252- new upstream release
253
254* Thu Mar 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.2.1-1
255- new upstream release
256
257* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 0.18.1.1-1
258- new upstream release
259- drop old patches
260- update msghack.py from fc14
261- add BRs: libacl-devel, libcroco-devel
262- fix files list
263
264* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
265- split to po-mode package: [VineSeed:20076]
266- update Packager value: update format
267- running autoreconf for automake-1.11.1 in %%build
268
269* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
270- correct some output messages on po-mode-install.sh
271- use %%emacsen_pkgdir
272
273* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
274- we better not to use BuildConflicts very often :-P
275  instead we pass --disable-java to configure here
276- add --enable-shared --disable-static --without-included-gettext to configure
277- remove .la files
278- add -devel and --libs subpackages
279
280* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
281- apply vine-default
282  - update po-mode-init.el (Source1)
283  - update po-mode-install.sh (Source3)
284  - update po-mode-remove.sh (Source4)
285  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
286- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
287
288* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
289- new upstream release
290
291* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
292- applied new versioning policy, spec in utf-8
293
294* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
295- changelog update missing
296
297* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
298- new upstream release
299
300* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
301- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
302
303* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
304- add BuildConflicts: libgcj34-devel not to depend on libgcj34
305
306* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
307- add BuildConflicts: libgcj-devel not to depend on libgcj
308- add BuildRequires: emacsen (if emacsen_pkg is enabled)
309- remove unneeded files at the %%install
310
311* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
312- rebuilt without libgcj package
313
314* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
315- modified emacsen-common path
316
317* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
318- new upstream release
319- updated Source3
320- added --disable-csharp
321
322* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
323- remove dependency to libgcj
324
325* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
326- new upstream release
327
328* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
329- build without libgcj package
330- create po-mode package for Emacsen
331
332* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
333- based on Redhat Rawhide 0.12.1-1
334- dropped all patches (Rawhide does so)
335- Source100(ja.po) is much older than source, dropped
336- s/Copyright/License/
337
338* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
339- new upstream release
340
341* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
342- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
343
344* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
345- sync with RH6.2
346
347* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
348- minor configure tweaks for ia64
349
350* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
351- add --comments to msghack
352
353* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
354- fix bug #9240 - gettextize has the right aclocal patch
355
356* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
357- add the --diff and --dummy options
358
359* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
360- add the --missing option to msghack
361
362* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
363- updated msghack not to merge in fuzzies in the master catalogs
364
365* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
366- update ja.po
367
368* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
369- use message.c.diff-2
370
371* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
372- updated msghack to understand --append
373
374* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
375- updated msghack to correctly deal with sorting files
376
377* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
378- added multibyte patch for msgmerge
379
380* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
381- ja locale support from JaPO Project
382
383* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
384- msghack updates
385
386* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
387- auto rebuild in the new build environment (release 8)
388
389* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
390- added patch for misc hacks to facilitate rpm translations
391
392* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
393- patch to allow to build on ARM
394
395* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
396- add Emacs po-mode.el files.
397
398* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
399- include the aclocal support files
400
401* Fri Sep  4 1998 Bill Nottingham <notting@redhat.com>
402- remove devel package (functionality is in glibc)
403
404* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
405- update to 0.10.35.
406
407* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
408- add gettextize.
409- create devel package for libintl.a and libgettext.h.
410
411* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
412- translations modified for de, fr, tr
413
414* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
415- added info handling
416- added misc-patch (skip emacs-lisp modofications)
417
418* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
419- removed locale.aliases as we get it from glibc now
420- uses a buildroot
421
422* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
423- Built against glibc
Note: See TracBrowser for help on using the repository browser.