source: projects/specs/trunk/g/gegl/gegl-vl.spec @ 8084

Revision 8084, 4.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define VER 0.2
2
3Summary:        A graph based image processing framework
4Summary(ja):    グラフベースの画像処理フレームワーク
5Name:           gegl
6Version:        0.2.0
7Release:        2%{?_dist_release}
8# The binary is under the GPL, while the libs are under LGPL
9License:        LGPLv3+ and GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gegl.org/
12Source0:        ftp://ftp.gtk.org/pub/gegl/%{VER}/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires:  babl-devel >= 0.1.10
16BuildRequires:  glib2-devel
17BuildRequires:  gdk-pixbuf2-devel
18BuildRequires:  pango-devel
19BuildRequires:  ruby
20BuildRequires:  libpng-devel
21BuildRequires:  libjpeg-devel
22BuildRequires:  librsvg2-devel
23BuildRequires:  perl
24BuildRequires:  SDL-devel
25BuildRequires:  OpenEXR-devel
26BuildRequires:  lua-devel
27BuildRequires:  asciidoc
28BuildRequires:  enscript
29BuildRequires:  w3m
30BuildRequires:  graphviz
31BuildRequires:  pkgconfig
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37GEGL (Generic Graphics Library) is a graph based image processing framework.
38GEGLs original design was made to scratch GIMPs itches for a new
39compositing and processing core. This core is being designed to have
40minimal dependencies. and a simple well defined API.
41
42%package devel
43Summary:        Development files for %{name}
44Summary(ja):    %{name} の開発ファイル
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
47Requires:       pkgconfig babl-devel glib2-devel
48
49%description devel
50This package contains the libraries and header files needed for
51developing with %{name}.
52
53%prep
54%setup -q
55
56chmod -x operations/external/ff-load.c operations/common/perlin/perlin.*
57
58%build
59# Needed by Ruby 1.9.3.
60export LANG=en_US.utf8
61
62%ifnarch ppc64
63%configure --disable-static --enable-workshop
64%else
65%configure --disable-static --enable-workshop --disable-docs
66%endif
67make %{?_smp_mflags}
68
69%install
70rm -rf %{buildroot}
71make DESTDIR=%{buildroot} install INSTALL='install -p'
72
73rm -f %{buildroot}%{_libdir}/*.la
74
75%find_lang %{name}-%{VER}
76
77%check
78make check
79
80%clean
81rm -rf %{buildroot}
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87%files -f %{name}-%{VER}.lang
88%defattr(-, root, root, -)
89%doc AUTHORS ChangeLog COPYING COPYING.LESSER NEWS README
90%{_bindir}/gegl
91%{_libdir}/*.so.*
92%{_libdir}/gegl-%{VER}
93
94%files devel
95%defattr(-, root, root, -)
96%ifnarch ppc64
97%doc %{_datadir}/gtk-doc/html/%{name}
98%endif
99%{_includedir}/gegl-%{VER}
100%{_libdir}/*.so
101%{_libdir}/pkgconfig/%{name}-%{VER}.pc
102
103%changelog
104* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-2
105- rebuild with VineSeed environment
106
107* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-1
108- new upstream release
109- remove old patches
110
111* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.6-1
112- new upstream release
113- update patches
114
115* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.1.2-2
116- rebuilt with rpm-4.8.1-3
117
118* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.2-1
119- new upstream release
120- add Patch0 and Patch1 from FC package
121
122* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  0.0.20-1
123- initial build for Vine Linux
124
125* Thu Jul 10 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.18-1
126- Update to latest release
127
128* Thu Feb 28 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.16-1
129- New release
130
131* Thu Jan 17 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.15-1.svn20080117
132- Update to a svn snapshot for gnome-scan
133- Apply patch to fix extensions loading on 64bit systems
134- Building the docs on ppc64 segfaults, avoid it for now.
135
136* Sat Dec 08 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.14-1
137- Update to 0.0.14 release
138- License change from GPLv2+ to GPLv3+
139
140* Thu Oct 25 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.7.20071011svn
141- Include missing requires for the devel subpackage
142
143* Thu Oct 25 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.6.20071011svn
144- BR graphiz instead of graphiz-devel
145- Remove the spurious exec flag from a couple of source codes
146
147* Tue Oct 23 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.5.20071011svn
148- Fix missing directory ownership
149
150* Mon Oct 22 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.4.20071011svn
151- Update the License field
152
153* Fri Oct 12 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.3.20071011svn
154- Package the extension libraries in the main package
155- Run 'make check'
156
157* Fri Oct 12 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.2.20071011svn
158- Remove the use of inexistent source
159
160* Thu Oct 11 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.1.20071011svn
161- Initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.