source: projects/specs/trunk/g/gegl/gegl-vl.spec @ 10490

Revision 10490, 5.0 KB checked in by tomop, 8 years ago (diff)

gegl-0.2.0-6

Line 
1%define VER 0.2
2
3Summary:        A graph based image processing framework
4Summary(ja):    グラフベースの画像処理フレームワーク
5Name:           gegl
6Version:        0.2.0
7Release:        6%{?_dist_release}
8# The binary is under the GPL, while the libs are under LGPL
9License:        LGPLv3+ and GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gegl.org/
12Source0:        ftp://ftp.gtk.org/pub/gegl/%{VER}/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires:  babl-devel >= 0.1.10
16BuildRequires:  glib2-devel
17BuildRequires:  gdk-pixbuf2-devel
18BuildRequires:  pango-devel
19BuildRequires:  ruby
20BuildRequires:  libpng-devel
21BuildRequires:  libjpeg-devel
22BuildRequires:  librsvg2-devel
23BuildRequires:  perl
24BuildRequires:  SDL-devel
25BuildRequires:  OpenEXR-devel
26BuildRequires:  lua-devel
27BuildRequires:  asciidoc
28BuildRequires:  enscript
29BuildRequires:  w3m
30BuildRequires:  graphviz
31BuildRequires:  pkgconfig
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37GEGL (Generic Graphics Library) is a graph based image processing framework.
38GEGLs original design was made to scratch GIMPs itches for a new
39compositing and processing core. This core is being designed to have
40minimal dependencies. and a simple well defined API.
41
42%package devel
43Summary:        Development files for %{name}
44Summary(ja):    %{name} の開発ファイル
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
47Requires:       pkgconfig babl-devel glib2-devel
48
49%description devel
50This package contains the libraries and header files needed for
51developing with %{name}.
52
53%prep
54%setup -q
55
56chmod -x operations/external/ff-load.c operations/common/perlin/perlin.*
57
58%build
59# Needed by Ruby 1.9.3.
60export LANG=en_US.utf8
61
62%ifnarch ppc64
63%configure --disable-static --enable-workshop
64%else
65%configure --disable-static --enable-workshop --disable-docs
66%endif
67make %{?_smp_mflags}
68
69%install
70rm -rf %{buildroot}
71make DESTDIR=%{buildroot} install INSTALL='install -p'
72
73find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
74
75%find_lang %{name}-%{VER}
76
77%check
78pushd tests/compositions
79rm -f run-clones.xml.sh
80cat << EOF > run-clones.xml.sh
81#!/bin/sh
82echo Skipping test "run-clones.xml.sh"
83EOF
84chmod 755 run-clones.xml.sh
85popd
86make check
87
88%clean
89rm -rf %{buildroot}
90
91%post -p /sbin/ldconfig
92
93%postun -p /sbin/ldconfig
94
95%files -f %{name}-%{VER}.lang
96%defattr(-, root, root, -)
97%doc AUTHORS ChangeLog COPYING COPYING.LESSER NEWS README
98%{_bindir}/gegl
99%{_libdir}/*.so.*
100%{_libdir}/gegl-%{VER}
101
102%files devel
103%defattr(-, root, root, -)
104%ifnarch ppc64
105%doc %{_datadir}/gtk-doc/html/%{name}
106%endif
107%{_includedir}/gegl-%{VER}
108%{_libdir}/*.so
109%{_libdir}/pkgconfig/%{name}-%{VER}.pc
110
111%changelog
112* Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.2.0-6
113- rebuilt with new toolchain.
114
115* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-5
116- remove *.la files
117
118* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.2.0-4
119- rebuilt with OpenEXR 2.2.0
120
121* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-3
122- rebuild with libpng-1.6.12
123
124* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-2
125- rebuild with VineSeed environment
126
127* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-1
128- new upstream release
129- remove old patches
130
131* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.6-1
132- new upstream release
133- update patches
134
135* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.1.2-2
136- rebuilt with rpm-4.8.1-3
137
138* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.2-1
139- new upstream release
140- add Patch0 and Patch1 from FC package
141
142* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  0.0.20-1
143- initial build for Vine Linux
144
145* Thu Jul 10 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.18-1
146- Update to latest release
147
148* Thu Feb 28 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.16-1
149- New release
150
151* Thu Jan 17 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.15-1.svn20080117
152- Update to a svn snapshot for gnome-scan
153- Apply patch to fix extensions loading on 64bit systems
154- Building the docs on ppc64 segfaults, avoid it for now.
155
156* Sat Dec 08 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.14-1
157- Update to 0.0.14 release
158- License change from GPLv2+ to GPLv3+
159
160* Thu Oct 25 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.7.20071011svn
161- Include missing requires for the devel subpackage
162
163* Thu Oct 25 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.6.20071011svn
164- BR graphiz instead of graphiz-devel
165- Remove the spurious exec flag from a couple of source codes
166
167* Tue Oct 23 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.5.20071011svn
168- Fix missing directory ownership
169
170* Mon Oct 22 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.4.20071011svn
171- Update the License field
172
173* Fri Oct 12 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.3.20071011svn
174- Package the extension libraries in the main package
175- Run 'make check'
176
177* Fri Oct 12 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.2.20071011svn
178- Remove the use of inexistent source
179
180* Thu Oct 11 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.1.20071011svn
181- Initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.