source: projects/specs/trunk/g/gegl/gegl-vl.spec @ 9559

Revision 9559, 4.9 KB checked in by Takemikaduchi, 9 years ago (diff)

cinnamon: new upstream release or rebuild
caja: fix typo
others: remove *.la files

Line 
1%define VER 0.2
2
3Summary:        A graph based image processing framework
4Summary(ja):    グラフベースの画像処理フレームワーク
5Name:           gegl
6Version:        0.2.0
7Release:        5%{?_dist_release}
8# The binary is under the GPL, while the libs are under LGPL
9License:        LGPLv3+ and GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gegl.org/
12Source0:        ftp://ftp.gtk.org/pub/gegl/%{VER}/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires:  babl-devel >= 0.1.10
16BuildRequires:  glib2-devel
17BuildRequires:  gdk-pixbuf2-devel
18BuildRequires:  pango-devel
19BuildRequires:  ruby
20BuildRequires:  libpng-devel
21BuildRequires:  libjpeg-devel
22BuildRequires:  librsvg2-devel
23BuildRequires:  perl
24BuildRequires:  SDL-devel
25BuildRequires:  OpenEXR-devel
26BuildRequires:  lua-devel
27BuildRequires:  asciidoc
28BuildRequires:  enscript
29BuildRequires:  w3m
30BuildRequires:  graphviz
31BuildRequires:  pkgconfig
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37GEGL (Generic Graphics Library) is a graph based image processing framework.
38GEGLs original design was made to scratch GIMPs itches for a new
39compositing and processing core. This core is being designed to have
40minimal dependencies. and a simple well defined API.
41
42%package devel
43Summary:        Development files for %{name}
44Summary(ja):    %{name} の開発ファイル
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
47Requires:       pkgconfig babl-devel glib2-devel
48
49%description devel
50This package contains the libraries and header files needed for
51developing with %{name}.
52
53%prep
54%setup -q
55
56chmod -x operations/external/ff-load.c operations/common/perlin/perlin.*
57
58%build
59# Needed by Ruby 1.9.3.
60export LANG=en_US.utf8
61
62%ifnarch ppc64
63%configure --disable-static --enable-workshop
64%else
65%configure --disable-static --enable-workshop --disable-docs
66%endif
67make %{?_smp_mflags}
68
69%install
70rm -rf %{buildroot}
71make DESTDIR=%{buildroot} install INSTALL='install -p'
72
73find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
74
75%find_lang %{name}-%{VER}
76
77%check
78pushd tests/compositions
79rm -f run-clones.xml.sh
80cat << EOF > run-clones.xml.sh
81#!/bin/sh
82echo Skipping test "run-clones.xml.sh"
83EOF
84chmod 755 run-clones.xml.sh
85popd
86make check
87
88%clean
89rm -rf %{buildroot}
90
91%post -p /sbin/ldconfig
92
93%postun -p /sbin/ldconfig
94
95%files -f %{name}-%{VER}.lang
96%defattr(-, root, root, -)
97%doc AUTHORS ChangeLog COPYING COPYING.LESSER NEWS README
98%{_bindir}/gegl
99%{_libdir}/*.so.*
100%{_libdir}/gegl-%{VER}
101
102%files devel
103%defattr(-, root, root, -)
104%ifnarch ppc64
105%doc %{_datadir}/gtk-doc/html/%{name}
106%endif
107%{_includedir}/gegl-%{VER}
108%{_libdir}/*.so
109%{_libdir}/pkgconfig/%{name}-%{VER}.pc
110
111%changelog
112* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-5
113- remove *.la files
114
115* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.2.0-4
116- rebuilt with OpenEXR 2.2.0
117
118* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-3
119- rebuild with libpng-1.6.12
120
121* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-2
122- rebuild with VineSeed environment
123
124* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.0-1
125- new upstream release
126- remove old patches
127
128* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.6-1
129- new upstream release
130- update patches
131
132* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.1.2-2
133- rebuilt with rpm-4.8.1-3
134
135* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.2-1
136- new upstream release
137- add Patch0 and Patch1 from FC package
138
139* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  0.0.20-1
140- initial build for Vine Linux
141
142* Thu Jul 10 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.18-1
143- Update to latest release
144
145* Thu Feb 28 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.16-1
146- New release
147
148* Thu Jan 17 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.15-1.svn20080117
149- Update to a svn snapshot for gnome-scan
150- Apply patch to fix extensions loading on 64bit systems
151- Building the docs on ppc64 segfaults, avoid it for now.
152
153* Sat Dec 08 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.14-1
154- Update to 0.0.14 release
155- License change from GPLv2+ to GPLv3+
156
157* Thu Oct 25 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.7.20071011svn
158- Include missing requires for the devel subpackage
159
160* Thu Oct 25 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.6.20071011svn
161- BR graphiz instead of graphiz-devel
162- Remove the spurious exec flag from a couple of source codes
163
164* Tue Oct 23 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.5.20071011svn
165- Fix missing directory ownership
166
167* Mon Oct 22 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.4.20071011svn
168- Update the License field
169
170* Fri Oct 12 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.3.20071011svn
171- Package the extension libraries in the main package
172- Run 'make check'
173
174* Fri Oct 12 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.2.20071011svn
175- Remove the use of inexistent source
176
177* Thu Oct 11 2007 Deji Akingunola <dakingun@gmail.com> - 0.0.13-0.1.20071011svn
178- Initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.