source: projects/specs/trunk/g/gdk-pixbuf2/gdk-pixbuf2-vl.spec @ 4704

Revision 4704, 7.2 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2 beta 1 (3.1.90)

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# biarch support
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5%define _query_suffix %{nil}
6%if %{build_compat32}
7%define _query_suffix -32
8%endif
9
10Name:           gdk-pixbuf2
11Version:        2.24.0
12Release:        1%{?_dist_release}
13Summary:        An image loading library
14
15Group:          System Environment/Libraries
16License:        LGPLv2+
17URL:            http://www.gt.org
18Source0:        http://download.gnome.org/sources/gdk-pixbuf/2.24/gdk-pixbuf-%{version}.tar.xz
19
20BuildRequires:  glib2-devel >= 2.26.0
21BuildRequires:  libpng-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libtiff-devel
24BuildRequires:  jasper-devel
25BuildRequires:  libX11-devel
26BuildRequires:  gobject-introspection-devel
27
28# gdk-pixbuf does a configure time check which uses the GIO mime
29# layer; we need to actually have the mime type database.
30BuildRequires:  shared-mime-info
31
32BuildRequires: gtk-doc
33## BuildRequires: libtool >= 2.2.10
34BuildRequires: libtool
35BuildRequires: gettext
36
37# We also need MIME information at runtime
38Requires: shared-mime-info
39
40# gdk-pixbuf was included in gtk2 until 2.21.2
41Conflicts: gtk2 <= 2.21.2
42
43# https://bugzilla.gnome.org/show_bug.cgi?id=624712
44Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Takemikaduchi
49
50%description
51gdk-pixbuf is an image loading library that can be extended by loadable
52modules for new image formats. It is used by toolkits such as GTK+ or
53clutter.
54
55%package devel
56Summary: Development files for gdk-pixbuf
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: glib2-devel
60Requires: gobject-introspection-devel
61Requires: libpng-devel
62
63# gdk-pixbuf was included in gtk2 until 2.21.2
64Conflicts: gtk2-devel <= 2.21.2
65
66%description devel
67This package contains the libraries and header files that are needed
68for writing applications that are using gdk-pixbuf.
69
70%if %{build_compat32}
71#######################################################################
72# compat32
73%package -n compat32-%{name}
74Summary:        An image loading library
75Group:          System Environment/Libraries
76Requires(post): compat32-glib2 >= %{glib2_version}
77# gdk-pixbuf was included in gtk2 until 2.21.2
78Conflicts: compat32-gtk2 <= 2.21.2
79
80%description -n compat32-%{name}
81gdk-pixbuf is an image loading library that can be extended by loadable
82modules for new image formats. It is used by toolkits such as GTK+ or
83clutter.
84
85%package -n compat32-%{name}-devel
86Summary: Development files for gdk-pixbuf
87Group: Development/Libraries
88Requires: compat32-%{name} = %{version}-%{release}
89Requires: %{name} = %{version}-%{release}
90Requires: compat32-libpng-devel
91
92# gdk-pixbuf was included in gtk2 until 2.21.2
93Conflicts: compat32-gtk2-devel <= 2.21.2
94
95%description -n compat32-%{name}-devel
96This package contains the libraries and header files that are needed
97for writing applications that are using gdk-pixbuf.
98
99%endif
100
101
102%prep
103%setup -q -n gdk-pixbuf-%{version}
104## %patch0 -p1 -b .libpng-linking
105
106%build
107libtoolize --copy --force
108autoreconf
109(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
110 %configure $CONFIGFLAGS \
111        --with-libjasper             \
112        --with-included-loaders=png  \
113        --enable-introspection=yes  )
114make %{?_smp_mflags}
115
116
117%install
118make install DESTDIR=$RPM_BUILD_ROOT    \
119             RUN_QUERY_LOADER_TEST=false
120
121# Remove unpackaged files
122rm $RPM_BUILD_ROOT%{_libdir}/*.la
123rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
124
125touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
126
127%if %{build_compat32}
128   cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
129      $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
130%endif
131
132%find_lang gdk-pixbuf
133
134%post
135/sbin/ldconfig
136gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
137
138%postun
139/sbin/ldconfig
140if [ $1 -gt 0 ]; then
141  gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
142fi
143
144%if %{build_compat32}
145%post -n compat32-%{name}
146/sbin/ldconfig
147gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
148
149%postun -n compat32-%{name}
150/sbin/ldconfig
151if [ $1 -gt 0 ]; then
152  gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
153fi
154%endif
155
156
157%files -f gdk-pixbuf.lang
158%defattr(-,root,root,-)
159%doc AUTHORS COPYING NEWS
160%{_libdir}/libgdk_pixbuf-2.0.so.*
161%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
162%{_libdir}/girepository-1.0
163%dir %{_libdir}/gdk-pixbuf-2.0
164%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
165%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
166%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
167%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
168%{_bindir}/gdk-pixbuf-query-loaders
169%{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
170
171%files devel
172%defattr(-,root,root,-)
173%{_includedir}/gdk-pixbuf-2.0
174%{_libdir}/libgdk_pixbuf-2.0.so
175%{_libdir}/libgdk_pixbuf_xlib-2.0.so
176%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
177%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
178%{_bindir}/gdk-pixbuf-csource
179%{_datadir}/gtk-doc/html/*
180%{_datadir}/gir-1.0
181%{_mandir}/man1/gdk-pixbuf-csource.1.gz
182
183%if %{build_compat32}
184%files -n compat32-%{name}
185%defattr(-,root,root,-)
186%{_libdir}/libgdk_pixbuf-2.0.so.*
187%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
188%dir %{_libdir}/gdk-pixbuf-2.0
189%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
190%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
191%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
192%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
193%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
194
195%files -n compat32-%{name}-devel
196%defattr(-,root,root,-)
197%{_libdir}/libgdk_pixbuf-2.0.so
198%{_libdir}/libgdk_pixbuf_xlib-2.0.so
199%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
200%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
201%endif
202
203%changelog
204* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
205- new upstream release
206
207* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.23.5-1
208- new upstream release
209
210* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
211- new upstream release
212
213* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
214- new upstream release
215- add configure option (--enable-introspection=yes)
216- drop Patch0
217
218* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
219- initial build for Vine Linux
220
221
222* Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
223- Require libpng for linking
224
225* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
226- Rebuild with new gobject-introspection
227
228* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
229- Update to 2.21.6
230
231* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
232- Also Require shared-mime-info for same reason
233
234* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
235- BR shared-mime-info; see comment above it
236
237* Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
238- Changes to support snapshot builds
239
240* Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
241- Update to 2.21.5
242
243* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
244- Rename to gdk-pixbuf2 to avoid conflict with the
245  existing gdk-pixbuf package
246
247* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
248- Update to 2.21.4
249- Incorporate package review feedback
250
251* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
252- Initial packaging
Note: See TracBrowser for help on using the repository browser.