source: projects/specs/trunk/g/gdk-pixbuf2/gdk-pixbuf2-vl.spec @ 12397

Revision 12397, 9.4 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

gdk-pixbuf2-2.40.0-1

gnumeric-1.12.46-1

goffice-0.10.46-1

libgsf-1.14.47-1

nss-3.51.1-2

rpm-4.12.0.1-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4# biarch support
5%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
6%define _query_suffix %{nil}
7%if %{build_compat32}
8%define _query_suffix -32
9%endif
10
11Name:           gdk-pixbuf2
12Summary:        An image loading library
13Version:        2.40.0
14Release:        1%{?_dist_release}
15Group:          System Environment/Libraries
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19License:        LGPLv2+
20URL:            http://www.gtk.org
21%global         shortver %(echo %{version} | cut -d . -f 1,2)
22Source:         https://download.gnome.org/sources/gdk-pixbuf/%{shortver}/gdk-pixbuf-%{version}.tar.xz
23
24BuildRequires:  meson
25BuildRequires:  glib2-devel >= 2.36.0
26BuildRequires:  libpng-devel
27BuildRequires:  libjpeg-turbo-devel
28BuildRequires:  libtiff-devel
29BuildRequires:  libX11-devel
30BuildRequires:  gobject-introspection-devel
31BuildConflicts: jasper-devel
32
33# gdk-pixbuf does a configure time check which uses the GIO mime
34# layer; we need to actually have the mime type database.
35BuildRequires:  shared-mime-info
36
37BuildRequires: gtk-doc
38## BuildRequires: libtool >= 2.2.10
39BuildRequires: libtool
40BuildRequires: gettext
41
42# We also need MIME information at runtime
43Requires: shared-mime-info
44
45# gdk-pixbuf was included in gtk2 until 2.21.2
46Conflicts: gtk2 <= 2.21.2
47
48# https://bugzilla.gnome.org/show_bug.cgi?id=624712
49Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
50
51%description
52gdk-pixbuf is an image loading library that can be extended by loadable
53modules for new image formats. It is used by toolkits such as GTK+ or
54clutter.
55
56%package devel
57Summary: Development files for gdk-pixbuf
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: glib2-devel
61Requires: gobject-introspection-devel
62Requires: libpng-devel
63
64# gdk-pixbuf was included in gtk2 until 2.21.2
65Conflicts: gtk2-devel <= 2.21.2
66
67%description devel
68This package contains the libraries and header files that are needed
69for writing applications that are using gdk-pixbuf.
70
71%if %{build_compat32}
72#######################################################################
73# compat32
74%package -n compat32-%{name}
75Summary:        An image loading library
76Group:          System Environment/Libraries
77Requires(post): compat32-glib2 >= %{glib2_version}
78# gdk-pixbuf was included in gtk2 until 2.21.2
79Conflicts: compat32-gtk2 <= 2.21.2
80
81%description -n compat32-%{name}
82gdk-pixbuf is an image loading library that can be extended by loadable
83modules for new image formats. It is used by toolkits such as GTK+ or
84clutter.
85
86%package -n compat32-%{name}-devel
87Summary: Development files for gdk-pixbuf
88Group: Development/Libraries
89Requires: compat32-%{name} = %{version}-%{release}
90Requires: %{name} = %{version}-%{release}
91Requires: compat32-libpng-devel
92
93# gdk-pixbuf was included in gtk2 until 2.21.2
94Conflicts: compat32-gtk2-devel <= 2.21.2
95
96%description -n compat32-%{name}-devel
97This package contains the libraries and header files that are needed
98for writing applications that are using gdk-pixbuf.
99
100%endif
101
102
103%prep
104%setup -q -n gdk-pixbuf-%{version}
105## %patch0 -p1 -b .libpng-linking
106
107%build
108%meson \
109  -Dbuiltin_loaders=png \
110  -Dinstalled_tests=false \
111  -Ddocs=true
112%meson_build
113
114
115%install
116%meson_install
117
118touch %{buildroot}%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
119
120%if %{build_compat32}
121   cp %{buildroot}%{_bindir}/gdk-pixbuf-query-loaders \
122      %{buildroot}%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
123%endif
124
125%find_lang gdk-pixbuf
126
127%post
128/sbin/ldconfig
129gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
130
131%postun
132/sbin/ldconfig
133if [ $1 -gt 0 ]; then
134  gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
135fi
136
137%if %{build_compat32}
138%post -n compat32-%{name}
139/sbin/ldconfig
140gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
141
142%postun -n compat32-%{name}
143/sbin/ldconfig
144if [ $1 -gt 0 ]; then
145  gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
146fi
147%endif
148
149
150%files -f gdk-pixbuf.lang
151%defattr(-,root,root,-)
152%license COPYING
153%doc NEWS README.md
154%{_bindir}/gdk-pixbuf-pixdata
155%{_bindir}/gdk-pixbuf-thumbnailer
156%{_libdir}/libgdk_pixbuf-2.0.so.*
157%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
158%{_libdir}/girepository-1.0
159%dir %{_libdir}/gdk-pixbuf-2.0
160%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
161%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
162%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
163%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
164%{_bindir}/gdk-pixbuf-query-loaders
165%{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
166%{_datadir}/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer
167
168%files devel
169%defattr(-,root,root,-)
170%{_includedir}/gdk-pixbuf-2.0
171%{_libdir}/libgdk_pixbuf-2.0.so
172%{_libdir}/libgdk_pixbuf_xlib-2.0.so
173%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
174%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
175%{_bindir}/gdk-pixbuf-csource
176%{_datadir}/gtk-doc/html/*
177%{_datadir}/gir-1.0
178%{_mandir}/man1/gdk-pixbuf-csource.1.gz
179
180%if %{build_compat32}
181%files -n compat32-%{name}
182%defattr(-,root,root,-)
183%{_libdir}/libgdk_pixbuf-2.0.so.*
184%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
185%dir %{_libdir}/gdk-pixbuf-2.0
186%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
187%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
188%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
189%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
190%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
191
192%files -n compat32-%{name}-devel
193%defattr(-,root,root,-)
194%{_libdir}/libgdk_pixbuf-2.0.so
195%{_libdir}/libgdk_pixbuf_xlib-2.0.so
196%endif
197
198
199%changelog
200* Sat May 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.0-1
201- new upstream release.
202
203* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.36.11-1
204- new upstream release.
205- disabled JPEG2000: jasper is too buggy and not fully implemented.
206
207* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
208- new upstream release
209
210* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
211- new upstream release
212
213* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
214- new upstream release
215
216* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
217- new upstream release
218
219* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.6-1
220- new upstream release
221
222* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.4-1
223- new upstream release
224
225* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.3-1
226- new upstream release
227
228* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.2-1
229- new upstream release
230
231* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.1-1
232- new upstream release
233
234* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-2
235- rebuild with libpng-1.6.12
236
237* Fri Jun 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-1
238- new upstream release
239
240* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.7-1
241- new upstream release
242
243* Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
244- new upstream release
245
246* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
247- new upstream release
248
249* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
250- new upstream release
251
252* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
253- new upstream release
254
255* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
256- new upstream release
257
258* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
259- new upstream release
260
261* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
262- new upstream release
263
264* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.5-1
265- new upstream release
266
267* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.4-1
268- new upstream release
269
270* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.2-1
271- new upstream release
272
273* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
274- new upstream release
275
276* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
277- new upstream release
278- add configure option (--with-x11)
279
280* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
281- new upstream release
282
283* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.23.5-1
284- new upstream release
285
286* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
287- new upstream release
288
289* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
290- new upstream release
291- add configure option (--enable-introspection=yes)
292- drop Patch0
293
294* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
295- initial build for Vine Linux
296
297
298* Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
299- Require libpng for linking
300
301* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
302- Rebuild with new gobject-introspection
303
304* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
305- Update to 2.21.6
306
307* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
308- Also Require shared-mime-info for same reason
309
310* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
311- BR shared-mime-info; see comment above it
312
313* Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
314- Changes to support snapshot builds
315
316* Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
317- Update to 2.21.5
318
319* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
320- Rename to gdk-pixbuf2 to avoid conflict with the
321  existing gdk-pixbuf package
322
323* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
324- Update to 2.21.4
325- Incorporate package review feedback
326
327* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
328- Initial packaging
Note: See TracBrowser for help on using the repository browser.