source: projects/specs/trunk/g/gdk-pixbuf2/gdk-pixbuf2-vl.spec @ 11331

Revision 11331, 9.6 KB checked in by tomop, 6 years ago (diff)

gdk-pixbuf2-2.36.11-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4# biarch support
5%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
6%define _query_suffix %{nil}
7%if %{build_compat32}
8%define _query_suffix -32
9%endif
10
11Name:           gdk-pixbuf2
12Version:        2.36.11
13Release:        1%{?_dist_release}
14Summary:        An image loading library
15
16Group:          System Environment/Libraries
17License:        LGPLv2+
18URL:            http://www.gt.org
19Source0:        http://download.gnome.org/sources/gdk-pixbuf/2.34/gdk-pixbuf-%{version}.tar.xz
20
21BuildRequires:  glib2-devel >= 2.36.0
22BuildRequires:  libpng-devel
23BuildRequires:  libjpeg-turbo-devel
24BuildRequires:  libtiff-devel
25BuildRequires:  libX11-devel
26BuildRequires:  gobject-introspection-devel
27BuildConflicts: jasper-devel
28
29# gdk-pixbuf does a configure time check which uses the GIO mime
30# layer; we need to actually have the mime type database.
31BuildRequires:  shared-mime-info
32
33BuildRequires: gtk-doc
34## BuildRequires: libtool >= 2.2.10
35BuildRequires: libtool
36BuildRequires: gettext
37
38# We also need MIME information at runtime
39Requires: shared-mime-info
40
41# gdk-pixbuf was included in gtk2 until 2.21.2
42Conflicts: gtk2 <= 2.21.2
43
44# https://bugzilla.gnome.org/show_bug.cgi?id=624712
45Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: Takemikaduchi
50
51%description
52gdk-pixbuf is an image loading library that can be extended by loadable
53modules for new image formats. It is used by toolkits such as GTK+ or
54clutter.
55
56%package devel
57Summary: Development files for gdk-pixbuf
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: glib2-devel
61Requires: gobject-introspection-devel
62Requires: libpng-devel
63
64# gdk-pixbuf was included in gtk2 until 2.21.2
65Conflicts: gtk2-devel <= 2.21.2
66
67%description devel
68This package contains the libraries and header files that are needed
69for writing applications that are using gdk-pixbuf.
70
71%if %{build_compat32}
72#######################################################################
73# compat32
74%package -n compat32-%{name}
75Summary:        An image loading library
76Group:          System Environment/Libraries
77Requires(post): compat32-glib2 >= %{glib2_version}
78# gdk-pixbuf was included in gtk2 until 2.21.2
79Conflicts: compat32-gtk2 <= 2.21.2
80
81%description -n compat32-%{name}
82gdk-pixbuf is an image loading library that can be extended by loadable
83modules for new image formats. It is used by toolkits such as GTK+ or
84clutter.
85
86%package -n compat32-%{name}-devel
87Summary: Development files for gdk-pixbuf
88Group: Development/Libraries
89Requires: compat32-%{name} = %{version}-%{release}
90Requires: %{name} = %{version}-%{release}
91Requires: compat32-libpng-devel
92
93# gdk-pixbuf was included in gtk2 until 2.21.2
94Conflicts: compat32-gtk2-devel <= 2.21.2
95
96%description -n compat32-%{name}-devel
97This package contains the libraries and header files that are needed
98for writing applications that are using gdk-pixbuf.
99
100%endif
101
102
103%prep
104%setup -q -n gdk-pixbuf-%{version}
105## %patch0 -p1 -b .libpng-linking
106
107%build
108(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
109 %configure $CONFIGFLAGS             \
110        --with-x11                       \
111        --with-included-loaders=png  \
112        --enable-introspection=yes  )
113make %{?_smp_mflags}
114
115
116%install
117make install DESTDIR=$RPM_BUILD_ROOT    \
118             RUN_QUERY_LOADER_TEST=false
119
120# Remove unpackaged files
121rm $RPM_BUILD_ROOT%{_libdir}/*.la
122rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
123
124touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
125
126%if %{build_compat32}
127   cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
128      $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
129%endif
130
131%find_lang gdk-pixbuf
132
133%post
134/sbin/ldconfig
135gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
136
137%postun
138/sbin/ldconfig
139if [ $1 -gt 0 ]; then
140  gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
141fi
142
143%if %{build_compat32}
144%post -n compat32-%{name}
145/sbin/ldconfig
146gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
147
148%postun -n compat32-%{name}
149/sbin/ldconfig
150if [ $1 -gt 0 ]; then
151  gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
152fi
153%endif
154
155
156%files -f gdk-pixbuf.lang
157%defattr(-,root,root,-)
158%doc AUTHORS COPYING NEWS
159%{_bindir}/gdk-pixbuf-pixdata
160%{_bindir}/gdk-pixbuf-thumbnailer
161%{_libdir}/libgdk_pixbuf-2.0.so.*
162%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
163%{_libdir}/girepository-1.0
164%dir %{_libdir}/gdk-pixbuf-2.0
165%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
166%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
167%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
168%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
169%{_bindir}/gdk-pixbuf-query-loaders
170%{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
171%{_datadir}/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer
172
173%files devel
174%defattr(-,root,root,-)
175%{_includedir}/gdk-pixbuf-2.0
176%{_libdir}/libgdk_pixbuf-2.0.so
177%{_libdir}/libgdk_pixbuf_xlib-2.0.so
178%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
179%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
180%{_bindir}/gdk-pixbuf-csource
181%{_datadir}/gtk-doc/html/*
182%{_datadir}/gir-1.0
183%{_mandir}/man1/gdk-pixbuf-csource.1.gz
184
185%if %{build_compat32}
186%files -n compat32-%{name}
187%defattr(-,root,root,-)
188%{_libdir}/libgdk_pixbuf-2.0.so.*
189%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
190%dir %{_libdir}/gdk-pixbuf-2.0
191%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
192%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
193%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
194%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
195%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
196
197%files -n compat32-%{name}-devel
198%defattr(-,root,root,-)
199%{_libdir}/libgdk_pixbuf-2.0.so
200%{_libdir}/libgdk_pixbuf_xlib-2.0.so
201%endif
202
203%changelog
204* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.36.11-1
205- new upstream release.
206- disabled JPEG2000: jasper is too buggy and not fully implemented.
207
208* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
209- new upstream release
210
211* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
212- new upstream release
213
214* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
215- new upstream release
216
217* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
218- new upstream release
219
220* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.6-1
221- new upstream release
222
223* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.4-1
224- new upstream release
225
226* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.3-1
227- new upstream release
228
229* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.2-1
230- new upstream release
231
232* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.1-1
233- new upstream release
234
235* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-2
236- rebuild with libpng-1.6.12
237
238* Fri Jun 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-1
239- new upstream release
240
241* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.7-1
242- new upstream release
243
244* Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
245- new upstream release
246
247* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
248- new upstream release
249
250* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
251- new upstream release
252
253* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
254- new upstream release
255
256* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
257- new upstream release
258
259* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
260- new upstream release
261
262* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
263- new upstream release
264
265* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.5-1
266- new upstream release
267
268* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.4-1
269- new upstream release
270
271* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.2-1
272- new upstream release
273
274* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
275- new upstream release
276
277* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
278- new upstream release
279- add configure option (--with-x11)
280
281* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
282- new upstream release
283
284* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.23.5-1
285- new upstream release
286
287* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
288- new upstream release
289
290* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
291- new upstream release
292- add configure option (--enable-introspection=yes)
293- drop Patch0
294
295* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
296- initial build for Vine Linux
297
298
299* Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
300- Require libpng for linking
301
302* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
303- Rebuild with new gobject-introspection
304
305* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
306- Update to 2.21.6
307
308* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
309- Also Require shared-mime-info for same reason
310
311* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
312- BR shared-mime-info; see comment above it
313
314* Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
315- Changes to support snapshot builds
316
317* Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
318- Update to 2.21.5
319
320* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
321- Rename to gdk-pixbuf2 to avoid conflict with the
322  existing gdk-pixbuf package
323
324* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
325- Update to 2.21.4
326- Incorporate package review feedback
327
328* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
329- Initial packaging
Note: See TracBrowser for help on using the repository browser.