source: projects/specs/trunk/g/gdk-pixbuf2/gdk-pixbuf2-vl.spec @ 9876

Revision 9876, 9.2 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# biarch support
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5%define _query_suffix %{nil}
6%if %{build_compat32}
7%define _query_suffix -32
8%endif
9
10Name:           gdk-pixbuf2
11Version:        2.32.3
12Release:        1%{?_dist_release}
13Summary:        An image loading library
14
15Group:          System Environment/Libraries
16License:        LGPLv2+
17URL:            http://www.gt.org
18Source0:        http://download.gnome.org/sources/gdk-pixbuf/2.32/gdk-pixbuf-%{version}.tar.xz
19
20BuildRequires:  glib2-devel >= 2.36.0
21BuildRequires:  libpng-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libtiff-devel
24BuildRequires:  jasper-devel
25BuildRequires:  libX11-devel
26BuildRequires:  gobject-introspection-devel
27
28# gdk-pixbuf does a configure time check which uses the GIO mime
29# layer; we need to actually have the mime type database.
30BuildRequires:  shared-mime-info
31
32BuildRequires: gtk-doc
33## BuildRequires: libtool >= 2.2.10
34BuildRequires: libtool
35BuildRequires: gettext
36
37# We also need MIME information at runtime
38Requires: shared-mime-info
39
40# gdk-pixbuf was included in gtk2 until 2.21.2
41Conflicts: gtk2 <= 2.21.2
42
43# https://bugzilla.gnome.org/show_bug.cgi?id=624712
44Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Takemikaduchi
49
50%description
51gdk-pixbuf is an image loading library that can be extended by loadable
52modules for new image formats. It is used by toolkits such as GTK+ or
53clutter.
54
55%package devel
56Summary: Development files for gdk-pixbuf
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: glib2-devel
60Requires: gobject-introspection-devel
61Requires: libpng-devel
62
63# gdk-pixbuf was included in gtk2 until 2.21.2
64Conflicts: gtk2-devel <= 2.21.2
65
66%description devel
67This package contains the libraries and header files that are needed
68for writing applications that are using gdk-pixbuf.
69
70%if %{build_compat32}
71#######################################################################
72# compat32
73%package -n compat32-%{name}
74Summary:        An image loading library
75Group:          System Environment/Libraries
76Requires(post): compat32-glib2 >= %{glib2_version}
77# gdk-pixbuf was included in gtk2 until 2.21.2
78Conflicts: compat32-gtk2 <= 2.21.2
79
80%description -n compat32-%{name}
81gdk-pixbuf is an image loading library that can be extended by loadable
82modules for new image formats. It is used by toolkits such as GTK+ or
83clutter.
84
85%package -n compat32-%{name}-devel
86Summary: Development files for gdk-pixbuf
87Group: Development/Libraries
88Requires: compat32-%{name} = %{version}-%{release}
89Requires: %{name} = %{version}-%{release}
90Requires: compat32-libpng-devel
91
92# gdk-pixbuf was included in gtk2 until 2.21.2
93Conflicts: compat32-gtk2-devel <= 2.21.2
94
95%description -n compat32-%{name}-devel
96This package contains the libraries and header files that are needed
97for writing applications that are using gdk-pixbuf.
98
99%endif
100
101
102%prep
103%setup -q -n gdk-pixbuf-%{version}
104## %patch0 -p1 -b .libpng-linking
105
106%build
107(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
108 %configure $CONFIGFLAGS             \
109        --with-libjasper             \
110        --with-x11                       \
111        --with-included-loaders=png  \
112        --enable-introspection=yes  )
113make %{?_smp_mflags}
114
115
116%install
117make install DESTDIR=$RPM_BUILD_ROOT    \
118             RUN_QUERY_LOADER_TEST=false
119
120# Remove unpackaged files
121rm $RPM_BUILD_ROOT%{_libdir}/*.la
122rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
123
124touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
125
126%if %{build_compat32}
127   cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
128      $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
129%endif
130
131%find_lang gdk-pixbuf
132
133%post
134/sbin/ldconfig
135gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
136
137%postun
138/sbin/ldconfig
139if [ $1 -gt 0 ]; then
140  gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
141fi
142
143%if %{build_compat32}
144%post -n compat32-%{name}
145/sbin/ldconfig
146gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
147
148%postun -n compat32-%{name}
149/sbin/ldconfig
150if [ $1 -gt 0 ]; then
151  gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
152fi
153%endif
154
155
156%files -f gdk-pixbuf.lang
157%defattr(-,root,root,-)
158%doc AUTHORS COPYING NEWS
159%{_bindir}/gdk-pixbuf-pixdata
160%{_libdir}/libgdk_pixbuf-2.0.so.*
161%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
162%{_libdir}/girepository-1.0
163%dir %{_libdir}/gdk-pixbuf-2.0
164%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
165%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
166%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
167%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
168%{_bindir}/gdk-pixbuf-query-loaders
169%{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
170
171%files devel
172%defattr(-,root,root,-)
173%{_includedir}/gdk-pixbuf-2.0
174%{_libdir}/libgdk_pixbuf-2.0.so
175%{_libdir}/libgdk_pixbuf_xlib-2.0.so
176%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
177%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
178%{_bindir}/gdk-pixbuf-csource
179%{_datadir}/gtk-doc/html/*
180%{_datadir}/gir-1.0
181%{_mandir}/man1/gdk-pixbuf-csource.1.gz
182
183%if %{build_compat32}
184%files -n compat32-%{name}
185%defattr(-,root,root,-)
186%{_libdir}/libgdk_pixbuf-2.0.so.*
187%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
188%dir %{_libdir}/gdk-pixbuf-2.0
189%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
190%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
191%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
192%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
193%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
194
195%files -n compat32-%{name}-devel
196%defattr(-,root,root,-)
197%{_libdir}/libgdk_pixbuf-2.0.so
198%{_libdir}/libgdk_pixbuf_xlib-2.0.so
199%endif
200
201%changelog
202* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
203- new upstream release
204
205* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
206- new upstream release
207
208* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
209- new upstream release
210
211* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.6-1
212- new upstream release
213
214* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.4-1
215- new upstream release
216
217* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.3-1
218- new upstream release
219
220* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.2-1
221- new upstream release
222
223* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.1-1
224- new upstream release
225
226* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-2
227- rebuild with libpng-1.6.12
228
229* Fri Jun 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-1
230- new upstream release
231
232* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.7-1
233- new upstream release
234
235* Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
236- new upstream release
237
238* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
239- new upstream release
240
241* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
242- new upstream release
243
244* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
245- new upstream release
246
247* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
248- new upstream release
249
250* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
251- new upstream release
252
253* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
254- new upstream release
255
256* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.5-1
257- new upstream release
258
259* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.4-1
260- new upstream release
261
262* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.2-1
263- new upstream release
264
265* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
266- new upstream release
267
268* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
269- new upstream release
270- add configure option (--with-x11)
271
272* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
273- new upstream release
274
275* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.23.5-1
276- new upstream release
277
278* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
279- new upstream release
280
281* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
282- new upstream release
283- add configure option (--enable-introspection=yes)
284- drop Patch0
285
286* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
287- initial build for Vine Linux
288
289
290* Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
291- Require libpng for linking
292
293* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
294- Rebuild with new gobject-introspection
295
296* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
297- Update to 2.21.6
298
299* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
300- Also Require shared-mime-info for same reason
301
302* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
303- BR shared-mime-info; see comment above it
304
305* Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
306- Changes to support snapshot builds
307
308* Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
309- Update to 2.21.5
310
311* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
312- Rename to gdk-pixbuf2 to avoid conflict with the
313  existing gdk-pixbuf package
314
315* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
316- Update to 2.21.4
317- Incorporate package review feedback
318
319* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
320- Initial packaging
Note: See TracBrowser for help on using the repository browser.