source: projects/specs/trunk/g/gdk-pixbuf2/gdk-pixbuf2-vl.spec @ 5316

Revision 5316, 7.4 KB checked in by Takemikaduchi, 12 years ago (diff)

mate: change category
fontconfig: rebuild
others: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# biarch support
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5%define _query_suffix %{nil}
6%if %{build_compat32}
7%define _query_suffix -32
8%endif
9
10Name:           gdk-pixbuf2
11Version:        2.24.1
12Release:        1%{?_dist_release}
13Summary:        An image loading library
14
15Group:          System Environment/Libraries
16License:        LGPLv2+
17URL:            http://www.gt.org
18Source0:        http://download.gnome.org/sources/gdk-pixbuf/2.24/gdk-pixbuf-%{version}.tar.xz
19
20BuildRequires:  glib2-devel >= 2.26.0
21BuildRequires:  libpng-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libtiff-devel
24BuildRequires:  jasper-devel
25BuildRequires:  libX11-devel
26BuildRequires:  gobject-introspection-devel
27
28# gdk-pixbuf does a configure time check which uses the GIO mime
29# layer; we need to actually have the mime type database.
30BuildRequires:  shared-mime-info
31
32BuildRequires: gtk-doc
33## BuildRequires: libtool >= 2.2.10
34BuildRequires: libtool
35BuildRequires: gettext
36
37# We also need MIME information at runtime
38Requires: shared-mime-info
39
40# gdk-pixbuf was included in gtk2 until 2.21.2
41Conflicts: gtk2 <= 2.21.2
42
43# https://bugzilla.gnome.org/show_bug.cgi?id=624712
44Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Takemikaduchi
49
50%description
51gdk-pixbuf is an image loading library that can be extended by loadable
52modules for new image formats. It is used by toolkits such as GTK+ or
53clutter.
54
55%package devel
56Summary: Development files for gdk-pixbuf
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: glib2-devel
60Requires: gobject-introspection-devel
61Requires: libpng-devel
62
63# gdk-pixbuf was included in gtk2 until 2.21.2
64Conflicts: gtk2-devel <= 2.21.2
65
66%description devel
67This package contains the libraries and header files that are needed
68for writing applications that are using gdk-pixbuf.
69
70%if %{build_compat32}
71#######################################################################
72# compat32
73%package -n compat32-%{name}
74Summary:        An image loading library
75Group:          System Environment/Libraries
76Requires(post): compat32-glib2 >= %{glib2_version}
77# gdk-pixbuf was included in gtk2 until 2.21.2
78Conflicts: compat32-gtk2 <= 2.21.2
79
80%description -n compat32-%{name}
81gdk-pixbuf is an image loading library that can be extended by loadable
82modules for new image formats. It is used by toolkits such as GTK+ or
83clutter.
84
85%package -n compat32-%{name}-devel
86Summary: Development files for gdk-pixbuf
87Group: Development/Libraries
88Requires: compat32-%{name} = %{version}-%{release}
89Requires: %{name} = %{version}-%{release}
90Requires: compat32-libpng-devel
91
92# gdk-pixbuf was included in gtk2 until 2.21.2
93Conflicts: compat32-gtk2-devel <= 2.21.2
94
95%description -n compat32-%{name}-devel
96This package contains the libraries and header files that are needed
97for writing applications that are using gdk-pixbuf.
98
99%endif
100
101
102%prep
103%setup -q -n gdk-pixbuf-%{version}
104## %patch0 -p1 -b .libpng-linking
105
106%build
107libtoolize --copy --force
108autoreconf
109(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
110 %configure $CONFIGFLAGS \
111        --with-libjasper             \
112        --with-x11                   \
113        --with-included-loaders=png  \
114        --enable-introspection=yes  )
115make %{?_smp_mflags}
116
117
118%install
119make install DESTDIR=$RPM_BUILD_ROOT    \
120             RUN_QUERY_LOADER_TEST=false
121
122# Remove unpackaged files
123rm $RPM_BUILD_ROOT%{_libdir}/*.la
124rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
125
126touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
127
128%if %{build_compat32}
129   cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
130      $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
131%endif
132
133%find_lang gdk-pixbuf
134
135%post
136/sbin/ldconfig
137gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
138
139%postun
140/sbin/ldconfig
141if [ $1 -gt 0 ]; then
142  gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
143fi
144
145%if %{build_compat32}
146%post -n compat32-%{name}
147/sbin/ldconfig
148gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
149
150%postun -n compat32-%{name}
151/sbin/ldconfig
152if [ $1 -gt 0 ]; then
153  gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
154fi
155%endif
156
157
158%files -f gdk-pixbuf.lang
159%defattr(-,root,root,-)
160%doc AUTHORS COPYING NEWS
161%{_libdir}/libgdk_pixbuf-2.0.so.*
162%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
163%{_libdir}/girepository-1.0
164%dir %{_libdir}/gdk-pixbuf-2.0
165%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
166%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
167%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
168%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
169%{_bindir}/gdk-pixbuf-query-loaders
170%{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
171
172%files devel
173%defattr(-,root,root,-)
174%{_includedir}/gdk-pixbuf-2.0
175%{_libdir}/libgdk_pixbuf-2.0.so
176%{_libdir}/libgdk_pixbuf_xlib-2.0.so
177%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
178%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
179%{_bindir}/gdk-pixbuf-csource
180%{_datadir}/gtk-doc/html/*
181%{_datadir}/gir-1.0
182%{_mandir}/man1/gdk-pixbuf-csource.1.gz
183
184%if %{build_compat32}
185%files -n compat32-%{name}
186%defattr(-,root,root,-)
187%{_libdir}/libgdk_pixbuf-2.0.so.*
188%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
189%dir %{_libdir}/gdk-pixbuf-2.0
190%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
191%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
192%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
193%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
194%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
195
196%files -n compat32-%{name}-devel
197%defattr(-,root,root,-)
198%{_libdir}/libgdk_pixbuf-2.0.so
199%{_libdir}/libgdk_pixbuf_xlib-2.0.so
200%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
201%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
202%endif
203
204%changelog
205* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
206- new upstream release
207- add configure option (--with-x11)
208
209* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
210- new upstream release
211
212* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.23.5-1
213- new upstream release
214
215* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
216- new upstream release
217
218* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
219- new upstream release
220- add configure option (--enable-introspection=yes)
221- drop Patch0
222
223* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
224- initial build for Vine Linux
225
226
227* Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
228- Require libpng for linking
229
230* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
231- Rebuild with new gobject-introspection
232
233* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
234- Update to 2.21.6
235
236* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
237- Also Require shared-mime-info for same reason
238
239* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
240- BR shared-mime-info; see comment above it
241
242* Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
243- Changes to support snapshot builds
244
245* Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
246- Update to 2.21.5
247
248* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
249- Rename to gdk-pixbuf2 to avoid conflict with the
250  existing gdk-pixbuf package
251
252* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
253- Update to 2.21.4
254- Incorporate package review feedback
255
256* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
257- Initial packaging
Note: See TracBrowser for help on using the repository browser.