source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 9139

Revision 9139, 13.3 KB checked in by Takemikaduchi, 9 years ago (diff)

dvipng, tuxtype2: rebuild
others: new upstream release

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 7.8.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.xz
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12BuildRequires: python-devel
13BuildRequires: zlib-devel
14Requires: install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: Takemikaduchi
19
20%description
21GDB, the GNU debugger, allows you to debug programs written in C, C++,
22and other languages, by executing them in a controlled fashion and
23printing their data.
24
25%description -l ja
26GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
27使うツールです.プログラムの実行を制御し,データを出力することができます.
28
29%prep
30%setup -q
31
32%build
33export CFLAGS="$RPM_OPT_FLAGS"
34rm -fr dejagnu tcl expect
35./configure \
36        --prefix=%{_prefix} \
37        --sysconfdir=%{_sysconfdir} \
38        --mandir=%{_mandir} \
39    --infodir=%{_infodir} \
40        %{_target_platform}
41
42make
43make info
44cp gdb/NEWS .
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
49
50# The above is broken, do this for now:
51#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
52#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
53
54# These are part of binutils
55#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
56#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
57rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
58rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
59rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
60rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
61rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
62rm -rf $RPM_BUILD_ROOT%{_includedir}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post
69[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
70[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
71[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
72[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
73[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
74[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
75
76
77%preun
78if [ $1 = 0 ]; then
79        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
80        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
81        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
82        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
83        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
84        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
85        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
86        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
87fi
88
89
90%files
91%defattr(-,root,root)
92%doc COPYING COPYING.LIB README NEWS
93%{_bindir}/*
94%{_mandir}/*/*
95%{_datadir}/gdb/syscalls
96%{_datadir}/gdb/python/gdb
97%{_datadir}/gdb/system-gdbinit/elinos.py
98%{_datadir}/gdb/system-gdbinit/wrs-linux.py
99%{_infodir}/annotate.info*
100%{_infodir}/gdb.info*
101%{_infodir}/stabs.info*
102%exclude %{_infodir}/dir
103%ifarch %{ix86} x86_64
104%{_libdir}/libinproctrace.so
105%endif
106## don't include the files in include, they are part of binutils
107#%{_includedir}/*
108#%{_infodir}/bfd.info*
109#%{_infodir}/configure.info*
110#%{_infodir}/standard.info*
111#%{_libdir}/*
112#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
113#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
114
115
116%changelog
117* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
118- new upstream release
119
120* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
121- new upstream release
122
123* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
124- new upstream release
125
126* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
127- new upstream release
128
129* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
130- new upstream release
131
132* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
133- new upstream release
134
135* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
136- add BuildRequires: python-devel, zlib-devel
137- fix %%files
138
139* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
140- updated gdb to 7.2
141
142* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
143- updated gdb to 7.0.1
144- rebuilt with new environment
145
146* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
147- applied new versioning policy, spec in utf-8
148
149* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
150- rebuild with expat-2.0.1
151- add BuildRequires: expat-devel
152
153* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
154- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
155
156* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
157- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
158
159* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
160- new upstream release
161
162* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
163- new upstream release
164
165* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
166- new upstream release
167
168* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
169- Oops, spec was written in Shift-JIS. Fixed.
170
171* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
172- based on 5.2.1-4 from Rawhide and built for Vine Linux
173
174* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
175- added mainframe patch from developerworks
176
177* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
178- Add changelogs to the previous patch
179
180* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
181- Add some patches from Elena Zannoni <ezannoni@redhat.com>
182
183* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
184- 5.2.1
185
186* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
187- compile on mainframe
188
189* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
190- Rebuild
191
192* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
193- Rebuild
194
195* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
196- 5.2
197
198* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
199- 5.1.92. Hopefully identical to 5.2 final
200
201* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
202- 5.1.91. 5.2 expected in a week
203
204* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
205- Update to current
206
207* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
208- Update to current
209
210* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
211- Update to current
212
213* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
214- Update to current
215
216* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
217- Update to current 5.2 branch
218
219* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
220- 5.1.1
221- add URL
222
223* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
224- automated rebuild
225
226* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
227- Fix some thread+fpu problems
228
229* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
230- 5.1
231
232* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
233- 5.0.94. Almost there....
234
235* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
236- Add patch from jakub@redhat.com to improve handling of DWARF
237
238* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
239- 5.0.93
240- handle missing info pages in post/pre scripts
241
242* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
243- 5.0.92
244
245* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
246- New snapshot
247- Use the 5.0.91 versioning from the snapshot
248
249* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
250- New snapshot
251
252* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
253- New snapshot
254
255* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
256- New snapshot
257
258* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
259- Don't buildrequire compat-glibc (#51690)
260
261* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
262- New snapshot, from the stable branch eventually leading to gdb 5.1
263
264* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
265- s/Copyright/License/
266- Add texinfo to BuildRequires
267
268* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
269- New snapshot
270
271* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
272- New snapshot
273- Add ncurses-devel to buildprereq
274- Remove perl from buildprereq, as gdb changed the way
275  version strings are generated
276
277* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
278- New snapshot
279
280* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
281- New snapshot - this had thread fixes for curing #39070
282- New way of specifying version
283
284* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
285- New tarball
286- Kevin's patch is now part of gdb
287
288* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
289- Add patch from kevinb@redhat.com to fix floating point + thread
290  problem (#24310)
291- remove old workarounds
292- new snapshot
293
294* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
295- New snapshot
296
297* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
298- on ia64, there are no old headers :)
299
300* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
301- build with old headers, new compiler
302
303* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
304- new snapshot
305
306* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
307- new snapshot which should fix some more IA64 problems (#29151)
308- remove IA64 patch, it's now integrated
309
310* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
311- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
312- use perl instead of patch for fixing the version string
313
314* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
315- don't use kgcc anymore
316- mark it as our own version
317- new snapshot
318
319* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
320- Link with ncurses 5.x even though we're using kgcc.
321  No need to drag in requirements on ncurses4 (Bug #24445)
322
323* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
324- new snapshot
325
326* Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
327- new snapshot
328
329* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
330- new snapshot
331- new alpha patch - it now compiles everywhere. Finally.
332
333* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
334- new snapshot
335
336* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
337- new CVS snapshot
338- disable the patches
339- don't use %%configure, as it confuses the autoconf script
340- enable SPARC, disable Alpha
341
342
343* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
344- added patch from GDB team for C++ symbol handling
345
346* Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
347- upgrade to CVS snapshot
348- excludearch SPARC, build on IA61
349
350* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
351- rebuild
352
353* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
354- automatic rebuild
355
356* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
357- rebuild
358
359* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
360- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
361  and %%{_tmppath}
362- the install scripts  for info are broken(they don't care about
363  you specify in the installstep), work around that.
364- don't build for IA64
365
366* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
367- upgraded to 5.0 - dump all patches. Reapply later if needed.
368- added the NEWS file to the %%doc files
369- don't delete files which doesn't get installed (readline, texinfo)
370- let build system handle stripping and gzipping
371- don't delete libmmalloc
372- apply patch from jakub@redhat.com to make it build on SPARC
373
374* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
375- rebuilt against new ncurses
376
377* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
378- rebuild for sparc baud rates > 38400.
379
380* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
381- fix core file handling on i386 with glibc 2.1.3 headers
382
383* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
384- fix reading registers from core on sparc.
385- hack around build problems on i386 with glibc 2.1.3 headers
386
387* Thu Oct 7 1999 Jim Kingdon
388- List files to install in /usr/info specifically (so we don't pick up
389things like info.info from GDB snapshots).
390
391* Thu Oct 7 1999 Jim Kingdon
392- Update GDB to 19991004 snapshot.  This eliminates the need for the
393sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
394
395* Mon Aug 23 1999 Jim Kingdon
396- Omit readline manpage.
397
398* Sat Aug 7 1999 Jim Kingdon
399- Remove H.J. Lu's patches (they had been commented out).
400- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
401from code fusion CD-ROM).
402
403* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
404- merge H.J. Lu's patches into 4.18.
405
406* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
407- updated the kern22 patch with stuff from davem
408
409* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
410- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
411
412* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
413- auto rebuild in the new build environment (release 3)
414
415* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
416- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.