source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 8914

Revision 8914, 13.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 7.8
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.xz
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12BuildRequires: python-devel
13BuildRequires: zlib-devel
14Requires: install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: Takemikaduchi
19
20%description
21GDB, the GNU debugger, allows you to debug programs written in C, C++,
22and other languages, by executing them in a controlled fashion and
23printing their data.
24
25%description -l ja
26GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
27使うツールです.プログラムの実行を制御し,データを出力することができます.
28
29%prep
30%setup -q
31
32%build
33export CFLAGS="$RPM_OPT_FLAGS"
34rm -fr dejagnu tcl expect
35./configure \
36        --prefix=%{_prefix} \
37        --sysconfdir=%{_sysconfdir} \
38        --mandir=%{_mandir} \
39    --infodir=%{_infodir} \
40        %{_target_platform}
41
42make
43make info
44cp gdb/NEWS .
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
49
50# The above is broken, do this for now:
51#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
52#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
53
54# These are part of binutils
55#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
56#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
57rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
58rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
59rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
60rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
61rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
62rm -rf $RPM_BUILD_ROOT%{_includedir}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post
69[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
70[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
71[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
72[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
73[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
74[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
75
76
77%preun
78if [ $1 = 0 ]; then
79        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
80        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
81        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
82        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
83        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
84        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
85        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
86        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
87fi
88
89
90%files
91%defattr(-,root,root)
92%doc COPYING COPYING.LIB README NEWS
93%{_bindir}/*
94%{_mandir}/*/*
95%{_datadir}/gdb/syscalls
96%{_datadir}/gdb/python/gdb
97%{_datadir}/gdb/system-gdbinit/elinos.py
98%{_datadir}/gdb/system-gdbinit/wrs-linux.py
99%{_infodir}/annotate.info*
100%{_infodir}/gdb.info*
101%{_infodir}/stabs.info*
102%exclude %{_infodir}/dir
103%ifarch %{ix86} x86_64
104%{_libdir}/libinproctrace.so
105%endif
106## don't include the files in include, they are part of binutils
107#%{_includedir}/*
108#%{_infodir}/bfd.info*
109#%{_infodir}/configure.info*
110#%{_infodir}/standard.info*
111#%{_libdir}/*
112#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
113#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
114
115
116%changelog
117* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
118- new upstream release
119
120* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
121- new upstream release
122
123* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
124- new upstream release
125
126* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
127- new upstream release
128
129* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
130- new upstream release
131
132* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
133- add BuildRequires: python-devel, zlib-devel
134- fix %%files
135
136* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
137- updated gdb to 7.2
138
139* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
140- updated gdb to 7.0.1
141- rebuilt with new environment
142
143* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
144- applied new versioning policy, spec in utf-8
145
146* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
147- rebuild with expat-2.0.1
148- add BuildRequires: expat-devel
149
150* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
151- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
152
153* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
154- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
155
156* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
157- new upstream release
158
159* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
160- new upstream release
161
162* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
163- new upstream release
164
165* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
166- Oops, spec was written in Shift-JIS. Fixed.
167
168* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
169- based on 5.2.1-4 from Rawhide and built for Vine Linux
170
171* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
172- added mainframe patch from developerworks
173
174* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
175- Add changelogs to the previous patch
176
177* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
178- Add some patches from Elena Zannoni <ezannoni@redhat.com>
179
180* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
181- 5.2.1
182
183* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
184- compile on mainframe
185
186* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
187- Rebuild
188
189* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
190- Rebuild
191
192* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
193- 5.2
194
195* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
196- 5.1.92. Hopefully identical to 5.2 final
197
198* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
199- 5.1.91. 5.2 expected in a week
200
201* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
202- Update to current
203
204* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
205- Update to current
206
207* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
208- Update to current
209
210* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
211- Update to current
212
213* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
214- Update to current 5.2 branch
215
216* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
217- 5.1.1
218- add URL
219
220* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
221- automated rebuild
222
223* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
224- Fix some thread+fpu problems
225
226* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
227- 5.1
228
229* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
230- 5.0.94. Almost there....
231
232* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
233- Add patch from jakub@redhat.com to improve handling of DWARF
234
235* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
236- 5.0.93
237- handle missing info pages in post/pre scripts
238
239* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
240- 5.0.92
241
242* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
243- New snapshot
244- Use the 5.0.91 versioning from the snapshot
245
246* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
247- New snapshot
248
249* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
250- New snapshot
251
252* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
253- New snapshot
254
255* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
256- Don't buildrequire compat-glibc (#51690)
257
258* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
259- New snapshot, from the stable branch eventually leading to gdb 5.1
260
261* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
262- s/Copyright/License/
263- Add texinfo to BuildRequires
264
265* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
266- New snapshot
267
268* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
269- New snapshot
270- Add ncurses-devel to buildprereq
271- Remove perl from buildprereq, as gdb changed the way
272  version strings are generated
273
274* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
275- New snapshot
276
277* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
278- New snapshot - this had thread fixes for curing #39070
279- New way of specifying version
280
281* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
282- New tarball
283- Kevin's patch is now part of gdb
284
285* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
286- Add patch from kevinb@redhat.com to fix floating point + thread
287  problem (#24310)
288- remove old workarounds
289- new snapshot
290
291* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
292- New snapshot
293
294* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
295- on ia64, there are no old headers :)
296
297* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
298- build with old headers, new compiler
299
300* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
301- new snapshot
302
303* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
304- new snapshot which should fix some more IA64 problems (#29151)
305- remove IA64 patch, it's now integrated
306
307* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
308- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
309- use perl instead of patch for fixing the version string
310
311* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
312- don't use kgcc anymore
313- mark it as our own version
314- new snapshot
315
316* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
317- Link with ncurses 5.x even though we're using kgcc.
318  No need to drag in requirements on ncurses4 (Bug #24445)
319
320* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
321- new snapshot
322
323* Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
324- new snapshot
325
326* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
327- new snapshot
328- new alpha patch - it now compiles everywhere. Finally.
329
330* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
331- new snapshot
332
333* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
334- new CVS snapshot
335- disable the patches
336- don't use %%configure, as it confuses the autoconf script
337- enable SPARC, disable Alpha
338
339
340* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
341- added patch from GDB team for C++ symbol handling
342
343* Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
344- upgrade to CVS snapshot
345- excludearch SPARC, build on IA61
346
347* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
348- rebuild
349
350* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
351- automatic rebuild
352
353* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
354- rebuild
355
356* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
357- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
358  and %%{_tmppath}
359- the install scripts  for info are broken(they don't care about
360  you specify in the installstep), work around that.
361- don't build for IA64
362
363* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
364- upgraded to 5.0 - dump all patches. Reapply later if needed.
365- added the NEWS file to the %%doc files
366- don't delete files which doesn't get installed (readline, texinfo)
367- let build system handle stripping and gzipping
368- don't delete libmmalloc
369- apply patch from jakub@redhat.com to make it build on SPARC
370
371* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
372- rebuilt against new ncurses
373
374* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
375- rebuild for sparc baud rates > 38400.
376
377* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
378- fix core file handling on i386 with glibc 2.1.3 headers
379
380* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
381- fix reading registers from core on sparc.
382- hack around build problems on i386 with glibc 2.1.3 headers
383
384* Thu Oct 7 1999 Jim Kingdon
385- List files to install in /usr/info specifically (so we don't pick up
386things like info.info from GDB snapshots).
387
388* Thu Oct 7 1999 Jim Kingdon
389- Update GDB to 19991004 snapshot.  This eliminates the need for the
390sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
391
392* Mon Aug 23 1999 Jim Kingdon
393- Omit readline manpage.
394
395* Sat Aug 7 1999 Jim Kingdon
396- Remove H.J. Lu's patches (they had been commented out).
397- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
398from code fusion CD-ROM).
399
400* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
401- merge H.J. Lu's patches into 4.18.
402
403* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
404- updated the kern22 patch with stuff from davem
405
406* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
407- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
408
409* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
410- auto rebuild in the new build environment (release 3)
411
412* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
413- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.