source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 8011

Revision 8011, 13.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 7.6.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12BuildRequires: python-devel
13BuildRequires: zlib-devel
14Requires: install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: Takemikaduchi
19
20%description
21GDB, the GNU debugger, allows you to debug programs written in C, C++,
22and other languages, by executing them in a controlled fashion and
23printing their data.
24
25%description -l ja
26GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
27使うツールです.プログラムの実行を制御し,データを出力することができます.
28
29%prep
30%setup -q
31
32%build
33export CFLAGS="$RPM_OPT_FLAGS"
34rm -fr dejagnu tcl expect
35./configure \
36        --prefix=%{_prefix} \
37        --sysconfdir=%{_sysconfdir} \
38        --mandir=%{_mandir} \
39    --infodir=%{_infodir} \
40        %{_target_platform}
41
42make
43make info
44cp gdb/NEWS .
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
49
50# install the gcore script in /usr/bin
51install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
52
53# The above is broken, do this for now:
54#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
55#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
56
57# These are part of binutils
58#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
59#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
60rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
61rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
62rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
63rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
64rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
65rm -rf $RPM_BUILD_ROOT%{_includedir}
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70
71%post
72[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
73[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
74[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
75[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
76[ -f %{_infodir}/gdbint.info ]         && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
77[ -f %{_infodir}/gdbint.info.gz ]      && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
78[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
79[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
80
81
82%preun
83if [ $1 = 0 ]; then
84        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
85        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
86        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
87        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
88        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
89        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
90        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
91        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
92fi
93
94
95%files
96%defattr(-,root,root)
97%doc COPYING COPYING.LIB README NEWS
98%{_bindir}/*
99%{_mandir}/*/*
100%{_datadir}/gdb/syscalls
101%{_datadir}/gdb/python/gdb
102%{_infodir}/annotate.info*
103%{_infodir}/gdb.info*
104%{_infodir}/gdbint.info*
105%{_infodir}/stabs.info*
106%exclude %{_infodir}/dir
107%ifarch %{ix86} x86_64
108%{_libdir}/libinproctrace.so
109%endif
110## don't include the files in include, they are part of binutils
111#%{_includedir}/*
112#%{_infodir}/bfd.info*
113#%{_infodir}/configure.info*
114#%{_infodir}/standard.info*
115#%{_libdir}/*
116#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
117#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
118
119
120%changelog
121* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
122- new upstream release
123
124* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
125- new upstream release
126
127* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
128- new upstream release
129
130* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
131- new upstream release
132
133* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
134- add BuildRequires: python-devel, zlib-devel
135- fix %%files
136
137* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
138- updated gdb to 7.2
139
140* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
141- updated gdb to 7.0.1
142- rebuilt with new environment
143
144* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
145- applied new versioning policy, spec in utf-8
146
147* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
148- rebuild with expat-2.0.1
149- add BuildRequires: expat-devel
150
151* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
152- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
153
154* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
155- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
156
157* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
158- new upstream release
159
160* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
161- new upstream release
162
163* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
164- new upstream release
165
166* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
167- Oops, spec was written in Shift-JIS. Fixed.
168
169* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
170- based on 5.2.1-4 from Rawhide and built for Vine Linux
171
172* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
173- added mainframe patch from developerworks
174
175* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
176- Add changelogs to the previous patch
177
178* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
179- Add some patches from Elena Zannoni <ezannoni@redhat.com>
180
181* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
182- 5.2.1
183
184* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
185- compile on mainframe
186
187* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
188- Rebuild
189
190* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
191- Rebuild
192
193* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
194- 5.2
195
196* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
197- 5.1.92. Hopefully identical to 5.2 final
198
199* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
200- 5.1.91. 5.2 expected in a week
201
202* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
203- Update to current
204
205* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
206- Update to current
207
208* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
209- Update to current
210
211* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
212- Update to current
213
214* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
215- Update to current 5.2 branch
216
217* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
218- 5.1.1
219- add URL
220
221* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
222- automated rebuild
223
224* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
225- Fix some thread+fpu problems
226
227* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
228- 5.1
229
230* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
231- 5.0.94. Almost there....
232
233* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
234- Add patch from jakub@redhat.com to improve handling of DWARF
235
236* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
237- 5.0.93
238- handle missing info pages in post/pre scripts
239
240* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
241- 5.0.92
242
243* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
244- New snapshot
245- Use the 5.0.91 versioning from the snapshot
246
247* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
248- New snapshot
249
250* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
251- New snapshot
252
253* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
254- New snapshot
255
256* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
257- Don't buildrequire compat-glibc (#51690)
258
259* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
260- New snapshot, from the stable branch eventually leading to gdb 5.1
261
262* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
263- s/Copyright/License/
264- Add texinfo to BuildRequires
265
266* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
267- New snapshot
268
269* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
270- New snapshot
271- Add ncurses-devel to buildprereq
272- Remove perl from buildprereq, as gdb changed the way
273  version strings are generated
274
275* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
276- New snapshot
277
278* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
279- New snapshot - this had thread fixes for curing #39070
280- New way of specifying version
281
282* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
283- New tarball
284- Kevin's patch is now part of gdb
285
286* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
287- Add patch from kevinb@redhat.com to fix floating point + thread
288  problem (#24310)
289- remove old workarounds
290- new snapshot
291
292* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
293- New snapshot
294
295* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
296- on ia64, there are no old headers :)
297
298* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
299- build with old headers, new compiler
300
301* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
302- new snapshot
303
304* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
305- new snapshot which should fix some more IA64 problems (#29151)
306- remove IA64 patch, it's now integrated
307
308* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
309- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
310- use perl instead of patch for fixing the version string
311
312* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
313- don't use kgcc anymore
314- mark it as our own version
315- new snapshot
316
317* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
318- Link with ncurses 5.x even though we're using kgcc.
319  No need to drag in requirements on ncurses4 (Bug #24445)
320
321* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
322- new snapshot
323
324* Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
325- new snapshot
326
327* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
328- new snapshot
329- new alpha patch - it now compiles everywhere. Finally.
330
331* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
332- new snapshot
333
334* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
335- new CVS snapshot
336- disable the patches
337- don't use %%configure, as it confuses the autoconf script
338- enable SPARC, disable Alpha
339
340
341* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
342- added patch from GDB team for C++ symbol handling
343
344* Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
345- upgrade to CVS snapshot
346- excludearch SPARC, build on IA61
347
348* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
349- rebuild
350
351* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
352- automatic rebuild
353
354* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
355- rebuild
356
357* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
358- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
359  and %%{_tmppath}
360- the install scripts  for info are broken(they don't care about
361  you specify in the installstep), work around that.
362- don't build for IA64
363
364* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
365- upgraded to 5.0 - dump all patches. Reapply later if needed.
366- added the NEWS file to the %%doc files
367- don't delete files which doesn't get installed (readline, texinfo)
368- let build system handle stripping and gzipping
369- don't delete libmmalloc
370- apply patch from jakub@redhat.com to make it build on SPARC
371
372* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
373- rebuilt against new ncurses
374
375* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
376- rebuild for sparc baud rates > 38400.
377
378* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
379- fix core file handling on i386 with glibc 2.1.3 headers
380
381* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
382- fix reading registers from core on sparc.
383- hack around build problems on i386 with glibc 2.1.3 headers
384
385* Thu Oct 7 1999 Jim Kingdon
386- List files to install in /usr/info specifically (so we don't pick up
387things like info.info from GDB snapshots).
388
389* Thu Oct 7 1999 Jim Kingdon
390- Update GDB to 19991004 snapshot.  This eliminates the need for the
391sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
392
393* Mon Aug 23 1999 Jim Kingdon
394- Omit readline manpage.
395
396* Sat Aug 7 1999 Jim Kingdon
397- Remove H.J. Lu's patches (they had been commented out).
398- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
399from code fusion CD-ROM).
400
401* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
402- merge H.J. Lu's patches into 4.18.
403
404* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
405- updated the kern22 patch with stuff from davem
406
407* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
408- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
409
410* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
411- auto rebuild in the new build environment (release 3)
412
413* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
414- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.