source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 7046

Revision 7046, 13.3 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 7.5
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12BuildRequires: python-devel
13BuildRequires: zlib-devel
14Requires: install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: Takemikaduchi
19
20%description
21GDB, the GNU debugger, allows you to debug programs written in C, C++,
22and other languages, by executing them in a controlled fashion and
23printing their data.
24
25%description -l ja
26GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
27使うツールです.プログラムの実行を制御し,データを出力することができます.
28
29%prep
30%setup -q
31
32%build
33export CFLAGS="$RPM_OPT_FLAGS"
34rm -fr dejagnu tcl expect
35./configure \
36        --prefix=%{_prefix} \
37        --sysconfdir=%{_sysconfdir} \
38        --mandir=%{_mandir} \
39    --infodir=%{_infodir} \
40        %{_target_platform}
41
42make
43make info
44cp gdb/NEWS .
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
49
50# install the gcore script in /usr/bin
51install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
52
53# The above is broken, do this for now:
54#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
55#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
56
57# These are part of binutils
58#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
59#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
60rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
61rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
62rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
63rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
64rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
65rm -rf $RPM_BUILD_ROOT%{_includedir}
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70
71%post
72[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
73[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
74[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
75[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
76[ -f %{_infodir}/gdbint.info ]         && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
77[ -f %{_infodir}/gdbint.info.gz ]      && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
78[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
79[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
80
81
82%preun
83if [ $1 = 0 ]; then
84        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
85        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
86        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
87        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
88        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
89        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
90        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
91        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
92fi
93
94
95%files
96%defattr(-,root,root)
97%doc COPYING COPYING.LIB README NEWS
98%{_bindir}/*
99%{_mandir}/*/*
100%{_datadir}/gdb/syscalls
101%{_datadir}/gdb/python/gdb
102%{_infodir}/annotate.info*
103%{_infodir}/gdb.info*
104%{_infodir}/gdbint.info*
105%{_infodir}/stabs.info*
106%exclude %{_infodir}/dir
107%ifarch %{ix86} x86_64
108%{_libdir}/libinproctrace.so
109%endif
110## don't include the files in include, they are part of binutils
111#%{_includedir}/*
112#%{_infodir}/bfd.info*
113#%{_infodir}/configure.info*
114#%{_infodir}/standard.info*
115#%{_libdir}/*
116#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
117#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
118
119
120%changelog
121* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
122- new upstream release
123
124* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
125- new upstream release
126
127* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
128- new upstream release
129
130* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
131- add BuildRequires: python-devel, zlib-devel
132- fix %%files
133
134* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
135- updated gdb to 7.2
136
137* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
138- updated gdb to 7.0.1
139- rebuilt with new environment
140
141* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
142- applied new versioning policy, spec in utf-8
143
144* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
145- rebuild with expat-2.0.1
146- add BuildRequires: expat-devel
147
148* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
149- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
150
151* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
152- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
153
154* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
155- new upstream release
156
157* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
158- new upstream release
159
160* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
161- new upstream release
162
163* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
164- Oops, spec was written in Shift-JIS. Fixed.
165
166* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
167- based on 5.2.1-4 from Rawhide and built for Vine Linux
168
169* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
170- added mainframe patch from developerworks
171
172* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
173- Add changelogs to the previous patch
174
175* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
176- Add some patches from Elena Zannoni <ezannoni@redhat.com>
177
178* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
179- 5.2.1
180
181* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
182- compile on mainframe
183
184* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
185- Rebuild
186
187* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
188- Rebuild
189
190* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
191- 5.2
192
193* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
194- 5.1.92. Hopefully identical to 5.2 final
195
196* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
197- 5.1.91. 5.2 expected in a week
198
199* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
200- Update to current
201
202* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
203- Update to current
204
205* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
206- Update to current
207
208* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
209- Update to current
210
211* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
212- Update to current 5.2 branch
213
214* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
215- 5.1.1
216- add URL
217
218* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
219- automated rebuild
220
221* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
222- Fix some thread+fpu problems
223
224* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
225- 5.1
226
227* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
228- 5.0.94. Almost there....
229
230* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
231- Add patch from jakub@redhat.com to improve handling of DWARF
232
233* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
234- 5.0.93
235- handle missing info pages in post/pre scripts
236
237* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
238- 5.0.92
239
240* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
241- New snapshot
242- Use the 5.0.91 versioning from the snapshot
243
244* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
245- New snapshot
246
247* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
248- New snapshot
249
250* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
251- New snapshot
252
253* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
254- Don't buildrequire compat-glibc (#51690)
255
256* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
257- New snapshot, from the stable branch eventually leading to gdb 5.1
258
259* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
260- s/Copyright/License/
261- Add texinfo to BuildRequires
262
263* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
264- New snapshot
265
266* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
267- New snapshot
268- Add ncurses-devel to buildprereq
269- Remove perl from buildprereq, as gdb changed the way
270  version strings are generated
271
272* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
273- New snapshot
274
275* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
276- New snapshot - this had thread fixes for curing #39070
277- New way of specifying version
278
279* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
280- New tarball
281- Kevin's patch is now part of gdb
282
283* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
284- Add patch from kevinb@redhat.com to fix floating point + thread
285  problem (#24310)
286- remove old workarounds
287- new snapshot
288
289* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
290- New snapshot
291
292* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
293- on ia64, there are no old headers :)
294
295* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
296- build with old headers, new compiler
297
298* Wed Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
299- new snapshot
300
301* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
302- new snapshot which should fix some more IA64 problems (#29151)
303- remove IA64 patch, it's now integrated
304
305* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
306- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
307- use perl instead of patch for fixing the version string
308
309* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
310- don't use kgcc anymore
311- mark it as our own version
312- new snapshot
313
314* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
315- Link with ncurses 5.x even though we're using kgcc.
316  No need to drag in requirements on ncurses4 (Bug #24445)
317
318* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
319- new snapshot
320
321* Thu Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
322- new snapshot
323
324* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
325- new snapshot
326- new alpha patch - it now compiles everywhere. Finally.
327
328* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
329- new snapshot
330
331* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
332- new CVS snapshot
333- disable the patches
334- don't use %%configure, as it confuses the autoconf script
335- enable SPARC, disable Alpha
336
337
338* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
339- added patch from GDB team for C++ symbol handling
340
341* Mon Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
342- upgrade to CVS snapshot
343- excludearch SPARC, build on IA61
344
345* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
346- rebuild
347
348* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
349- automatic rebuild
350
351* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
352- rebuild
353
354* Fri Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
355- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
356  and %%{_tmppath}
357- the install scripts  for info are broken(they don't care about
358  you specify in the installstep), work around that.
359- don't build for IA64
360
361* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
362- upgraded to 5.0 - dump all patches. Reapply later if needed.
363- added the NEWS file to the %%doc files
364- don't delete files which doesn't get installed (readline, texinfo)
365- let build system handle stripping and gzipping
366- don't delete libmmalloc
367- apply patch from jakub@redhat.com to make it build on SPARC
368
369* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
370- rebuilt against new ncurses
371
372* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
373- rebuild for sparc baud rates > 38400.
374
375* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
376- fix core file handling on i386 with glibc 2.1.3 headers
377
378* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
379- fix reading registers from core on sparc.
380- hack around build problems on i386 with glibc 2.1.3 headers
381
382* Thu Oct 7 1999 Jim Kingdon
383- List files to install in /usr/info specifically (so we don't pick up
384things like info.info from GDB snapshots).
385
386* Thu Oct 7 1999 Jim Kingdon
387- Update GDB to 19991004 snapshot.  This eliminates the need for the
388sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
389
390* Mon Aug 23 1999 Jim Kingdon
391- Omit readline manpage.
392
393* Tue Aug 7 1999 Jim Kingdon
394- Remove H.J. Lu's patches (they had been commented out).
395- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
396from code fusion CD-ROM).
397
398* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
399- merge H.J. Lu's patches into 4.18.
400
401* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
402- updated the kern22 patch with stuff from davem
403
404* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
405- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
406
407* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
408- auto rebuild in the new build environment (release 3)
409
410* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
411- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.