source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 12020

Revision 12020, 14.0 KB checked in by tomop, 5 years ago (diff)

update toolchain

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 8.2.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.xz
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12BuildRequires: python3-devel python3-rpm-macros
13BuildRequires: zlib-devel
14Requires: install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20GDB, the GNU debugger, allows you to debug programs written in C, C++,
21and other languages, by executing them in a controlled fashion and
22printing their data.
23
24%description -l ja
25GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
26使うツールです.プログラムの実行を制御し,データを出力することができます.
27
28%prep
29%setup -q
30
31%build
32export CFLAGS="$RPM_OPT_FLAGS"
33rm -fr dejagnu tcl expect
34./configure \
35        --prefix=%{_prefix} \
36        --sysconfdir=%{_sysconfdir} \
37        --mandir=%{_mandir} \
38    --infodir=%{_infodir} \
39    --with-python=%{__python3} \
40        %{_target_platform}
41
42make %{?_smp_mflags}
43make %{?_smp_mflags} info
44cp gdb/NEWS .
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
49
50# The above is broken, do this for now:
51#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
52#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
53
54# These are part of binutils
55#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
56#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
57rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
58rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
59rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
60rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
61rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
62rm -rf $RPM_BUILD_ROOT%{_includedir}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post
69[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
70[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
71[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
72[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
73[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
74[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
75
76
77%preun
78if [ $1 = 0 ]; then
79        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
80        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
81        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
82        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
83        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
84        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
85        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
86        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
87fi
88
89
90%files
91%defattr(-,root,root)
92%license COPYING COPYING.LIB
93%doc README NEWS
94%{_bindir}/*
95%{_mandir}/*/*
96%dir %{_datadir}/gdb
97%{_datadir}/gdb/syscalls
98%dir %{_datadir}/gdb/python
99%{_datadir}/gdb/python/gdb
100%dir %{_datadir}/gdb/system-gdbinit
101%{_datadir}/gdb/system-gdbinit/elinos.py
102%{_datadir}/gdb/system-gdbinit/wrs-linux.py
103%{_infodir}/annotate.info*
104%{_infodir}/gdb.info*
105%{_infodir}/stabs.info*
106%exclude %{_infodir}/dir
107%ifarch %{ix86} x86_64
108%{_libdir}/libinproctrace.so
109%endif
110## don't include the files in include, they are part of binutils
111#%{_includedir}/*
112#%{_infodir}/bfd.info*
113#%{_infodir}/configure.info*
114#%{_infodir}/standard.info*
115#%{_libdir}/*
116#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
117#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
118
119
120%changelog
121* Wed Jan 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
122- new upstream release.
123
124* Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11.1-1
125- new upstream release
126
127* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
128- new upstream release
129
130* Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
131- new upstream release
132
133* Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
134- new upstream release
135
136* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
137- new upstream release
138
139* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
140- new upstream release
141
142* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
143- new upstream release
144
145* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
146- new upstream release
147
148* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
149- new upstream release
150
151* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
152- new upstream release
153
154* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
155- new upstream release
156
157* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
158- add BuildRequires: python-devel, zlib-devel
159- fix %%files
160
161* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
162- updated gdb to 7.2
163
164* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
165- updated gdb to 7.0.1
166- rebuilt with new environment
167
168* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
169- applied new versioning policy, spec in utf-8
170
171* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
172- rebuild with expat-2.0.1
173- add BuildRequires: expat-devel
174
175* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
176- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
177
178* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
179- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
180
181* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
182- new upstream release
183
184* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
185- new upstream release
186
187* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
188- new upstream release
189
190* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
191- Oops, spec was written in Shift-JIS. Fixed.
192
193* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
194- based on 5.2.1-4 from Rawhide and built for Vine Linux
195
196* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
197- added mainframe patch from developerworks
198
199* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
200- Add changelogs to the previous patch
201
202* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
203- Add some patches from Elena Zannoni <ezannoni@redhat.com>
204
205* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
206- 5.2.1
207
208* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
209- compile on mainframe
210
211* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
212- Rebuild
213
214* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
215- Rebuild
216
217* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
218- 5.2
219
220* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
221- 5.1.92. Hopefully identical to 5.2 final
222
223* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
224- 5.1.91. 5.2 expected in a week
225
226* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
227- Update to current
228
229* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
230- Update to current
231
232* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
233- Update to current
234
235* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
236- Update to current
237
238* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
239- Update to current 5.2 branch
240
241* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
242- 5.1.1
243- add URL
244
245* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
246- automated rebuild
247
248* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
249- Fix some thread+fpu problems
250
251* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
252- 5.1
253
254* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
255- 5.0.94. Almost there....
256
257* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
258- Add patch from jakub@redhat.com to improve handling of DWARF
259
260* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
261- 5.0.93
262- handle missing info pages in post/pre scripts
263
264* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
265- 5.0.92
266
267* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
268- New snapshot
269- Use the 5.0.91 versioning from the snapshot
270
271* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
272- New snapshot
273
274* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
275- New snapshot
276
277* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
278- New snapshot
279
280* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
281- Don't buildrequire compat-glibc (#51690)
282
283* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
284- New snapshot, from the stable branch eventually leading to gdb 5.1
285
286* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
287- s/Copyright/License/
288- Add texinfo to BuildRequires
289
290* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
291- New snapshot
292
293* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
294- New snapshot
295- Add ncurses-devel to buildprereq
296- Remove perl from buildprereq, as gdb changed the way
297  version strings are generated
298
299* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
300- New snapshot
301
302* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
303- New snapshot - this had thread fixes for curing #39070
304- New way of specifying version
305
306* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
307- New tarball
308- Kevin's patch is now part of gdb
309
310* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
311- Add patch from kevinb@redhat.com to fix floating point + thread
312  problem (#24310)
313- remove old workarounds
314- new snapshot
315
316* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
317- New snapshot
318
319* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
320- on ia64, there are no old headers :)
321
322* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
323- build with old headers, new compiler
324
325* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
326- new snapshot
327
328* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
329- new snapshot which should fix some more IA64 problems (#29151)
330- remove IA64 patch, it's now integrated
331
332* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
333- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
334- use perl instead of patch for fixing the version string
335
336* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
337- don't use kgcc anymore
338- mark it as our own version
339- new snapshot
340
341* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
342- Link with ncurses 5.x even though we're using kgcc.
343  No need to drag in requirements on ncurses4 (Bug #24445)
344
345* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
346- new snapshot
347
348* Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
349- new snapshot
350
351* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
352- new snapshot
353- new alpha patch - it now compiles everywhere. Finally.
354
355* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
356- new snapshot
357
358* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
359- new CVS snapshot
360- disable the patches
361- don't use %%configure, as it confuses the autoconf script
362- enable SPARC, disable Alpha
363
364
365* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
366- added patch from GDB team for C++ symbol handling
367
368* Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
369- upgrade to CVS snapshot
370- excludearch SPARC, build on IA61
371
372* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
373- rebuild
374
375* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
376- automatic rebuild
377
378* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
379- rebuild
380
381* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
382- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
383  and %%{_tmppath}
384- the install scripts  for info are broken(they don't care about
385  you specify in the installstep), work around that.
386- don't build for IA64
387
388* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
389- upgraded to 5.0 - dump all patches. Reapply later if needed.
390- added the NEWS file to the %%doc files
391- don't delete files which doesn't get installed (readline, texinfo)
392- let build system handle stripping and gzipping
393- don't delete libmmalloc
394- apply patch from jakub@redhat.com to make it build on SPARC
395
396* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
397- rebuilt against new ncurses
398
399* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
400- rebuild for sparc baud rates > 38400.
401
402* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
403- fix core file handling on i386 with glibc 2.1.3 headers
404
405* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
406- fix reading registers from core on sparc.
407- hack around build problems on i386 with glibc 2.1.3 headers
408
409* Thu Oct 7 1999 Jim Kingdon
410- List files to install in /usr/info specifically (so we don't pick up
411things like info.info from GDB snapshots).
412
413* Thu Oct 7 1999 Jim Kingdon
414- Update GDB to 19991004 snapshot.  This eliminates the need for the
415sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
416
417* Mon Aug 23 1999 Jim Kingdon
418- Omit readline manpage.
419
420* Sat Aug 7 1999 Jim Kingdon
421- Remove H.J. Lu's patches (they had been commented out).
422- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
423from code fusion CD-ROM).
424
425* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
426- merge H.J. Lu's patches into 4.18.
427
428* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
429- updated the kern22 patch with stuff from davem
430
431* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
432- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
433
434* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
435- auto rebuild in the new build environment (release 3)
436
437* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
438- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.