source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 10192

Revision 10192, 13.6 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 7.11
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.xz
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12BuildRequires: python-devel
13BuildRequires: zlib-devel
14Requires: install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: Takemikaduchi
19
20%description
21GDB, the GNU debugger, allows you to debug programs written in C, C++,
22and other languages, by executing them in a controlled fashion and
23printing their data.
24
25%description -l ja
26GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
27使うツールです.プログラムの実行を制御し,データを出力することができます.
28
29%prep
30%setup -q
31
32%build
33export CFLAGS="$RPM_OPT_FLAGS"
34rm -fr dejagnu tcl expect
35./configure \
36        --prefix=%{_prefix} \
37        --sysconfdir=%{_sysconfdir} \
38        --mandir=%{_mandir} \
39    --infodir=%{_infodir} \
40        %{_target_platform}
41
42make
43make info
44cp gdb/NEWS .
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
49
50# The above is broken, do this for now:
51#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
52#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
53
54# These are part of binutils
55#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
56#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
57rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
58rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
59rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
60rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
61rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
62rm -rf $RPM_BUILD_ROOT%{_includedir}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post
69[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
70[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
71[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
72[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
73[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
74[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
75
76
77%preun
78if [ $1 = 0 ]; then
79        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
80        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
81        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
82        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
83        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
84        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
85        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
86        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
87fi
88
89
90%files
91%defattr(-,root,root)
92%doc COPYING COPYING.LIB README NEWS
93%{_bindir}/*
94%{_mandir}/*/*
95%{_datadir}/gdb/syscalls
96%{_datadir}/gdb/python/gdb
97%{_datadir}/gdb/system-gdbinit/elinos.py
98%{_datadir}/gdb/system-gdbinit/wrs-linux.py
99%{_infodir}/annotate.info*
100%{_infodir}/gdb.info*
101%{_infodir}/stabs.info*
102%exclude %{_infodir}/dir
103%ifarch %{ix86} x86_64
104%{_libdir}/libinproctrace.so
105%endif
106## don't include the files in include, they are part of binutils
107#%{_includedir}/*
108#%{_infodir}/bfd.info*
109#%{_infodir}/configure.info*
110#%{_infodir}/standard.info*
111#%{_libdir}/*
112#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
113#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
114
115
116%changelog
117* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
118- new upstream release
119
120* Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
121- new upstream release
122
123* Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
124- new upstream release
125
126* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
127- new upstream release
128
129* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
130- new upstream release
131
132* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
133- new upstream release
134
135* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
136- new upstream release
137
138* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
139- new upstream release
140
141* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
142- new upstream release
143
144* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
145- new upstream release
146
147* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
148- add BuildRequires: python-devel, zlib-devel
149- fix %%files
150
151* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
152- updated gdb to 7.2
153
154* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
155- updated gdb to 7.0.1
156- rebuilt with new environment
157
158* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
159- applied new versioning policy, spec in utf-8
160
161* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
162- rebuild with expat-2.0.1
163- add BuildRequires: expat-devel
164
165* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
166- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
167
168* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
169- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
170
171* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
172- new upstream release
173
174* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
175- new upstream release
176
177* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
178- new upstream release
179
180* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
181- Oops, spec was written in Shift-JIS. Fixed.
182
183* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
184- based on 5.2.1-4 from Rawhide and built for Vine Linux
185
186* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
187- added mainframe patch from developerworks
188
189* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
190- Add changelogs to the previous patch
191
192* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
193- Add some patches from Elena Zannoni <ezannoni@redhat.com>
194
195* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
196- 5.2.1
197
198* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
199- compile on mainframe
200
201* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
202- Rebuild
203
204* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
205- Rebuild
206
207* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
208- 5.2
209
210* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
211- 5.1.92. Hopefully identical to 5.2 final
212
213* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
214- 5.1.91. 5.2 expected in a week
215
216* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
217- Update to current
218
219* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
220- Update to current
221
222* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
223- Update to current
224
225* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
226- Update to current
227
228* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
229- Update to current 5.2 branch
230
231* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
232- 5.1.1
233- add URL
234
235* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
236- automated rebuild
237
238* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
239- Fix some thread+fpu problems
240
241* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
242- 5.1
243
244* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
245- 5.0.94. Almost there....
246
247* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
248- Add patch from jakub@redhat.com to improve handling of DWARF
249
250* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
251- 5.0.93
252- handle missing info pages in post/pre scripts
253
254* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
255- 5.0.92
256
257* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
258- New snapshot
259- Use the 5.0.91 versioning from the snapshot
260
261* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
262- New snapshot
263
264* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
265- New snapshot
266
267* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
268- New snapshot
269
270* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
271- Don't buildrequire compat-glibc (#51690)
272
273* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
274- New snapshot, from the stable branch eventually leading to gdb 5.1
275
276* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
277- s/Copyright/License/
278- Add texinfo to BuildRequires
279
280* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
281- New snapshot
282
283* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
284- New snapshot
285- Add ncurses-devel to buildprereq
286- Remove perl from buildprereq, as gdb changed the way
287  version strings are generated
288
289* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
290- New snapshot
291
292* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
293- New snapshot - this had thread fixes for curing #39070
294- New way of specifying version
295
296* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
297- New tarball
298- Kevin's patch is now part of gdb
299
300* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
301- Add patch from kevinb@redhat.com to fix floating point + thread
302  problem (#24310)
303- remove old workarounds
304- new snapshot
305
306* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
307- New snapshot
308
309* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
310- on ia64, there are no old headers :)
311
312* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
313- build with old headers, new compiler
314
315* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
316- new snapshot
317
318* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
319- new snapshot which should fix some more IA64 problems (#29151)
320- remove IA64 patch, it's now integrated
321
322* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
323- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
324- use perl instead of patch for fixing the version string
325
326* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
327- don't use kgcc anymore
328- mark it as our own version
329- new snapshot
330
331* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
332- Link with ncurses 5.x even though we're using kgcc.
333  No need to drag in requirements on ncurses4 (Bug #24445)
334
335* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
336- new snapshot
337
338* Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
339- new snapshot
340
341* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
342- new snapshot
343- new alpha patch - it now compiles everywhere. Finally.
344
345* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
346- new snapshot
347
348* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
349- new CVS snapshot
350- disable the patches
351- don't use %%configure, as it confuses the autoconf script
352- enable SPARC, disable Alpha
353
354
355* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
356- added patch from GDB team for C++ symbol handling
357
358* Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
359- upgrade to CVS snapshot
360- excludearch SPARC, build on IA61
361
362* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
363- rebuild
364
365* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
366- automatic rebuild
367
368* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
369- rebuild
370
371* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
372- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
373  and %%{_tmppath}
374- the install scripts  for info are broken(they don't care about
375  you specify in the installstep), work around that.
376- don't build for IA64
377
378* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
379- upgraded to 5.0 - dump all patches. Reapply later if needed.
380- added the NEWS file to the %%doc files
381- don't delete files which doesn't get installed (readline, texinfo)
382- let build system handle stripping and gzipping
383- don't delete libmmalloc
384- apply patch from jakub@redhat.com to make it build on SPARC
385
386* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
387- rebuilt against new ncurses
388
389* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
390- rebuild for sparc baud rates > 38400.
391
392* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
393- fix core file handling on i386 with glibc 2.1.3 headers
394
395* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
396- fix reading registers from core on sparc.
397- hack around build problems on i386 with glibc 2.1.3 headers
398
399* Thu Oct 7 1999 Jim Kingdon
400- List files to install in /usr/info specifically (so we don't pick up
401things like info.info from GDB snapshots).
402
403* Thu Oct 7 1999 Jim Kingdon
404- Update GDB to 19991004 snapshot.  This eliminates the need for the
405sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
406
407* Mon Aug 23 1999 Jim Kingdon
408- Omit readline manpage.
409
410* Sat Aug 7 1999 Jim Kingdon
411- Remove H.J. Lu's patches (they had been commented out).
412- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
413from code fusion CD-ROM).
414
415* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
416- merge H.J. Lu's patches into 4.18.
417
418* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
419- updated the kern22 patch with stuff from davem
420
421* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
422- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
423
424* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
425- auto rebuild in the new build environment (release 3)
426
427* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
428- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.