source: projects/specs/trunk/g/gd/gd-vl.spec @ 5866

Revision 5866, 8.5 KB checked in by shaolin, 12 years ago (diff)
  • gd: move gdlib-config from gd-progs to gd-devel
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: A graphics library for drawing .png files.
3Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
4Name: gd
5Version: 2.0.35
6Release: 7%{_dist_release}
7Source0: http://www.libgd.org/releases/gd-%{version}.tar.bz2
8Patch1:  gd-2.0.35-overflow.patch
9Patch2:  gd-2.0.35-CVE-2009-3546.diff
10License: BSD-style
11URL: http://www.libgd.org/
12Group: System Environment/Libraries
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libjpeg-devel zlib-devel freetype2-devel
16BuildRequires: libpng-devel >= 2:1.2.5
17BuildRequires: libX11-devel libXpm-devel
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23Gd is a graphics library for drawing .png files.  Gd allows your code to
24quickly draw images (lines, arcs, text, multiple colors, cutting and
25pasting from other images, flood fills) and write out the result as a
26.png file. Gd is particularly useful in web applications, where .pngs
27are commonly used as inline images.  Note, however, that gd is not a
28paint program.
29
30Install gd if you are developing applications which need to draw .png
31files.  If you install gd, you'll also need to install the gd-devel
32package.
33
34%description -l ja
35GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
36画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
37簡単に描写して、PNGファイルへ結果を出力することができます。
38Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
39便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
40ん。
41
42PNGファイルを描写する必要のあるアプリケーションを開発する場合、
43Gdをインストールしてください。gdをインストールした場合、gd-devel
44パッケージも必要になります。
45
46%package progs
47Summary: Utility programs that use libgd.
48Summary(ja): libgd を用いたユーティリティプログラム
49Group: Applications/Graphics
50Requires: gd = %{version}, perl
51
52%description progs
53These are utility programs supplied with gd, the .png graphics library.
54If you install these, you must install gd.
55
56%description progs -l ja
57これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
58プログラムです。これをインストールするには, gdをインストールする必要
59があります。
60
61%package devel
62Requires: gd = %{version}
63Summary: The development libraries and header files for gd.
64Summary(ja): gd用の開発ライブラリとヘッダファイル
65Group: Development/Libraries
66
67%description devel
68These are the development libraries and header files for gd, the .png
69graphics library.
70
71If you're installing the gd graphics library, you must install gd-devel.
72
73%description devel -l ja
74これらは開発ライブラリです。
75PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
76です。
77
78gdをインストールした場合、gd-develパッケージも必要になります。
79
80
81## to build compat32 for x86_64 architecture support
82%package -n compat32-%{name}
83Summary: A graphics library for drawing .png files.
84Group: System Environment/Libraries
85%description -n compat32-%{name}
86Gd is a graphics library for drawing .png files.  Gd allows your code to
87quickly draw images (lines, arcs, text, multiple colors, cutting and
88pasting from other images, flood fills) and write out the result as a
89.png file. Gd is particularly useful in web applications, where .pngs
90are commonly used as inline images.  Note, however, that gd is not a
91paint program.
92
93Install gd if you are developing applications which need to draw .png
94files.  If you install gd, you'll also need to install the gd-devel
95package.
96
97%package -n compat32-%{name}-devel
98Summary: The development libraries and header files for gd.
99Group: Development/Libraries
100%description -n compat32-%{name}-devel
101These are the development libraries and header files for gd, the .png
102graphics library.
103
104If you're installing the gd graphics library, you must install gd-devel.
105
106
107%prep
108%setup -q
109%patch1 -p1 -b .overflow
110%patch2 -p0 -b .CVE-2009-3546
111
112%build
113# %if %{build_compat32}
114# export CC='gcc -m32'
115# %configure CPPFLAGS="-DJISX0208"
116# make %{?_smp_mflags} LDFLAGS='-L/usr/lib -Wl,-rpath,/usr/lib  -L/usr/X11R6/lib'
117# %else
118%configure CPPFLAGS="-DJISX0208"
119make %{?_smp_mflags}
120# %endif
121
122%install
123[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
124make DESTDIR=$RPM_BUILD_ROOT install
125## remove unuse files
126rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
127
128%clean
129[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
130
131%post -p /sbin/ldconfig
132%postun -p /sbin/ldconfig
133
134%if %{build_compat32}
135%post -n compat32-%{name} -p /sbin/ldconfig
136%postun -n compat32-%{name} -p /sbin/ldconfig
137%endif
138
139# %if !%{build_compat32}
140%files
141%defattr(-,root,root)
142%doc COPYING README*
143%{_libdir}/*.so.*
144
145%files progs
146%defattr(-,root,root)
147%{_bindir}/*
148%exclude %{_bindir}/gdlib-config
149
150%files devel
151%defattr(-,root,root)
152%{_bindir}/gdlib-config
153%{_includedir}/*
154%{_libdir}/*.so
155%{_libdir}/*.a
156#%{_libdir}/*.la
157# %endif
158
159%if %{build_compat32}
160%files -n compat32-%{name}
161%defattr(-,root,root)
162%{_libdir}/*.so.*
163%files -n compat32-%{name}-devel
164%defattr(-,root,root)
165%{_libdir}/*.so
166%{_libdir}/*.a
167#%{_libdir}/*.la
168%endif
169
170%changelog
171* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
172- move gdlib-config from gd-progs subpackage to gd-devel subpackage
173
174* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
175- build on current VineSeed
176
177* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
178- fix build_compat32 if-endif sections
179
180* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
181- add patch2 for fix CVE-2009-3546 (_gdGetColors())
182
183* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
184- updated URL
185- changed progs Group to Applications/Graphics
186- added %%postun section
187
188* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
189- removed  *.la
190- spec in utf-8
191
192* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
193- add patch1 from centos5
194- new versioning policy
195
196* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
197- new upstream release with security fix (CVE-2007-2756)
198
199* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
200- new upstream release with security fix
201- change source tarball format gz -> bz2
202
203* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
204- added compat32-* packages for x86_64 architecture support
205
206* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
207- source upgrade
208
209* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
210- source update
211- added -DJISX0208 flag
212
213* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
214- source upgrade
215- BuildPrereq: XOrg-devel instead of XFree86-devel
216
217* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
218- source upgrade
219- remove patch0 (no need for freetype2-2.1.7)
220
221* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
222- add patch0 to build against freetype2-2.1.7
223
224* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
225- source upgrade
226- add URL
227- remove all patches
228- use %%configure script
229- add BuildPrereq: freetype2-devel XFree86-devel
230- remove BuildPrereq: VFlib-devel
231- update %%files
232- update Requires:
233- use License tag instead of Copyright
234
235* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
236- rebuild with libpng-devel-1.2.5-0vl1
237
238* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
239- rebuild with new toolchain
240
241* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
242- 1.8.3-0vl2
243- symlink to libgd.so.1 (for backward compatibility)
244
245* Mon Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
246- first gd 1.8.x release for Vine from rawhide.
247- enable freetype support and defined JISX208 macro.
248
249* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
250- break out a -progs subpackage
251- disable freetype support
252
253* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
254- update to latest version (1.8.2)
255- disable xpm support
256
257* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
258- auto rebuild in the new build environment (release 6)
259
260* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
261- auto rebuild in the new build environment (release 5)
262
263* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
264- buiuld for glibc 2.1
265
266* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
267- built for 5.2
Note: See TracBrowser for help on using the repository browser.