source: projects/specs/trunk/g/gd/gd-vl.spec @ 12370

Revision 12370, 11.3 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

dosfstools-4.1-1

fontconfig-2.13.1-1

gd-2.3.0-1

itstool-2.0.6-1

logrotate-3.16.0-1

ntfs-3g-2017.3.23-1

pciutils-3.6.4-1

redis-5.0.8-1

shared-mime-info-1.15-1

Line 
1%bcond_with libvpx
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4Summary: A graphics library for drawing .png files.
5Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
6Name: gd
7Version: 2.3.0
8Release: 1%{_dist_release}
9Group: System Environment/Libraries
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: daisuke
13
14License: BSD-style
15URL: http://www.libgd.org/
16Source0: https://github.com/libgd/libgd/releases/download/gd-%{version}/libgd-%{version}.tar.xz
17Patch0: gd-2.1.0-multilib.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: freetype2-devel
21BuildRequires: fontconfig-devel
22BuildRequires: gettext-devel
23BuildRequires: libjpeg-turbo-devel
24BuildRequires: libpng-devel
25BuildRequires: libtiff-devel
26%if %{with libvpx}
27BuildRequires: libvpx-devel
28%endif
29BuildRequires: libX11-devel
30BuildRequires: libXpm-devel
31BuildRequires: zlib-devel
32BuildRequires: pkgconfig
33# for test
34BuildRequires: TrueType-vlgothic
35
36%description
37Gd is a graphics library for drawing .png files.  Gd allows your code to
38quickly draw images (lines, arcs, text, multiple colors, cutting and
39pasting from other images, flood fills) and write out the result as a
40.png file. Gd is particularly useful in web applications, where .pngs
41are commonly used as inline images.  Note, however, that gd is not a
42paint program.
43
44Install gd if you are developing applications which need to draw .png
45files.  If you install gd, you'll also need to install the gd-devel
46package.
47
48%description -l ja
49GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
50画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
51簡単に描写して、PNGファイルへ結果を出力することができます。
52Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
53便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
54ん。
55
56PNGファイルを描写する必要のあるアプリケーションを開発する場合、
57Gdをインストールしてください。gdをインストールした場合、gd-devel
58パッケージも必要になります。
59
60%package progs
61Summary: Utility programs that use libgd.
62Summary(ja): libgd を用いたユーティリティプログラム
63Group: Applications/Graphics
64Requires: gd = %{version}
65Requires: perl
66
67%description progs
68These are utility programs supplied with gd, the .png graphics library.
69If you install these, you must install gd.
70
71%description progs -l ja
72これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
73プログラムです。これをインストールするには, gdをインストールする必要
74があります。
75
76%package devel
77Summary: The development libraries and header files for gd.
78Summary(ja): Gd用の開発ライブラリとヘッダファイル
79Group: Development/Libraries
80Requires: gd = %{version}
81Requires: freetype2-devel
82Requires: fontconfig-devel
83Requires: libjpeg-turbo-devel
84Requires: libpng-devel
85Requires: libtiff-devel
86%if %{with libvpx}
87Requires: libvpx-devel
88%endif
89Requires: libX11-devel
90Requires: libXpm-devel
91Requires: zlib-devel
92
93%description devel
94These are the development libraries and header files for gd, the .png
95graphics library.
96
97If you're installing the gd graphics library, you must install gd-devel.
98
99%description devel -l ja
100これらは開発ライブラリです。
101PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
102です。
103
104gdをインストールした場合、gd-develパッケージも必要になります。
105
106
107## to build compat32 for x86_64 architecture support
108%package -n compat32-%{name}
109Summary: A graphics library for drawing .png files.
110Group: System Environment/Libraries
111%description -n compat32-%{name}
112Gd is a graphics library for drawing .png files.  Gd allows your code to
113quickly draw images (lines, arcs, text, multiple colors, cutting and
114pasting from other images, flood fills) and write out the result as a
115.png file. Gd is particularly useful in web applications, where .pngs
116are commonly used as inline images.  Note, however, that gd is not a
117paint program.
118
119Install gd if you are developing applications which need to draw .png
120files.  If you install gd, you'll also need to install the gd-devel
121package.
122
123%package -n compat32-%{name}-devel
124Summary: The development libraries and header files for gd.
125Group: Development/Libraries
126Requires: compat32-freetype2-devel
127Requires: compat32-fontconfig-devel
128Requires: compat32-libjpeg-turbo-devel
129Requires: compat32-libpng-devel
130Requires: compat32-libtiff-devel
131%if %{with libvpx}
132Requires: compat32-libvpx-devel
133%endif
134Requires: compat32-libX11-devel
135Requires: compat32-libXpm-devel
136Requires: compat32-zlib-devel
137
138%description -n compat32-%{name}-devel
139These are the development libraries and header files for gd, the .png
140graphics library.
141
142If you're installing the gd graphics library, you must install gd-devel.
143
144
145%prep
146%setup -q -n libgd-%{version}
147#patch0 -p1 -b .mlib
148
149# disable until till this bug is fixed.
150#  - https://github.com/libgd/libgd/issues/610
151#: regenerate autotool stuff
152#if [ -f configure ]; then
153#   libtoolize --copy --force
154#   autoreconf -vif
155#else
156#   ./bootstrap.sh
157#fi
158
159
160%build
161# Provide a correct default font search path
162CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
163/usr/share/fonts/alias/TrueType/:\
164/usr/share/fonts/TrueType-vlgothic/:\
165/usr/share/fonts/bitstream-vera/:\
166/usr/share/fonts/TrueType-dejavu/:\
167/usr/share/fonts/TrueType-ipafont/:\
168/usr/share/fonts/TrueType-ipaexfont/:\
169/usr/share/fonts/default/Type1/:\
170/usr/share/X11/fonts/Type1/:\
171/usr/share/fonts/TrueType-linux-liberation/\
172\"'"
173
174%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
175    --with-freetype \
176    --with-tiff=%{_prefix} \
177%if %{with libvpx}
178    --with-vpx=%{_prefix} \
179%endif
180        --disable-rpath
181make %{?_smp_mflags}
182
183%install
184[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
185make DESTDIR=$RPM_BUILD_ROOT install
186## remove unuse files
187rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
188
189%check
190%ifarch x86_64
191make %{?_smp_mflags} check
192%endif
193
194%clean
195[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
196
197%post -p /sbin/ldconfig
198%postun -p /sbin/ldconfig
199
200%if %{build_compat32}
201%post -n compat32-%{name} -p /sbin/ldconfig
202%postun -n compat32-%{name} -p /sbin/ldconfig
203%endif
204
205%files
206%defattr(-,root,root)
207%license COPYING
208%doc README.md CHANGELOG.md docs/*
209%{_libdir}/*.so.*
210
211%files progs
212%defattr(-,root,root)
213%{_bindir}/*
214
215%files devel
216%defattr(-,root,root)
217%{_includedir}/*
218%{_libdir}/*.so
219%{_libdir}/pkgconfig/*.pc
220
221%if %{build_compat32}
222%files -n compat32-%{name}
223%defattr(-,root,root)
224%{_libdir}/*.so.*
225%files -n compat32-%{name}-devel
226%defattr(-,root,root)
227%{_libdir}/*.so
228%endif
229
230%changelog
231* Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-1
232- new upstream release.
233
234* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
235- new upstream release.
236- dropped %%patch1 and 2: fixed in upstream.
237
238* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
239- new upstream release.
240- made to skip %%check on i686.
241
242* Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
243- new upstream release.
244- removed Patch1000 (fixed in upstream).
245
246* Wed May  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
247- added Patch1000 to fix CVE-2016-3074.
248
249* Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
250- new upstream release.
251
252* Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
253- BR: freetype2-devel instead of freetype-devel on devel package
254
255* Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
256- fixed version in gd.h.
257- added fontconfig and tiff support.
258
259* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
260- new upstream release.
261- dropped unnecessary patches.
262
263* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
264- import patches from fedora package
265- modified font path patch for Vine Linux
266- drop static library
267- remove "-DJISX0208"
268- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
269
270* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
271- move gdlib-config from gd-progs subpackage to gd-devel subpackage
272
273* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
274- build on current VineSeed
275
276* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
277- fix build_compat32 if-endif sections
278
279* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
280- add patch2 for fix CVE-2009-3546 (_gdGetColors())
281
282* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
283- updated URL
284- changed progs Group to Applications/Graphics
285- added %%postun section
286
287* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
288- removed  *.la
289- spec in utf-8
290
291* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
292- add patch1 from centos5
293- new versioning policy
294
295* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
296- new upstream release with security fix (CVE-2007-2756)
297
298* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
299- new upstream release with security fix
300- change source tarball format gz -> bz2
301
302* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
303- added compat32-* packages for x86_64 architecture support
304
305* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
306- source upgrade
307
308* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
309- source update
310- added -DJISX0208 flag
311
312* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
313- source upgrade
314- BuildPrereq: XOrg-devel instead of XFree86-devel
315
316* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
317- source upgrade
318- remove patch0 (no need for freetype2-2.1.7)
319
320* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
321- add patch0 to build against freetype2-2.1.7
322
323* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
324- source upgrade
325- add URL
326- remove all patches
327- use %%configure script
328- add BuildPrereq: freetype2-devel XFree86-devel
329- remove BuildPrereq: VFlib-devel
330- update %%files
331- update Requires:
332- use License tag instead of Copyright
333
334* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
335- rebuild with libpng-devel-1.2.5-0vl1
336
337* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
338- rebuild with new toolchain
339
340* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
341- 1.8.3-0vl2
342- symlink to libgd.so.1 (for backward compatibility)
343
344* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
345- first gd 1.8.x release for Vine from rawhide.
346- enable freetype support and defined JISX208 macro.
347
348* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
349- break out a -progs subpackage
350- disable freetype support
351
352* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
353- update to latest version (1.8.2)
354- disable xpm support
355
356* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
357- auto rebuild in the new build environment (release 6)
358
359* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
360- auto rebuild in the new build environment (release 5)
361
362* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
363- buiuld for glibc 2.1
364
365* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
366- built for 5.2
Note: See TracBrowser for help on using the repository browser.