source: projects/specs/trunk/g/gd/gd-vl.spec @ 11263

Revision 11263, 11.1 KB checked in by tomop, 6 years ago (diff)

gd-2.2.5-1

Line 
1%bcond_with libvpx
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4Summary: A graphics library for drawing .png files.
5Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
6Name: gd
7Version: 2.2.5
8Release: 1%{_dist_release}
9Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
10Patch0: gd-2.1.0-multilib.patch
11License: BSD-style
12URL: http://www.libgd.org/
13Group: System Environment/Libraries
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: freetype2-devel
17BuildRequires: fontconfig-devel
18BuildRequires: gettext-devel
19BuildRequires: libjpeg-turbo-devel
20BuildRequires: libpng-devel
21BuildRequires: libtiff-devel
22%if %{with libvpx}
23BuildRequires: libvpx-devel
24%endif
25BuildRequires: libX11-devel
26BuildRequires: libXpm-devel
27BuildRequires: zlib-devel
28BuildRequires: pkgconfig
29# for test
30BuildRequires: TrueType-vlgothic
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: daisuke
35
36%description
37Gd is a graphics library for drawing .png files.  Gd allows your code to
38quickly draw images (lines, arcs, text, multiple colors, cutting and
39pasting from other images, flood fills) and write out the result as a
40.png file. Gd is particularly useful in web applications, where .pngs
41are commonly used as inline images.  Note, however, that gd is not a
42paint program.
43
44Install gd if you are developing applications which need to draw .png
45files.  If you install gd, you'll also need to install the gd-devel
46package.
47
48%description -l ja
49GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
50画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
51簡単に描写して、PNGファイルへ結果を出力することができます。
52Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
53便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
54ん。
55
56PNGファイルを描写する必要のあるアプリケーションを開発する場合、
57Gdをインストールしてください。gdをインストールした場合、gd-devel
58パッケージも必要になります。
59
60%package progs
61Summary: Utility programs that use libgd.
62Summary(ja): libgd を用いたユーティリティプログラム
63Group: Applications/Graphics
64Requires: gd = %{version}
65Requires: perl
66
67%description progs
68These are utility programs supplied with gd, the .png graphics library.
69If you install these, you must install gd.
70
71%description progs -l ja
72これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
73プログラムです。これをインストールするには, gdをインストールする必要
74があります。
75
76%package devel
77Summary: The development libraries and header files for gd.
78Summary(ja): Gd用の開発ライブラリとヘッダファイル
79Group: Development/Libraries
80Requires: gd = %{version}
81Requires: freetype2-devel
82Requires: fontconfig-devel
83Requires: libjpeg-turbo-devel
84Requires: libpng-devel
85Requires: libtiff-devel
86%if %{with libvpx}
87Requires: libvpx-devel
88%endif
89Requires: libX11-devel
90Requires: libXpm-devel
91Requires: zlib-devel
92
93%description devel
94These are the development libraries and header files for gd, the .png
95graphics library.
96
97If you're installing the gd graphics library, you must install gd-devel.
98
99%description devel -l ja
100これらは開発ライブラリです。
101PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
102です。
103
104gdをインストールした場合、gd-develパッケージも必要になります。
105
106
107## to build compat32 for x86_64 architecture support
108%package -n compat32-%{name}
109Summary: A graphics library for drawing .png files.
110Group: System Environment/Libraries
111%description -n compat32-%{name}
112Gd is a graphics library for drawing .png files.  Gd allows your code to
113quickly draw images (lines, arcs, text, multiple colors, cutting and
114pasting from other images, flood fills) and write out the result as a
115.png file. Gd is particularly useful in web applications, where .pngs
116are commonly used as inline images.  Note, however, that gd is not a
117paint program.
118
119Install gd if you are developing applications which need to draw .png
120files.  If you install gd, you'll also need to install the gd-devel
121package.
122
123%package -n compat32-%{name}-devel
124Summary: The development libraries and header files for gd.
125Group: Development/Libraries
126Requires: compat32-freetype2-devel
127Requires: compat32-fontconfig-devel
128Requires: compat32-libjpeg-turbo-devel
129Requires: compat32-libpng-devel
130Requires: compat32-libtiff-devel
131%if %{with libvpx}
132Requires: compat32-libvpx-devel
133%endif
134Requires: compat32-libX11-devel
135Requires: compat32-libXpm-devel
136Requires: compat32-zlib-devel
137
138%description -n compat32-%{name}-devel
139These are the development libraries and header files for gd, the .png
140graphics library.
141
142If you're installing the gd graphics library, you must install gd-devel.
143
144
145%prep
146%setup -q -n libgd-%{version}
147%patch0 -p1 -b .mlib
148
149: regenerate autotool stuff
150if [ -f configure ]; then
151   libtoolize --copy --force
152   autoreconf -vif
153else
154   ./bootstrap.sh
155fi
156
157
158%build
159# Provide a correct default font search path
160CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
161/usr/share/fonts/alias/TrueType/:\
162/usr/share/fonts/TrueType-vlgothic/:\
163/usr/share/fonts/bitstream-vera/:\
164/usr/share/fonts/TrueType-dejavu/:\
165/usr/share/fonts/TrueType-ipafont/:\
166/usr/share/fonts/TrueType-ipaexfont/:\
167/usr/share/fonts/default/Type1/:\
168/usr/share/X11/fonts/Type1/:\
169/usr/share/fonts/TrueType-linux-liberation/\
170\"'"
171
172%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
173    --with-freetype \
174    --with-tiff=%{_prefix} \
175%if %{with libvpx}
176    --with-vpx=%{_prefix} \
177%endif
178        --disable-rpath
179make %{?_smp_mflags}
180
181%install
182[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
183make DESTDIR=$RPM_BUILD_ROOT install
184## remove unuse files
185rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
186
187%check
188%ifarch x86_64
189make %{?_smp_mflags} check
190%endif
191
192%clean
193[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
194
195%post -p /sbin/ldconfig
196%postun -p /sbin/ldconfig
197
198%if %{build_compat32}
199%post -n compat32-%{name} -p /sbin/ldconfig
200%postun -n compat32-%{name} -p /sbin/ldconfig
201%endif
202
203%files
204%defattr(-,root,root)
205%doc ChangeLog COPYING NEWS docs/*
206%{_libdir}/*.so.*
207
208%files progs
209%defattr(-,root,root)
210%{_bindir}/*
211%exclude %{_bindir}/gdlib-config
212
213%files devel
214%defattr(-,root,root)
215%{_bindir}/gdlib-config
216%{_includedir}/*
217%{_libdir}/*.so
218%{_libdir}/pkgconfig/*.pc
219
220%if %{build_compat32}
221%files -n compat32-%{name}
222%defattr(-,root,root)
223%{_libdir}/*.so.*
224%files -n compat32-%{name}-devel
225%defattr(-,root,root)
226%{_libdir}/*.so
227%endif
228
229%changelog
230* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
231- new upstream release.
232- dropped %%patch1 and 2: fixed in upstream.
233
234* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
235- new upstream release.
236- made to skip %%check on i686.
237
238* Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
239- new upstream release.
240- removed Patch1000 (fixed in upstream).
241
242* Wed May  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
243- added Patch1000 to fix CVE-2016-3074.
244
245* Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
246- new upstream release.
247
248* Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
249- BR: freetype2-devel instead of freetype-devel on devel package
250
251* Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
252- fixed version in gd.h.
253- added fontconfig and tiff support.
254
255* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
256- new upstream release.
257- dropped unnecessary patches.
258
259* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
260- import patches from fedora package
261- modified font path patch for Vine Linux
262- drop static library
263- remove "-DJISX0208"
264- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
265
266* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
267- move gdlib-config from gd-progs subpackage to gd-devel subpackage
268
269* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
270- build on current VineSeed
271
272* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
273- fix build_compat32 if-endif sections
274
275* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
276- add patch2 for fix CVE-2009-3546 (_gdGetColors())
277
278* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
279- updated URL
280- changed progs Group to Applications/Graphics
281- added %%postun section
282
283* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
284- removed  *.la
285- spec in utf-8
286
287* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
288- add patch1 from centos5
289- new versioning policy
290
291* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
292- new upstream release with security fix (CVE-2007-2756)
293
294* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
295- new upstream release with security fix
296- change source tarball format gz -> bz2
297
298* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
299- added compat32-* packages for x86_64 architecture support
300
301* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
302- source upgrade
303
304* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
305- source update
306- added -DJISX0208 flag
307
308* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
309- source upgrade
310- BuildPrereq: XOrg-devel instead of XFree86-devel
311
312* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
313- source upgrade
314- remove patch0 (no need for freetype2-2.1.7)
315
316* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
317- add patch0 to build against freetype2-2.1.7
318
319* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
320- source upgrade
321- add URL
322- remove all patches
323- use %%configure script
324- add BuildPrereq: freetype2-devel XFree86-devel
325- remove BuildPrereq: VFlib-devel
326- update %%files
327- update Requires:
328- use License tag instead of Copyright
329
330* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
331- rebuild with libpng-devel-1.2.5-0vl1
332
333* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
334- rebuild with new toolchain
335
336* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
337- 1.8.3-0vl2
338- symlink to libgd.so.1 (for backward compatibility)
339
340* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
341- first gd 1.8.x release for Vine from rawhide.
342- enable freetype support and defined JISX208 macro.
343
344* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
345- break out a -progs subpackage
346- disable freetype support
347
348* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
349- update to latest version (1.8.2)
350- disable xpm support
351
352* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
353- auto rebuild in the new build environment (release 6)
354
355* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
356- auto rebuild in the new build environment (release 5)
357
358* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
359- buiuld for glibc 2.1
360
361* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
362- built for 5.2
Note: See TracBrowser for help on using the repository browser.