source: projects/specs/trunk/g/gd/gd-vl.spec @ 10956

Revision 10956, 11.1 KB checked in by tomop, 7 years ago (diff)

gd, jasper, jasper1, libtiff, openjpeg2, sqlite3

Line 
1%bcond_with libvpx
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4Summary: A graphics library for drawing .png files.
5Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
6Name: gd
7Version: 2.2.4
8Release: 1%{_dist_release}
9Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
10Patch0: gd-2.1.0-multilib.patch
11Patch1: issue357.patch
12Patch2: issue364.patch
13License: BSD-style
14URL: http://www.libgd.org/
15Group: System Environment/Libraries
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: freetype2-devel
19BuildRequires: fontconfig-devel
20BuildRequires: gettext-devel
21BuildRequires: libjpeg-turbo-devel
22BuildRequires: libpng-devel
23BuildRequires: libtiff-devel
24%if %{with libvpx}
25BuildRequires: libvpx-devel
26%endif
27BuildRequires: libX11-devel
28BuildRequires: libXpm-devel
29BuildRequires: zlib-devel
30BuildRequires: pkgconfig
31# for test
32BuildRequires: TrueType-vlgothic
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: daisuke
37
38%description
39Gd is a graphics library for drawing .png files.  Gd allows your code to
40quickly draw images (lines, arcs, text, multiple colors, cutting and
41pasting from other images, flood fills) and write out the result as a
42.png file. Gd is particularly useful in web applications, where .pngs
43are commonly used as inline images.  Note, however, that gd is not a
44paint program.
45
46Install gd if you are developing applications which need to draw .png
47files.  If you install gd, you'll also need to install the gd-devel
48package.
49
50%description -l ja
51GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
52画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
53簡単に描写して、PNGファイルへ結果を出力することができます。
54Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
55便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
56ん。
57
58PNGファイルを描写する必要のあるアプリケーションを開発する場合、
59Gdをインストールしてください。gdをインストールした場合、gd-devel
60パッケージも必要になります。
61
62%package progs
63Summary: Utility programs that use libgd.
64Summary(ja): libgd を用いたユーティリティプログラム
65Group: Applications/Graphics
66Requires: gd = %{version}
67Requires: perl
68
69%description progs
70These are utility programs supplied with gd, the .png graphics library.
71If you install these, you must install gd.
72
73%description progs -l ja
74これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
75プログラムです。これをインストールするには, gdをインストールする必要
76があります。
77
78%package devel
79Summary: The development libraries and header files for gd.
80Summary(ja): Gd用の開発ライブラリとヘッダファイル
81Group: Development/Libraries
82Requires: gd = %{version}
83Requires: freetype2-devel
84Requires: fontconfig-devel
85Requires: libjpeg-turbo-devel
86Requires: libpng-devel
87Requires: libtiff-devel
88%if %{with libvpx}
89Requires: libvpx-devel
90%endif
91Requires: libX11-devel
92Requires: libXpm-devel
93Requires: zlib-devel
94
95%description devel
96These are the development libraries and header files for gd, the .png
97graphics library.
98
99If you're installing the gd graphics library, you must install gd-devel.
100
101%description devel -l ja
102これらは開発ライブラリです。
103PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
104です。
105
106gdをインストールした場合、gd-develパッケージも必要になります。
107
108
109## to build compat32 for x86_64 architecture support
110%package -n compat32-%{name}
111Summary: A graphics library for drawing .png files.
112Group: System Environment/Libraries
113%description -n compat32-%{name}
114Gd is a graphics library for drawing .png files.  Gd allows your code to
115quickly draw images (lines, arcs, text, multiple colors, cutting and
116pasting from other images, flood fills) and write out the result as a
117.png file. Gd is particularly useful in web applications, where .pngs
118are commonly used as inline images.  Note, however, that gd is not a
119paint program.
120
121Install gd if you are developing applications which need to draw .png
122files.  If you install gd, you'll also need to install the gd-devel
123package.
124
125%package -n compat32-%{name}-devel
126Summary: The development libraries and header files for gd.
127Group: Development/Libraries
128Requires: compat32-freetype2-devel
129Requires: compat32-fontconfig-devel
130Requires: compat32-libjpeg-turbo-devel
131Requires: compat32-libpng-devel
132Requires: compat32-libtiff-devel
133%if %{with libvpx}
134Requires: compat32-libvpx-devel
135%endif
136Requires: compat32-libX11-devel
137Requires: compat32-libXpm-devel
138Requires: compat32-zlib-devel
139
140%description -n compat32-%{name}-devel
141These are the development libraries and header files for gd, the .png
142graphics library.
143
144If you're installing the gd graphics library, you must install gd-devel.
145
146
147%prep
148%setup -q -n libgd-%{version}
149%patch0 -p1 -b .mlib
150%patch1 -p1 -b .issue357
151%patch2 -p1 -b .issue364
152
153: regenerate autotool stuff
154if [ -f configure ]; then
155   libtoolize --copy --force
156   autoreconf -vif
157else
158   ./bootstrap.sh
159fi
160
161
162%build
163# Provide a correct default font search path
164CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
165/usr/share/fonts/alias/TrueType/:\
166/usr/share/fonts/TrueType-vlgothic/:\
167/usr/share/fonts/bitstream-vera/:\
168/usr/share/fonts/TrueType-dejavu/:\
169/usr/share/fonts/TrueType-ipafont/:\
170/usr/share/fonts/TrueType-ipaexfont/:\
171/usr/share/fonts/default/Type1/:\
172/usr/share/X11/fonts/Type1/:\
173/usr/share/fonts/TrueType-linux-liberation/\
174\"'"
175
176%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
177    --with-freetype \
178    --with-tiff=%{_prefix} \
179%if %{with libvpx}
180    --with-vpx=%{_prefix} \
181%endif
182        --disable-rpath
183make %{?_smp_mflags}
184
185%install
186[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
187make DESTDIR=$RPM_BUILD_ROOT install
188## remove unuse files
189rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
190
191%check
192%ifarch x86_64
193make %{?_smp_mflags} check
194%endif
195
196%clean
197[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
198
199%post -p /sbin/ldconfig
200%postun -p /sbin/ldconfig
201
202%if %{build_compat32}
203%post -n compat32-%{name} -p /sbin/ldconfig
204%postun -n compat32-%{name} -p /sbin/ldconfig
205%endif
206
207%files
208%defattr(-,root,root)
209%doc ChangeLog COPYING NEWS docs/*
210%{_libdir}/*.so.*
211
212%files progs
213%defattr(-,root,root)
214%{_bindir}/*
215%exclude %{_bindir}/gdlib-config
216
217%files devel
218%defattr(-,root,root)
219%{_bindir}/gdlib-config
220%{_includedir}/*
221%{_libdir}/*.so
222%{_libdir}/pkgconfig/*.pc
223
224%if %{build_compat32}
225%files -n compat32-%{name}
226%defattr(-,root,root)
227%{_libdir}/*.so.*
228%files -n compat32-%{name}-devel
229%defattr(-,root,root)
230%{_libdir}/*.so
231%endif
232
233%changelog
234* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
235- new upstream release.
236- made to skip %%check on i686.
237
238* Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
239- new upstream release.
240- removed Patch1000 (fixed in upstream).
241
242* Wed May  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
243- added Patch1000 to fix CVE-2016-3074.
244
245* Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
246- new upstream release.
247
248* Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
249- BR: freetype2-devel instead of freetype-devel on devel package
250
251* Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
252- fixed version in gd.h.
253- added fontconfig and tiff support.
254
255* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
256- new upstream release.
257- dropped unnecessary patches.
258
259* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
260- import patches from fedora package
261- modified font path patch for Vine Linux
262- drop static library
263- remove "-DJISX0208"
264- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
265
266* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
267- move gdlib-config from gd-progs subpackage to gd-devel subpackage
268
269* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
270- build on current VineSeed
271
272* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
273- fix build_compat32 if-endif sections
274
275* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
276- add patch2 for fix CVE-2009-3546 (_gdGetColors())
277
278* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
279- updated URL
280- changed progs Group to Applications/Graphics
281- added %%postun section
282
283* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
284- removed  *.la
285- spec in utf-8
286
287* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
288- add patch1 from centos5
289- new versioning policy
290
291* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
292- new upstream release with security fix (CVE-2007-2756)
293
294* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
295- new upstream release with security fix
296- change source tarball format gz -> bz2
297
298* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
299- added compat32-* packages for x86_64 architecture support
300
301* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
302- source upgrade
303
304* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
305- source update
306- added -DJISX0208 flag
307
308* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
309- source upgrade
310- BuildPrereq: XOrg-devel instead of XFree86-devel
311
312* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
313- source upgrade
314- remove patch0 (no need for freetype2-2.1.7)
315
316* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
317- add patch0 to build against freetype2-2.1.7
318
319* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
320- source upgrade
321- add URL
322- remove all patches
323- use %%configure script
324- add BuildPrereq: freetype2-devel XFree86-devel
325- remove BuildPrereq: VFlib-devel
326- update %%files
327- update Requires:
328- use License tag instead of Copyright
329
330* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
331- rebuild with libpng-devel-1.2.5-0vl1
332
333* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
334- rebuild with new toolchain
335
336* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
337- 1.8.3-0vl2
338- symlink to libgd.so.1 (for backward compatibility)
339
340* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
341- first gd 1.8.x release for Vine from rawhide.
342- enable freetype support and defined JISX208 macro.
343
344* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
345- break out a -progs subpackage
346- disable freetype support
347
348* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
349- update to latest version (1.8.2)
350- disable xpm support
351
352* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
353- auto rebuild in the new build environment (release 6)
354
355* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
356- auto rebuild in the new build environment (release 5)
357
358* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
359- buiuld for glibc 2.1
360
361* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
362- built for 5.2
Note: See TracBrowser for help on using the repository browser.