source: projects/specs/trunk/g/gamin/gamin-vl.spec @ 521

Revision 521, 12.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define python_archlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
3Summary: Library providing the FAM File Alteration Monitor API
4Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
5Name: gamin
6Version: 0.1.10
7Release: 2%{?_dist_release}
8License: LGPLv2
9Group: System Environment/Daemons
10Source: gamin-%{version}.tar.bz2
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13URL: http://www.gnome.org/~veillard/gamin/
14Obsoletes: fam
15Provides: fam
16BuildRequires: glib2-devel, python, python-devel
17
18
19%description
20The Gamin library provides an API and ABI compatible file alteration
21monitor mechanism compatible with FAM but not dependent on a system wide
22daemon.
23
24%description -l ja
25Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
26します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
27パープログラムをオンデマンドに起動します。
28
29%package devel
30Summary: Development files for the Gamin library
31Summary(ja): Gamin ライブラリの開発用ファイル
32Group: Development/Libraries
33Requires: gamin = %{version}-%{release}
34Obsoletes: fam-devel
35Provides: fam-devel
36
37%description devel
38The Gamin library provides an API and ABI compatible file alteration
39monitor mechanism compatible with FAM but not dependent on a system wide
40daemon.
41
42%description devel -l ja
43Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
44します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
45パープログラムをオンデマンドに起動します。
46
47%package python
48Summary: Python bindings for the Gamin library
49Summary(ja): Gamin ライブラリ用の Python バインディング
50Group: Development/Libraries
51Requires: gamin = %{version}-%{release}
52Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
53
54%description python
55The gamin-python package contains a module that allow monitoring of
56files and directories from the Python language based on the support
57of the gamin package.
58
59%description python -l ja
60gamin-python は gamin ライブラリを利用して Python 言語からファイルや
61ディレクトリのモニタリングを行うためのモジュールです。
62
63## to build compat32 for x86_64 architecture support
64%package -n compat32-%{name}
65Summary: Library providing the FAM File Alteration Monitor API
66Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
67Group: System Environment/Daemons
68Requires: gamin = %{version}-%{release}
69
70%description -n compat32-%{name}
71The Gamin library provides an API and ABI compatible file alteration
72monitor mechanism compatible with FAM but not dependent on a system wide
73daemon.
74
75%description -n compat32-%{name} -l ja
76Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
77します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
78パープログラムをオンデマンドに起動します。
79
80%package -n compat32-%{name}-devel
81Summary: Development files for the Gamin library
82Summary(ja): Gamin ライブラリの開発用ファイル
83Group: Development/Libraries
84Requires: compat32-gamin = %{version}-%{release}
85
86%description -n compat32-%{name}-devel
87The Gamin library provides an API and ABI compatible file alteration
88monitor mechanism compatible with FAM but not dependent on a system wide
89daemon.
90
91%description -n compat32-%{name}-devel -l ja
92Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
93します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
94
95%prep
96%setup -q
97
98%build
99%configure
100%__make %{?_smp_mflags}
101
102%install
103rm -fr %{buildroot}
104
105%makeinstall
106
107## remove unuse files
108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{python_archlib}/*.la
110
111
112%clean
113rm -fr %{buildroot}
114
115%post -p /sbin/ldconfig
116
117%postun -p /sbin/ldconfig
118
119%post -n compat32-%{name} -p /sbin/ldconfig
120
121%postun -n compat32-%{name} -p /sbin/ldconfig
122
123%files
124%defattr(-, root, root)
125
126%doc AUTHORS ChangeLog NEWS README Copyright TODO
127%doc doc/*.html
128%doc doc/*.gif
129%doc doc/*.txt
130%{_libdir}/lib*.so.*
131%{_libexecdir}/gam_server
132
133%files devel
134%defattr(-, root, root)
135
136%{_libdir}/lib*.so
137%{_libdir}/*a
138%{_includedir}/fam.h
139%{_libdir}/pkgconfig/gamin.pc
140
141%files python
142%defattr(-, root, root)
143%doc AUTHORS ChangeLog NEWS README Copyright TODO
144%{_libdir}/python*/site-packages/gamin.py*
145%{_libdir}/python*/site-packages/_gamin*
146%doc python/tests/*.py
147%doc doc/python.html
148
149%if %{build_compat32}
150%files -n compat32-%{name}
151%defattr(-, root, root)
152%{_libdir}/lib*.so.*
153
154%files -n compat32-%{name}-devel
155%defattr(-, root, root)
156%{_libdir}/lib*.so
157%{_libdir}/*a
158%{_libdir}/pkgconfig/gamin.pc
159%endif
160
161%changelog
162* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
163- rebuild with python-2.6
164
165* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
166- new upstream release
167
168* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
169- fix license tag to LGPLv2
170- import patches from Fedora development
171  - Patch0: don't poll for non-existant watched files
172  - Patch1: Fix a memory leak
173  - Patch2: workaround for missing struct ucred in glibc headers
174    (fixed x86_64/ppc compilation)
175
176* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
177- spec in utf-8
178- removed *.la
179
180* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
181- added compat32-* packages for x86_64 architecture support
182- applied new versioning policy
183
184* Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
185- new upstream release
186- Patch10 was included in upstream, dropped
187
188* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
189- added Patch10 (<BTS:507>) which should be fixed in the new upstream release
190
191* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
192- new upstream release
193
194* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
195- stop removing *.la
196
197* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
198- initial build for Vine Linux
199
200* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
201- bump again for double-long bug on ppc(64)
202
203* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
204- rebuilt for new gcc4.1 snapshot and glibc changes
205
206* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
207- rebuilt
208
209* Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
210- hopefully fixes gam_server crashes
211- some portability fixes
212- removed a minor leak
213* Thu Sep  8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
214- revamp of the inotify back-end
215- memory leak fix
216- various fixes and cleanups
217* Tue Aug  9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
218- Improvement of configuration, system wide configuration files and
219  per filesystem type default
220- Rewrite of the inotify back-end, reduce resources usage, tuning in
221  case of busy resources
222- Documentation updates
223- Changes to compile inotify back-end on various architectures
224- Debugging output improvements
225* Tue Aug  2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
226- Fix to compile on older gcc versions
227- Inotify back-end changes and optimizations
228- Debug ouput cleanup, pid and process name reports
229- Dropped kernel monitor bugfix
230- Removed the old glist copy used for debugging
231- Maintain mounted filesystems knowledge, and per fstype preferences
232* Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
233- inotify back end patches, ready for the new inotify support in kernel
234- lot of server code cleanup patches
235- fixed an authentication problem
236* Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
237- gamin_data_conn_event fix
238- crash from bug gnome #303932
239- Inotify and mounted media #171201
240- mounted media did not show up on Desktop #159748
241- write may not be atomic
242- Monitoring a directory when it is a file
243- Portability to Hurd/Mach and various code cleanups
244- Added support for ~ as user home alias in .gaminrc
245* Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
246- Close inherited file descriptors on exec of gam_server
247- Cancelling a monitor send back a FAMAcknowledge
248- Fixed for big files > 2GB
249- Bug when monitoring a non existing directory
250- Make client side thread safe
251- Unreadable directory fixes
252- Better flow control handling
253- Updated to latest inotify version: 0.23-6
254* Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
255- Fix an include problem showing up with gcc4</li>
256- Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
257- removed an incompatibility with SGI FAM #149822
258* Tue Mar  1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
259- Fix a configure problem reported by Martin Schlemmer
260- Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
261- Fix the monitoring of directory using poll and not kernel
262* Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
263- more documentation
264- lot of serious bug fixes including Gnome Desktop refresh bug
265- extending the framework for more debug (configure --enable-debug-api)
266- extending the python bindings for watching the same resource multiple times
267  and adding debug framework support
268- growing the regression tests a lot based on python bindings
269- inotify-0.19 patch from John McCutchan
270- renamed python private module to _gamin to follow Python PEP 8
271
272* Tue Feb  8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
273- memory corruption fix from Mark on the client side
274- extending the protocol and API to allow skipping Exists and EndExists
275  events to avoid deadlock on reconnect or when they are not used.
276
277* Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
278- bit of python bindings improvements, added test
279- fixed 3 bugs
280
281* Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
282- Added Python support
283- Updated for inotify-0.18
284
285* Thu Jan  6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
286- Frederic Crozat seems to have found the GList corruption which may fix
287  #132354 and related problems
288- Frederic Crozat also fixed poll only mode
289
290* Fri Dec  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
291- still chasing the loop bug, made another pass at checking GList,
292  added own copy with memory poisonning of GList implementation.
293- fixed a compile issue when compiling without debug
294
295* Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
296- still chasing the loop bug, checked and cleaned up all GList use
297- patch from markmc to minimize load on busy apps
298
299* Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
300- chasing #132354, lot of debugging, checking and testing and a bit
301  of refactoring
302
303* Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
304- workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
305
306* Sun Oct  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
307- Found and fixed the annoying bug where update were not received
308  should fix bugs ##132429, #133665 and #134413
309- new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
310- Added documentation about internals
311
312* Fri Oct  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
313- applied portability fixes
314- hardened the code while chasing a segfault
315
316* Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
317- potential fix for a hard to reproduce looping problem.
318
319* Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
320- update to the latest version of inotify
321- inotify support compiled in by default
322- fix ABI FAM compatibility problems #133162
323
324* Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
325- more documentation
326- Added support for a configuration file $HOME/.gaminrc
327- fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
328
329* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
330- fix crash with konqueror #130967
331- exclude kernel (dnotify) monitoring for /mnt//* /media//*
332
333* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
334- Fixes crashes of the gam_server
335- try to correct the kernel/poll switching mode
336
337* Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
338- add support for both polling and dnotify simultaneously
339- fixes monitoring of initially missing files
340- load control on very busy resources #124361, desactivating
341  dnotify and falling back to polling for CPU drain
342
343* Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
344- fixes simple file monitoring should close RH #129974
345- relocate gam_server in $(libexec)
346
347* Thu Aug  5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
348- Fix a crash when the client binary forks the gam_server and an
349  atexit handler is run.
350
351* Wed Aug  4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
352- should fix KDE build problems
Note: See TracBrowser for help on using the repository browser.