source: projects/specs/trunk/g/galera/galera-vl.spec @ 12464

Revision 12464, 8.7 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

galera-26.4.5-1

mariadb-10.5.5-1

Line 
1%bcond_with             systemd
2%bcond_with             python3
3
4%define mariadb_version 10.5.5
5
6%if %{with python3}
7%global scons scons-3
8%else
9%global scons scons
10%endif
11
12Summary:        Synchronous multi-master wsrep provider (replication engine)
13Name:           galera
14Version:        26.4.5
15Release:        1%{?_dist_release}%{?with_systemd:.systemd}
16%global         galera_api_version %(echo %{version} | cut -d . -f 1,2)
17Group:          servers
18Vendor:         Project Vine
19Distribution:   Vine Linux
20
21License:        GPLv2
22URL:            http://galeracluster.com/
23# Actually, the truth is, we do use galera source tarball provided by MariaDB on
24# following URL (without macros):
25#   https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
26Source0:        https://downloads.mariadb.com/MariaDB/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
27
28Source1:        garbd.service
29Source2:        garbd-wrapper
30Source3:        garbd.init
31
32Patch0:         galera-python3.patch
33
34BuildRequires:  libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
35%if %{with systemd}
36BuildRequires:  systemd
37%endif
38Requires:       nmap
39Provides:       galera(%{galera_api_version})
40
41%if %{with systemd}
42Requires(post): systemd
43Requires(preun): systemd
44Requires(postun): systemd
45%else
46Requires(post): chkconfig
47Requires(preun): chkconfig initscripts
48%endif
49
50%description
51Galera is a fast synchronous multi-master wsrep provider (replication engine)
52for transactional databases and similar applications. For more information
53about wsrep API see http://launchpad.net/wsrep. For a description of Galera
54replication engine see http://www.codership.com.
55
56
57%debug_package
58
59
60%prep
61%setup -q
62%if %{with python3}
63%patch0 -p1
64%endif
65
66%build
67CPPFLAGS="%{optflags}"
68CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
69export CPPFLAGS
70
71%{scons} %{?_smp_mflags} strict_build_flags=0
72
73
74%install
75%if %{with systemd}
76install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
77install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
78%else
79install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
80%endif
81install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
82install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
83install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
84install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
85install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
86install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
87install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
88install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
89
90
91%post
92/sbin/ldconfig
93%if %{with systemd}
94%systemd_post garbd.service
95%else
96/sbin/chkconfig --add garbd
97%endif
98
99%preun
100%if %{with systemd}
101%systemd_preun garbd.service
102%else
103if [ $1 = 0 -o -x /bin/systemctl ]; then
104/sbin/service garbd stop >/dev/null 2>/dev/null ||:
105/sbin/chkconfig --del garbd
106fi
107%endif
108
109%postun
110/sbin/ldconfig
111%if %{with systemd}
112%systemd_postun_with_restart garbd.service
113%endif
114
115
116%files
117%license %{_docdir}/galera/COPYING
118%license %{_docdir}/galera/LICENSE.asio
119%license %{_docdir}/galera/LICENSE.crc32
120%doc %{_docdir}/galera/README
121%doc %{_docdir}/galera/README-MySQL
122%config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
123%dir %{_docdir}/galera
124%dir %{_libdir}/galera
125%{_sbindir}/garbd
126%if %{with systemd}
127%{_sbindir}/garbd-wrapper
128%{_unitdir}/garbd.service
129%else
130%{_initdir}/garbd
131%endif
132%{_libdir}/galera/libgalera_smm.so
133
134
135%changelog
136* Wed Aug 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.5-1
137- new upstream release.
138
139* Thu May 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.4-1
140- new upstream release.
141
142* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-2
143- rebuilt with boost-1.72.0.
144
145* Wed Nov 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-1
146- new upstream release.
147
148* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
149- updated to 26.4.2 for MariaDB-10.4.
150
151* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
152- initial build for Vine Linux.
153
154* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
156
157* Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
158- Rebuilt for Boost 1.69
159
160* Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
161- Rebase to 25.3.25
162
163* Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
164- Require asio also on rhel
165
166* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
167- Add explicit gcc-c++ BR
168- Use python3-scons
169
170* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
171- Do not require asio on rhel
172
173* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
175
176* Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
177- Update to 25.3.23
178
179* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
181
182* Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
183- Update to 25.3.22
184
185* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
187
188* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
190
191* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
192- Rebuilt for Boost 1.64
193
194* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
196
197* Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
198- Use asio-devel instead of bundled asio library
199
200* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
202
203* Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
204- Update to 25.3.16
205
206* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
207- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
208
209* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
210- Rebuilt for Boost 1.60
211
212* Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
213- Remove use of -mtune=native which breaks build on secondary architectures
214
215* Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
216- Update to 25.3.12.
217- Should fix the build on 32 bit ARM (RHBZ#1241164).
218- Remove ExcludeArch (should have read the BZ more closely).
219
220* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
221- Rebuilt for Boost 1.59
222
223* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
224- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
225
226* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
227- rebuild for Boost 1.58
228
229* Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
230- Disable ARM builds (#1241164, #1239516)
231
232* Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
233- Update to version 25.3.10
234
235* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
237
238* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
239- Rebuild for boost 1.57.0
240
241* Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
242- Add aarch64 support.
243
244* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
245- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
246
247* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
249
250* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
251- Rebuild for boost 1.55.0
252
253* Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
254- set ExclusiveArch
255
256* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
257- Use strict_build_flags=0 to avoid -Werror
258- Remove unnecessary clean section
259
260* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
261- Include galera directories in file list
262- Set CPPFLAGS to optflags
263
264* Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
265- Fix client certificate verification (#1090604)
266
267* Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
268- Update to version 25.3.5
269
270* Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
271- Add systemd service
272
273* Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
274- Initial build
Note: See TracBrowser for help on using the repository browser.