source: projects/specs/trunk/g/galera/galera-vl.spec @ 12537

Revision 12537, 8.7 KB checked in by tomop, 3 years ago (diff)

updated 8 packages

Field3D-1.7.3-3

OpenImageIO-2.2.11.1-1

c-ares-1.17.1-1

curl-7.75.0-1

galera-26.4.6-1

libboost-1.75.0-1

nghttp2-1.43.0-1

source-highlight-3.1.8-3

Line 
1%bcond_with             systemd
2%bcond_with             python3
3
4%define mariadb_version 10.5.8
5
6%if %{with python3}
7%global scons scons-3
8%else
9%global scons scons
10%endif
11
12Summary:        Synchronous multi-master wsrep provider (replication engine)
13Name:           galera
14Version:        26.4.6
15Release:        1%{?_dist_release}%{?with_systemd:.systemd}
16%global         galera_api_version %(echo %{version} | cut -d . -f 1,2)
17Group:          servers
18Vendor:         Project Vine
19Distribution:   Vine Linux
20
21License:        GPLv2
22URL:            http://galeracluster.com/
23# Actually, the truth is, we do use galera source tarball provided by MariaDB on
24# following URL (without macros):
25#   https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
26Source0:        https://downloads.mariadb.com/MariaDB/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
27
28Source1:        garbd.service
29Source2:        garbd-wrapper
30Source3:        garbd.init
31
32Patch0:         galera-python3.patch
33
34BuildRequires:  libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
35%if %{with systemd}
36BuildRequires:  systemd
37%endif
38Requires:       nmap
39Provides:       galera(%{galera_api_version})
40
41%if %{with systemd}
42Requires(post): systemd
43Requires(preun): systemd
44Requires(postun): systemd
45%else
46Requires(post): chkconfig
47Requires(preun): chkconfig initscripts
48%endif
49
50%description
51Galera is a fast synchronous multi-master wsrep provider (replication engine)
52for transactional databases and similar applications. For more information
53about wsrep API see http://launchpad.net/wsrep. For a description of Galera
54replication engine see http://www.codership.com.
55
56
57%debug_package
58
59
60%prep
61%setup -q
62%if %{with python3}
63%patch0 -p1
64%endif
65
66%build
67CPPFLAGS="%{optflags}"
68CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
69export CPPFLAGS
70
71%{scons} %{?_smp_mflags} strict_build_flags=0
72
73
74%install
75%if %{with systemd}
76install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
77install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
78%else
79install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
80%endif
81install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
82install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
83install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
84install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
85install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
86install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
87install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
88
89
90%post
91/sbin/ldconfig
92%if %{with systemd}
93%systemd_post garbd.service
94%else
95/sbin/chkconfig --add garbd
96%endif
97
98%preun
99%if %{with systemd}
100%systemd_preun garbd.service
101%else
102if [ $1 = 0 -o -x /bin/systemctl ]; then
103/sbin/service garbd stop >/dev/null 2>/dev/null ||:
104/sbin/chkconfig --del garbd
105fi
106%endif
107
108%postun
109/sbin/ldconfig
110%if %{with systemd}
111%systemd_postun_with_restart garbd.service
112%endif
113
114
115%files
116%license %{_docdir}/galera/COPYING
117%license %{_docdir}/galera/LICENSE.asio
118%doc %{_docdir}/galera/README
119%doc %{_docdir}/galera/README-MySQL
120%config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
121%dir %{_docdir}/galera
122%dir %{_libdir}/galera
123%{_sbindir}/garbd
124%if %{with systemd}
125%{_sbindir}/garbd-wrapper
126%{_unitdir}/garbd.service
127%else
128%{_initdir}/garbd
129%endif
130%{_libdir}/galera/libgalera_smm.so
131
132
133%changelog
134* Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.6-1
135- new upstream release.
136
137* Wed Aug 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.5-1
138- new upstream release.
139
140* Thu May 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.4-1
141- new upstream release.
142
143* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-2
144- rebuilt with boost-1.72.0.
145
146* Wed Nov 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-1
147- new upstream release.
148
149* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
150- updated to 26.4.2 for MariaDB-10.4.
151
152* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
153- initial build for Vine Linux.
154
155* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
157
158* Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
159- Rebuilt for Boost 1.69
160
161* Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
162- Rebase to 25.3.25
163
164* Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
165- Require asio also on rhel
166
167* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
168- Add explicit gcc-c++ BR
169- Use python3-scons
170
171* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
172- Do not require asio on rhel
173
174* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
176
177* Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
178- Update to 25.3.23
179
180* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
182
183* Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
184- Update to 25.3.22
185
186* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
188
189* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
191
192* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
193- Rebuilt for Boost 1.64
194
195* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
197
198* Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
199- Use asio-devel instead of bundled asio library
200
201* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
203
204* Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
205- Update to 25.3.16
206
207* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
209
210* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
211- Rebuilt for Boost 1.60
212
213* Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
214- Remove use of -mtune=native which breaks build on secondary architectures
215
216* Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
217- Update to 25.3.12.
218- Should fix the build on 32 bit ARM (RHBZ#1241164).
219- Remove ExcludeArch (should have read the BZ more closely).
220
221* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
222- Rebuilt for Boost 1.59
223
224* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
225- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
226
227* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
228- rebuild for Boost 1.58
229
230* Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
231- Disable ARM builds (#1241164, #1239516)
232
233* Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
234- Update to version 25.3.10
235
236* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
237- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
238
239* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
240- Rebuild for boost 1.57.0
241
242* Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
243- Add aarch64 support.
244
245* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
246- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
247
248* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
249- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
250
251* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
252- Rebuild for boost 1.55.0
253
254* Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
255- set ExclusiveArch
256
257* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
258- Use strict_build_flags=0 to avoid -Werror
259- Remove unnecessary clean section
260
261* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
262- Include galera directories in file list
263- Set CPPFLAGS to optflags
264
265* Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
266- Fix client certificate verification (#1090604)
267
268* Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
269- Update to version 25.3.5
270
271* Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
272- Add systemd service
273
274* Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
275- Initial build
Note: See TracBrowser for help on using the repository browser.