source: projects/specs/trunk/g/galera/galera-vl.spec @ 12387

Revision 12387, 8.5 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

Field3D-1.7.3-1

OpenImageIO-2.1.10.1-1

ekiga-4.0.1-11

galera-26.4.3-2

gnucash-3.10-1

libboost-1.72.0-1

nghttp2-1.40.0-2

opal-3.10.11-1

ptlib-2.10.11-1

source-highlight-3.1.8-2

Line 
1%bcond_with             systemd
2%bcond_with             python3
3
4%define galera_api_version 26.4
5%define mariadb_version 10.4.12
6
7%if %{with python3}
8%global scons scons-3
9%else
10%global scons scons
11%endif
12
13Name:           galera
14Version:        %{galera_api_version}.3
15Release:        2%{?_dist_release}%{?with_systemd:.systemd}
16Summary:        Synchronous multi-master wsrep provider (replication engine)
17
18License:        GPLv2
19URL:            http://galeracluster.com/
20
21# Actually, the truth is, we do use galera source tarball provided by MariaDB on
22# following URL (without macros):
23#   https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
24
25Source0:        https://downloads.mariadb.com/MariaDB/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
26
27Source1:        garbd.service
28Source2:        garbd-wrapper
29Source3:        garbd.init
30
31Patch0:         galera-python3.patch
32
33BuildRequires:  libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
34%if %{with systemd}
35BuildRequires:  systemd
36%endif
37Requires:       nmap
38Provides:       galera(%{galera_api_version})
39
40%if %{with systemd}
41Requires(post): systemd
42Requires(preun): systemd
43Requires(postun): systemd
44%else
45Requires(post): chkconfig
46Requires(preun): chkconfig initscripts
47%endif
48
49%description
50Galera is a fast synchronous multi-master wsrep provider (replication engine)
51for transactional databases and similar applications. For more information
52about wsrep API see http://launchpad.net/wsrep. For a description of Galera
53replication engine see http://www.codership.com.
54
55
56%debug_package
57
58
59%prep
60%setup -q
61%if %{with python3}
62%patch0 -p1
63%endif
64
65%build
66CPPFLAGS="%{optflags}"
67CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
68export CPPFLAGS
69
70%{scons} %{?_smp_mflags} strict_build_flags=0
71
72
73%install
74%if %{with systemd}
75install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
76install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
77%else
78install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
79%endif
80install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
81install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
82install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
83install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
84install -D -m 644 chromium/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.chromium
85install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
86install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
87install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
88install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
89
90
91%post
92/sbin/ldconfig
93%if %{with systemd}
94%systemd_post garbd.service
95%else
96/sbin/chkconfig --add garbd
97%endif
98
99%preun
100%if %{with systemd}
101%systemd_preun garbd.service
102%else
103if [ $1 = 0 ]; then
104/sbin/service garbd stop >/dev/null 2>/dev/null ||:
105/sbin/chkconfig --del garbd
106fi
107%endif
108
109%postun
110/sbin/ldconfig
111%if %{with systemd}
112%systemd_postun_with_restart garbd.service
113%endif
114
115
116%files
117%config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
118%dir %{_docdir}/galera
119%dir %{_libdir}/galera
120%{_sbindir}/garbd
121%if %{with systemd}
122%{_sbindir}/garbd-wrapper
123%{_unitdir}/garbd.service
124%else
125%{_initdir}/garbd
126%endif
127%{_libdir}/galera/libgalera_smm.so
128%license %{_docdir}/galera/COPYING
129%license %{_docdir}/galera/LICENSE.asio
130%license %{_docdir}/galera/LICENSE.crc32
131%license %{_docdir}/galera/LICENSE.chromium
132%doc %{_docdir}/galera/README
133%doc %{_docdir}/galera/README-MySQL
134
135
136%changelog
137* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-2
138- rebuilt with boost-1.72.0.
139
140* Wed Nov 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-1
141- new upstream release.
142
143* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
144- updated to 26.4.2 for MariaDB-10.4.
145
146* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
147- initial build for Vine Linux.
148
149* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
151
152* Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
153- Rebuilt for Boost 1.69
154
155* Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
156- Rebase to 25.3.25
157
158* Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
159- Require asio also on rhel
160
161* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
162- Add explicit gcc-c++ BR
163- Use python3-scons
164
165* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
166- Do not require asio on rhel
167
168* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
170
171* Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
172- Update to 25.3.23
173
174* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
176
177* Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
178- Update to 25.3.22
179
180* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
182
183* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
185
186* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
187- Rebuilt for Boost 1.64
188
189* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
191
192* Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
193- Use asio-devel instead of bundled asio library
194
195* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
197
198* Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
199- Update to 25.3.16
200
201* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
203
204* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
205- Rebuilt for Boost 1.60
206
207* Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
208- Remove use of -mtune=native which breaks build on secondary architectures
209
210* Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
211- Update to 25.3.12.
212- Should fix the build on 32 bit ARM (RHBZ#1241164).
213- Remove ExcludeArch (should have read the BZ more closely).
214
215* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
216- Rebuilt for Boost 1.59
217
218* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
219- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
220
221* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
222- rebuild for Boost 1.58
223
224* Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
225- Disable ARM builds (#1241164, #1239516)
226
227* Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
228- Update to version 25.3.10
229
230* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
232
233* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
234- Rebuild for boost 1.57.0
235
236* Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
237- Add aarch64 support.
238
239* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
240- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
241
242* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
244
245* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
246- Rebuild for boost 1.55.0
247
248* Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
249- set ExclusiveArch
250
251* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
252- Use strict_build_flags=0 to avoid -Werror
253- Remove unnecessary clean section
254
255* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
256- Include galera directories in file list
257- Set CPPFLAGS to optflags
258
259* Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
260- Fix client certificate verification (#1090604)
261
262* Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
263- Update to version 25.3.5
264
265* Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
266- Add systemd service
267
268* Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
269- Initial build
Note: See TracBrowser for help on using the repository browser.