source: projects/specs/trunk/g/galera/galera-vl.spec @ 12310

Revision 12310, 8.4 KB checked in by tomop, 5 years ago (diff)

updated 18 packages

bind-9.11.12-1

bison-3.4.2-1

clisp-2.49.93-1

exiv2-0.27.2-1

firefox-68.2.0-1

galera-26.4.3-1

gcr-3.28.1-1

glib2-2.62.2-1

golang-1.13.4-1

incron-0.5.12-3

libgexiv2-0.12.0-1

libsecret-0.18.8-2

mariadb-10.4.10-1

perl-Bit-Vector-7.4-1

perl-Class-Accessor-0.51-1

seahorse-3.34-1

thunderbird-68.2.1-1

wireshark-3.0.6-1

Line 
1%bcond_with             systemd
2%bcond_with             python3
3
4%define galera_api_version 26.4
5%define mariadb_version 10.4.9
6
7%if %{with python3}
8%global scons scons-3
9%else
10%global scons scons
11%endif
12
13Name:           galera
14Version:        %{galera_api_version}.3
15Release:        1%{?_dist_release}
16Summary:        Synchronous multi-master wsrep provider (replication engine)
17
18License:        GPLv2
19URL:            http://galeracluster.com/
20
21# Actually, the truth is, we do use galera source tarball provided by MariaDB on
22# following URL (without macros):
23#   https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
24
25Source0:        https://downloads.mariadb.com/MariaDB/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
26
27Source1:        garbd.service
28Source2:        garbd-wrapper
29Source3:        garbd.init
30
31Patch0:         galera-python3.patch
32
33BuildRequires:  libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
34%if %{with systemd}
35BuildRequires:  systemd
36%endif
37Requires:       nmap
38Provides:       galera(%{galera_api_version})
39
40%if %{with systemd}
41Requires(post): systemd
42Requires(preun): systemd
43Requires(postun): systemd
44%else
45Requires(post): chkconfig
46Requires(preun): chkconfig initscripts
47%endif
48
49
50%description
51Galera is a fast synchronous multi-master wsrep provider (replication engine)
52for transactional databases and similar applications. For more information
53about wsrep API see http://launchpad.net/wsrep. For a description of Galera
54replication engine see http://www.codership.com.
55
56
57%prep
58%setup -q
59%if %{with python3}
60%patch0 -p1
61%endif
62
63%build
64CPPFLAGS="%{optflags}"
65CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
66export CPPFLAGS
67
68%{scons} %{?_smp_mflags} strict_build_flags=0
69
70
71%install
72%if %{with systemd}
73install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
74install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
75%else
76install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
77%endif
78install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
79install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
80install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
81install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
82install -D -m 644 chromium/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.chromium
83install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
84install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
85install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
86install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
87
88
89%post
90/sbin/ldconfig
91%if %{with systemd}
92%systemd_post garbd.service
93%else
94/sbin/chkconfig --add garbd
95%endif
96
97%preun
98%if %{with systemd}
99%systemd_preun garbd.service
100%else
101if [ $1 = 0 ]; then
102/sbin/service garbd stop >/dev/null 2>/dev/null ||:
103/sbin/chkconfig --del garbd
104fi
105%endif
106
107%postun
108/sbin/ldconfig
109%if %{with systemd}
110%systemd_postun_with_restart garbd.service
111%endif
112
113
114%files
115%config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
116%dir %{_docdir}/galera
117%dir %{_libdir}/galera
118%{_sbindir}/garbd
119%if %{with systemd}
120%{_sbindir}/garbd-wrapper
121%{_unitdir}/garbd.service
122%else
123%{_initdir}/garbd
124%endif
125%{_libdir}/galera/libgalera_smm.so
126%license %{_docdir}/galera/COPYING
127%license %{_docdir}/galera/LICENSE.asio
128%license %{_docdir}/galera/LICENSE.crc32
129%license %{_docdir}/galera/LICENSE.chromium
130%doc %{_docdir}/galera/README
131%doc %{_docdir}/galera/README-MySQL
132
133
134%changelog
135* Wed Nov 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-1
136- new upstream release.
137
138* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
139- updated to 26.4.2 for MariaDB-10.4.
140
141* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
142- initial build for Vine Linux.
143
144* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
146
147* Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
148- Rebuilt for Boost 1.69
149
150* Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
151- Rebase to 25.3.25
152
153* Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
154- Require asio also on rhel
155
156* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
157- Add explicit gcc-c++ BR
158- Use python3-scons
159
160* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
161- Do not require asio on rhel
162
163* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
165
166* Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
167- Update to 25.3.23
168
169* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
171
172* Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
173- Update to 25.3.22
174
175* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
177
178* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
180
181* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
182- Rebuilt for Boost 1.64
183
184* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
185- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
186
187* Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
188- Use asio-devel instead of bundled asio library
189
190* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
191- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
192
193* Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
194- Update to 25.3.16
195
196* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
198
199* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
200- Rebuilt for Boost 1.60
201
202* Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
203- Remove use of -mtune=native which breaks build on secondary architectures
204
205* Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
206- Update to 25.3.12.
207- Should fix the build on 32 bit ARM (RHBZ#1241164).
208- Remove ExcludeArch (should have read the BZ more closely).
209
210* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
211- Rebuilt for Boost 1.59
212
213* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
214- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
215
216* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
217- rebuild for Boost 1.58
218
219* Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
220- Disable ARM builds (#1241164, #1239516)
221
222* Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
223- Update to version 25.3.10
224
225* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
227
228* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
229- Rebuild for boost 1.57.0
230
231* Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
232- Add aarch64 support.
233
234* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
235- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
236
237* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
239
240* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
241- Rebuild for boost 1.55.0
242
243* Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
244- set ExclusiveArch
245
246* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
247- Use strict_build_flags=0 to avoid -Werror
248- Remove unnecessary clean section
249
250* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
251- Include galera directories in file list
252- Set CPPFLAGS to optflags
253
254* Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
255- Fix client certificate verification (#1090604)
256
257* Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
258- Update to version 25.3.5
259
260* Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
261- Add systemd service
262
263* Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
264- Initial build
Note: See TracBrowser for help on using the repository browser.