source: projects/specs/trunk/g/galera/galera-vl.spec @ 12131

Revision 12131, 8.3 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%bcond_with             systemd
2%bcond_with             python3
3
4%define galera_api_version 26.4
5%define mariadb_version 10.4.7
6
7%if %{with python3}
8%global scons scons-3
9%else
10%global scons scons
11%endif
12
13Name:           galera
14Version:        %{galera_api_version}.2
15Release:        1%{?_dist_release}
16Summary:        Synchronous multi-master wsrep provider (replication engine)
17
18License:        GPLv2
19URL:            http://galeracluster.com/
20
21# Actually, the truth is, we do use galera source tarball provided by MariaDB on
22# following URL (without macros):
23#   https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
24
25Source0:        http://ftp.yz.yamagata-u.ac.jp/pub/dbms/mariadb/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
26
27
28Source1:        garbd.service
29Source2:        garbd-wrapper
30Source3:        garbd.init
31
32Patch0:         galera-python3.patch
33
34BuildRequires:  libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
35%if %{with systemd}
36BuildRequires:  systemd
37%endif
38Requires:       nmap
39Provides:       galera(%{galera_api_version})
40
41%if %{with systemd}
42Requires(post): systemd
43Requires(preun): systemd
44Requires(postun): systemd
45%else
46Requires(post): chkconfig
47Requires(preun): chkconfig initscripts
48%endif
49
50
51%description
52Galera is a fast synchronous multi-master wsrep provider (replication engine)
53for transactional databases and similar applications. For more information
54about wsrep API see http://launchpad.net/wsrep. For a description of Galera
55replication engine see http://www.codership.com.
56
57
58%prep
59%setup -q
60%if %{with python3}
61%patch0 -p1
62%endif
63
64%build
65CPPFLAGS="%{optflags}"
66CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
67export CPPFLAGS
68
69%{scons} %{?_smp_mflags} strict_build_flags=0
70
71
72%install
73%if %{with systemd}
74install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
75install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
76%else
77install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
78%endif
79install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
80install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
81install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
82install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
83install -D -m 644 chromium/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.chromium
84install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
85install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
86install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
87install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
88
89
90%post
91/sbin/ldconfig
92%if %{with systemd}
93%systemd_post garbd.service
94%else
95/sbin/chkconfig --add garbd
96%endif
97
98%preun
99%if %{with systemd}
100%systemd_preun garbd.service
101%else
102if [ $1 = 0 ]; then
103/sbin/service garbd stop >/dev/null 2>/dev/null ||:
104/sbin/chkconfig --del garbd
105fi
106%endif
107
108%postun
109/sbin/ldconfig
110%if %{with systemd}
111%systemd_postun_with_restart garbd.service
112%endif
113
114
115%files
116%config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
117%dir %{_docdir}/galera
118%dir %{_libdir}/galera
119%{_sbindir}/garbd
120%if %{with systemd}
121%{_sbindir}/garbd-wrapper
122%{_unitdir}/garbd.service
123%else
124%{_initdir}/garbd
125%endif
126%{_libdir}/galera/libgalera_smm.so
127%license %{_docdir}/galera/COPYING
128%license %{_docdir}/galera/LICENSE.asio
129%license %{_docdir}/galera/LICENSE.crc32
130%license %{_docdir}/galera/LICENSE.chromium
131%doc %{_docdir}/galera/README
132%doc %{_docdir}/galera/README-MySQL
133
134
135%changelog
136* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
137- updated to 26.4.2 for MariaDB-10.4.
138
139* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
140- initial build for Vine Linux.
141
142* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
144
145* Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
146- Rebuilt for Boost 1.69
147
148* Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
149- Rebase to 25.3.25
150
151* Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
152- Require asio also on rhel
153
154* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
155- Add explicit gcc-c++ BR
156- Use python3-scons
157
158* Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
159- Do not require asio on rhel
160
161* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
163
164* Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
165- Update to 25.3.23
166
167* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
169
170* Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
171- Update to 25.3.22
172
173* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
175
176* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
178
179* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
180- Rebuilt for Boost 1.64
181
182* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
184
185* Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
186- Use asio-devel instead of bundled asio library
187
188* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
190
191* Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
192- Update to 25.3.16
193
194* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
196
197* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
198- Rebuilt for Boost 1.60
199
200* Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
201- Remove use of -mtune=native which breaks build on secondary architectures
202
203* Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
204- Update to 25.3.12.
205- Should fix the build on 32 bit ARM (RHBZ#1241164).
206- Remove ExcludeArch (should have read the BZ more closely).
207
208* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
209- Rebuilt for Boost 1.59
210
211* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
212- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
213
214* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
215- rebuild for Boost 1.58
216
217* Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
218- Disable ARM builds (#1241164, #1239516)
219
220* Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
221- Update to version 25.3.10
222
223* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
225
226* Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
227- Rebuild for boost 1.57.0
228
229* Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
230- Add aarch64 support.
231
232* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
234
235* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
237
238* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
239- Rebuild for boost 1.55.0
240
241* Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
242- set ExclusiveArch
243
244* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
245- Use strict_build_flags=0 to avoid -Werror
246- Remove unnecessary clean section
247
248* Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
249- Include galera directories in file list
250- Set CPPFLAGS to optflags
251
252* Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
253- Fix client certificate verification (#1090604)
254
255* Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
256- Update to version 25.3.5
257
258* Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
259- Add systemd service
260
261* Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
262- Initial build
Note: See TracBrowser for help on using the repository browser.