source: projects/specs/trunk/g/g-wrap/g-wrap-vl.spec @ 521

Revision 521, 6.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver 1.9.11
2%define rel 1%{?_dist_release}
3
4Summary: A tool for creating Scheme interfaces to C libraries.
5Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
6Name: g-wrap
7Version: %{ver}
8Release: %{rel}
9Group: Development/Libraries
10License: GPL
11URL: http://www.gnucash.org/
12Source: ftp://ftp.gnucash.org/pub/g-wrap/%{name}-%{version}.tar.gz
13Patch0: g-wrap-1.9.6-shaddup.patch
14Patch1: g-wrap-1.9.11-libffi.patch
15Requires: guile
16BuildRequires: guile-devel, libffi-devel
17BuildRequires: glib2-devel, slib
18Prereq: /sbin/install-info /sbin/ldconfig
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24
25%description
26g-wrap is a tool for creating Scheme interfaces to C libraries.  At
27the moment it is most heavily focused on providing access to C
28libraries from guile, but it also supports RScheme.
29
30The g-wrap package contains the libraries necessary to run
31applications built with g-wrap.  If you wish to build applications
32that use g-wrap, you should install the g-wrap-devel package.
33
34%description -l ja
35g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
36guile から C言語のライブライリへのアクセスを提供することを目的
37としています。 RScheme もサポートしています
38
39g-wrap には g-wrap 使って作成したアプリケーションを動作させるために
40必要なライブラリが含まれています. g-wrap を使ってアプリケーションを
41作成したい場合 g-wrap-devel をinstallしてください.
42
43
44%package devel
45Summary: Include files and libraries needed for g-wrap development.
46Summary(ja): g-wrap を使用した開発に必要なヘッダファイルやライブラリ
47Group: Development/Libraries
48Prereq: /sbin/install-info
49Requires: g-wrap = %{version}, guile-devel
50
51
52%description devel
53g-wrap is a tool for creating Scheme interfaces to C libraries.  At
54the moment it is most heavily focused on providing access to C
55libraries from guile, but it also supports RScheme.
56
57You can provide access to a given C API by creating a specification
58file describing the interface you want published at the Scheme level.
59g-wrap will handle generating all the lower level library interface
60code so that the C library shows up as a set of Scheme functions.
61
62You should install g-wrap-devel if you need to compile programs that
63need to use g-wrap C<->Scheme functionality
64
65%description devel -l ja
66g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
67guile から C言語のライブライリへのアクセスを提供することを目的
68としています。 RScheme もサポートしています
69
70Schem レベルで表現したいインターフェースを記述を指定したファイルを作成
71することによりC PAI へのアクセスを提供します.
72g-wrap は 低レベルライブラリインターフェースすべての生成を扱うことが
73できます。したがって C ライブラリには Schem 関数の集合としてみえます.
74
75g-wrap のC と Scheme 間の変換機能を必要とするプログラムをコンパイルする
76場合 g-wrap-devel をinstallしておかねかればなりません.
77
78%prep
79%setup -q
80%patch0 -p1 -b .shaddup
81# https://savannah.nongnu.org/bugs/index.php?25187
82%patch1 -p1 -b .libffi
83
84%build
85%configure --disable-static
86
87#remove Rpath
88sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
89sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
90
91#Is not parallel-build-safe
92%{__make}
93
94%install
95%{__rm} -rf ${RPM_BUILD_ROOT}
96%{__make} install DESTDIR=${RPM_BUILD_ROOT}
97
98#Remove unneeded file
99find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
100rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir
101mv  ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm ./config.old
102cat config.old > config.scm
103install -p -m 644 config.scm  ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm
104
105
106%clean
107%{__rm} -rf ${RPM_BUILD_ROOT}
108
109
110%post -p /sbin/ldconfig
111
112%post devel
113/sbin/install-info \
114    --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
115
116
117%preun -p /sbin/ldconfig
118
119%preun devel
120if [ "$1" = "0" ]; then
121    /sbin/install-info --delete \
122        --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
123fi
124
125%files
126%defattr(-,root,root)
127%doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README THANKS
128%dir %{_libdir}/%{name}
129%dir %{_libdir}/%{name}/modules
130%{_libdir}/%{name}/modules/*.so.*
131%{_libdir}/*.so.*
132%{_datadir}/guile/site/*
133
134
135%files devel
136%defattr(-,root,root)
137%{_bindir}/*
138%{_libdir}/*.so
139%{_libdir}/%{name}/modules/libgw-guile-gw-glib.so
140%{_libdir}/%{name}/modules/libgw-guile-standard.so
141%{_includedir}/*
142%{_datadir}/aclocal/*
143%{_libdir}/pkgconfig/*
144%doc %{_infodir}/g-wrap.*
145
146
147%changelog
148* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.9.1-1
149- new upstream release
150- update BuildRequires: umb-scheme -> slib
151
152* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.4-10vl5
153- applied new versioning policy, spec in utf-8
154- removed *.la
155
156* Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-9vl1
157- added Patches from Fedora
158  * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> 1.3.4-9
159  - add patch for M4 quoting (#162649, <rc040203@freenet.de>)
160
161* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl3
162- rebuild with new toolchains
163- s/Copyright/License/
164
165* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl2
166- build against new guile 1.6.4
167
168* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2vl1
169- based on rawhide 1.3.4-2
170  - update to 1.3.4
171  - move .la files to main package (#79068)
172- rebuild with new guile 1.6.3
173
174* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1vl1
175- updated to 1.1.10
176
177* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl4
178- add defattr
179
180* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl2
181- japanized spec file ( add %descripsion -l ja Summary(ja)
182
183
184* Wed Nov 08 2000 Derek Atkins <warlord@MIT.EDU>
185- Don't destroy the build directory -- RPM can do that on its own
186- Properly build both g-wrap and g-wrap-devel (info file into -devel)
187- currently only one info file
188
189* Wed Oct 25 2000 Dave Peticolas <dave@krondo.com>
190- use /usr/info/* for automatic gzipping
191
192* Sat May 27 2000 Mark Horning <rip6@rip6.net>
193- Created spec file
Note: See TracBrowser for help on using the repository browser.