source: projects/specs/trunk/g/g-wrap/g-wrap-vl.spec @ 12376

Revision 12376, 6.7 KB checked in by tomop, 4 years ago (diff)

updated 19 packages

g-wrap-1.9.15-2

gjs-1.54.3-2

glib2-2.64.2-2

gobject-introspection-1.64.1-1

guile-2.2.7-1

guile20-2.0.14-5

hardinfo-0.5.1-4

llvm-10.0.0-2

libffi-3.3-1

libffi321-3.2.1-1

p11-kit-0.23.20-2

pycairo-1.18.2-1

pygobject-2.28.6-7

pygobject3-3.34.0-1

python-cffi-1.14.0-1

python-2.7.17-1

python3-3.5.9-1

ruby-2.6.6-2

uim-1.8.8-3

Line 
1Summary: A tool for creating Scheme interfaces to C libraries.
2Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
3Name: g-wrap
4Version: 1.9.15
5Release: 2%{?_dist_release}
6Group: Development/Libraries
7License: GPL
8URL: https://www.nongnu.org/g-wrap/
9Source: http://savannah.nongnu.org/download/g-wrap/%{name}-%{version}.tar.gz
10
11Requires: guile
12BuildRequires: guile-devel, libffi-devel
13BuildRequires: glib2-devel
14Requires(pre): /sbin/install-info /sbin/ldconfig
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20
21%description
22g-wrap is a tool for creating Scheme interfaces to C libraries.  At
23the moment it is most heavily focused on providing access to C
24libraries from guile, but it also supports RScheme.
25
26The g-wrap package contains the libraries necessary to run
27applications built with g-wrap.  If you wish to build applications
28that use g-wrap, you should install the g-wrap-devel package.
29
30%description -l ja
31g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
32guile から C言語のライブライリへのアクセスを提供することを目的
33としています。 RScheme もサポートしています
34
35g-wrap には g-wrap 使って作成したアプリケーションを動作させるために
36必要なライブラリが含まれています. g-wrap を使ってアプリケーションを
37作成したい場合 g-wrap-devel をinstallしてください.
38
39
40%package devel
41Summary: Include files and libraries needed for g-wrap development.
42Summary(ja): g-wrap を使用した開発に必要なヘッダファイルやライブラリ
43Group: Development/Libraries
44Requires(pre): /sbin/install-info
45Requires: g-wrap = %{version}, guile-devel
46
47
48%description devel
49g-wrap is a tool for creating Scheme interfaces to C libraries.  At
50the moment it is most heavily focused on providing access to C
51libraries from guile, but it also supports RScheme.
52
53You can provide access to a given C API by creating a specification
54file describing the interface you want published at the Scheme level.
55g-wrap will handle generating all the lower level library interface
56code so that the C library shows up as a set of Scheme functions.
57
58You should install g-wrap-devel if you need to compile programs that
59need to use g-wrap C<->Scheme functionality
60
61%description devel -l ja
62g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
63guile から C言語のライブライリへのアクセスを提供することを目的
64としています。 RScheme もサポートしています
65
66Schem レベルで表現したいインターフェースを記述を指定したファイルを作成
67することによりC PAI へのアクセスを提供します.
68g-wrap は 低レベルライブラリインターフェースすべての生成を扱うことが
69できます。したがって C ライブラリには Schem 関数の集合としてみえます.
70
71g-wrap のC と Scheme 間の変換機能を必要とするプログラムをコンパイルする
72場合 g-wrap-devel をinstallしておかねかればなりません.
73
74%prep
75%setup -q
76
77%build
78CFLAGS="%{optflags} -Wno-deprecated-declarations" \
79%configure --disable-static
80
81#remove Rpath
82sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
83sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
84
85#Is not parallel-build-safe
86%{__make}
87
88%install
89%{__rm} -rf ${RPM_BUILD_ROOT}
90%{__make} install DESTDIR=${RPM_BUILD_ROOT}
91
92#Remove unneeded file
93find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
94rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir
95mv  ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm ./config.old
96cat config.old > config.scm
97install -p -m 644 config.scm  ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm
98
99
100%clean
101%{__rm} -rf ${RPM_BUILD_ROOT}
102
103
104%post -p /sbin/ldconfig
105
106%post devel
107/sbin/install-info \
108    --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
109
110
111%preun -p /sbin/ldconfig
112
113%preun devel
114if [ "$1" = "0" ]; then
115    /sbin/install-info --delete \
116        --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
117fi
118
119%files
120%defattr(-,root,root)
121%license COPYING.LIB
122%doc AUTHORS ChangeLog INSTALL NEWS README THANKS
123%dir %{_libdir}/%{name}
124%dir %{_libdir}/%{name}/modules
125%{_libdir}/%{name}/modules/*.so.*
126%{_libdir}/*.so.*
127%{_datadir}/guile/site/*
128
129
130%files devel
131%defattr(-,root,root)
132%{_bindir}/*
133%{_libdir}/*.so
134%{_libdir}/%{name}/modules/libgw-guile-gw-glib.so
135%{_libdir}/%{name}/modules/libgw-guile-standard.so
136%{_includedir}/*
137%{_datadir}/aclocal/*
138%{_libdir}/pkgconfig/*
139%{_mandir}/man1/g-wrap-config.1.gz
140%doc %{_infodir}/g-wrap.*
141
142
143%changelog
144* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.15-2
145- rebuilt with libffi-3.3.
146
147* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.15-1
148- new upstream release.
149- built with guile-2.2.6.
150- dropped Patch0.
151
152* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-3
153- rebuild with guile-2.0.11
154- add Patch0 (g-wrap-1.9.14-guile-2.0.patch)
155
156* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-2
157- rebuild with libffi-3.0.13
158
159* Tue Jun 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-1
160- update to 1.9.14
161- remove old patches
162
163* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.9.1-1
164- new upstream release
165- update BuildRequires: umb-scheme -> slib
166
167* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.4-10vl5
168- applied new versioning policy, spec in utf-8
169- removed *.la
170
171* Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-9vl1
172- added Patches from Fedora
173  * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> 1.3.4-9
174  - add patch for M4 quoting (#162649, <rc040203@freenet.de>)
175
176* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl3
177- rebuild with new toolchains
178- s/Copyright/License/
179
180* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl2
181- build against new guile 1.6.4
182
183* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2vl1
184- based on rawhide 1.3.4-2
185  - update to 1.3.4
186  - move .la files to main package (#79068)
187- rebuild with new guile 1.6.3
188
189* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1vl1
190- updated to 1.1.10
191
192* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl4
193- add defattr
194
195* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl2
196- japanized spec file ( add %descripsion -l ja Summary(ja)
197
198
199* Wed Nov 08 2000 Derek Atkins <warlord@MIT.EDU>
200- Don't destroy the build directory -- RPM can do that on its own
201- Properly build both g-wrap and g-wrap-devel (info file into -devel)
202- currently only one info file
203
204* Wed Oct 25 2000 Dave Peticolas <dave@krondo.com>
205- use /usr/info/* for automatic gzipping
206
207* Sat May 27 2000 Mark Horning <rip6@rip6.net>
208- Created spec file
Note: See TracBrowser for help on using the repository browser.