source: projects/specs/trunk/g/g-wrap/g-wrap-vl.spec @ 9291

Revision 9291, 6.5 KB checked in by Takemikaduchi, 9 years ago (diff)

libdbi-drivers,goffice08,guile18: NEW package
geda-gaf,missile,rrdtool,trackballs,trackballs-music,ulogd,xkeycaps,xorg-x11-jpfonts: rebuild
others: new upstream release

Line 
1%define ver 1.9.14
2%define rel 3%{?_dist_release}
3
4Summary: A tool for creating Scheme interfaces to C libraries.
5Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
6Name: g-wrap
7Version: %{ver}
8Release: %{rel}
9Group: Development/Libraries
10License: GPL
11URL: http://www.gnucash.org/
12Source: ftp://ftp.gnucash.org/pub/g-wrap/%{name}-%{version}.tar.gz
13
14# upstream patch
15Patch0: g-wrap-1.9.14-guile-2.0.patch
16
17Requires: guile
18BuildRequires: guile-devel, libffi-devel
19BuildRequires: glib2-devel
20Requires(pre): /sbin/install-info /sbin/ldconfig
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26
27%description
28g-wrap is a tool for creating Scheme interfaces to C libraries.  At
29the moment it is most heavily focused on providing access to C
30libraries from guile, but it also supports RScheme.
31
32The g-wrap package contains the libraries necessary to run
33applications built with g-wrap.  If you wish to build applications
34that use g-wrap, you should install the g-wrap-devel package.
35
36%description -l ja
37g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
38guile から C言語のライブライリへのアクセスを提供することを目的
39としています。 RScheme もサポートしています
40
41g-wrap には g-wrap 使って作成したアプリケーションを動作させるために
42必要なライブラリが含まれています. g-wrap を使ってアプリケーションを
43作成したい場合 g-wrap-devel をinstallしてください.
44
45
46%package devel
47Summary: Include files and libraries needed for g-wrap development.
48Summary(ja): g-wrap を使用した開発に必要なヘッダファイルやライブラリ
49Group: Development/Libraries
50Requires(pre): /sbin/install-info
51Requires: g-wrap = %{version}, guile-devel
52
53
54%description devel
55g-wrap is a tool for creating Scheme interfaces to C libraries.  At
56the moment it is most heavily focused on providing access to C
57libraries from guile, but it also supports RScheme.
58
59You can provide access to a given C API by creating a specification
60file describing the interface you want published at the Scheme level.
61g-wrap will handle generating all the lower level library interface
62code so that the C library shows up as a set of Scheme functions.
63
64You should install g-wrap-devel if you need to compile programs that
65need to use g-wrap C<->Scheme functionality
66
67%description devel -l ja
68g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
69guile から C言語のライブライリへのアクセスを提供することを目的
70としています。 RScheme もサポートしています
71
72Schem レベルで表現したいインターフェースを記述を指定したファイルを作成
73することによりC PAI へのアクセスを提供します.
74g-wrap は 低レベルライブラリインターフェースすべての生成を扱うことが
75できます。したがって C ライブラリには Schem 関数の集合としてみえます.
76
77g-wrap のC と Scheme 間の変換機能を必要とするプログラムをコンパイルする
78場合 g-wrap-devel をinstallしておかねかればなりません.
79
80%prep
81%setup -q
82%patch0 -p1 -b .guile2
83
84%build
85%configure --disable-static
86
87#remove Rpath
88sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
89sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
90
91#Is not parallel-build-safe
92%{__make}
93
94%install
95%{__rm} -rf ${RPM_BUILD_ROOT}
96%{__make} install DESTDIR=${RPM_BUILD_ROOT}
97
98#Remove unneeded file
99find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
100rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir
101mv  ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm ./config.old
102cat config.old > config.scm
103install -p -m 644 config.scm  ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm
104
105
106%clean
107%{__rm} -rf ${RPM_BUILD_ROOT}
108
109
110%post -p /sbin/ldconfig
111
112%post devel
113/sbin/install-info \
114    --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
115
116
117%preun -p /sbin/ldconfig
118
119%preun devel
120if [ "$1" = "0" ]; then
121    /sbin/install-info --delete \
122        --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
123fi
124
125%files
126%defattr(-,root,root)
127%doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README THANKS
128%dir %{_libdir}/%{name}
129%dir %{_libdir}/%{name}/modules
130%{_libdir}/%{name}/modules/*.so.*
131%{_libdir}/*.so.*
132%{_datadir}/guile/site/*
133
134
135%files devel
136%defattr(-,root,root)
137%{_bindir}/*
138%{_libdir}/*.so
139%{_libdir}/%{name}/modules/libgw-guile-gw-glib.so
140%{_libdir}/%{name}/modules/libgw-guile-standard.so
141%{_includedir}/*
142%{_datadir}/aclocal/*
143%{_libdir}/pkgconfig/*
144%{_mandir}/man1/g-wrap-config.1.gz
145%doc %{_infodir}/g-wrap.*
146
147
148%changelog
149* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-3
150- rebuild with guile-2.0.11
151- add Patch0 (g-wrap-1.9.14-guile-2.0.patch)
152
153* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-2
154- rebuild with libffi-3.0.13
155
156* Tue Jun 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-1
157- update to 1.9.14
158- remove old patches
159
160* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.9.1-1
161- new upstream release
162- update BuildRequires: umb-scheme -> slib
163
164* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.4-10vl5
165- applied new versioning policy, spec in utf-8
166- removed *.la
167
168* Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-9vl1
169- added Patches from Fedora
170  * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> 1.3.4-9
171  - add patch for M4 quoting (#162649, <rc040203@freenet.de>)
172
173* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl3
174- rebuild with new toolchains
175- s/Copyright/License/
176
177* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl2
178- build against new guile 1.6.4
179
180* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2vl1
181- based on rawhide 1.3.4-2
182  - update to 1.3.4
183  - move .la files to main package (#79068)
184- rebuild with new guile 1.6.3
185
186* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1vl1
187- updated to 1.1.10
188
189* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl4
190- add defattr
191
192* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl2
193- japanized spec file ( add %descripsion -l ja Summary(ja)
194
195
196* Wed Nov 08 2000 Derek Atkins <warlord@MIT.EDU>
197- Don't destroy the build directory -- RPM can do that on its own
198- Properly build both g-wrap and g-wrap-devel (info file into -devel)
199- currently only one info file
200
201* Wed Oct 25 2000 Dave Peticolas <dave@krondo.com>
202- use /usr/info/* for automatic gzipping
203
204* Sat May 27 2000 Mark Horning <rip6@rip6.net>
205- Created spec file
Note: See TracBrowser for help on using the repository browser.