source: projects/specs/trunk/f/freerdp/freerdp-vl.spec @ 8966

Revision 8966, 6.4 KB checked in by inagaki, 10 years ago (diff)

2014-09-23 Ryoichi INAGAKI <ryo1@…>

  • freerdp, xfce4-timer-plugin, xfce4-xkb-plugin: update
  • xfce4-power-manager, xfce4-weather-plugin: rebuild


Line 
1Name:           freerdp
2Summary:        Remote Desktop Protocol client
3Summary(ja):    リモートデスクトッププロトコルクライアント
4Version:        1.0.2
5Release:        1%{?_dist_release}
6
7Group:          Applications/Internet
8License:        GPLv2+
9URL:            http://www.freerdp.com/
10
11Source0:        https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
12# https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
13
14Patch0:         fastpath_send_input_pdu-sec_bytes.patch
15Patch1:         c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
16Patch2:         freerdp-1.0.2_xmlto.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires:  cmake
20BuildRequires:  xmlto
21BuildRequires:  openssl-devel
22BuildRequires:  libX11-devel
23BuildRequires:  libXext-devel
24BuildRequires:  libXinerama-devel
25BuildRequires:  libXcursor-devel
26BuildRequires:  libXdamage-devel
27BuildRequires:  libXv-devel
28BuildRequires:  libxkbfile-devel
29BuildRequires:  pulseaudio-libs-devel
30BuildRequires:  cups-devel
31BuildRequires:  pcsc-lite-devel
32BuildRequires:  desktop-file-utils
33
34Provides:       xfreerdp = %{version}-%{release}
35Requires:       %{name}-libs = %{version}-%{release}, %{name}-plugins = %{version}-%{release}
36Requires:       %{name}-plugins = %{version}-%{release}
37
38%description
39The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
40project.
41
42xfreerdp can connect to RDP servers such as Microsoft Windows
43machines, xrdp and VirtualBox.
44
45
46%package        libs
47Summary:        Core libraries implementing the RDP protocol
48Summary(ja):    RDPプロトコル実装のコアライブラリ
49Group:          System Environment/Libraries
50
51%description    libs
52libfreerdp implements the core of the RDP protocol.
53
54libfreerdpchanman can be used to load plugins that can handle channels
55in the RDP protocol.
56
57libfreerdpkbd implements functionality for handling keyboards in X.
58
59
60%package        plugins
61Summary:        Plugins for handling the standard RDP channels
62Summary(ja):    標準RDPチャンネルを扱うためのプラグイン
63Group:          System Environment/Libraries
64Requires:       %{name}-libs = %{version}-%{release}
65
66%description    plugins
67A set of plugins to the channel manager implementing the standard virtual
68channels extending RDP core functionality.  For example, sounds, clipboard
69sync, disk/printer redirection, etc.
70
71
72%package        devel
73Summary:        Development files for %{name}
74Summary(ja):    %{name}の開発ファイル
75Group:          Development/Libraries
76Requires:       %{name}-libs = %{version}-%{release}
77Requires:       pkgconfig
78
79%description    devel
80The %{name}-devel package contains libraries and header files for
81developing applications that use %{name}-libs.
82
83
84%prep
85%setup -q -n FreeRDP-%{version}
86#patch0 -p1
87#patch1 -p1
88%patch2 -p1
89
90cat << EOF > xfreerdp.desktop
91[Desktop Entry]
92Type=Application
93Name=X FreeRDP
94NoDisplay=true
95Comment=Connect to RDP server and display remote desktop
96Icon=%{name}
97Exec=/usr/bin/xfreerdp
98Terminal=false
99Categories=Network;RemoteAccess;
100EOF
101
102%build
103%cmake \
104        -DCMAKE_BUILD_TYPE=Release \
105        -DWITH_CUPS=ON \
106        -DWITH_PCSC=ON \
107        -DWITH_PULSEAUDIO=ON \
108        -DWITH_X11=ON \
109        -DWITH_XCURSOR=ON \
110        -DWITH_XEXT=ON \
111        -DWITH_XINERAMA=ON \
112        -DWITH_XKBFILE=ON \
113        -DWITH_XV=ON \
114        -DWITH_ALSA=OFF \
115        -DWITH_CUNIT=OFF \
116        -DWITH_DIRECTFB=OFF \
117        -DWITH_FFMPEG=OFF \
118        -DWITH_SSE2=OFF \
119        -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
120        .
121
122
123make %{?_smp_mflags}
124
125
126%install
127rm -rf $RPM_BUILD_ROOT
128
129make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
130
131# No need for keymap files when using xkbfile
132rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
133
134desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications xfreerdp.desktop
135install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
136
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141
142%post
143# This is no gtk application, but try to integrate nicely with GNOME if it is available
144gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
145
146
147%post libs -p /sbin/ldconfig
148
149
150%postun libs -p /sbin/ldconfig
151
152
153%files
154%defattr(-,root,root,-)
155%{_bindir}/xfreerdp
156%{_mandir}/man1/xfreerdp.*
157%{_datadir}/applications/xfreerdp.desktop
158%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
159
160%files libs
161%defattr(-,root,root,-)
162%doc LICENSE README ChangeLog
163%{_libdir}/lib%{name}-*.so.*
164%dir %{_libdir}/%{name}/
165
166%files plugins
167%defattr(-,root,root,-)
168%{_libdir}/%{name}/*
169
170%files devel
171%defattr(-,root,root,-)
172%{_includedir}/%{name}/
173%{_libdir}/lib%{name}-*.so
174%{_libdir}/pkgconfig/%{name}.pc
175
176
177%changelog
178* Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
179- update to 1.0.2
180- fixed typo in Group
181- dropped Patch0 and Patch1
182- added Patch2 to build with current xmlto
183
184* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
185- update to 1.0.1
186- import patches from fedora package.
187- add BRs.
188
189* Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
190- initial build for Vine Linux
191
192* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
194
195* Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
196- rebuild on rawhide because of broken dependencies
197
198* Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
199- freerdp-0.8.2
200
201* Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
202- make -devel require pkgconfig
203- first official Fedora package
204
205* Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
206- freerdp-0.8.1
207
208* Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
209- hack the generated libtool to not set rpath on x86_64
210- configure with alsa explicitly
211
212* Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
213- freerdp-0.7.4
214- cleanup of packaging structure
215
216* Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
217- 0.7.3
218- fix some minor pylint warnings
219
220* Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
221- 0.7.2
222- Address many comments from cwickert:
223- - cleanup of old formatting, alignment with spectemplate-lib.spec and
224    cwickert spec from #616193
225- - add alsa as build requirement
226- - remove superfluous configure options and disable static libs
227- - add missing rpm groups
228
229* Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
230- First official release, first review request
Note: See TracBrowser for help on using the repository browser.